Under Review
Last Updated: 11 Aug 2021 18:42 by ADMIN
Matt
Created on: 05 Aug 2021 04:57
Category: RadioGroup
Type: Bug Report
0
TelerikRadioGroup Accessibility - Labelling Missing
ISSUE - ul (role="radiogroup") needs a group label
what to do:
  • create a span before first LI as label
  • UL shall reference span via aria-labelledby
  • group label needs to look like a group label (it must be more significant/important than the radio labels)

As these elements are wrapped by the control this needs to be updated internally.

1 comment
ADMIN
Eric R | Senior Technical Support Engineer
Posted on: 11 Aug 2021 18:42

Hi Matt,

Thank you for the feedback. I believe that this is related to accessibility. If so, this does appear to be a known issue and related to the Accessibility Issues in the TelerikRadioGroup feature request which is currently unplanned.

If this is related to accessibility, an important consideration is that due to the customizability of Telerik UI for Blazor, some implementations may not pass accessibility checks. For example, I was able to test our Overview demo with the axe DevTools and the group label issue did not appear it. 

In any case, can you confirm if this is related to the accessibility and possibly the recommended fix from a WCAG scanner? Additionally, if so, can you also run the attached sample against the same WCAG scanner and confirm if the issue appears?

In the meantime, please let me know if you need any additional information. Thank you and I look forward to your reply.

Regards,


Eric R | Senior Technical Support Engineer
Progress Telerik

Virtual Classroom, the free self-paced technical training that gets you up to speed with Telerik and Kendo UI products quickly just got a fresh new look + new and improved content including a brand new Blazor course! Check it out at https://learn.telerik.com/.

Attached Files: