Unplanned
Last Updated: 02 Jul 2021 13:11 by ADMIN
Dominik
Created on: 30 Jun 2021 09:47
Category: ApplicationMenu
Type: Bug Report
0
RadApplicationMenu: sometimes RadMenuComboItem hides before clicking on it

RadMenuComboItem is vanishing before can be reached if its not in main manu colum.

 

 

1: works

2: works NOT - menu is popping in but if you move the mouse from "style" to the combobox its vanishing before you can do anything.

5 comments
ADMIN
Nadya
Posted on: 02 Jul 2021 13:11

Hi, Dominik,

Thank you for the provided files.

I was able to reproduce the undesired behavior after running the TelerikBug_RadApplicationMenu.exe file. Then, I modified my sample project according to your setup and reproduce the same random behavior when trying to reach the RadMenuComboItem.

I have approved this as a bug report in our feedback portal. You can track its progress, subscribe for status changes and add your comments on the following link - feedback item.

I have also updated your Telerik Points.

I hope this helps. If you have any other questions do not hesitate to contact me.

Regards,
Nadya
Progress Telerik

Virtual Classroom, the free self-paced technical training that gets you up to speed with Telerik and Kendo UI products quickly just got a fresh new look + new and improved content including a brand new Blazor course! Check it out at https://learn.telerik.com/.

Dominik
Posted on: 01 Jul 2021 11:23

Hi Nadya,

 

thanks for the fast answer.

It happens in the second layer of the columns setction in the application menu.

Sometimes its possible to use the combobox but most of the time not.

 

Attached Files:
ADMIN
Nadya
Posted on: 01 Jul 2021 10:01

Hello, Dominik,

Thank you for clarifying that you use RadApplicationMenu control. I updated the product name in the ticket info as well.

I have tested the same scenario with RadApplicationMenu but did not observe the problem you described. Please check the attached gif file. Am I missing something? I updated my test project accordingly. Can you give it a try and let me know if you can reproduce the problem there. It would be of great help if you can modify the project in order to demonstrate the undesired behavior or provide the exact steps how to reproduce the problem locally.

I am looking forward to your reply.

Regards,
Nadya
Progress Telerik

Virtual Classroom, the free self-paced technical training that gets you up to speed with Telerik and Kendo UI products quickly just got a fresh new look + new and improved content including a brand new Blazor course! Check it out at https://learn.telerik.com/.

Dominik
Posted on: 01 Jul 2021 08:59

Hi Naya,

 

i am using a RadApplicationMenu.

in the RadMenu its working.

ADMIN
Nadya
Posted on: 30 Jun 2021 15:44

Hello, Dominik,

According to the provided picture, I suppose that you use RadMenu control. In case you are using another control, it would be greatly appreciated if you can specify it.

Following the provided information, I created a sample project to test this scenario in RadMenu. I have added nested RadMenuItems and RadMenuComboItems. However, I am not able to observe unusual behavior when reaching the nested items. Please see the result on my end in the gif file. Am I missing something? Can you please give this project a try and let me know how to reproduce the problem.

I am looking forward to your reply.

Regards,
Nadya
Progress Telerik

Love the Telerik and Kendo UI products and believe more people should try them? Invite a fellow developer to become a Progress customer and each of you can get a $50 Amazon gift voucher.

Attached Files: