Completed
Last Updated: 04 May 2020 11:53 by ADMIN
Release R2 2020
Rajesh
Created on: 15 Apr 2020 06:37
Category: UI for WinForms
Type: Bug Report
0
Visual Style Builder issue: object reference not set to an instance of an object on DPI scaling higher than 100%

Hi,

 

  • Open the VisualStudio2012Light.tssp using UI WinForms Visual Style Builder.
  • Select on RadButtonElement and Element state is ButtonFill. Double click on NormalFill repository, below is the error (attached the snapshot) -

object reference not set to an instance of an object

 

Questions:

  • How to resolve this issue.
  • How to trace log if any.

 

Regards,

Rajesh

Attached Files:
5 comments
ADMIN
Dess | Tech Support Engineer, Sr.
Posted on: 16 Apr 2020 12:05

Hello, Rajesh,

Thank you for the provided information.

I was able to replicate the problem with Visual Style Builder when running it on 125% DPI scaling. 

I have logged it in our feedback portal by making this thread public on your behalf. You can track its progress, subscribe for status changes and add your comments on the following link - feedback item.

I have also updated your Telerik points.

Currently, due to the specificity of the issue the possible solution that I can suggest is to run VSB on 100% DPI scaling. Please excuse us for the inconvenience caused. We will do our best to introduce a fix as soon as possible. Please make sure that you follow this item. Thus, you will get notified once the feedback item is changed.

Should you have further questions please let me know.

Regards,
Dess | Tech Support Engineer, Sr.
Progress Telerik

Progress is here for your business, like always. Read more about the measures we are taking to ensure business continuity and help fight the COVID-19 pandemic.
Our thoughts here at Progress are with those affected by the outbreak.
Rajesh
Posted on: 16 Apr 2020 05:55

Hi,

Issue is with all tssp files and tried with fresh export as well.

BY changing the display scale settings from 125% to 100%, no issues.

But in our laptops, 125% is the recommended setting. What should we do? What is the science here? We can't change our setting for this issue.

 If this the only solution, please let me know.

Regards,

Rajesh

ADMIN
Dess | Tech Support Engineer, Sr.
Posted on: 16 Apr 2020 05:37
Hello, Rajesh,

If you have .NET Framework 4.7.2 installed on your machine, you don't need anything else for running Visual Style Builder.

Indeed, the illustrated behaviour and the obtained exception is not correct. However, I would like to note that before logging an issue with Visual Style Builder, we need to identify how the exception is reproducible in order to properly address it then. Since the problem can't be replicated on several machines on our end we are still trying to find out what causes the error message.

Are you running Visual Style Builder on a monitor with DPI scaling higher than 100%? Is the problem reproducible only with VisualStudio2012Light or it can be seen with other themes as well? Have you tried to export the built-in themes again and test with the newly exported VisualStudio2012Light.tssp file?

Thank you in advance for your cooperation. I am looking forward to your reply.

Regards,
Dess | Tech Support Engineer, Sr.
Progress Telerik

Progress is here for your business, like always. Read more about the measures we are taking to ensure business continuity and help fight the COVID-19 pandemic.
Our thoughts here at Progress are with those affected by the outbreak.
Rajesh
Posted on: 15 Apr 2020 12:15

Deleted the file and  tried with the Edit repository item, but No luck.

One observation is: In our previous Dell laptop WIN 10 OS, it worked, we made color changes also. Issue now in latest Dell laptop, with Win 10 OS. Are we missing any .Net Frameworks. Presently we have latest 4.7.2 framework. Do we need any mandatory Frameworks? Or any settings?

We are expecting at least Logging. Even no information in Event Viewer.

ADMIN
Dess | Tech Support Engineer, Sr.
Posted on: 15 Apr 2020 10:46

Hello, Rajesh,

Following the provided information, I was unable to reproduce the issue you are facing. Please refer to the attached gif file illustrating the behavior on my end. Am I missing something?

I would suggest you to try the Edit repository item... option instead of double clicking:

Does the error message occur?

According to the provided information, it is difficult to determine what is the issue with Visual Style Builder on your end. Another idea that pops up in my mind is to navigate to the C:\Users\'your user name'\AppData\Roaming\Telerik\WinForms\VSB folder and delete the VsbLayout.xml. Give it a try and let me know the obtained result. 

I am looking forward to your reply.

Regards,
Dess | Tech Support Engineer, Sr.
Progress Telerik

Progress is here for your business, like always. Read more about the measures we are taking to ensure business continuity and help fight the COVID-19 pandemic.
Our thoughts here at Progress are with those affected by the outbreak.
Attached Files: