Unplanned
Last Updated: 16 Nov 2021 14:52 by ADMIN
Martin Ivanov
Created on: 16 Nov 2021 14:51
Category: EntityFrameworkCoreDataSource
Type: Feature Request
1
EntityFrameworkCoreDataSource: Add support for EntityFramework Core for .NET 5 and 6
Currently, the RadEntityFrameworkCoreDataSource will work properly only in EF Core 3.1. Otherwise, the following error occurs when using the source with EF Core 5 or 6:
System.TypeLoadException: 'Could not load type 'Microsoft.EntityFrameworkCore.Query.Internal.IAsyncQueryProvider' from assembly 'Microsoft.EntityFrameworkCore, Version=6.0.0.0, Culture=neutral, PublicKeyToken=adb9793829ddae60'.'
In case you need to use the Telerik EF support, you can use the QueryableEntityCoreCollectionView instead of RadEntityFrameworkCoreDataSource as shown in the MVVM Usage article.
0 comments