Completed
Last Updated: 07 Nov 2018 07:54 by ADMIN
ADMIN
Martin Ivanov
Created on: 06 Dec 2017 13:57
Category: ChartView3D
Type: Bug Report
2
ChartView3D: Null values on the Z axis are rendered wrongly in some cases when using SurfaceSeries3D
This issue is related to the SurfaceSeries3D. Originally when you have a data point with its ZValue set to null, the chart will create a gap on the surface. This always happens. However, on some machines the null values are treated a bit differently by the renderer and a triangle is drawn from the points around the null data to the center of the viewport. This leads to an unexpected visual glitch.
Attached Files:
(Total attached files size should be smaller than 20mb. Allowed extensions: .zip, .rar, .jpg, .png, .gif)
3 comments
ADMIN
Ralitsa
Posted on: 07 Nov 2018 07:54
Hi all, 

We considered the scenario where the value is set to null or Double.NaN. On 12 November 2018 (Monday), we are uploading our next LIB version (2018.3.1112) where the fix will be included. It will also be included in our official version – R1 2019, scheduled for the mid of January 2019.

Best regards,
Ralitsa Kumanova
Dinko
Posted on: 21 Sep 2018 11:16
Hello,

Recently, a scenario have been hit where this behavior is still reproducible. When the first or last data point have ZValue set to null. The status of the item is changed back to In Development for further investigation. 

Best Regards,
Dinko Krastev
ADMIN
Ralitsa
Posted on: 18 May 2018 11:12
Hi,

The fix for the issue will be available in next LIB version (2018.2.521). It will also be included in our next official version – R2 2018 SP1, scheduled for the end of June.

Best regards,
Ralitsa Kumanova