Pending Review
Last Updated: 21 Jun 2017 18:33 by moegal
ADMIN
Vessy
Created on: 15 Nov 2016 13:14
Category: Grid
Type: Bug Report
2
FooterAggregateFormatString value does not work in a client-side bound Grid
The FooterAggregateFormatString functionality of the Grid does not affect the Aggregates values format in a client-bound Grid.

Code to reproduce:
            <telerik:RadGrid RenderMode="Lightweight" ID="RadGrid1" runat="server" ClientDataSourceID="RadClientDataSource1" AllowPaging="true" AllowSorting="true" AllowFilteringByColumn="true" ShowFooter="true">
                <MasterTableView ClientDataKeyNames="CustomerID" EditMode="Batch" CommandItemDisplay="Top" BatchEditingSettings-HighlightDeletedRows="true">
                    <Columns>
                        <telerik:GridBoundColumn DataField="CustomerID" HeaderText="Customer ID"  Aggregate="Count" FooterAggregateFormatString="No currency sign here: {0:C}">
                        </telerik:GridBoundColumn>
                        <telerik:GridBoundColumn DataField="CompanyName" HeaderText="Company Name" ColumnEditorID="GridTextBoxEditor">
                        </telerik:GridBoundColumn>
                        <telerik:GridBoundColumn DataField="ContactName" HeaderText="Contact Name" ColumnEditorID="GridTextBoxEditor">
                        </telerik:GridBoundColumn>
                        <telerik:GridBoundColumn DataField="ContactTitle" HeaderText="Contact Title" ColumnEditorID="GridTextBoxEditor">
                        </telerik:GridBoundColumn>
                        <telerik:GridClientDeleteColumn HeaderText="Delete">
                            <HeaderStyle Width="70px" />
                        </telerik:GridClientDeleteColumn>
                    </Columns>
                </MasterTableView>
                <ClientSettings>
                    <ClientEvents OnUserAction="UserAction" />
                </ClientSettings>
            </telerik:RadGrid>
2 comments
moegal
Posted on: 21 Jun 2017 18:33
When is this going to get fixed???

What am I paying for?
Marty
moegal
Posted on: 02 Mar 2017 20:28
This is not a new feature request.  This is a bug.  Come on Telerik!
Marty