Unplanned
Last Updated: 02 Apr 2021 12:27 by Andy
Andy
Created on: 02 Apr 2021 12:27
Category: MultiSelect
Type: Bug Report
0
MultiSelect configured for server filtering sends an empty request on focusout

Bug report

MultiSelect configured for server-filtering="true" sends an empty request on focusout

     <kendo-multiselect for="SelectedOrderIds" style="width:100%"
                       placeholder="Select addresses..."
                       datatextfield="ShipName"
                       datavaluefield="OrderID"
                       filter="FilterType.Contains"
                       value="Model.SelectedOrders.Select(x=>x.OrderID)">
        <datasource type="DataSourceTagHelperType.Ajax" server-filtering="true">
            <transport>
                <read url="@Url.Page("Index", "Read")" data="forgeryToken" />
            </transport>
            <schema data="Data">
                <model id="OrderID">
                    <fields>
                        <field name="ShipName" type="string"></field>
                    </fields>
                </model>              
            </schema>
        </datasource>
    </kendo-multiselect>

Reproduction of the problem

TelerikAspNetCoreApp197.zip

  1. Run the attached application
  2. Enter 34, for example, and select the returned item
  3. Click outside of the MultiSelect

Current behavior

An empty request is sent, fetching all data.

Expected/desired behavior

A request should not be sent.

Environment

  • Kendo UI version: 2021.1.330
  • Browser: [all]
0 comments