When working with a dynamically setup of the tabstrip, and hiding/showing tabs according to the data entered in a form, I use jquery scripts to do the logical setup.
Each tab is referenced in the script by their array position:
var tbs = $("#tabstripDetail").data("kendoTabStrip");
$(tbs.items()[0]).hide();
$(tbs.items()[4]).show();
tbs.select(4);
For some functions I move/duplicate field from models according to the different customers needs, and to avoid several fields on the form with the same id/name I remove tabs from the collection.
tbs.remove(4);
By doing this the array of tabs are changed, and I have to keep track of which array number each tab has compared to the initial number.
My suggestion is that each tab could be named so that it is possible to keep references of the tabs by logical names and avoid array numbers.
tbs.remove("maritimeProducts");
This functionality will simplify working with show, hide, remove, select of single tabs.
Thank you for sharing your enhancement idea, I have updated your Telerik points. I have made it public in the portal (link for you here) so the community can vote and comment on it - this will help management gauge its traction and priority.