Elena Tsvetkova
Team Member

Wait/Verify NOT exists step for element with data driven expression does not throw exception for missing variable

Please find attached a sample project demonstrating the below listed issue.

Details shared internally
Feedback by Elena Tsvetkova Status: Reviewed by QA Comments: 0 Last update: 2018-04-10T07:50:14 by Ivaylo Todorov
0
Elena Tsvetkova
Team Member

Publish results to TFS options are not working with the new vNext builds in TFS 2017

The options optionally provided to the command line runner related to publish results to TFS are not working correctly with the new builds in TFS 2017 vNext.
Feedback by Elena Tsvetkova Status: Won't Fix Comments: 1 Last update: 2018-04-10T06:49:21 by Ivaylo Todorov
0
Steve Charlton

Multiple ramp up/down times in load/performance

Hey guys,

I'm looking for a feature in test studio that would allow users to have multiple ramp up/down times using the load/performance testing functionality. For example, start with X users then gradually ramp up to Y users over the next N minutes. After N minutes maintain a constant load of Y users for the rest of the duration of the load test.

To me, this is the one feature test studio is lacking compared to the other players in the load/performance testing industry. Please like if you agree that this would be a great feature for the test studio team to implement.

Thanks all!

Steve Charlton
T4G Limited
Feature Request by Steve Charlton Status: Not Done Comments: 3 Last update: 2018-04-05T18:30:17 by Zach Shuster
0
Nikolay Petrov
Team Member

Test files with no data does not open in VS 2015 on a specific environment

When open a test project in VS 2015 - Update 3 and try to open test file with no data - the following exception occur:

"Object reference not set to an instance of an object."

All other test files with data are opened normally.
The problem is hard to reproduce.
The workaround is to use different VS version or to attach empty data to a test.
Problem by Nikolay Petrov Status: Reviewed by QA Comments: 2 Last update: 2018-04-05T12:47:29 by John Maddox
0
Nikolay Petrov
Team Member

Certain type IE FileDownload dialog is not properly handled on specific Windows 7 environment

Steps to reproduce and further environment setup information - in the internal description.
Problem by Nikolay Petrov Status: Reviewed by QA Comments: 0 Last update: 2018-04-04T11:14:43 by Ivaylo Todorov
0
Nikolay Petrov
Team Member

A popup is not properly handled in a customer specific WPF application

Steps to reproduce and access to the application are in the internal description.
Problem by Nikolay Petrov Status: Reviewed by QA Comments: 0 Last update: 2018-04-04T10:57:29 by Ivaylo Todorov
0
Elena Tsvetkova
Team Member

Verify or Wait for element to ExistNot do not refer the element from the repository when converted to code

Steps to reproduce:

1. Create a sample project and add the following steps:

- Verify element Exists

- Verify element ExistsNot

- Wait element Exists

- Wait element ExistsNot

2. Convert these to code and double check that the ExistsNot steps refer to an element with the current find expression. In contrary the Exists steps refer the element from the Pages file directly.

That way editing the find expression of the element will be updated and referred in the Exists steps. But the ExistsNot steps in code should be manually updated.

Expected: The elements in all converted steps to be referred from the elements' repository.
Feedback by Elena Tsvetkova Status: Won't Fix Comments: 1 Last update: 2018-04-04T08:33:22 by Ivaylo Todorov
0
Nikolay Petrov
Team Member

Encrypted part of the url is not recognized as dynamic parameter for customer specific application

In a load test - encrypted part of the URL is not recognized as a dynamic parameter.
Steps to reproduce and further details are available in the internal description.
Feature Request by Nikolay Petrov Status: Not Done Comments: 0 Last update: 2018-04-04T07:33:52 by Nikolay Petrov
0
Stoil Stoychev

"string cannot have zero length." exception when opening tests with coded steps in vs

Not sure about exact repro. Sometimes when I open a test with coded steps in Visual Studio I get the following error when I try to run it:

'17-Dec-16 11:23:32 PM' - System.ArgumentException: String cannot have zero length.
at System.Reflection.RuntimeAssembly.GetType(RuntimeAssembly assembly, String name, Boolean throwOnError, Boolean ignoreCase, ObjectHandleOnStack type)
at System.Reflection.RuntimeAssembly.GetType(String name, Boolean throwOnError, Boolean ignoreCase)
at System.Reflection.Assembly.GetType(String name)
at ArtOfTest.WebAii.Design.Execution.ExecutionUtils.EnsureTypeExists(Assembly assm, String typeName)
at ArtOfTest.WebAii.Design.Execution.ExecutionUtils.CreateCodedTestInstance(Test test, TestResult result, String binariesFolder)
at ArtOfTest.WebAii.Design.Execution.ExecutionEngine.InternalExecuteTest(Test test, TestResult initializationResult)
at ArtOfTest.WebAii.Design.Execution.TestExecuteProxy.ExecuteTest(ExecuteTestCommand command)

Closing the test, rebuilding and opening it again seems to work. But I think this same issue also causes problems when the test suite is deployed on remote machines.
Problem by Stoil Stoychev Status: Deferred Comments: 2 Last update: 2018-04-03T12:15:19 by Ivaylo Todorov
0
Elena Tsvetkova
Team Member

Converting Verify or Wait step to code generates the same line of code

Steps to reproduce:

1. Create a Verify element Exists and Wait for element exists steps

2. Converting both to code generates Pages.Element.Wait.ForExists(30000);

Expected would be that the Verify element Exists step rely on the global project elements timeout or alternatively verifies immediately.

Actual: The current implementation is that the Verify step takes the default wait timeout for a wait step.
Feedback by Elena Tsvetkova Status: Won't Fix Comments: 1 Last update: 2018-04-03T12:12:14 by Ivaylo Todorov
0
Displaying items 81 - 90 of 2241