Pending Review
Last Updated: 06 Aug 2019 06:33 by Ilan

Hi there,

I've successfully setup fiddler-everywhere 0.4.0 and am able to sniff traffic to various websites on my linux (Ubuntu 18.04) laptop. However some https sites are not working - fiddler-everywhere severs the connection at the SSL handshake phase. These same sites work in the windows version of Fiddler (v 5.0.20192.25091 - built 04 June 2019) however.

What is the status of the SSL support in fiddler-everywhere vs windows Fiddler?

Example site that fails over https:

Example site that works over https:

Fiddler captures for absa.co.za

REQUEST: 

CONNECT www.absa.co.za:443 HTTP/1.1
Host: www.absa.co.za:443
Connection: keep-alive
User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.142 Safari/537.36

A SSLv3-compatible ClientHello handshake was found. Fiddler extracted the parameters below.

Version: 3.3 (TLS/1.2)
Random: 1F 0E B0 54 5D 66 42 82 C9 A8 A6 D5 8F C2 F0 C6 A8 16 0C 8E 14 45 F2 B4 B5 95 92 66 B6 53 D6 F4
"Time": 2015/01/09 19:21:35
SessionID: empty
Extensions: 
	0x5a5a		empty
	server_name	www.absa.co.za
	extended_master_secret	empty
	renegotiation_info	00
	elliptic_curves	unknown [0xBABA), unknown [0x1D), secp256r1 [0x17], secp384r1 [0x18]
	ec_point_formats	uncompressed [0x0]
	SessionTicket	empty
	ALPN		h2, http/1.1
	status_request	OCSP - Implicit Responder
	signature_algs	sha256_ecdsa, Unknown[0x8]_Unknown[0x4], sha256_rsa, sha384_ecdsa, Unknown[0x8]_Unknown[0x5], sha384_rsa, Unknown[0x8]_Unknown[0x6], sha512_rsa, sha1_rsa
	SignedCertTimestamp (RFC6962)	empty
	0x001b		02 00 02
	0xeaea		00
Ciphers: 
	[5A5A]	Unrecognized cipher - See http://www.iana.org/assignments/tls-parameters/
	[C02B]	TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256
	[C02F]	TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256
	[C02C]	TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384
	[C030]	TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384
	[CCA9]	TLS_ECDHE_ECDSA_WITH_CHACHA20_POLY1305_SHA256
	[CCA8]	TLS_ECDHE_RSA_WITH_CHACHA20_POLY1305_SHA256
	[C013]	TLS1_CK_ECDHE_RSA_WITH_AES_128_CBC_SHA
	[C014]	TLS1_CK_ECDHE_RSA_WITH_AES_256_CBC_SHA
	[009C]	TLS_RSA_WITH_AES_128_GCM_SHA256
	[009D]	TLS_RSA_WITH_AES_256_GCM_SHA384
	[002F]	TLS_RSA_AES_128_SHA
	[0035]	TLS_RSA_AES_256_SHA
	[000A]	SSL_RSA_WITH_3DES_EDE_SHA

Compression: 
	[00]	NO_COMPRESSION
 

 

RESPONSE:

HTTP/1.1 200 Connection Established
FiddlerGateway: Direct
StartTime: 10:28:40.706
Connection: close

fiddler.network.https> HTTPS handshake to www.absa.co.za (for #329) failed. System.IO.IOException Unable to read data from the transport connection: Connection reset by peer. < Connection reset by peer

Pending Review
Last Updated: 31 Jul 2019 08:55 by ADMIN

howdy,

I've downloaded the latest 0.4.0 Fiddler Everywhere. When I run it I get an error - "A JavaScript error occurred in the main process". This occurs every time I launch the app. However it appears to run normally after I dismiss the error dialog.

I'm running Ubuntu 18.0.4:

```

lsb_release -a

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.2 LTS
Release: 18.04
Codename: bionic

```

 

Pending Review
Last Updated: 21 Jun 2019 14:48 by ADMIN
Created by: Alex
Comments: 1
Type: Bug Report
3
Fiddler Everywhere won't even open on my ubuntu 19.04. I can see the logo-loading banner, and then nothing.
Pending Review
Last Updated: 31 May 2019 11:51 by ADMIN
Created by: Ryan
Comments: 6
Type: Bug Report
7

I fire up Fiddler Everywhere on my Mac. Generally, it appears to do nothing.

In further detail, "Stream" and "Decode" can be toggled, but otherwise do nothing. The connections icon has a hover-over describing my host and states I have a network connection. The help icon goes to the very limited documentation via browser. The settings icon pops open the settings dialog, which does appear to save changes, but not impact the "nothing" being done by the application. The capture button and inspectors button appear to do nothing. The main viewing area states "No records available." The area to the right of the main area states "Please, select a single Web Session to inspect." And that is it.

Either I'm doing (or not doing) something dumb, or it just isn't working for me. Any help would be appreciated :)

Mac specs: High Sierra 10.13.6, 2.6GHz i7, 16 GB memory

Completed
Last Updated: 10 Dec 2018 15:09 by ADMIN

Sometimes when I close Fiddler Everywhere, the process Fiddler.WebUi stays alive.

When I try opening a second Fiddler Everywhere it can't bind on 8886 and I have to force quit (kill -9) the process before re-opening Fiddler.

Pending Review
Last Updated: 22 Nov 2018 18:10 by Alexander
Created by: Roman
Comments: 1
Type: Bug Report
0

Im using MacOS Sierra 10.12.5

 

2 BIG Issues are present.

First of all, I don't have an INTERNET connection any more after closing FIDDLER it has to be always running!

Second issue Fiddler is working properly ONLY on the first Start. If  closing it and opening it again it's not working at all.

FIX this ASAP

 

very very critical