Declined
Last Updated: 05 Mar 2020 15:34 by ADMIN

I am using a component (GoogleMapControl) that inherit IExtenderControl . when i add it in to radajaxmanager updated controls or if i use it in dynamically loaded usercontrol by RadTab & RadMultiPage i am getting error of Unable to cast object of type 'GoogleMaps.Markers.GoogleMarkers' to type 'System.Web.UI.ExtenderControl'.

When i check the error detail by AsyncPostBackError event, i found that error comes from Telerik.Web.UI.ProxyScriptControl.GetChildScriptDescriptorsRecursive(Control parent, ArrayList scriptDescriptors).

Someones lived same problem old but same... As in https://dnntracker.atlassian.net/browse/DNN-25819

Unplanned
Last Updated: 09 Dec 2019 14:46 by ADMIN
When using RadAjaxManager or RadAjaxPanel in SharePoint 2019 for the purpose to enable ajax for Controls, a partial PostBack will cause the page become Blank. A test was conducted using the generic ASP UpdatePanel which worked as expected.
Completed
Last Updated: 24 Jul 2019 08:41 by ADMIN

When AutoResizeHeight is set to true in Chrome, on Editing in the content area, the view jerks, for example, when I select some text and click bold the view moves up. This happens on and off. The requirement for an editor is not to change position of the text which is being edited, it distracts the user.

<telerik:RadEditor RenderMode="Lightweight" runat="server"
               
  AutoResizeHeight="true">
    <ContextMenus>
        <telerik:EditorContextMenu TagName="P">
            <telerik:EditorContextMenuTool Name="Formatting" IconCssClass="reBold">
                <Tools>
                    <telerik:EditorTool Name="Bold" />
                    <telerik:EditorTool Name="Italic" />
                    <telerik:EditorTool Name="Underline" />
                </Tools>
            </telerik:EditorContextMenuTool>
            <telerik:EditorTool Name="Superscript" />
            <telerik:EditorTool Name="Subscript" />
            <telerik:EditorTool Name="Undo" />
            <telerik:EditorTool Name="Redo" />
            <telerik:EditorTool Name="FindAndReplace" />
        </telerik:EditorContextMenu>
        <telerik:EditorContextMenu TagName="H1">
            <telerik:EditorContextMenuTool Name="Formatting" IconCssClass="reBold">
                <Tools>
                    <telerik:EditorTool Name="Bold" />
                    <telerik:EditorTool Name="Italic" />
                    <telerik:EditorTool Name="Underline" />
                </Tools>
            </telerik:EditorContextMenuTool>
            <telerik:EditorTool Name="Superscript" />
            <telerik:EditorTool Name="Subscript" />
            <telerik:EditorTool Name="Undo" />
            <telerik:EditorTool Name="Redo" />
            <telerik:EditorTool Name="FindAndReplace" />
        </telerik:EditorContextMenu>
        <telerik:EditorContextMenu TagName="A" Enabled="false">
        </telerik:EditorContextMenu>
        <telerik:EditorContextMenu TagName="IMG">
            <telerik:EditorTool Name="SetImageProperties" />
            <telerik:EditorTool Name="ImageMapDialog" />
        </telerik:EditorContextMenu>
    </ContextMenus>
    <Content>
                                    <p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p><p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p>
   
<p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p>
   
<p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p>
   
<p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p>
<p>This is a plain text</p>
    </Content>
</telerik:RadEditor>

Declined
Last Updated: 12 Apr 2019 16:50 by ADMIN
Created by: Wei Dong
Comments: 1
Category: Ajax
Type: Bug Report
0
Hi guy,

      I want use alert function in radajaxmanager,  After i  set  radajaxmanager.alert, if code is running it ,page will pop-up a window. but this window is not middle positon in current page.
How can i  solve this question.thanks.


David
Completed
Last Updated: 28 Mar 2019 10:06 by ADMIN
moving application to godaddy web server hosting results in tab control not handling changing tabs.  app is using ajax handler and multpage.  its works on locall iis server.  Also tried calendar control which also did not change date when clicked.  
Completed
Last Updated: 09 Jul 2018 12:45 by ADMIN
Using a hidden button and calling its .click() method is sometimes used to invoke a postback under some application logic conditions. If you use the jQuery method and a RadAjaxPanel, this will no longer work with jQuery3 because its strict mode causes the MS AJAX scripts to throw an error.

Below is a sample repro of the scenario and it shows two of the workarounds. The third workaround is to downgrade jQuery to an older version (for example, 1.11.1 which is the previous version the suite used): https://docs.telerik.com/devtools/aspnet-ajax/controls/scriptmanager/disabling-the-embedded-jquery


        <telerik:RadScriptManager ID="RadScriptManager1" runat="server">
            <Scripts>
                <asp:ScriptReference Assembly="Telerik.Web.UI" Name="Telerik.Web.UI.Common.Core.js" />
                <asp:ScriptReference Assembly="Telerik.Web.UI" Name="Telerik.Web.UI.Common.jQuery.js" />
                <asp:ScriptReference Assembly="Telerik.Web.UI" Name="Telerik.Web.UI.Common.jQueryInclude.js" />
            </Scripts>
        </telerik:RadScriptManager>
        <telerik:RadCodeBlock runat="server" ID="rcb1">
            <script>
                function clickHiddenButton1() {
                    $telerik.$("#<%=Button1.ClientID%>").click();
                    //workaround 1
                    //__doPostBack("<%=Button1.UniqueID%>", "");
                    //workaround 2
                    //$find("<%=rap1.ClientID%>").ajaxRequest();
                }
            </script>
        </telerik:RadCodeBlock>
        <asp:Button Text="click hidden button" ID="testButton1" OnClientClick="clickHiddenButton1(); return false;" runat="server" />
        <telerik:RadAjaxPanel runat="server" ID="rap1" OnAjaxRequest="rap1_AjaxRequest">
            <asp:Label Text="" ID="Label1" runat="server" />
            <asp:Button Style="display: none;" Text="hidden button" ID="Button1" OnClick="Button1_Click" runat="server" />
        </telerik:RadAjaxPanel>
Pending Review
Last Updated: 11 Dec 2017 22:00 by Joel
Created by: Joel
Comments: 0
Category: Ajax
Type: Bug Report
0
I have a RadGrid with several thousand elements on it. In attempting to improve performance, the Visual Studio profiler informed me that it spent more than half of the request in PopulatePlainPanels checking whether something was in a list. (see attached before.png)

I changed the type of the variable plainPanelsClientIDs in RadAjaxControl.cs to be a HashSet<string> instead of a List<string>. As a knock-on effect, I had to import System.Linq into RadAjaxManager.cs to get the .toArray() call to work.

The result in the attached after.png shows the percentage of execution time dropped from 55% to 3%.

I'd appreciate it if the team would evaluate this change for inclusion in future releases.

Note 1: I have not done extensive testing on this, so I don't know what might break. The variable isn't referenced much, so the only thing I'm suspicious of is reflection, which I didn't check for and don't expect.
Note 2: If importing Linq is undesirable, a more manual conversion to an array can be done pretty easily.
Note 3: plainPanelsClientIDs is .add() 'ed to in two places, and both check for membership before being called. This shouldn't be necessary for a HashSet, which simply doesn't add if it's there. This seems a very minor improvement, but I didn't actually try it yet.
Unplanned
Last Updated: 19 Oct 2017 16:36 by Mike
A grid in a RadAjaxPanel will fire several requests when exporting if there is a RadAjaxManager on the page as well.

Stems from the _setupExclusionFilters function where each RadAjaxControl adds as a handler to Sys.WebForms.PageRequestManager.getInstance().add_initializeRequest which does a  sender._form.submit(); and gets called in the initialize method of the control.

The resolution is to use only RadAjaxManager to AJAX-enable complex pages that require the built-in exports as well and make sure to remove all RadAjaxPanel instances. This is the better approach anyway: http://docs.telerik.com/devtools/aspnet-ajax/controls/ajaxmanager/troubleshooting/controls-wrapped-in-ajaxpanel-and-added-to-ajaxmanager-settings

Repro and example solutions are added in the file attached below.
Declined
Last Updated: 30 Nov 2015 09:26 by ADMIN
ADMIN
Created by: Danail Vasilev
Comments: 0
Category: Ajax
Type: Bug Report
1
The Ajax in the sample page is made using:

$find("<%= RadAjaxManager.GetCurrent(Page).ClientID %>").ajaxRequest();

In on the page the AjaxManger updates the panel, in the other the setting is that the proxy should update the panel. This is invalid setting.

<telerik:AjaxSetting AjaxControlID="RadAjaxManagerProxy1" >
    <UpdatedControls>
        <telerik:AjaxUpdatedControl ControlID="rsLeftPanel" LoadingPanelID="ralp1" />
    </UpdatedControls>
</telerik:AjaxSetting>

The correct way of doing this is to use add the settings programatically, or to use the ajaxRequestWithTarget instead of ajaxRequest method
http://docs.telerik.com/devtools/aspnet-ajax/controls/ajax/radajaxmanager/how-to/add-ajaxsettings-programmatically
Declined
Last Updated: 17 Aug 2015 11:28 by ADMIN
Won't Fix
Last Updated: 16 Jul 2015 08:36 by ADMIN
The Response.Redirect is not supposed to work during through Ajax call. 
Completed
Last Updated: 16 Jul 2015 08:34 by ADMIN
When a RadContol is placed into a RadAjaxPanel, its method DescribeComponent is fired twice on postback.
Declined
Last Updated: 17 Mar 2015 12:00 by Jeff
Created by: Jeff
Comments: 3
Category: Ajax
Type: Bug Report
0
Using RadAjax controls. Using a RadMenu control and referencing an image for the submenus using the ImageUrl property. Code is in AdminMenu.ascx file.

Running from Visual Studio 2013

In Version 2014.1.403.40 of the dlls, the images do not align properly with the child menu items. Tested this in both Chrome and IE 11 and neither aligns the images properly. Screenshot: MisalignedMenuItemImages.png

In Version 2013.3.1324.40 of the dlls, the images algin properly. Screenshot: ProperlyAlignedMenuImages.png
Unplanned
Last Updated: 17 Mar 2015 08:40 by ADMIN
Had a go to meeting to discuss Telerik tools integration with Desislava Nikolo and another consultant. They acknowledged this issue and resolved to contact me after the meeting to provide a fix. 
Basically, from the Telerik Tab in the IDE 2010, I am unable to load any of the RAD tools for development.
Declined
Last Updated: 05 Mar 2015 08:48 by ADMIN
Our project  works fine with .Net 3.5  with Telerik 2009.2.701.35  version.

When it is migrated to .Net 4.5 framework.  
It throws error like this.
"0x800a139e - Microsoft JScript runtime error: Sys.WebForms.PageRequestManagerServerErrorException: 
Object reference not set to an instance of an object."

Detailed Error message is given.


Unhandled exception at line 3, column 69963 in http://localhost:57537/...../Telerik.Web.UI.WebResource.axd?_TSM_HiddenField_=ctl00_DefaultMasterScriptManager_TSM&compress=1&_TSM_CombinedScripts_=;
;AjaxControlToolkit,+Version=4.5.7.725,+Culture=neutral,+PublicKeyToken=28f01b0e84b6d53e:en-US:f3ec7948-9e31-4562-b526-b0088d3f7327:
ea597d4b:b25378d2;Telerik.Web.UI,+Version=2013.1.417.45,+Culture=neutral,+PublicKeyToken=121fae78165ba3d4:
en-US:42f3bd03-686e-4514-94d4-9dc03944a160:16e4e7cd:ed16cbdc:f7645509:24ee1bba:19620875:874f8ea2:f46195d3:490a9d4e:bd8f85e4:
2003d0b8:e330518b:1e771326:c8618e41:b7778d6c:e085fe68:8e6f0d33:6a6d718d:8674cba1:7c926187:c08e9f8a:a51ee93e:59462f1:
aa288e2d:82923ac3:58366029

0x800a139e - Microsoft JScript runtime error: Sys.WebForms.PageRequestManagerServerErrorException: 
Object reference not set to an instance of an object.

If there is a handler for this exception, the program may be safely continued.




So it is upgraded to Telerik  2013.1.417.45 version.  It is throwing  same error.  [Even tried with Latest Telerik AspnetAjax Q2 version is also throwing the same error]


I suspect that the error might be because the AjaxRadManager  and/or  skins which is implemented from  Telerik.Web.UI. Skins.dll  is causing the 
trouble. 
 
Declined
Last Updated: 21 Jan 2015 09:51 by Phillip Moore
I'm not sure if this should be RadAjax, RadDock, or RadListView.
I have been trying to use the RadListView to page RadDocks.  The ultimate goal is to page 4 RadDocks at a time.  The RadDocks have RadAjaxPanels inside of them.  The ajax panels are used to update content inside the RadDock items.

When I call the Ajax Request on the RadAjaxPanel the first time, the Ajax Request works fine.  Any subsequent times, the page is reloaded (postback).  We expect that we should continue to get Ajax Requests.

Any help would be appreciated.
Declined
Last Updated: 20 Jan 2015 08:26 by ADMIN
Created by: Alex
Comments: 1
Category: Ajax
Type: Bug Report
1
Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; GTB7.5; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET4.0C; .NET4.0E)
Timestamp: Tue, 5 Nov 2013 20:08:42 UTC


Message: Expected identifier
Line: 541
Char: 18
Code: 0
URI: http://test/Telerik.Web.UI.WebResource.axd?_TSM_HiddenField_=rsmMain_TSM&compress=1&_TSM_CombinedScripts_=%3b%3bSystem.Web.Extensions%2c+Version%3d4.0.0.0%2c+Culture%3dneutral%2c+PublicKeyToken%3d31bf3856ad364e35%3aen-US%3ac9cbdec3-c810-4e87-846c-fb25a7c08002%3aea597d4b%3ab25378d2%3bRMSWeb%3aen-US%3affbcc4ad-6e36-47e9-bd28-56e10d4d3ccd%3a43e04e1c%3ae90c43c6%3ac2fa243f%3a748e57f2%3bLAO.Web%3aen-US%3a789e0dea-6f9a-4c0f-a1db-5b64c6e6f0d7%3ad16f8f2a%3ae282b917%3bTelerik.Web.UI%2c+Version%3d2013.3.1015.45%2c+Culture%3dneutral%2c+PublicKeyToken%3d121fae78165ba3d4%3aen-US%3a7a1d9c2d-6cf2-464f-9ad3-e479c730ac61%3a16e4e7cd%3aed16cbdc%3af7645509%3a24ee1bba%3a874f8ea2%3af46195d3%3a92fe8ea0%3a19620875%3afa31b949%3a490a9d4e%3abd8f85e4%3a88144a7a%3a1e771326%3a4cacbc31%3a2003d0b8%3ae524c98b%3aa7e79140%3ab7778d6c%3a7165f74%3a58366029%3aaa288e2d 
Declined
Last Updated: 02 Sep 2014 13:28 by ADMIN
Created by: Lohith
Comments: 2
Category: Ajax
Type: Bug Report
0
We see that there is Memory Leak when using Rad controls.  IE process memory keeps increasing until the process crashes.  I am attaching a sample webpage default.aspx.  You could use it to simulate it.  Leave the IE browsing running after navigating to the page.  You gradually see that the memory consumed by IE increase.  Please also note I have not written any javascript used default functionality provided as is.
These application where in we use telerik run for long and ajax calls keep running in the background and hence they are crashing.  Please do have a look and if possible let us know if there is any way to avoid it.
version of telerik that we have tried: 2012.3.1308.40 & 2013.1.220.0
version of IE used 8.0.760.1.17514
other versions of IE also have the issue.  
Hope you respond soon.
1 2