Approved
Last Updated: 22 May 2019 15:38 by ADMIN
Created by: Chris Dalessandri
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
0

Reproduction steps:

Go to the Telerik demo at https://demos.telerik.com/aspnet-ajax/textbox/overview/defaultcs.aspx
In the Comment box, type "one two".  Do not let the textbox lose focus.
Highlight "two" and start to drag it to move it before "one". The other text ("one") will disappear, and is gone forever, as far as I can tell.

It can be also reproduced with this configuration:

<telerik:RadTextBox RenderMode="Lightweight" runat="server" ID="RadTextBox3" Width="200px" EmptyMessage="Enter comment" TextMode="MultiLine" Height="100px" Resize="None"></telerik:RadTextBox>

Approved
Last Updated: 17 May 2019 06:57 by ADMIN
Created by: Kasim
Comments: 3
Category: PivotGrid
Type: Bug Report
1

The code in the ASPx file is 

 <DataCellStyle CssClass="cfDataCell" Width="9%"/>


The expected output in the client browser is


 <tr style="height: 35px;">
        <td class="rpgDataCell cfDataCell" style="width:9%;">823</td>
        <td class="rpgDataCell cfDataCell" style="width:9%;">2,488</td>
        <td class="rpgDataCell cfDataCell" style="width:9%;">7,518</td>
        <td class="rpgDataCell cfDataCell" style="width:9%;">10,851</td>
        <td class="rpgDataCell cfDataCell" style="width:9%;">13,017</td>
        <td class="rpgDataCell cfDataCell" style="width:9%;">13,069</td>
        <td class="rpgDataCell cfDataCell" style="width:9%;">13,253</td>
        <td class="rpgDataCell cfDataCell" style="width:9%;">12,799</td>
        <td class="rpgDataCell cfDataCell" style="width:9%;">9,861</td>
        <td class="rpgDataCell cfDataCell" style="width:9%;">4,543</td>
        <td class="rpgDataCell cfDataCell" style="width:9%;">2,038</td>
        <td class="rpgDataCell cfDataCell" style="width:9%;">592</td>
      </tr>

However the generated Html is as below:


 <tr style="height: 35px;">
        <td class="rpgDataCell" style="width:9%;">823</td>
        <td class="rpgDataCell" style="width:9%;">2,488</td>
        <td class="rpgDataCell" style="width:9%;">7,518</td>
        <td class="rpgDataCell" style="width:9%;">10,851</td>
        <td class="rpgDataCell" style="width:9%;">13,017</td>
        <td class="rpgDataCell" style="width:9%;">13,069</td>
        <td class="rpgDataCell" style="width:9%;">13,253</td>
        <td class="rpgDataCell" style="width:9%;">12,799</td>
        <td class="rpgDataCell" style="width:9%;">9,861</td>
        <td class="rpgDataCell" style="width:9%;">4,543</td>
        <td class="rpgDataCell" style="width:9%;">2,038</td>
        <td class="rpgDataCell" style="width:9%;">592</td>
      </tr>

Completed
Last Updated: 16 May 2019 15:54 by ADMIN
Created by: Sergey
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
3

Hello,

There seems to be a bug with the RadEditor "Find and Replace" feature. I have recorded a screencast available here documenting the issue and will also provide below the information written: https://www.screencast.com/t/MXFawxIPp

Reproduction Steps:

Expected: '<img' is replaced with '<picture'

Actual:'<img' is replaced with '&lt;picture'

Notes:This seems to be an issue with encoding as &lt; is a less than tag. As you can see in the video, I do not think there is a way to escape the character to allow it to be replaced correctly. If you have additional questions, please ask.

 

Best Regards

Completed
Last Updated: 15 May 2019 09:05 by ADMIN
Can be reproduced with the code below:

<telerik:RadEditor runat="server" ID="RadEditor1" >
    <Content>
   Here is sample content!
    </Content>
</telerik:RadEditor>
 
<input type="button" value="Set Focus On RadEditor" onclick="SetFocusOnRadEditor(); return false;" />
<script type="text/javascript">
    function SetFocusOnRadEditor() {
        var editor = $find("<%=RadEditor1.ClientID%>"); //get a reference to RadEditor client object
            editor.setFocus(); //set the focus on the the editor
    }
</script>


The problem is not reproducible when the ContentAreaMode is set to DIV or in the other browsers.

Workaround

<telerik:RadEditor runat="server" ID="RadEditor1">
    <Content>
    Here is sample content!
    </Content>
</telerik:RadEditor>
 
<button type="button"  onclick="SetFocusOnRadEditor()">Focuse On RadEditor</button>
<script type="text/javascript">
    function SetFocusOnRadEditor() {
        var editor = $find("<%=RadEditor1.ClientID%>");
        if ($telerik.isChrome) {
            var iframe = editor.get_contentAreaElement();
            iframe.contentWindow.document.body.focus();
        }
        else {
                editor.setFocus();
        }
    }
</script>
Completed
Last Updated: 14 May 2019 11:56 by ADMIN

Use The following markup:
 
<telerik:RadEditor runat="server"  ID="RadEditor1" ToolbarMode="Floating"></telerik:RadEditor>          
<telerik:RadEditor runat="server"  ID="RadEditor2" ToolProviderID="RadEditor1" ToolbarMode="Floating"></telerik:RadEditor>           
<telerik:RadEditor runat="server"  ID="RadEditor3" ToolProviderID="RadEditor1" ToolbarMode="Floating"> </telerik:RadEditor>
 
Open RadEditor1 toolbar;
Open RadEditor2 toolbar;
 
Expected: No errors are thrown'
 
Actual: The following error is thrown: 
Line: 1135Error: Unable to get property 'getElementsByTagName' of undefined or null reference

 
Use The following markup:
 
  <telerik:RadEditor runat="server"  ID="RadEditor1" ToolbarMode="Floating">            </telerik:RadEditor>            <telerik:RadEditor runat="server"  ID="RadEditor2" ToolProviderID="RadEditor1" ToolbarMode="Floating">            </telerik:RadEditor>            <telerik:RadEditor runat="server"  ID="RadEditor3" ToolProviderID="RadEditor1" ToolbarMode="Floating">            </telerik:RadEditor>
 
 
Open RadEditor1 toolbar;
 
Open RadEditor2 toolbar;
 
Expected: No errors are thrown'
 
Actual: The following error is thrown:
 
Line: 1135Error: Unable to get property 'getElementsByTagName' of undefined or null reference
 
Use The following markup:
 
  <telerik:RadEditor runat="server"  ID="RadEditor1" ToolbarMode="Floating">            </telerik:RadEditor>            <telerik:RadEditor runat="server"  ID="RadEditor2" ToolProviderID="RadEditor1" ToolbarMode="Floating">            </telerik:RadEditor>            <telerik:RadEditor runat="server"  ID="RadEditor3" ToolProviderID="RadEditor1" ToolbarMode="Floating">            </telerik:RadEditor>
 
 
Open RadEditor1 toolbar;
 
Open RadEditor2 toolbar;
 
Expected: No errors are thrown'
 
Actual: The following error is thrown:
 
Line: 1135Error: Unable to get property 'getElementsByTagName' of undefined or null reference
Approved
Last Updated: 09 May 2019 07:55 by ADMIN
We are using the Telerik tabStrip ASP.NET AJAX control.

We have set PerTabScrolling="true" on the tabStrip.

Then we have hidden a tab on the client side that is apart of the tabstrip.

Now when we scroll to the end of the list we receive a JavaScript error: Sys.InvalidOperationException: Cannot serialize non finite numbers.

This only happens when we hide a tab.

 
Approved
Last Updated: 07 May 2019 11:43 by ADMIN
In Classic RenderMode, Windows7 skin, TreeView nodes are higher when inside ContentTemplate of RadPanelBarItem:



<div>
    wrong:
    <telerik:RadPanelBar RenderMode="Classic" Skin="Windows7" runat="server" ID="RadPanelBar1" Width="100%" Height="100%">
        <Items>
            <telerik:RadPanelItem Text="Custom" Expanded="true">
                <ContentTemplate>
                    <telerik:RadTreeView RenderMode="Classic" Skin="Windows7" ID="radTreeView" runat="server">
                        <Nodes>
                            <telerik:RadTreeNode  Text="Custom">
                                <Nodes>
                                </Nodes>
                            </telerik:RadTreeNode>
                            <telerik:RadTreeNode  Text="Custom">
                                <Nodes>
                                </Nodes>
                            </telerik:RadTreeNode>
                            <telerik:RadTreeNode  Text="Custom">
                                <Nodes>
                                </Nodes>
                            </telerik:RadTreeNode>
                        </Nodes>
                    </telerik:RadTreeView>
                </ContentTemplate>
            </telerik:RadPanelItem>
        </Items>
    </telerik:RadPanelBar>
</div>
<div>
        OK:
    <telerik:RadTreeView ID="radTreeView2" RenderMode="Classic" Skin="Windows7" runat="server">
        <Nodes>
            <telerik:RadTreeNode Text="Custom">
                <Nodes>
                </Nodes>
            </telerik:RadTreeNode>
            <telerik:RadTreeNode  Text="Custom">
                <Nodes>
                </Nodes>
            </telerik:RadTreeNode>
            <telerik:RadTreeNode  Text="Custom">
                <Nodes>
                </Nodes>
            </telerik:RadTreeNode>
        </Nodes>
    </telerik:RadTreeView>
</div>


Approved
Last Updated: 06 May 2019 12:26 by ADMIN
Problem:

In the RadEditor we have the NewLineMode set to Div
We are also using a ToolsFile xml document to control the tools available in RadEditor.
The problem is the InsertParagraph tool now inserts <div> tags instead of <p> tags.
We want to keep the NewLineMode behavior as DIV while still having a tool that can insert a paragraph (i.e. a <p> tag).

To replicate this problem:

On the RadEditor demo page, first set "NEW LINES AS" to "Divs".
Then, in the editor content area just above the "Destinations" table, Type in three lines:
Comment1
Comment2
Comment3

If you then toggle to the HTML tab, you will see that the Comment1 line is (incorrectly) bracketed by a <p> tag while the Comment2 and Comment3 lines are (correctly) bracketed by <div> tags.

Next, go back to the Design tab and position yourself at the beginning of the Comment3 line then click the [Insert Paragraph] button.

In the newly inserted "paragraph" type "Comment2b".

If you then toggle to the HTML tab you will see that Comment2b is incorrectly bracketed by a <div> tag.  It should be a <p> tag.

Pending Review
Last Updated: 02 May 2019 08:52 by ADMIN
Created by: Vance
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
0

Steps to repro:

1. Go to https://demos.telerik.com/aspnet-ajax/chat/toolbar/defaultcs.aspx

2. Show the toolbar with the ellipses

3. Enter enough messages so that the scroll is shown and continue to enter

4. The toolbar drop down on each click of an icon

See the attached video for more information.

Pending Review
Last Updated: 30 Apr 2019 10:06 by ADMIN
If anchor links of GridButtonColumn do not define a text links are still rendered and screen readers read their href attribute. Anchor links with no text could define an attribute area-hidden="true".
Declined
Last Updated: 26 Apr 2019 07:59 by ADMIN
Created by: Kaarthic
Comments: 1
Category: Grid
Type: Bug Report
0
I have added Listview in Header template in Template column, its showing the data on the grid as expected. When I am exporting to Excel or PDF its not exporting the header. Header you see in headertemplate.jpg is not exporting to PDF

Thanks
Approved
Last Updated: 23 Apr 2019 08:37 by ADMIN
Hello guys,

 

We've faced an issue with menu on several RAD controls when running on MacOS 10.14.x (Mojave) with FireFox 66.0.x (Quantum).

Using touchpad or mouse, when right clicking for context menu, it just flashed and doesn't stay open: it opens and then suddenly closes.

We are using Telerik Asp.Net Ajax version 2017.2.503.40 but it can be also replicated on your demo version:

https://demos.telerik.com/aspnet-ajax/grid/examples/columns-rows/columns/context-menu/defaultcs.aspx

https://demos.telerik.com/aspnet-ajax/scheduler/examples/overview/defaultcs.aspx


Not sure if you can provide a fast workaround for this but I just wanted to let you know.

I've checked for some open cases before creating this thread and hope I didn't duplicate something. Please move/close it if necessary.

 

Regards,

Andrei V.
Pending Review
Last Updated: 23 Apr 2019 08:33 by CaseNet
When the RenderMode of RadGrid is set to Mobile and UniqueName is different from the DataField then trying to Ungroup an item, it throws an exception: Object reference not set to an instance of an object
Approved
Last Updated: 22 Apr 2019 13:10 by ADMIN
I have a few instances where I need OnClientSelectedIndexChanging inorder to stop the listbox selectedIndexChanged event from posting back in certain cases. In those cases I stop it from posting back by setting the e.set_cancel(true);

function CheckForListBoxReorder_OnClientEvent(sender, e) {
    if (ListboxReordered()) {
        alert('Please save changes to the bus order.');
        e.set_cancel(true);
    }
}

This works very nicely, but I'm getting many errors because although it looks like it's still selected to the proper row in the listbox the selectedIndex is now -1.
Pending Review
Last Updated: 19 Apr 2019 13:20 by Jon
RadCodeBLock and RadScriptBlock is not able to handle the server tags for all case scenarios, hence RadAjaxManager throws the exception mentioned in the title.
Approved
Last Updated: 19 Apr 2019 09:41 by ADMIN

Using CommandItemTemplate (Grid - Command Item) for Editing DetailTable records and selecting an item after filtering or from another page, one item from the first page is put for editing instead. Open the attached GIF animation (EditSelectedEditWrongItem.gif) to see it in action.

 

Currently the workaround we offer is to handle the EditSelected command manually for all the DetailTables Except for the Master.

 

Grid markup:

 

        <telerik:RadGrid ID="RadGrid1" runat="server" AllowPaging="True" Width="100%" PageSize="3"
            OnItemCommand="RadGrid1_ItemCommand"
            OnDetailTableDataBind="RadGrid1_DetailTableDataBind"
            OnNeedDataSource="RadGrid1_NeedDataSource">
            <MasterTableView Name="MasterTable" AutoGenerateColumns="true" DataKeyNames="OrderID">
                <DetailTables>
                    <telerik:GridTableView Name="ChildTable" DataKeyNames="OrderID" AutoGenerateColumns="true" CommandItemDisplay="Top">
                        <CommandItemTemplate>
                            <asp:LinkButton ID="btnEditSelected" runat="server" CommandName="EditSelected" CssClass="btn btn-default">Edit Selected</asp:LinkButton>
                        </CommandItemTemplate>
                    </telerik:GridTableView>
                </DetailTables>
            </MasterTableView>
            <ClientSettings>
                <Selecting AllowRowSelect="true" />
            </ClientSettings>
        </telerik:RadGrid>

 

C# - ItemCommand

 

    protected void RadGrid1_ItemCommand(object sender, GridCommandEventArgs e)
    {
        // Logic applies for all the tables (detail tables) which are not named "MasterTable"
        if(e.Item.OwnerTableView.Name != "MasterTable" && e.CommandName == RadGrid.EditSelectedCommandName)
        {
            e.Canceled = true;

            GridTableView detailTable = e.Item.OwnerTableView;

            if (detailTable.OwnerGrid.SelectedIndexes.Count == 0)
            {
                return;
            }

            foreach (GridDataItem selectedItem in detailTable.OwnerGrid.SelectedItems)
            {
                selectedItem.Edit = true;
            }

            detailTable.Rebind();
        }
    }

 

VB - ItemCommand


Protected Sub RadGrid1_ItemCommand(ByVal sender As Object, ByVal e As GridCommandEventArgs)
    If e.Item.OwnerTableView.Name <> "MasterTable" AndAlso e.CommandName = RadGrid.EditSelectedCommandName Then
        e.Canceled = True
        Dim detailTable As GridTableView = e.Item.OwnerTableView

        If detailTable.OwnerGrid.SelectedIndexes.Count = 0 Then
            Return
        End If

        For Each selectedItem As GridDataItem In detailTable.OwnerGrid.SelectedItems
            selectedItem.Edit = True
        Next

        detailTable.Rebind()
    End If
End Sub

Approved
Last Updated: 19 Apr 2019 05:50 by ADMIN
ImageEditor keeps in the undo stack a reference to the last written text, but not last inserted one. 

Video: https://www.screencast.com/t/z6z5gwA6

Steps to reproduce:

1. Open https://demos.telerik.com/aspnet-ajax/imageeditor/examples/overview/defaultcs.aspx
2. Click the add text tool and insert "One"
3. Click the add text tool and insert "Two"
4. Click the add text tool, write "Three" and cancel/close the dialog
5. Click "Undo"
6. Click "Redo"
Result: The last written "Three" string is inserted instead of the expected "Two"

Completed
Last Updated: 18 Apr 2019 11:21 by ADMIN
Code snippets coming after remove table style from insert table popup in chrome,ie,ff.

I am facing a big problem in editor please give any solution.

Link: https://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx

Steps to reproduce

Step 1

Try to insert table from Insert Table from editor toolbar.

Step 2

Right click on cell then click on Table/cell properties. A table wizard popup will come.

Step 3

Click on Table Layouts tab on the table wizard popup.

Step 4

Select any value from table styles drop down.

Step 5

Now you can see  TABLE>TR>TD>RemoveElement on the bottom of the editor.click on RemoveElement .

After click on RemoveElement you can see STYLE>RemoveElement  again click on RemoveElement.

then you can see like below in the editor.

.telerik-reTable-2 { border-collapse: collapse; border: solid 0px; font-family: Tahoma; } .telerik-reTable-2 tr.telerik-reTableHeaderRow-2 { border-width: 1.0pt 1.0pt 3.0pt 1.0pt...........
Completed
Last Updated: 18 Apr 2019 07:43 by ADMIN
If you put a radspreadsheet inside a radtabstrip with multipage, the controls do not render properly.

In my scenario, I have a tabstrip embedded within a tabstrip, and a grid in the nested tabstrip.  That works fine.  Once you put a spreadsheet control in the multipage, the controls do not render properly. 

However, I was able to reproduce the results with the first scenario above, which is the most simple.
1 2 3 4 5 6