Completed
Last Updated: 22 Sep 2021 13:35 by Leonardo
Created by: Leonardo
Comments: 3
Type: Bug Report
1

Simple as that: fiddler everywhere does not capture traffic to localhost, 172.0.0.1 AND when you insert your local address, it captures your request only to return that "

[Fiddler] DNS Lookup for "www.192.168.0.18" failed. System.Net.Internals.SocketExceptionFactory+ExtendedSocketException Device not configured

"...

 

MAC OSX, using safari.

Other address are captured as expected

Completed
Last Updated: 22 Sep 2021 08:56 by ADMIN
Created by: Olga
Comments: 2
Type: Bug Report
1

I'm running on an Ubuntu 18.04 server. using VNC via gdm3 (gnome) display manager.

The first time I tried to run progress-telerik-fiddler.AppImage, it brought up a dialog asking if I wanted to integrate with VNC and install a desktop icon, to which I answered yes.

The window then closed, and each time I try to run progress-telerik-fiddler.AppImage again, nothing at all happens, as follows:

wxr-xr-x 1 root root 113958410 Mar 25 14:15 progress-telerik-fiddler.AppImage
root@cupertino:/nethome/osmolyar/fiddler#

There is no desktop icon, log, or anything.

Completed
Last Updated: 22 Sep 2021 08:54 by ADMIN

tazik@mx-linux:/mnt/Software/Linux $ ./progress-telerik-fiddler.AppImage --no-sandbox License accepted zenity, kdialog, Xdialog missing. Skipping /tmp/.mount_progrekwdZmY/AppRun. 14:44:47.550 › [Product information] Progress Telerik Fiddler 0.5.0 14:44:47.561 › [System information] Linux mx-linux 4.19.0-6-amd64 #1 SMP Debian 4.19.67-2+deb10u2 (2019-11-11) x86_64 GNU/Linux 14:44:47.698 › Initializing splash screen. 14:44:47.832 › Attempting to run server - 5 attempts left. 14:44:47.832 › Generating random port. 14:44:47.833 › Trying to start server at port [39169]. 14:44:49.324 › Fetching .NET Core server status. 14:44:49.338 › Error occurred while fetching .NET Core server [39169] status. Error message: connect ECONNREFUSED 127.0.0.1:39169 14:44:49.338 › Attempting to run server - 4 attempts left. 14:44:49.338 › Generating random port. 14:44:49.338 › Trying to start server at port [14105]. 14:44:50.065 › Fetching .NET Core server status. 14:44:50.071 › Error occurred while fetching .NET Core server [14105] status. Error message: connect ECONNREFUSED 127.0.0.1:14105 14:44:50.072 › Attempting to run server - 3 attempts left. 14:44:50.072 › Generating random port. 14:44:50.072 › Trying to start server at port [64355]. 14:44:50.788 › Fetching .NET Core server status. 14:44:50.792 › Error occurred while fetching .NET Core server [64355] status. Error message: connect ECONNREFUSED 127.0.0.1:64355 14:44:50.792 › Attempting to run server - 2 attempts left. 14:44:50.792 › Generating random port. 14:44:50.792 › Trying to start server at port [4034]. 14:44:51.504 › Fetching .NET Core server status. 14:44:51.509 › Error occurred while fetching .NET Core server [4034] status. Error message: connect ECONNREFUSED 127.0.0.1:4034 14:44:51.509 › Attempting to run server - 1 attempts left. 14:44:51.510 › Generating random port. 14:44:51.510 › Trying to start server at port [28542]. 14:44:52.228 › Fetching .NET Core server status. 14:44:52.233 › Error occurred while fetching .NET Core server [28542] status. Error message: connect ECONNREFUSED 127.0.0.1:28542 14:44:52.233 › Attempting to run server - 0 attempts left. 14:44:52.234 › Maximum number of attempts reached - quitting application. 14:44:52.260 › Generating random port. 14:44:52.261 › Trying to start server at port [25311]. tazik@mx-linux:/mnt/Software/Linux

 


Hi all,
I tried to start app but every time nothing happens except short appearing a splash screen. Bellow detail from terminal:

***************

tazik@mx-linux:/mnt/Software/Linux
$ ./progress-telerik-fiddler.AppImage --no-sandbox
License accepted
zenity, kdialog, Xdialog missing. Skipping /tmp/.mount_progrekwdZmY/AppRun.
14:44:47.550 › [Product information] Progress Telerik Fiddler 0.5.0
14:44:47.561 › [System information] Linux mx-linux 4.19.0-6-amd64 #1 SMP Debian 4.19.67-2+deb10u2 (2019-11-11) x86_64 GNU/Linux
14:44:47.698 › Initializing splash screen.
14:44:47.832 › Attempting to run server - 5 attempts left.
14:44:47.832 › Generating random port.
14:44:47.833 › Trying to start server at port [39169].
14:44:49.324 › Fetching .NET Core server status.
14:44:49.338 › Error occurred while fetching .NET Core server [39169] status. Error message: connect ECONNREFUSED 127.0.0.1:39169
14:44:49.338 › Attempting to run server - 4 attempts left.
14:44:49.338 › Generating random port.
14:44:49.338 › Trying to start server at port [14105].
14:44:50.065 › Fetching .NET Core server status.
14:44:50.071 › Error occurred while fetching .NET Core server [14105] status. Error message: connect ECONNREFUSED 127.0.0.1:14105
14:44:50.072 › Attempting to run server - 3 attempts left.
14:44:50.072 › Generating random port.
14:44:50.072 › Trying to start server at port [64355].
14:44:50.788 › Fetching .NET Core server status.
14:44:50.792 › Error occurred while fetching .NET Core server [64355] status. Error message: connect ECONNREFUSED 127.0.0.1:64355
14:44:50.792 › Attempting to run server - 2 attempts left.
14:44:50.792 › Generating random port.
14:44:50.792 › Trying to start server at port [4034].
14:44:51.504 › Fetching .NET Core server status.
14:44:51.509 › Error occurred while fetching .NET Core server [4034] status. Error message: connect ECONNREFUSED 127.0.0.1:4034
14:44:51.509 › Attempting to run server - 1 attempts left.
14:44:51.510 › Generating random port.
14:44:51.510 › Trying to start server at port [28542].
14:44:52.228 › Fetching .NET Core server status.
14:44:52.233 › Error occurred while fetching .NET Core server [28542] status. Error message: connect ECONNREFUSED 127.0.0.1:28542
14:44:52.233 › Attempting to run server - 0 attempts left.
14:44:52.234 › Maximum number of attempts reached - quitting application.
14:44:52.260 › Generating random port.
14:44:52.261 › Trying to start server at port [25311].
tazik@mx-linux:/mnt/Software/Linux
Completed
Last Updated: 22 Sep 2021 08:44 by ADMIN
Created by: Roman
Comments: 1
Type: Bug Report
0

Im using MacOS Sierra 10.12.5

 

2 BIG Issues are present.

First of all, I don't have an INTERNET connection any more after closing FIDDLER it has to be always running!

Second issue Fiddler is working properly ONLY on the first Start. If  closing it and opening it again it's not working at all.

FIX this ASAP

 

very very critical

Completed
Last Updated: 22 Sep 2021 08:30 by ADMIN
Summary:

When I toggle the 'Live Traffic (Capturing)', mac prompts for a password. When this prompt is canceled by the user (no password entered) the toggle incorrectly toggles to off/on.

 

Steps to Reproduce:

1. Fiddler Everywhere open on a Mac

2. Toggle 'Live Traffic (Capturing)'

3. Select 'Cancel'

4. Notice Toggle changes state and the state of the Capturing does not change. 

Expected Result: The 'Live Traffic (Capturing)' toggle does not change state if the mac users permissions are not accepted. 

 

Observed Result: The 'Live Traffic (Capturing)' toggle changes state if the mac users permissions are not accepted. 

Completed
Last Updated: 22 Sep 2021 07:52 by ADMIN

While inspecting requests where Content-Length > 3000, only 3000 characters of the request body gets displayed in both Raw and Text views. When I copy the whole contents of the selectable area (CMD + A, CMD + C) and paste it into a text editor, it seems like there is a 'View full request...' text somewhere which does not show up. I remember this button from previous versions. 

OS : macOS Mojave Version 10.14.6

A sample HTML with dummy form to reproduce the bug and recorded session is attached. 

Completed
Last Updated: 22 Sep 2021 07:50 by ADMIN

On Request Inspector, Web Forms Tab, the header row seems duplicate. 

Completed
Last Updated: 22 Sep 2021 07:48 by ADMIN

On Request Inspector Screen, Web Forms Tab, I'm unable to highlight or copy contents. Cmd + A also doesn't work to highlight contents. 
Completed
Last Updated: 22 Sep 2021 07:38 by ADMIN

Latest version of Fiddler (v0.10.0) and Android Emulator is not proxying the connections properly.

I have Fiddler Everywhere running and know it is working when I can send requests through Postman and see them show up in Fiddler properly.

However, if I set up the Android Emulator through Android Studio, and set the proxy to be Fiddler, connections do not fully reach the backend service I am sending requests to. All that shows up in Fiddler is

REQUEST

CONNECT 192.168.5.7:5000 HTTP/1.1
Host: 192.168.5.7:5000

RESPONSE

HTTP/1.1 200 Connection Established
FiddlerGateway: Direct
StartTime: 16:12:05.141
Connection: close

The service is running on my local host machine (192.168.5.7) on port 5000.

If I close Fiddler and run charles-proxy, then set the Android Emulator to use that as the proxy, I see the full request, my service responds, and I see the response in Charles.

Completed
Last Updated: 22 Sep 2021 07:34 by ADMIN

Steps to reproduce:

  1. Post a 69k request to a web api (encoded JSON data) via browser.
  2. Inspect request data in Text and Raw fields.
  3. Observe that the data is truncated in the middle of a property name (not a null char).

Example data posted (snippet with middle section excerpted):

valuesString=%7B%22request%22%3A%...oneTimeApproval%22%3A%22no%22%2C%22immediatePatientSaf

There is much more data that should occur after the property "immediatePatientSafety".  There does appear to possibly be additional fields presented in the Web Form inspector although some of the values are truncated and have an ellipsis (...) following those lines, so I believe that the tool is capturing the data but will not make it visible or available in the Text or Raw Inspectors.

No option exists to configure the amount of request data that is captured or to cause the Inspector to "show more" data.

I need to be able to see the full text request to troubleshoot an issue with the back-end application.

I need the data available in the Text or Raw inspector so that I can cut and paste it out for external processing and discussion with the developers.

I noted that a separate bug report has been issued for a missing "show more data" option on large response records.

Thanks,
Daniel

 

 

Completed
Last Updated: 22 Sep 2021 07:32 by ADMIN

I'm unable to connect to "gateway.icloud.com" when Fiddler is open and decrypting HTTPS traffic.

This is Fiddler Everywhere 0.10.0 on macOS 10.15.5.

To reproduce:

Open Fiddler and make sure it's decrypting HTTPS traffic.

Open any browser and go to https://gateway.icloud.com/

Expected result: Page loads (it's blank. This is normal.)

What actually happens: fiddler.network.https> HTTPS handshake to gateway.icloud.com (for #820) failed. System.Security.Authentication.AuthenticationException The remote certificate is invalid according to the validation procedure.

 

Same thing happens on https://configuration.apple.com/

Completed
Last Updated: 22 Sep 2021 07:19 by ADMIN

MacOs, Fiddler Everywhere 10, Cisco AnyConnect.

Here's the workflow...

In the morning, Cisco VPN isn't connected.  All traffic is blocked by design.  Attempt to start Fiddler Everywhere.  WON'T START because it can't login.  What is this new requirement to login?  If I don't start Fiddler before the VPN, no traffic ever logs.  If i don't start the VPN, Fiddler won't start.  A bit of a cartch-22, ya think?

Somehow I bypass the VPN (Don't tell corp security) and get logged-in.  Fiddler is up.  Start the VPN. Get some work done.  Shiny new UI!  Still can't drag-drop from inspector to composer?  Damn.

At some point the Fiddler login EXPIRES.  Why does it expire?  What do I even need a login for?  At this point ALL TRAFFIC fails, since Fiddler was the system proxy.  All work stops.  Now I need to stop Fiddler, Stop the VPN, attempt to start Fiddler again....oh wait, can't login because the VPN is down...  here we go again.

This is all a serious waste of time.  I can see registering Fiddler so you know who your users are.  What's with the REQUIREMENT to have a login, and why does it expire?  It kinda makes Fiddler useless.

Please remove the requirement to login to an account before being able to use Fiddler Everywhere.

 

Thanks,

Sean

Completed
Last Updated: 31 Jul 2020 08:20 by ADMIN
Created by: qiao
Comments: 1
Type: Bug Report
0

the logs:

```

 ~/soft  ./fiddler-everywhere-0.11.0.AppImage 

[8989:0727/220513.696997:FATAL:setuid_sandbox_host.cc(157)] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I'm aborting now. You need to make sure that /tmp/.mount_fiddle4WxzEm/chrome-sandbox is owned by root and has mode 4755.
[1]    8989 trace trap  ./fiddler-everywhere-0.11.0.AppImage

```

the environment:

Linux pc 5.3.0-3-amd64 #1 SMP deepin 5.3.15-6apricot (2020-04-13) x86_64 GNU/Linux
Completed
Last Updated: 01 Jun 2020 14:35 by ADMIN

howdy,

I've downloaded the latest 0.4.0 Fiddler Everywhere. When I run it I get an error - "A JavaScript error occurred in the main process". This occurs every time I launch the app. However it appears to run normally after I dismiss the error dialog.

I'm running Ubuntu 18.0.4:

```

lsb_release -a

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.2 LTS
Release: 18.04
Codename: bionic

```

 

Completed
Last Updated: 01 Jun 2020 14:21 by ADMIN
If you go to Composer and compose a request, if you switch back to inspector for whatever reason (fetch some info for exemple) the composer resets to an empty state!
Completed
Last Updated: 01 Jun 2020 14:06 by ADMIN

Platform: Linux.
Product: Progress Telerik Fiddler 0.5.0, downloaded today.

Bug 1: switching between Composer and Inspectors clear Composer fields
Start the program
Click Composer on the right side
Under Headers, fill something in
Click on Inspectors on the right side
Click Composer on the right side
The text under Headers is now resetted

Bug 2: POST body double new line delimiter and body data are formatted as headers
Start the program
Click Composer on the right side
Select POST

Under Headers, fill in a POST header:

Host: example.com
User-Agent: test
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
Accept-Language: en-US;q=0.7,en;q=0.3
Content-Type: application/x-www-form-urlencoded
Connection: keep-alive

Under Body, fill in some POST data:

data=1

Click Execute
Click on Inspectors
Click on the result request

Check Headers or Raw, it says:

POST http://example.com HTTP/1.1
Host: example.com
User-Agent: test
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
Accept-Language: en-US;q=0.7,en;q=0.3
Content-Type: application/x-www-form-urlencoded
Connection: keep-alive
:
data=1:

Notice the ending, it handles the POST data as parts of the header

Completed
Last Updated: 15 May 2020 06:02 by ADMIN
Created by: Carsten
Comments: 1
Type: Bug Report
0

To Reproduce:

1. Open Fiddler.

2. Open up a web browser and go to any page that is reasonably large (e.g. https://www.aol.com/)

3. In Fiddler, select the request (click Decode if necessary), then go to the "Raw" tab, scroll down, and click View full response.

Expected result: A decently large window opens with the response

What happens: The window only shows 1 line at a time. See attachment.

Completed
Last Updated: 14 May 2020 17:52 by ADMIN
Release Fiddler Everywhere Sprint 1
Created by: Alex
Comments: 20
Type: Bug Report
24
Fiddler Everywhere won't even open on my ubuntu 19.04. I can see the logo-loading banner, and then nothing.
Completed
Last Updated: 10 Dec 2018 15:09 by ADMIN

Sometimes when I close Fiddler Everywhere, the process Fiddler.WebUi stays alive.

When I try opening a second Fiddler Everywhere it can't bind on 8886 and I have to force quit (kill -9) the process before re-opening Fiddler.