In Development
Last Updated: 20 May 2022 14:30 by ADMIN

Bug report

The loading spinner does not appear on the first data binding.

Reproduction of the problem

Reproduction :
https://dojo.telerik.com/iKoyESUV/7

  1. Click on the 'Refresh' button. The loading spinner does not appear.
  2. When the refresh button is clicked a second time, the spinner appears.

Current behavior

The loading spinner does not appear on the first data binding.

Expected/desired behavior

The loading spinner should appear on the first data binding too.

Environment

  • Kendo UI version: 202x.r.ddd
  • jQuery version: x.y
  • Browser: [all ]
Unplanned
Last Updated: 20 May 2022 13:16 by Steven
Created by: Steven
Comments: 0
Category: ListView
Type: Bug Report
0

Bug report

When ServerOperation(true) is set, the paging is not applied after creating a new record.

Reproduction of the problem

https://demos.telerik.com/aspnet-mvc/listview/editing

Current behavior

PageSize is set to 4, but after inserting a new item, it appears along with the other items.

Expected/desired behavior

https://demos.telerik.com/kendo-ui/listview/editing
When a new item is created, remove the last one from the current page.

Environment

  • Kendo UI version: 2022.1.301
  • Browser: [all ]
Completed
Last Updated: 10 Jun 2021 06:27 by ADMIN
Release 2019.R2.SP1
Created by: Taki Xaftellis
Comments: 1
Category: ListView
Type: Bug Report
0

Since upgrading to 2019.2.514, all Kendo ListViews have the following styling added:

overflow-y: scroll; position: relative;

Please explain the purpose and the best way to turn off.

 

Completed
Last Updated: 01 Jun 2021 13:56 by ADMIN
Release 2021.R2.SP.next
Created by: Petr
Comments: 2
Category: ListView
Type: Bug Report
0

Hello,

option Borderd(false) is not working on ListView.
If I set Borderd(false), option is generated on page:

If is set to "false", option is not generated:


But default option in "kendo.all.js" or in "kendo.listview.js" is "true":


Regards

Petr

Completed
Last Updated: 23 Mar 2021 16:11 by ADMIN
Created by: Christian
Comments: 2
Category: ListView
Type: Bug Report
0

Hello guys,

 

i used the listview widget with a client template and a flexing layout. I set some bootstrap classes in the htmlattributes (see example), but this set no longer the item container attributes, it sets only the widget wrapper attributes.

So far I haven't even noticed that the elements are no longer flexing, so I can't say which update changed this behavior. I also tried the (new?) flex settings, but this change anything in the mvc wrapper version.

@(Html.Kendo().ListView<mmvln.Models.FormularcenterModel.FormularcenterFormularModel>(Model.FormularcenterFormulars)
	.Name("listView")
	.TagName("div").HtmlAttributes(new { @class = "d-flex flex-wrap" })
	.Flex(x => x.Direction("column").Wrap("nowrap"))
	.ClientTemplateId("formular-template")
	.DataSource(dataSource => dataSource
		.PageSize(8)
		.ServerOperation(false)
		.Sort(sort => sort.Add(m => m.Description))
	)
	.Events(e => e.DataBound("formularDataBound"))
	.Pageable(p => p.Info(true).Input(true).Numeric(true).Refresh(true))
)

 

My workaround is some custom css for flexing.

    #listView .k-listview-content {
        display: flex;
        -ms-flex-wrap: wrap;
        -webkit-flex-wrap: wrap;
        flex-wrap: wrap;
    }

 

Best regards

Christian