Unplanned
Last Updated: 30 Jan 2020 07:17 by ADMIN
When loading custom skin trough  RadSkinManager -> Skins -> SkinReference.Path, the logic inside RadSkinManager.FillNonEmbeddedSkinsInfo does not work correctly: in order to load ComboBox.MySkin.css, per say, it requires ComboBox folder to be present inside the custom skin folder.
Unplanned
Last Updated: 23 Jan 2020 16:18 by ADMIN
A JavaScript error is thrown when the Print dialog is being disposed.
Error message:
Uncaught TypeError: Cannot read property 'dispose' of undefined

    at $IE.Print.dispose (<anonymous>:90:18)

 

Workaround:
Enable the external dialogs of the Editor/ImageEditor and modify dispose() function of the Print.ascx dialog:

 

Print.ascx

				dispose: function ()
				{
					this._attachHandlers(false);

					this._printBtn.dispose();
					this._cancelBtn.dispose();

					$IE.Print.callBaseMethod(this, "dispose");
				},

 

Declined
Last Updated: 13 Jan 2020 12:30 by ADMIN

Hi all,

 

I saw an error File/Dir not found 404 on your demo as attached picture.

 

How to fixed error File/Dir not found 404 by drag and drop folder(s) after I clicked open it?

Won't Fix
Last Updated: 02 Jan 2020 16:57 by ADMIN
ADMIN
Created by: Rumen
Comments: 0
Category: UI for ASP.NET AJAX
Type: Bug Report
0
There is a black line that has appeared in my RadMenu.

The problem can be solved by adding a display: none in the following class:

.RadMenu .rmGroup:before, .RadMenu .rmMultiColumn:before, .RadMenu .rmScrollWrap>.rmHorizontal:before, .RadMenu .rmScrollWrap>.rmVertical:before
Under Review
Last Updated: 02 Jan 2020 16:48 by ADMIN
RadCodeBLock and RadScriptBlock is not able to handle the server tags for all case scenarios, hence RadAjaxManager throws the exception mentioned in the title.
Unplanned
Last Updated: 02 Jan 2020 16:33 by ADMIN

Hi, I have trouble with RadScriptManager. I would like combine scripts on page to only one file. But when I enabled it, my site threw javascript error on loading.
Please help me fix it, it would also be better if you can help me understand what happened.

First image is what I set up for RadScriptManager

Secondary image is the error.



I have no idea what's Telerik.Web.UI.Point, I haven't used it anywhere.

Please help me get this error out & fix it.
Thank you.

Declined
Last Updated: 02 Jan 2020 16:32 by ADMIN

We suspect a bug of Telerik controls:

 

Bug of Telerik: PageView.set_contentUrl(MyUrl) method - call MyUrl twice if RadTabStrip and RadMultiPage is inside RadAjaxPanel control. Firefox only.

Code: http://bit.ly/2NVbm8Z

It enter here two times: http://bit.ly/2NZ0cQH

 

If try it in chrome - request goes only one time.

If remove RadAjaxPanel - also request goes only one time.

 

Is it bug of your Controls?

Unplanned
Last Updated: 27 Dec 2019 00:06 by ADMIN
Created by: Vance
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
0

Steps to repro:

1. Go to https://demos.telerik.com/aspnet-ajax/chat/toolbar/defaultcs.aspx

2. Show the toolbar with the ellipses

3. Enter enough messages so that the scroll is shown and continue to enter

4. The toolbar drop down on each click of an icon

See the attached video for more information.

Won't Fix
Last Updated: 03 Dec 2019 10:03 by ADMIN
ADMIN
Created by: Marin
Comments: 9
Category: UI for ASP.NET AJAX
Type: Bug Report
3
Native browser behavior is vendor specific and the above issue cannot be replicated with the latest version. Default browser in latest Android versions is Chrome and we recommend using it instead of the older native browser
Completed
Last Updated: 22 Nov 2019 14:08 by ADMIN
Release R1 2020
ADMIN
Created by: Vessy
Comments: 0
Category: UI for ASP.NET AJAX
Type: Bug Report
1
Misspelled words in the TileList's Configuration wizard in Visual Studio:
https://www.screencast.com/t/VmdVK11Q1nLi
Completed
Last Updated: 08 Nov 2019 11:26 by ADMIN
Release R1 2020
Created by: Randy
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
1

I have a RadCheckboxList In an ASP Panel. When Enabling/Disabling the panel the CheckBoxList does not Enable/Disable.  I tested this with a simple mock up with additional controls that work as expected:

 

<asp:Panel ID="TestPanel" runat="server" Enabled="true">

<telerik:RadCheckBoxList ID="WeeklyDays" runat="server" Columns="4" AutoPostBack="false">

<Items>

<telerik:ButtonListItem Text="Monday" Value="2" />

<telerik:ButtonListItem Text="Tuesday" Value="4" />

<telerik:ButtonListItem Text="Wednesday" Value="8" />

<telerik:ButtonListItem Text="Thursday" Value="16" />

<telerik:ButtonListItem Text="Friday" Value="32" />

<telerik:ButtonListItem Text="Saturday" Value="64" />

<telerik:ButtonListItem Text="Sunday" Value="1" Selected="true" />

</Items>

</telerik:RadCheckBoxList>

<telerik:RadTextBox ID="TestText" runat="server"></telerik:RadTextBox>

<telerik:RadDatePicker ID="TestDate" runat="server"></telerik:RadDatePicker>

</asp:Panel>

<br />

<telerik:RadCheckBox ID="ToggleEnabled" runat="server" Text="Toggle Panel" AutoPostBack="true" Checked="true" OnCheckedChanged="ToggleEnabled_CheckedChanged"></telerik:RadCheckBox>

 

 

 protected voidToggleEnabled_CheckedChanged(objectsender, EventArgs e)

{

TestPanel.Enabled = Convert.ToBoolean(ToggleEnabled.Checked);

}

Completed
Last Updated: 06 Nov 2019 14:48 by ADMIN
Release R2 2018
Possible Workaround:

Telerik.Web.UI.Grid.PositionDragElement = function(element, mouseEvent)
{    
    var clientX = $telerik.isTouchDevice ? $telerik.getTouchEventLocation(mouseEvent).x : mouseEvent.clientX;
    var clientY = $telerik.isTouchDevice ? $telerik.getTouchEventLocation(mouseEvent).y : mouseEvent.clientY;

    element.style.top = clientY + $telerik.getDocumentElementScrollTop() + 10 + "px";

    element.style.left = clientX + $telerik.getDocumentElementScrollLeft() + 10 + "px";

	if ($telerik.isOpera || $telerik.isTouchDevice)
	{
	    element.style.top = parseInt(element.style.top, 10) - document.body.scrollTop + "px";
	}

};
Completed
Last Updated: 02 Oct 2019 14:34 by ADMIN
ADMIN
Created by: Vessy
Comments: 0
Category: UI for ASP.NET AJAX
Type: Bug Report
0
Missing background color of the Grid's headers in IE9 due to the unsupported by the browser linear-gradient. The issue can be reproduced with Skin="Web20".

Workaround:

        div.RadGrid_Web20 .rgHeader, .RadGrid_Web20 th.rgResizeCol, .RadGrid_Web20 .rgHeaderWrapper {
            background-image: linear-gradient(#9db7db,#7b95c6 50%,#698ac0 50%,#92b3de);
            background-color: #92b3de;
        }

Code to reproduce:
                <telerik:RadGrid ID="RadGrid1" runat="server" OnNeedDataSource="RadGrid1_NeedDataSource" AutoGenerateColumns="false" Skin="Web20" EnableEmbeddedSkins="true">
                    <MasterTableView>
                        <Columns>
                            <telerik:GridBoundColumn DataField="description" HeaderText="Description"></telerik:GridBoundColumn>
                            <telerik:GridBoundColumn DataField="value" HeaderText="Value"></telerik:GridBoundColumn>
                        </Columns>
                    </MasterTableView>
                </telerik:RadGrid>

    protected void RadGrid1_NeedDataSource(object sender, Telerik.Web.UI.GridNeedDataSourceEventArgs e)
    {
        (sender as RadGrid).DataSource = GetData();
    }

    private DataTable GetData()
    {
        DataTable dt = new DataTable();
        dt.Columns.Add("description");
        dt.Columns.Add("value");
        for (int i = 0; i < 100; i++)
        {
            dt.Rows.Add(
                "description_" + i.ToString(),
                i * 100);
        }

        return dt;
    }
Completed
Last Updated: 02 Oct 2019 14:34 by ADMIN
ADMIN
Created by: Peter Milchev
Comments: 0
Category: UI for ASP.NET AJAX
Type: Bug Report
0
Screencast demonstrating the issue and the fixes: https://www.screencast.com/t/hvCSwumhW

Caused by 

https://groups.google.com/a/chromium.org/forum/#!topic/blink-dev/GbVcuwg_QjM/discussion%5B1-25%5D
https://stackoverflow.com/a/45495974
https://stackoverflow.com/a/45746963

Workaround attached
Completed
Last Updated: 02 Oct 2019 14:33 by ADMIN
 https://www.screencast.com/t/UgqUZbqenpj5
Unplanned
Last Updated: 02 Oct 2019 14:01 by ADMIN
  1. Open your demo for Batch Editing: https://demos.telerik.com/aspnet-ajax/grid/examples/data-editing/batch-editing/defaultcs.aspx
  2. Add a new row
  3. Enter values
  4. Click on x to delete

Expected: the row disappears.

Actual result: nothing happens.

 

 

Declined
Last Updated: 04 Sep 2019 09:02 by ADMIN
ADMIN
Created by: Chavdar Dimitrov
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
6

			
Completed
Last Updated: 02 Sep 2019 14:52 by ADMIN
Created by: Patrick
Comments: 2
Category: UI for ASP.NET AJAX
Type: Bug Report
0
When we create a link to an external web site such as www.cnn.com using the RadEditor (6.3.0.0) on our SP2010 farm we are getting an error that says this:
"cannot find this location in the current site location"
"the URL may refer to an external web site for to a location in the site collection that does not exist or you do not have the right to access"

When I bring up a browser on the SharePoint server themselves I can access those sites.

Completed
Last Updated: 27 Aug 2019 10:43 by ADMIN
ADMIN
Created by: Dimitar
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
1

			
1 2 3 4 5 6