Completed
Last Updated: 25 Aug 2020 10:21 by ADMIN
Release R3 2020 (LIB 2020.2.826)

One cannot set the SvgImage of the RadListDataItems.

Additionally, when ShowImageInEditorArea is true the SvgImage must be displayed in the editor area.

Completed
Last Updated: 07 Jul 2020 08:18 by ADMIN
Release R3 2020 (LIB 2020.2.713)
Created by: Seth
Comments: 3
Category: DropDownList
Type: Bug Report
0

There is still an issue related to the drop down auto complete described in this bug report.

https://feedback.telerik.com/winforms/1468737-raddropdownlist-autocomplete-mode-works-only-the-first-time-afterward-i-can-only-type-1-character

 

After downloading the Release R2 2020 SP1, we can now enter more than 1 character. However, if the user keys the space bar the text in the edit area of the drop down is deleted. Additionally, if the first 2 characters are the same (for example AA), the second character is never added to the text. The issue can be re-produced using the same steps as the linked post. I have also attached a screenshot.

 

Let me know if you need any additional info.

Seth


Unplanned
Last Updated: 15 Jun 2020 09:31 by ADMIN
When I select items 1 through 4 in the drop-down list, the expected event occurs (the selected item is removed from the drop-down list and added to the list view).  When I select the last item in the list (item 5), the item is added to the list and then I get the ArgumentOutOfRangeException. 
Completed
Last Updated: 03 Jun 2020 16:31 by ADMIN
Release R2 2020 SP1 (LIB 2020_2_603)

I created a simple project just with a dropdownlist. The data source of the dropdownlist is a reader from SQL. First time, when I type something in the text area of the dropdownlist, the autocomplete works perfectly: if a type "235", it brings me at the first job starting with '235' and I can select the job. After, when I click back in the text area to type something else (for example: "236"), I can just type '2'. It won't let me type anything else and the autocomplete is not working. The autocomplete mode is Suggest.

This is a new problem with telerik 2020.2.512.40. Just previously, I had the trial version (2020.1.218.40) and it was working without problem. I didn't change anything in the small project. In fact, I took this project and put Telerik.Wincontrols.UI version 2020.1.218.40 anf it was working properly. I put back the version 2020.2.512.40 of the control and the problem reappeared.

 

First time (works fine):

 

Seconf time: not able to type more than 1 character

 

Declined
Last Updated: 03 Jun 2020 12:57 by ADMIN

My scenario is that I have two Panels which changes Size on mouseleave/ mouseEnter events. One panel has a dropdownlist control. When popup is opened and Panel1 changes size upon Mouseenter event, the popup does not change its location. I've tried changing the popup Left property but doesn't fix the issue. Please see attached sample application.

Workaround:

        private void RadPanel1_MouseLeave(object sender, EventArgs e)
        {
            this.radDropDownList1.DropDownAnimationEnabled = false;
            this.radDropDownList1.DropDownListElement.ClosePopup();
            radPanel1.Size = new Size(30, 400);
            radPanel2.Left = radPanel1.Right + 30;
            this.radDropDownList1.DropDownListElement.ShowPopup();
        }

        private void RadPanel1_MouseEnter(object sender, EventArgs e)
        {
            this.radDropDownList1.DropDownAnimationEnabled = false;
            this.radDropDownList1.DropDownListElement.ClosePopup();
            radPanel1.Size = new Size(200, 400);
            radPanel2.Left = radPanel1.Right + 30;
            this.radDropDownList1.DropDownListElement.ShowPopup();
        }

Unplanned
Last Updated: 12 Mar 2020 13:51 by ADMIN

Hi,

 

When using a RadDropDownList component and the RadVirtualKeyboard component I have a problem. The AutoCompleteMode.Suggest works fine the first time I click on RadVirtualKeyboard but for the other clics the suggested items don't appears on the screen.

 

Regards

   Gilles

Completed
Last Updated: 21 Jan 2020 12:35 by ADMIN
Release R1 2020 SP1 (LIB 2020_1_127)
The ItemHeight property of ListElement cannot be set at design time. ElementHierarchyEditor can set the property, but it is not serialized.
Declined
Last Updated: 15 Nov 2019 13:47 by ADMIN
Created by: tstephens
Comments: 5
Category: DropDownList
Type: Bug Report
0

I am using Visual Studio 2019, version 16.3.1 and when using the DropDownList and running it in the VS debugger, the DropDownList get populated properly, but when you click the down arrow for the first time, the list drops down and you can scroll with the mouse wheel, but it will not allow you to select anything with the mouse.

If you click the down arrow to close the list, and click it again to reopen the list, it works properly - selecting the item chosen.

I have tried numerous property setting in attempt to narrow down if any of the properties set are causing it, but have been unsuccessful.

I have created several test projects with only 1 form and only the dropdownlist on the form and this happens reliably in every project I have tested within Visual Studio.

If I build the executable and run it directly, the DropDownList works properly as expected.

The DropDownList version is listed as 2019.3.917.40 in Visual Studio 2019 16.3.1.

I opened the project in JetBrains Rider on the same machine and everything works fine.

Unplanned
Last Updated: 17 Sep 2019 14:09 by ADMIN

To reproduce the problem, we need 2 Monitors with different scaling.
Let's say that Monitor 1 has 150% Scaling and Monitor 2 has 100% (Monitor 2 is the main monitor). When starting the program and click on radbutton1, then an empty form (Toolbox) is shown. Move the Toolbox form to the other monitor and then open the RadDropDownList. The problem is that the drop-down is shown not under the control.

Please refer to the attached project.

Unplanned
Last Updated: 19 Feb 2020 14:27 by ADMIN