Planned
Last Updated: 30 Oct 2019 11:41 by ADMIN

Bug report
When using Spreadsheet with SASS theme and entering an array formula with Ctrl+Shift+Enter the {} braces surrounding array formula in the formula bar are not displayed.

Reproduction of the problem
Enter the following formula in any cell within the dojos below cell and press Ctrl+Shift+Enter : =Product(C3:C11)
dojo of a Spreadsheet demo with LESS theme
dojo of a Spreadsheet demo with SASS theme

Current behavior
Spreadsheet with LESS based theme displays the array formula correctly in the formula bar: {=Product(C3:C11)}
Spreadsheet with SASS based theme displays the array formula incorrectly in the formula bar: =Product(C3:C11)

Expected/desired behavior
Spreadsheet with SASS based theme should display array formulas with {} braces: {=Product(C3:C11)}

Environment
Kendo UI version: 2019.3.1023

Planned
Last Updated: 16 Sep 2019 14:27 by ADMIN
Scheduled for 2019.R3
Created by: CrazyLemon
Comments: 0
Category: ModalView (Mobile)
Type: Bug Report
0

Using the MobileView AngularJS directive throws an error upon initialization. This is a regression from 2019 R2 release.

Reproduction of the problem

https://dojo.telerik.com/EpobaCid

Planned
Last Updated: 13 Mar 2020 09:27 by ADMIN
Created by: Ralph
Comments: 1
Category: Badge
Type: Bug Report
0

I was working with a badge widget and I noticed an issue when the value property is specified as 0. It does not change the value displayed in the badge. I have attached a snippet based on the Basic usage demo for a Badge. I originally noticed it because I'm using the badge in MVVM pattern.

 

<!DOCTYPE html>
<html>
<head>
    <base href="https://demos.telerik.com/kendo-ui/badge/index">
    <style>html { font-size: 14px; font-family: Arial, Helvetica, sans-serif; }</style>
    <title></title>
    <link rel="stylesheet" href="https://kendo.cdn.telerik.com/2020.1.219/styles/kendo.default-v2.min.css" />

    <script src="https://kendo.cdn.telerik.com/2020.1.219/js/jquery.min.js"></script>
    
    
    <script src="https://kendo.cdn.telerik.com/2020.1.219/js/kendo.all.min.js"></script>
    

</head>
<body>
<div id="example">
    <div class="demo-section k-content">
        <div id="toolbar"></div>
    </div>
    <script>

        $("#toolbar").kendoToolBar({
            items: [
                {
                    template: '<a class="k-button k-badge-overlay" href="#"><span class="k-icon k-i-user"></span><span id="badge-overlay">2</span></a>'
                },
                {
                    template: '<a class="k-button k-badge-overlay" href="#"><span class="k-icon k-i-email"></span><span id="badge-inbox">5</span></a>'
                },
                {
                    template: '<a class="k-button" href="#">See later <span id="badge-sent">15</span></a>'
                },
                {
                    template: '<a class="k-button" href="#">News<span id="badge-missed">99+</span></a>'
                }

            ]
        });

        $('#badge-inbox').kendoBadge({
            type: 'info',
            appearance: 'rectangle'
        })

        $('#badge-sent').kendoBadge({
            type: 'success',
            appearance: 'rectangle'
        })

        $('#badge-missed').kendoBadge({
            type: 'warning',
            value: 0, /*The span has an original value specified in HTML. When it is run, the value doesn't change unless you change it to something other than 0, i.e. 10*/
            appearance: 'rectangle'
        })

        $('#badge-overlay').kendoBadge({
            type: 'primary'
        })
    </script>
    <style>
        #toolbar {
            display: flex;
            justify-content: center;
            height: 80px;
        }

        #example a{
            margin-left: 5px;
        }

        #example .k-icon {
            font-size: 20px;
        }
    </style>
</div>


</body>
</html>
Planned
Last Updated: 09 Mar 2020 13:05 by ADMIN
Created by: Jason Feng
Comments: 1
Category: AutoComplete
Type: Bug Report
0
Hi, I think this is a bug with AutoComplete widget. The document says the highlightFirst default is true, which means I don't need to specifically define it. In reality, I have to set it as true in order for it to work. Please verify.
Planned
Last Updated: 13 Feb 2020 15:05 by ADMIN
Scheduled for 2020.R1.SP.next
Created by: SKUBOREV
Comments: 0
Category: Date/Time Pickers
Type: Bug Report
0

Bug report

 

DatePicker throws JS error "Cannot read property '_focus' of undefined" in the following scenario:

1. Focus element

2. Select all text inside

3  Press Backspace or Delete

4. Remove focus from the element by clicking outside

Dojo to reproduce: https://dojo.telerik.com/uZAhiHuC

Reported in #1450532