How about a simple addition to zooming, whereby the zoom just automatically zooms into the current data set by filtering off the outer elements? For example, have a zoomStep property, which defines the number of elements to filter off the start and end of the data. This would allow really simple zooming without having to write filters and would allow for easy use in shared code scenarios (eg, we have a single Knockout custom binding for all our charts).
I shouldn't be penalized in having to write more code to get kendo validation working with kendo controls. You guys should know I'm validating a KendoNumericTextBox and auto-place the span in the appropriate spot outside of the control. http://www.kendoui.com/forums/framework/validation/error-tooltip-showing-up-in-the-picker.aspx
Enhance the RTL support because if you check list view control at demo page and click RTL u will see that the pager still not switched rtl
When working in a team based setting where you have developers and functional specification owners what is your approach? Is there anything available in Kendo UI that allows groups to collaborate on UI concepts before the first line of code is written? How does one offer feedback? Kendo sounds like its a development platform but where is the UI ideation taking place to firm up what the product will provide while giving an early stage visual tease? These would be tools that specification owners could use to flesh out the functionality. So my question is how do you guys do this in your shops?
Hello, I want to update the kendo ui version to 2012.2.913. but couldnt find the proper link to update it. please help me. Thank You
KendoUI Mobile currently has only back button. There should also be a forward button along with it.
Throughout the examples/docs for the KendoUI Window component, a variable named 'window' is used to reference the component. This is a terrible pratice, because the variable masks the global window object and prevents the script from acessing it further. As your examples are often used as a starting point for custom solutions, you should rename the variable into something like kWindow or similar.
I can't select date in my kendoDatePicker when I set readonly option or call readonly method. This problem is in the new version 2013.1.319, in version 2012.3.1114 all work perfectly
Update dependencies in documentation + add dependencies info in the beginning of each source code file.
The Switch element is styled after the iOS 4 and earlier rounded rectangle instead of the round switch used in iOS 5 and later. It's certainly possible to do this newer style using css/js as well and it would help apps built with KendoUI from diverging from the controls used in the rest of the OS. http://css3wizardry.com/2011/12/18/ios-5-style-switch-control/
Developers these days are spoiled with choice when it comes to selecting an MV* framework for structuring and organizing their JavaScript web apps. To help solve this problem, www.todomvc.com offers the same Todo application implemented using MV* concepts in most of the popular JavaScript MV* frameworks of today EXCEPT OF Kendou UI...
I suggest develop a wigdget for Calendare (like Google Calendar or this http://arshaw.com/fullcalendar/)
Hi Teleric, could you incorporate a full calendar (day, week, and month views) like this: https://github.com/arshaw/fullcalendar Thanks, Pau
Implement screen boundary detection for the depicted widgets and adjust the popup position to be completely shown in the visible area of the browser.