Approved
Last Updated: 26 Feb 2018 10:49 by ADMIN
ADMIN
Created by: Nikolay
Comments: 0
Category: Chart
Type: Bug Report
3
Put several Pie charts in a StackPanel and set the WidthRequest and HeightRequest to let's say 60. You will notice that the circular pie itlsef appears much smaller than the expected 60. In Android and Windows Phone it appears as expected.
Approved
Last Updated: 19 Dec 2018 15:51 by Didi
When RadChart is placed inside a ScrollViewer and there is tooltip displayed, scrolling the content with a slide gesture does not hide the tooltip.
Approved
Last Updated: 29 Aug 2018 15:33 by ADMIN
Approved
Last Updated: 08 Oct 2018 14:21 by Didi
Approved
Last Updated: 19 Jun 2018 11:01 by ADMIN
ADMIN
Created by: Lance | Team Lead - US DevTools Support
Comments: 0
Category: Chart
Type: Bug Report
2
Add the ability to render points outside of the plot area when the data point value exceeds the explicitly set Min or Max values of the horizontal axis.

On Android and iOS, the line series will continue to extend off the plot area to a point that isn't rendered. Here's a screenshot, notice the line coming in from the left side of the plot area: https://www.telerik.com/clientsfiles/77e02115-6de0-4dd0-b572-5d5bc17a59b9_xamarin.jpg

On UWP, the beginning of the line series only starts on the first plot-able point. Here's a screenshot, notice the start of the line series: https://www.telerik.com/clientsfiles/d8c342e3-608b-40eb-95eb-8bd5e0dbc2e6_uwp.jpg 



Approved
Last Updated: 05 Apr 2019 08:19 by ADMIN
Once the data of the bar chart is changed, the selection behavior does not fire. The issue is reproducible when the chart is placed inside AnimationPanel,
Approved
Last Updated: 16 Jul 2019 09:51 by ADMIN

If you have a Chart with BarSeries and TooltipBehavior defined, the tooltip of each bar is shown only when the user taps in the area around the tip of the bar.

The expected behavior is the tooltip to be displayed when clicking anywhere on the bar.

Approved
Last Updated: 15 Jul 2019 08:38 by ADMIN
When you set custom stroke to ScatterLineSeries, the colors in the RadLegend are not updated.
Approved
Last Updated: 01 Oct 2019 13:04 by ADMIN
When you update the data in the chart so that the vertical axis values are changed - the annotation does not properly update and stays at the same location.

Approved
Last Updated: 17 Oct 2019 14:11 by ADMIN
When the series data is updated and axis labels are redrawn, occasionally the default DateTime format is shown in DateTimeContinuousAxis.
Approved
Last Updated: 12 Nov 2019 12:55 by ADMIN

As of the latest release (10/04/2019) RadPieChart with a PieSeries having LabelBinding set to a property name, and ShowLabels set to True, with the list of data bound to ItemsSource containing one or more empty pie slices (a null in the list), causes a System.Reflection.TargetException to be thrown on load of the page containing the chart in iOS (this scenario works fine in UWP).

I am using the latest available Visual Studio 2019 (16.3.5) and the latest available Xamarin.Forms package (4.2.0.848062) and testing on an iPad with iOS 13.1.  The reason I need to have a null value in the list is so that the custom color palette I'm applying will always apply the same colors to the same data points (pie slices), even though in some cases, zero or one or two of the three pie slices will have no data value (and so should not appear in the chart, but still "use up" the corresponding color in the 3 colors of the palette).

In the 08/02/2019 release, this scenario worked fine in iOS (the 09/13/2019 release had the https://feedback.telerik.com/xamarin/1431067-chart-ios-invalidcastexception-is-thrown-when-the-chart-is-loaded issue, which is now resolved in the 10/04/2019 release, but which prevented my testing in iOS since in my app I had RadCartesianCharts on the same pages as the RadPieCharts).

The newly broken functionality in iOS could possibly be related to two other items that are marked completed:
https://feedback.telerik.com/xamarin/1366403-piechart-tooltip-behavior-is-not-working-properly (in 10/04/2019 release)
https://feedback.telerik.com/xamarin/1365842-chart-null-value-support (in R3 2018 SP release)

Approved
Last Updated: 24 Apr 2019 12:35 by ADMIN
Setting SelectedPointOffset and RadiusFactor in DonutSeries or PieSeries causes unexpected behavior when selecting a pie piece in the chart.
Approved
Last Updated: 11 Mar 2019 08:39 by ADMIN

If we have a Chart with combined barseries and lineseries, and the lineseries is added first, the bars are misaligned - they are not placed in the center of the axis label on Android.

As a workaround, make sure to add first the barseries, then the lineseries.

Approved
Last Updated: 22 Mar 2019 13:18 by ADMIN
SelectionChanged event of the Chart SelectionBehavior is not raised for LineSeries when DataPointSelectionMode is "Single" and  SeriesSelectionMode is "None".  

Approved
Last Updated: 03 Aug 2018 13:52 by ADMIN
Approved
Last Updated: 12 Apr 2018 08:08 by ADMIN
If you have BarSeries with CombineMode set to "Stack" with zero values, the bars are placed to the maximum of the y-axis. 
As a work-around, you would need to manually adjust the Maximum value of the vertical axis.
Approved
Last Updated: 25 May 2018 08:32 by ADMIN
Approved
Last Updated: 09 Oct 2018 15:00 by ADMIN
Approved
Last Updated: 20 Feb 2019 07:16 by ADMIN
If the series is added after the page constructor, the vertical axis labels are not shown.

As a workaround, create the series in the constructor and set its ItemsSource at a later stage.
Approved
Last Updated: 15 Feb 2018 09:59 by ADMIN
Series labels are not displayed for horizontal BarSeries in UWP.
1 2 3