Declined
Last Updated: 15 Oct 2019 08:43 by ADMIN
Cell height is not being adjusted to show all the content. the text overflow and it overlap the cell below. It seems that dynamic size is not respected.
Approved
Last Updated: 10 Oct 2019 13:49 by ADMIN
With Automatic LoadOnDemand, once all items are loaded and IsLoadOnDemandEnabled is set to false, when I scroll till the end the loading indicator keeps flickering on knowing that no more items are called.
Approved
Last Updated: 08 Oct 2019 11:05 by ADMIN
if the swipe content of the cells are buttons, dragging the buttons up and down will keep the swiped cells in the same position of the screen, creating unexpected animations and showing the entire swipe content of the cell.
Approved
Last Updated: 08 Oct 2019 10:45 by ADMIN
When swiping a cell, the swipe content of the cell will be shown if the swipe threshold is reached.  On iOS, the swipe content of another cell can be shown immediately by swiping another cell (which is an expected behaviour).  However on Android, when the user swipes another cell, the swipe content of the other cell isn't shown (while the swipe content of the first cell becomes hidden).  The user has to swipe the other cell again to show the swipe content.
Approved
Last Updated: 07 Oct 2019 10:08 by ADMIN

Activating the ItemHold event of an item in a list view requires holding down an item for a while.  On a physical/virtual Android device and a virtual iOS device, this can be done by holding down the mouse/finger lightly on an item for a short period of time.  However, on a physical iOS device (I am using a physical iPhone 6s to test this), holding down the item lightly with my finger won't activate the ItemHold event, and I have to hold the item really hard on the screen in order to activate it (similar to using 3D Touch / Force Touch, and I cannot reliably activate the ItemHold event possibly because my force is sometimes not hard enough).  I noticed this behaviour on the physical iOS device since the ItemHold event got implemented in early 2018.

I created a simple application to demonstrate the issue.  The app displays an alert when the user taps/holds an item in the list view.  On a physical iOS device, holding down an item in the list view requires the user to press the item very hard on the screen.

Thanks,
Kori

Completed
Last Updated: 04 Oct 2019 14:46 by ADMIN
Release 2019.3.1004 (R3 2019 minor release)
GroupHeaderTemplate has a default gray background applied and setting Transparent does not take any effect.
Completed
Last Updated: 04 Oct 2019 14:45 by ADMIN
Release 2019.3.1004 (R3 2019 minor release)
When any control (Frame, for example) with applied Margin is placed inside GroupHeaderTemplate of the ListView, the Margin value is not respected on iOS.
Completed
Last Updated: 18 Sep 2019 11:49 by ADMIN
Release R3 2019
RadListView item height is not adjusted to fit the content in the cell on iOS 13 Beta.
Approved
Last Updated: 05 Sep 2019 08:53 by ADMIN
When you initiate a swipe gesture and the SwipeContentTemplate is shown,  changing the device orientation from portrait to landscape, does not update the ListView layout and the swiped item width is incorrect.
Approved
Last Updated: 09 Aug 2019 09:54 by ADMIN
Java.Lang.IllegalStateException: The specified child already has a parent. You must call removeView() on the child's parent first.

For example change the IsPullToRefreshEnabled state on button click, when button is pressed several times, exception is throw.
Approved
Last Updated: 22 Jul 2019 12:29 by ADMIN
When using DataTemplates on the ListView for Android, items are constantly redrawn when data shown on the template is updated, this is obvious to the user as it flashes and doesn't look great. Note that the native ListView does not do this.
Declined
Last Updated: 19 Sep 2019 14:22 by ADMIN

Hi,

I rolled my app with the ListView out to production and are getting 8+ crashes a day from 140 users with the above issue. I have included a stack trace. I cannot find the steps to reproduce the issue in development. I have rolled back to using the native ListView as this does not crash the app.

Attached is an example project to see what I am doing in general terms, but I have not been able to reproduce this crash in it.

My guess is that a DataTemplate is not being cleaned up properly and when the data behind is changed it attempts to access the control that represented the data in the DataTemplate.

Regards
Anthony

Xamarin caused by: android.runtime.JavaProxyThrowable: System.ObjectDisposedException: Cannot access a disposed object.
Object name: 'Android.Support.V7.Widget.SwitchCompat'.
Java.Interop.JniPeerMembers.AssertSelf(IJavaPeerable self)<9cb01525c8ce48268eb7a54e1b653d67>:0
Java.Interop.JniPeerMembers.JniInstanceMethods.InvokeVirtualVoidMethod(string encodedMember, IJavaPeerable self, JniArgumentValue* parameters)<9cb01525c8ce48268eb7a54e1b653d67>:0
Android.Widget.CompoundButton.set_Checked(bool value)<83e36ed05052486983583851de96589e>:0
Xamarin.Forms.Platform.Android.AppCompat.SwitchRenderer.HandleToggled(object sender, EventArgs e)<e6fe81c4055a4db5bd435b7d12d894e3>:0
at Xamarin.Forms.Switch+<>c.<.cctor>b__14_0 (Xamarin.Forms.BindableObject bindable, System.Object oldValue, System.Object newValue) [0x0001c] in <209f66ed8fe04cb6a815feb8c3b62471>:0
Xamarin.Forms.BindableObject.SetValueActual(BindableProperty property, BindableObject.BindablePropertyContext context, object value, bool currentlyApplying, SetValueFlags attributes, bool silent)<209f66ed8fe04cb6a815feb8c3b62471>:0
Xamarin.Forms.BindableObject.SetValueCore(BindableProperty property, object value, SetValueFlags attributes, BindableObject.SetValuePrivateFlags privateAttributes)<209f66ed8fe04cb6a815feb8c3b62471>:0
Xamarin.Forms.BindingExpression.ApplyCore(object sourceObject, BindableObject target, BindableProperty property, bool fromTarget)<209f66ed8fe04cb6a815feb8c3b62471>:0
Xamarin.Forms.BindingExpression.Apply(bool fromTarget)<209f66ed8fe04cb6a815feb8c3b62471>:0
Xamarin.Forms.BindingExpression.BindingExpressionPart.<PropertyChanged>b__49_0()<209f66ed8fe04cb6a815feb8c3b62471>:0
Java.Lang.Thread.RunnableImplementor.Run()<83e36ed05052486983583851de96589e>:0
Java.Lang.IRunnableInvoker.n_Run(IntPtr jnienv, IntPtr native__this)<83e36ed05052486983583851de96589e>:0
at (wrapper dynamic-method) System.Object.31(intptr,intptr)
mono.java.lang.RunnableImplementor.n_run(Native Method)
mono.java.lang.RunnableImplementor.run()RunnableImplementor.java:30
android.os.Handler.handleCallback()Handler.java:739
android.os.Handler.dispatchMessage()Handler.java:95
android.os.Looper.loop()Looper.java:145
android.app.ActivityThread.main()ActivityThread.java:6914
java.lang.reflect.Method.invoke(Native Method)
java.lang.reflect.Method.invoke()Method.java:372
com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run()ZygoteInit.java:1404
com.android.internal.os.ZygoteInit.main()ZygoteInit.java:1199

 

Declined
Last Updated: 08 Aug 2019 11:58 by ADMIN
Created by: Anthony
Comments: 3
Category: ListView
Type: Bug Report
0

Hi,

As the header suggests, Swipe No Longer Works When Offset And Threshold Are Equal, the swipe closes on finger release. This started happening in the latest release, 2019.2.619.1, previously this worked without issue.

This can be replicated in the SDKBrowser by setting the following in Cell Swipe - Interactive Content example:

SwipeOffset="70, 0, 0, 0"
SwipeThreshold="70"

I have only tested this on Android. 

Regards

Anthony 

 

Declined
Last Updated: 19 Sep 2019 14:17 by ADMIN

When using a RadListview with a Grid or a Stack Layout in iOS I get the following exception. I haven't tested using the stacklayout outside of the RadListView nor have I tested it outside of the ItemTemplateSelector


Telerik.XamarinForms.Common.NotRegisteredRendererException: There is no renderer registered for the specified type: Xamarin.Forms.Grid
It works fine on Android. Below is the xaml I'm using.


<?xml version="1.0" encoding="utf-8" ?>
<ContentPage xmlns="http://xamarin.com/schemas/2014/forms"
             xmlns:telerikDataControls="clr-namespace:Telerik.XamarinForms.DataControls;assembly=Telerik.XamarinForms.DataControls"
             xmlns:telerikListView="clr-namespace:Telerik.XamarinForms.DataControls.ListView;assembly=Telerik.XamarinForms.DataControls"
             xmlns:x="http://schemas.microsoft.com/winfx/2009/xaml"
             xmlns:d="http://xamarin.com/schemas/2014/forms/design"
             xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006"
             xmlns:models="clr-namespace:AlertTest.Models"
             mc:Ignorable="d"
             xmlns:views="clr-namespace:AlertTest.Views"
             x:Class="AlertTest.Views.MainPage">
    <ContentPage.Resources>
        <ResourceDictionary>
            <DataTemplate x:Key="NonDivisibleTemplate">
                <Grid>
                    <StackLayout Orientation="Vertical" Padding="10" Spacing="0" BackgroundColor="Yellow" InputTransparent="True" Unfocused="StackLayout_Unfocused">
                        <Label Text="{Binding ItemText}"/>
                    </StackLayout>
            </DataTemplate>
            <DataTemplate x:Key="DivisibleTemplate">
                <Grid>
                    <StackLayout Orientation="Vertical" Padding="15" Spacing="0" BackgroundColor="White" Unfocused="StackLayout_Unfocused">
                        <Label Text="{Binding ItemText}" FontSize="Large" HorizontalTextAlignment="Center"/>
                        <Label Text="{Binding ItemText}" FontSize="Small" FontAttributes="Italic" TextColor="Gray"/>
                    </StackLayout>
                </Grid>
            </DataTemplate>

            <models:MyDataTemplateSelector
                x:Key="MyTemplateSelector"
                NonDivisibleTemplate="{StaticResource NonDivisibleTemplate}"
                DivisibleTemplate="{StaticResource DivisibleTemplate}" />
        </ResourceDictionary>
    </ContentPage.Resources>

    <StackLayout VerticalOptions="StartAndExpand">
        <!-- Place new controls here -->
        <views:FloatingLabelEntry EntryText="{Binding EntryText}" Margin="20" BackgroundColor="Yellow" PlaceholderText="{Binding PlaceholderText}"/>
        <Entry TextChanged="Entry_TextChanged" BackgroundColor="AliceBlue" Margin="20"/>
        <telerikDataControls:RadListView x:Name="listView" ItemsSource="{Binding ListItems}" ItemTemplateSelector="{StaticResource MyTemplateSelector}" SelectionMode="Single" IsItemSwipeEnabled="False" >
            <!--<telerikDataControls:RadListView.ItemSwipeContentTemplate>
                <DataTemplate>
                    -->
            <!--<Grid Margin="0"
                  Padding="0"
                  ColumnSpacing="0"
                  RowSpacing="0">-->
            <!--<Grid.ColumnDefinitions>
                            <ColumnDefinition Width="*" />
                            <ColumnDefinition Width="*" />
                        </Grid.ColumnDefinitions>-->
            <!--
                    <StackLayout Orientation="Horizontal" HorizontalOptions="FillAndExpand">
                        <Label BackgroundColor="#2474d2"
                       HorizontalTextAlignment="Start"
                               HorizontalOptions="StartAndExpand"
                       Text="Mark as read"
                       TextColor="White"
                       VerticalTextAlignment="Center" />
                        <Label Grid.Column="2"
                       BackgroundColor="Red"
                       HorizontalTextAlignment="End"
                               HorizontalOptions="EndAndExpand"
                       Text="delete"
                       TextColor="White"
                       VerticalTextAlignment="Center"/>
                    </StackLayout>
                    -->
            <!--</Grid>-->
            <!--
                </DataTemplate>
            </telerikDataControls:RadListView.ItemSwipeContentTemplate>-->
        </telerikDataControls:RadListView>
    </StackLayout>
</ContentPage>

Approved
Last Updated: 12 Jun 2019 12:55 by ADMIN
Created by: Safan
Comments: 0
Category: ListView
Type: Bug Report
12
When the ListView has more items, it could be vertically scrolled, however, there is no UI for vertical scrollbar on Android.  The same can be observed with RadTreeView control.
Approved
Last Updated: 06 Jun 2019 14:45 by ADMIN
NullReferenceException is thrown when Singleton ViewModel is used
Approved
Last Updated: 05 Jun 2019 11:47 by ADMIN
When LoadOnDemand feature is enabled and you're using LoadOnDemand event to add more items asynchronously, the loading indicator is not shown and it is not clear to the end user that any action is currently processed. 
Approved
Last Updated: 05 Jun 2019 11:05 by Stefan
When you try to swipe several items at once by using more than 1 finger - the items are stuck and the space where the ItemSwipe content should be present is left blank. The issue can also be observed if you swipe items very fast. 
Approved
Last Updated: 04 Jun 2019 13:36 by ADMIN
the items are reordered when DelegateFilterDescriptor is used and a property from the business object is changed. 
Approved
Last Updated: 04 Jun 2019 12:56 by ADMIN
When LoadOnDemandMode is set to "Automatic" and LoadOnDemand event is used to load items asynchronously, the event is fired multiple times with a single gesture.
1 2 3 4 5 6