Completed
Last Updated: 04 Oct 2016 11:41 by ADMIN
ADMIN
Created by: Boyan Boev
Comments: 1
Type: Bug Report
2
Steps to reproduce:

1. Create a simple html page with a link to https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=M88NTGBA23M34

2. Start recording and navigate to the page created by you.

3. Right click on the link and select open in a new window.

Expected: Test Studio should attach the recorder to the window.

Actual: The new IE windows freezes. This happens almost all the time.
Completed
Last Updated: 04 Oct 2016 10:47 by ADMIN
while executing the test script, we are unable to switch from frame1 to frame2 and access the text fields which are in frame2. 
Where we have recorded both the frames. Please tell us how we can switch from one frame to another using record option.
Completed
Last Updated: 04 Oct 2016 10:30 by ADMIN
Created by: Geoffrey Hudik
Comments: 1
Type: Bug Report
0
Recorded a test and went to the storyboard but notice there are no screenshots there like there were in your product demo.

v 2016.2.630.0
Completed
Last Updated: 04 Oct 2016 10:24 by ADMIN
Created by: Geoffrey Hudik
Comments: 1
Type: Bug Report
0
I started off recording for a test. I then created data under Local Data and changed the steps to bind to that local data. The step in the test showed "data bound" but the runner executed it passed the text contents of the field (which were empty) instead of the data bound values. This causes the test to fail.

v 2016.2.630.0
Completed
Last Updated: 17 Sep 2016 09:56 by ADMIN
ADMIN
Created by: Cody
Comments: 1
Type: Bug Report
0
1) Open a test that has a NavigateTo step
2) Start recording in IE (other browsers may be have the same problem)
3) Select the NavigateTo step and do Run Selected Steps

Expected: The navigate to be performed and the recording window to be displayed.
Actual: The navigate completes, but you don't get the recording window.
Completed
Last Updated: 16 Sep 2016 06:52 by ADMIN
Attempt to invoke virtual method 'java.lang.String android.content.res.Resources.getResourceName(int)' on a null object reference
Completed
Last Updated: 30 Aug 2016 07:43 by ADMIN
When I try to get an access to .Source property of ...Wpf.Image element, I get the following exception:
 
Unable to cast object of type 'ArtOfTest.WebAii.Controls.Xaml.Wpf.BitmapFrameDecode' to type 'ArtOfTest.WebAii.Controls.Xaml.Wpf.ImageSource'.
 
I want to have possibility to read file name of the displayed image in WPF application.
 

To reproduce:
Sample WPF application and a sample WPF test are provided in the internal description.
Completed
Last Updated: 25 Aug 2016 13:50 by ADMIN
Steps to reproduce: 

1. Execute the provided test in Edge browser

Expected result: The test to be successfully executed.

Actual behavior: The execution stops at the step to connect to the new popup window. 

Completed
Last Updated: 25 Aug 2016 13:37 by ADMIN
Access to the application and steps to reproduce are in the internal description.
Completed
Last Updated: 23 Aug 2016 08:24 by ADMIN
Setup:

Machine A - Test Studio
Machine B - Scheduling and Storage
Machine C - Remote Executor connected to Machine B

When you run the customers test list it runs to completion. When you look at the results you get:

Can't reach the remote executor; exception: An error occurred while sending the request.

And the test list is marked Failed even though it actually passed.

The location of the customers test plus repro steps will be add to the internal bug report.
Completed
Last Updated: 23 Aug 2016 08:22 by ADMIN
Steps to reproduce: 

1. Using the attached sample project execute test list 3 remotely. 

Expected result: The test list to pass successfully. 

Actual result: An exception is thrown. 
Completed
Last Updated: 22 Aug 2016 13:44 by ADMIN
The steps to reproduce and access to the application are in the internal description.
Completed
Last Updated: 22 Aug 2016 13:30 by ADMIN
Customer specific application could not load the DOM in Chrome browser. 

Completed
Last Updated: 19 Aug 2016 09:27 by ADMIN
ADMIN
Created by: Boyan Boev
Comments: 1
Type: Bug Report
0
When you calibrate Chrome the zoom level is not affected which brakes the highlighting.
Completed
Last Updated: 19 Aug 2016 08:09 by ADMIN
If the one intend to run a WPF test using ArtOfTest.Runner.exe and using environment variables for path to the application and to the test - it has to be done when default path to the application is not set. If it is set the ArtOfTest.Runner will trow an exception. For example: ArtOfTest.Runner.exe test="%TEST_PATH%\WPFTest.tstest" root="%TEST_PATH%"
Completed
Last Updated: 16 Aug 2016 06:47 by ADMIN
ADMIN
Created by: Elena
Comments: 3
Type: Bug Report
0
Steps to reproduce: 

Use the attached project. 

1. Execute the test list. 

2. If using a coded test as step after the first failed iteration that throws an exception no other iterations are executed. 

3. If using Test-as-step (not coded step) all iterations are executed as expected. 
Completed
Last Updated: 15 Aug 2016 12:44 by ADMIN
The text cursor (i.e. current position) is not visible in the Notes panel in a manual test.

Steps to reproduce:

1. Create a manual test

2. Add a note

Actual behavior: the text cursor is not visible

Expected behavior: you should be able to see the text cursor
Completed
Last Updated: 11 Aug 2016 13:00 by ADMIN
Steps to reproduce: 

1. Create a Sitefinity test project and access its admin dashboard.

2. Use the attached test as a reference (since the user should be logged in) 

3. Execute the test in Edge. 

4. When trying to click on the 'Dashboard' element Edge turns to Not responding state and the test fails. 

Expected behavior: To execute the action and navigate to the respective page.

Actual behavior: The test fails. 
Completed
Last Updated: 01 Aug 2016 11:15 by ADMIN
In the scheduling configuration the email notifications are configured along with sending attachments. The email subject time stamps are as UTC -5:00 and in the attachment it is UTC. 

Expected result: Both time stamps to be the same and equal to the system/machine time. 
Completed
Last Updated: 01 Aug 2016 11:10 by ADMIN
Steps to reproduce:

1. Go to the Help tab in Test Studio.

2. Click submit ticket.

3. Log into your Telerik account.

Expected: To see the page with your tickets.

Actual: The page is not rendered correctly and the customers are not able to see their tickets.