Completed
Last Updated: 11 Oct 2019 08:32 by ADMIN
Chrome v.77 cannot recognize OnBeforeUnload dialo. The dialog is not being recorded and if added manually (add Handle Confirm dialog step) from the Step Builder, the dialog is not handled during test execution. 
Completed
Last Updated: 02 Oct 2019 07:05 by ADMIN

Steps to reproduce: 

1. Open an Enter password step and expand in the step pane

2. Set the encrypt property

Expected: All fields with the actual text entered should be masked with *

Actual: If the step is expanded the actual text entered field does not change its value. 

Note: Reopening the test fixes the visual glitch. 

Completed
Last Updated: 02 Oct 2019 07:03 by ADMIN

A popup with "End of Central Directory record could not be found." error shows up when I try to add a custom step from the step builder.

When I restart Test Studio, the test works fine.

Completed
Last Updated: 01 Oct 2019 10:45 by ADMIN
When I generate a unit test in Visual Studio 2019 from existing .tstest, the structure is incorrect. As a result the project has compilation errors.
Completed
Last Updated: 18 Sep 2019 11:35 by ADMIN

Hello,

After installing my DevCraft package, my keyboard has limited functionality, when trying to create a new project/solution in Visual Studio 2019. I am able to use "space" and "backspace" keys, but not letters and numbers.

Uninstalled Test Studio Dev or disabling Telerik.TestStudio extension and I have full keyboard functionality on screen for creating a new project in Visual Studio 2019.

As a workaround I am able to use CTRL + V to paste any text from my clipboard.

Thanks.

Jason

Completed
Last Updated: 12 Sep 2019 11:56 by ADMIN

Data bound request does not support "application/json" content type. 

The exception listed in the log: 


[Telerik.TestStudio.Load.Agent.exe(3640:5),Load] AsyncTaskMethodBuilder`1.Start() : An outstanding request finished, but was marked as a failed request.
[Telerik.TestStudio.Load.Agent.exe(3640:3),Error] OutstandingRequest.Run() : EXCEPTION! (see below)
     Situation: Exception during HTTP Request, url [https://server.com]
     Outer Exception Type: System.NotImplementedException
     Message: Content type "application/json" is not implemented.
     HRESULT: 0x80004001 (Official ID (if app.) = E_NOTIMPL, Error Bit = FAILED, Facility = FACILITY_NULL, Code = 16385)
     Call Stack:
          at Telerik.TestingFramework.Net.HttpUtilities.SerializeContent(String strContentEncoding, ContentType contentType, Object objTransformedContent)
          at Telerik.TestStudio.Load.Http.OutstandingRequest.ApplyBindingsToRequest(HttpRequestBuilder requestBuilder)
          at Telerik.TestStudio.Load.Http.OutstandingRequest.<Run>d__24.MoveNext()

Completed
Last Updated: 09 Sep 2019 08:01 by ADMIN

Wait for exists step is failing with the error below, when Test Studio is not able to find the element:

Object reference not set to an instance of an object.
InnerException:
System.NullReferenceException: Object reference not set to an instance of an object.

As a result the conditional steps are not working as expected and the test fails.

The workaround for this issue is to change the WaitForExists step to VerifyExists step and the test works.

Completed
Last Updated: 06 Aug 2019 12:23 by ADMIN

Hi

 

I have some databound parrent tests.

 

For these I have created seperate sheets in my excel, to ensure my part test are working i switch their databinding between the sheets to ensure them working in all environments.

 

Everytime i rebind a test the excel file gets corrupted! I have to restart the computer and then it works again… What is the fix for this? 

 

I have attached an example of being unable to open the excel document! 

Completed
Last Updated: 26 Jul 2019 14:36 by ADMIN
Steps to reproduce:

Using the project attached execute the test which should handle a dialog.

Expected behavior: The save dialog is handled successfully

Actual behavior: The dialog is not handled and the following is output in the log:


System.TimeoutException: Timed out waiting '60000' msec. for any dialog to be handled '1'
Result StackTrace:    
at ArtOfTest.WebAii.Win32.Dialogs.BaseDialog.WaitUntilAnyHandled(IEnumerable`1 dialogs, Int32 handleCount, Int64 timeoutMilliseconds, Boolean resetHandleCount)
   at ArtOfTest.WebAii.Win32.Dialogs.BaseDialog.WaitUntilHandled(Int32 handleCount, Int32 timeout, Boolean resetHandleCount)
   at ArtOfTest.WebAii.Win32.Dialogs.BaseDialog.WaitUntilHandled()
   at UnitTestProject2.UnitTest1.TestMethod1() in c:\Users\ittodorov\Documents\Visual Studio 2012\Projects\UnitTestProject2\UnitTestProject2\UnitTest1.cs:line 42
Completed
Last Updated: 22 Jul 2019 09:58 by ADMIN

Changing the DPI settings to 125%, for example, on Windows 7 causes troubles with the Desktop clicks when running tests against Chrome. The click is below or above the target element. Highlighting in record mode may also be affected. 

Workaround: As a workaround the Desktop clicks (MouseClick() method) can be replaced with the Click() method, which works as expected. The alternative in a non-coded solution is to disable the 'SimulateRealClick' option for the click steps. 

Completed
Last Updated: 17 Jul 2019 08:02 by ADMIN
Completed
Last Updated: 26 Jun 2019 08:06 by ADMIN
If using the Testing Framework, there is no way to set the  InitializationTime() property for the DownloadDialogsHandler. 
Completed
Last Updated: 13 Jun 2019 06:24 by ADMIN

Multiselect control cannot be recorded against IE as expected. When selecting more than one value from it, using the Ctrl key, not all selected options are listed in the 'SelectedItems' step property.

The 'SelectedItems' step property does not display names of the selected items and it is not visible how many elements there are to be selected. 

If the desired items are manually added in the mentioned property, they will be selected correctly in run-time. 

Completed
Last Updated: 11 Jun 2019 10:52 by ADMIN
Unable to scroll the execution machines for scheduling test lists. The vertical scroll bar is missing and the options to distribute tests and get the latest version from TFS are missing.
Completed
Last Updated: 16 May 2019 07:25 by ADMIN

The latestMongoDB 4.0.6. cannot be restarted from Scheduling Configuration setup, the mongo service config gets broken if started through the Scheduling wizard and service cannot be started anymore. 

Workaround to resolve the not working MongoDB service: 

Using the latest version of MongoDB 4.0.6.
1. Since the current state of the Mongo service is not a working one, it will be required to completely uninstall the MongoDB and then perform a clean installation again. 
2. The important note is to install the MongoDB as a Windows service - this is the default configuration. 
3. This installation will install and start the MongoDB service. 
4. Next important thing to keep in mind is to avoid restarting the MongoDB service from the Scheduling configuration - this is the first tab of the wizard and it shouldn't be used until a permanent fix is available. 
5. The Scheduling and Storage services can be freely configured from the respective two tabs and the remote execution should be working now. 

Using a previous version of MongoDB 
1. If the version of MongoDB is not of great importance, you can install any previous version. 
2. The easiest way is to completely uninstall both MongoDB and Test Studio from Windows Control Panel. 
3. Then perform a clean installation of the latest version of Test Studio. This will install MongoDB 3.0. and you can freely start the Scheduling configuration. 

Completed
Last Updated: 09 May 2019 12:20 by ADMIN
Created by: shikha
Comments: 1
Type: Bug Report
0

The recorder is not recognizing elements in the iframe and I am not able to record any actions.

Completed
Last Updated: 12 Apr 2019 08:10 by ADMIN

Test Studio  Run-time edition does not deploy the TestAdapter.dll with its installation.

Thus Test Studio tests cannot be executed with the VSTestConsole.exe in a Azure DevOps (VSTS) pipeline. 

Workaround: 

The TestAdapter.dll for VS 2017 and VS 2019 is being deployed to the Test Studio installation folder (for Ultimate or Dev Edition installations) along with the respective *.vsix package. Until the misbehavior is fixed, the vsix package can be copied to the agent machine and installed with double click. Then refer the dll from the respective location. 

Completed
Last Updated: 01 Apr 2019 14:55 by ADMIN

in some cases when load run with profiling is triggered, randomly null data is returned that cannot be serialized and serialization exception is thrown in log and load result reports wrong default data

2019.1.307 LIB

Completed
Last Updated: 20 Mar 2019 12:39 by ADMIN
ADMIN
Created by: Boyan Boev
Comments: 0
Type: Bug Report
0
Invoke OnBlur fails with the following exception in IE 11:

ExecuteCommand failed!
InError set by the client. Client Error:
System.ArgumentOutOfRangeException: Index and length must refer to a location within the string.
Parameter name: length
   at System.String.Substring(Int32 startIndex, Int32 length)
   at ArtOfTest.InternetExplorer.IECommandProcessor.InvokeEvent(IHTMLElement target, BrowserCommand command)
   at ArtOfTest.InternetExplorer.IECommandProcessor.ProcessActionCommands(BrowserCommand request)
   at ArtOfTest.InternetExplorer.IECommandProcessor.ProcessCommandInternal(WebBrowserClass ieInstance, BrowserCommand request, IHTMLDocument2 document)
BrowserCommand (Type:'Action',Info:'NotSet',Action:'InvokeEvent',Target:'ElementId (tagName: 'input',occurrenceIndex: '74')',Data:'onblur--@@--null',ClientId:'Client_007162c7-bb26-4f8e-a68b-32c177fccba3',HasFrames:'False',FramesInfo:'',TargetFrameIndex:'0',InError:'True',Response:'System.ArgumentOutOfRangeException: Index and length must refer to a location within the string.
Parameter name: length
   at System.String.Substring(Int32 startIndex, Int32 length)
   at ArtOfTest.InternetExplorer.IECommandProcessor.InvokeEvent(IHTMLElement target, BrowserCommand command)
   at ArtOfTest.InternetExplorer.IECommandProcessor.ProcessActionCommands(BrowserCommand request)
   at ArtOfTest.InternetExplorer.IECommandProcessor.ProcessCommandInternal(WebBrowserClass ieInstance, BrowserCommand request, IHTMLDocument2 document)')
InnerException: none.
Completed
Last Updated: 18 Mar 2019 15:07 by ADMIN
Created by: Sean
Comments: 10
Type: Bug Report
2
I have updated to the latest version of Test Studio Ultimate 2019.1.212.0 and now my test lists are not running in the order I have them set-up. 
1 2 3 4 5 6