Pending Review
Last Updated: 19 Sep 2019 14:35 by Ajinkya
Created by: Ajinkya
Comments: 0
Type: Bug Report
0
For certain control Test Studio can record elements using chained queries - include parent and child element. If one wants to create such manually or modify an existing element to use chained query, needs to use the coded approach to define elements' queries. There is no way how to adjust an element's query to be chained if using the Edit element pane in the UI. 

It will be really useful to add the ability to modify the elements queries and transform these to chained queries.
Pending Review
Last Updated: 19 Sep 2019 14:29 by Ajinkya

For certain control Test Studio can record elements using chained queries - include parent and child element. If one wants to create such manually or modify an existing element to use chained query, needs to use the coded approach to define elements' queries. There is no way how to adjust an element's query to be chained if using the Edit element pane in the UI. 

It will be really useful to add the ability to modify the elements queries and transform these to chained queries. 

Pending Review
Last Updated: 19 Sep 2019 10:35 by Justin
Created by: Justin
Comments: 0
Type: Bug Report
0
The recorder freezes during recording in customer's application. The issue is most likely with RadMenu for ASP.NET AJAX Translator and when you disable it from the Project Settings, the recording against the basic elements work.
Completed
Last Updated: 18 Sep 2019 11:35 by ADMIN

Hello,

After installing my DevCraft package, my keyboard has limited functionality, when trying to create a new project/solution in Visual Studio 2019. I am able to use "space" and "backspace" keys, but not letters and numbers.

Uninstalled Test Studio Dev or disabling Telerik.TestStudio extension and I have full keyboard functionality on screen for creating a new project in Visual Studio 2019.

As a workaround I am able to use CTRL + V to paste any text from my clipboard.

Thanks.

Jason

Approved
Last Updated: 16 Sep 2019 13:27 by ADMIN

A popup with "End of Central Directory record could not be found." error shows up when I try to add a custom step from the step builder.

When I restart Test Studio, the test works fine.

Pending Review
Last Updated: 16 Sep 2019 12:56 by Estrategy

We are trying to record mobile web tests, but after visiting the first page the device gets disconnected.
A loading screen appears in the DOM explorer, but after a while it stops without recording the second page.

The switching between pages is with normal anchors on the website.

This happens on certain pages with large DOM size.

Pending Review
Last Updated: 13 Sep 2019 06:33 by David
When I generate a unit test in Visual Studio 2019 from existing .tstest, the structure is incorrect. As a result the project has compilation errors.
Pending Review
Last Updated: 12 Sep 2019 13:51 by Dhruv
Created by: Dhruv
Comments: 0
Type: Bug Report
0

I have a project with load test. The test has many user profiles and I need to add more in some cases. When they become too much, I can not save my changes in Test Studio.

The .tstest file is about 40-50 MB when I have this issue. 

Completed
Last Updated: 12 Sep 2019 11:56 by ADMIN

Data bound request does not support "application/json" content type. 

The exception listed in the log: 


[Telerik.TestStudio.Load.Agent.exe(3640:5),Load] AsyncTaskMethodBuilder`1.Start() : An outstanding request finished, but was marked as a failed request.
[Telerik.TestStudio.Load.Agent.exe(3640:3),Error] OutstandingRequest.Run() : EXCEPTION! (see below)
     Situation: Exception during HTTP Request, url [https://server.com]
     Outer Exception Type: System.NotImplementedException
     Message: Content type "application/json" is not implemented.
     HRESULT: 0x80004001 (Official ID (if app.) = E_NOTIMPL, Error Bit = FAILED, Facility = FACILITY_NULL, Code = 16385)
     Call Stack:
          at Telerik.TestingFramework.Net.HttpUtilities.SerializeContent(String strContentEncoding, ContentType contentType, Object objTransformedContent)
          at Telerik.TestStudio.Load.Http.OutstandingRequest.ApplyBindingsToRequest(HttpRequestBuilder requestBuilder)
          at Telerik.TestStudio.Load.Http.OutstandingRequest.<Run>d__24.MoveNext()

Pending Review
Last Updated: 10 Sep 2019 08:13 by Thong

I was able to add a custom dynamic target and bind it to a data source. When I do the same for another custom dynamic target with the same Field Name and save the changes, the data binding breaks.

Both dynamic targets are changed to the first target with the lower destination step.

Completed
Last Updated: 09 Sep 2019 08:01 by ADMIN

Wait for exists step is failing with the error below, when Test Studio is not able to find the element:

Object reference not set to an instance of an object.
InnerException:
System.NullReferenceException: Object reference not set to an instance of an object.

As a result the conditional steps are not working as expected and the test fails.

The workaround for this issue is to change the WaitForExists step to VerifyExists step and the test works.

Pending Review
Last Updated: 06 Sep 2019 11:20 by Brian
Created by: Brian
Comments: 0
Type: Bug Report
0
Hello,

 I downloaded and upgraded Test Studio today to  2019.2.903.0.  During my first attempt to record a test with the newest version it crashed once again.  Attached you will find the logs in zip format.  I look forward to receiving your response, the system has crashed several times today and I was hoping the upgrade would have resolved this issue.
Pending Review
Last Updated: 04 Sep 2019 07:27 by Manuela

The selection from a KendoAngularList dropdown is defaulting to the recorded selection, when the step is data driven.

The temporary workaround is to convert the step to code from the context menu, after it is all configured.

Approved
Last Updated: 22 Aug 2019 16:05 by ADMIN

Android mobile app cannot be configured with Android Gradle plugin 3.4.2 and no test can be recorded against that. 


Approved
Last Updated: 16 Aug 2019 08:15 by ADMIN

Steps to reproduce: 

1. Open an Enter password step and expand in the step pane

2. Set the encrypt property

Expected: All fields with the actual text entered should be masked with *

Actual: If the step is expanded the actual text entered field does not change its value. 

Note: Reopening the test fixes the visual glitch. 

Approved
Last Updated: 06 Aug 2019 13:30 by ADMIN

When using a builtin step for checking rowscount of a table that uses "greater than" or "less than" it fails even though it should not.

"Equals" works fine.. but if I use any other TableVerificationType than "equals", then it fails.. unless if I convert it to a coded step.

So to reiterate: If I convert the step to a coded step then it works.

 

We have several test projects that now have failing tests because of this.

 

Attached test project that showcases the problem.

 

regards

Elo

Completed
Last Updated: 06 Aug 2019 12:23 by ADMIN

Hi

 

I have some databound parrent tests.

 

For these I have created seperate sheets in my excel, to ensure my part test are working i switch their databinding between the sheets to ensure them working in all environments.

 

Everytime i rebind a test the excel file gets corrupted! I have to restart the computer and then it works again… What is the fix for this? 

 

I have attached an example of being unable to open the excel document! 

Approved
Last Updated: 06 Aug 2019 11:19 by ADMIN

Pre-requisite: Upgrade to 2019.1.212.0 from 2018.3.1004.0

1. Select the Test List tab

2. Click the List button and add a new Test List with appropriate tests.

3. Click Save

4. Notice the "Storage service unreachable." message pop-up.

5. Click "OK" on the pop-up.

6. Notice that the Test List and Tests are saved as expected.

 

**This issue did not happen on the previous version of Test Studio

In Development
Last Updated: 05 Aug 2019 12:02 by ADMIN

The step gets successfully executed but fails with the following exception: 

Failure Information: 
~~~~~~~~~~~~~~~
ExecuteCommand failed!
InError set by the client. Client Error:
Cannot read property 'toggle' of undefined
BrowserCommand (Type:'Action',Info:'NotSet',Action:'InvokeJsFunction',Target:'ElementId (tagName: '',occurrenceIndex: '-1')',Data:'$("th:eq(1)").data("kendoFilterMenu").popup.toggle()',ClientId:'663fc963-6051-4044-9dfb-ce01ca15339d',HasFrames:'False',FramesInfo:'',TargetFrameIndex:'-1',InError:'True',Response:'Cannot read property 'toggle' of undefined')
InnerException: none.

Workaround: Record the click step to open the filter without using the Test Studio translator, or in other words against the span element directly. 

Completed
Last Updated: 26 Jul 2019 14:36 by ADMIN
Steps to reproduce:

Using the project attached execute the test which should handle a dialog.

Expected behavior: The save dialog is handled successfully

Actual behavior: The dialog is not handled and the following is output in the log:


System.TimeoutException: Timed out waiting '60000' msec. for any dialog to be handled '1'
Result StackTrace:    
at ArtOfTest.WebAii.Win32.Dialogs.BaseDialog.WaitUntilAnyHandled(IEnumerable`1 dialogs, Int32 handleCount, Int64 timeoutMilliseconds, Boolean resetHandleCount)
   at ArtOfTest.WebAii.Win32.Dialogs.BaseDialog.WaitUntilHandled(Int32 handleCount, Int32 timeout, Boolean resetHandleCount)
   at ArtOfTest.WebAii.Win32.Dialogs.BaseDialog.WaitUntilHandled()
   at UnitTestProject2.UnitTest1.TestMethod1() in c:\Users\ittodorov\Documents\Visual Studio 2012\Projects\UnitTestProject2\UnitTestProject2\UnitTest1.cs:line 42
1 2 3 4 5 6