Completed
Last Updated: 26 Sep 2017 11:10 by ADMIN
1. Record some traffic
2. Try to apply a filter in the last column 'Type'
Expected: To be able to apply a filter
Actual: The filter icon and menu are missing. 
Completed
Last Updated: 26 Sep 2017 11:01 by ADMIN
Using Turkish Character in Folder name and test steps causes Test Studio not to respond
Completed
Last Updated: 12 Sep 2017 11:19 by ADMIN
Often tests require dynamically generated data like a random value that could provide the ability to generate unique test input (like unique user names). One way is to generate random strings/numbers. Another options is to take the current date and time from the system.
Aside from randomness, it might be useful to be able to access environment variables related to the operating system.
Any comments with other use-cases are appreciated.
Completed
Last Updated: 05 Sep 2017 12:06 by ADMIN
As we are using the new TFS API In SP1 2017.2 when trying to connect to TFS Service Online you are getting not authotized error as the one attached.
Completed
Last Updated: 10 Jul 2017 18:39 by Jeremy
ADMIN
Created by: Ryan
Comments: 3
Type: Feature Request
10
Hi all,

I would like the ability for Test Studio to integrate with an array of different Device Cloud providers for mobile testing. 

Thanks!
Completed
Last Updated: 28 Jun 2017 06:56 by ADMIN
Please find attached few sample files and double check the duration of the TRX files/ 

Expected: To be calculated based on the end and start time of test

Actual: It is the same for each result file. 
Completed
Last Updated: 05 Jun 2017 14:59 by Chris
In Test Studio 2017 R2 official release we have detected a problem in the Scheduling functionality for sending results via email. 
We are working on a fix and this is set with the highest priority possible.

Thank you for your understanding and patience!
Completed
Last Updated: 31 May 2017 14:01 by ADMIN
Created by: Tom
Comments: 1
Type: Feature Request
0
More of a question than a feature request.  If I update the description for a test case in the description field, I am not seeing the update in the test list when I have that open prior to the update.  I do see if once I close and re-open the test list.  So my question is, when does a test case get loaded into a test list?  Does it get loaded when you open the test list to execute, or does the test case get loaded just prior to its execution in the test list?  I am hoping the latter.
Completed
Last Updated: 31 May 2017 13:48 by ADMIN
1.The attached sample application initially displays three windows. Two of them are visible and one is hidden. Clicking the button in the second window will make the third one visible. 

Actual: Manager.ActiveApplication.Windows.Count; returns 2 even when the third window is visible. 

Expected: To detect the third window and count it as well. 

Note: If using the Test Studio UI recorder the third window is detected once shown and the recorder is attached to it as expected. 
Completed
Last Updated: 30 May 2017 09:35 by ADMIN
ADMIN
Created by: Elena
Comments: 1
Type: Feature Request
1
Running tests (quick execution or testlists) occasionally Chrome says that one or more browser extensions are missing (screenshot here). This could be randomly observed by local and remote as well as quick execution. Browser is calibrated and latest extensions are installed and enabled. 
Completed
Last Updated: 30 May 2017 09:33 by ADMIN
Please investigate what triggers the message: 

[05/23 16:55:14,Telerik.TestStudio.Desktop.exe(4520:1),Framework] Manager.get_ActiveBrowser() : The current ActiveBrowser is either invisible or disconnected. 

and if it could be restricted to reasonable appearance since it floods the log file currently and make it difficult to read. 
Completed
Last Updated: 17 May 2017 10:48 by ADMIN
1.Create a *.vsmdi item in VS solution. 

2. Open a blank test to access its properties and modify the description. 

3. Add another blank test and add the initial with changed description property as TestAsStep. 

Expected behavior: In the dialog window  to choose test to be executed in the test as step to be able to see the modified description property. 

Actual result: Only the name of test is present in this dialog window. 

This all works fine in standalone version. Tested with both R1.2016 and R3.2015, respectively VS2015 and VS2013. 
Completed
Last Updated: 16 May 2017 12:07 by ADMIN
Like:
- CustomProperty (1/2/3)
- StopTestListOnFailure

Accessing test properties in VS in general is discussed here:
http://feedback.telerik.com/Project/161/Feedback/Details/41122-cannot-get-to-ts-test-properties-in-vs-2012
Completed
Last Updated: 05 May 2017 08:06 by ADMIN
Steps to reproduce. 

1. Open the attached project 

2. The coded step will fail to locate the rad grid as well as a not related element outside of the grid when executed in Edge. 

3 .The UI recorded steps against the same elements from the coded step will be working fine in Edge

Expected: Both coded and UI steps to locate the same elements

Actual: Edge execution could not locate the elements in code. All other browsers work fine in both scenarios. 
Completed
Last Updated: 05 May 2017 08:03 by ADMIN
ADMIN
Created by: Ivaylo
Comments: 1
Type: Feature Request
0
Steps to reproduce:



1. Execute the internally attached test in Edge.



Expected behavior: The test should pass

Actual behavior: The extract step fails immediately (step 3)
Completed
Last Updated: 18 Apr 2017 10:21 by ADMIN
Created by: Miguel
Comments: 1
Type: Feature Request
0
Hi
 I can perform performance tests to an .exe using Telerik Test Studio?
Completed
Last Updated: 29 Mar 2017 10:04 by ADMIN
Completed
Last Updated: 23 Mar 2017 15:09 by ADMIN
Created by: Jed
Comments: 1
Type: Feature Request
0
Here's the link for the c# code sample:
http://docs.telerik.com/teststudio/libraries/testingtoolssamples/skipiteration.sflb

The link for the VB sample is broken as well.
Completed
Last Updated: 22 Mar 2017 18:38 by ADMIN
Steps to reproduce: 

1. Into the attached sample project there are recorded elements from the same frame. 

After the first recording session a baseURL was added for the project and the frame was modified accordingly

2.Trying to record further steps against elements in the same frame disregards the set BaseURL and adds the element under new frame in Elements Explorer. 

Expected would be to use the already recorded frame and element. 

Details shared internally. 
Completed
Last Updated: 22 Mar 2017 06:07 by ADMIN
Navigate to the provided page and try to enter text in the text area. When in JS browsers nothing is recorded. In IE the enter text step is successfully recorded and could be also executed against Chrome and FF. 

Details shared internally.