Unplanned
Last Updated: 15 Nov 2016 07:55 by ADMIN
The project is in TFS.

When using "Get latest version of tests automatically from TFS" while test list scheduling - the project is downloaded much faster from TFS than it is uploaded on the execution machine.

It is observable for large projects (>1Gb)
Unplanned
Last Updated: 27 Jul 2016 11:29 by ADMIN
The project is in TFS source control environment.

The scheduling machine is used as execution as well.

When scheduled test list using option "Get latest version of tests automatically from TFS" the project is copied twice.
Unplanned
Last Updated: 21 Oct 2016 05:55 by ADMIN
ADMIN
Created by: Boyan Boev
Comments: 4
Type: Bug Report
1
When we use TLS 1.0 the recording of the load traffic works as expected. As soon as we change TLS to version 1.2 it does not work.
Unplanned
Last Updated: 07 Apr 2016 13:11 by ADMIN
 Steps to reproduce:

  1. Set a break point in code file of Test Studio VS plugin project

  2. Run in debug mode

  3. Press F10 to continue

Error message:

Unable to find the window 'WPF Application' inside application '....\bin\Debug\Application.exe'

Unplanned
Last Updated: 30 Mar 2016 08:19 by ADMIN
Steps to reproduce and access to the application are in the internal description.
Unplanned
Last Updated: 21 Mar 2016 13:52 by ADMIN
 If you have TestList tab opened by default in VS, when opening the project we used to detect .tstest type tests and load them - now we don't and we do not show them in Test List view, unless they are opened from solution, but still show only test opened in solution, not all tests.
Unplanned
Last Updated: 17 Mar 2016 13:36 by ADMIN
Steps to reproduce and access to the application are in the internal description.

Unplanned
Last Updated: 22 Feb 2016 09:38 by ADMIN
All the information is on a single row and it also contains some unexpected symbols.

See the attached screen shot.
Unplanned
Last Updated: 20 Jan 2016 12:27 by Don
Steps to reproduce and video of the issue are in the internal description.
Unplanned
Last Updated: 23 Nov 2015 09:26 by ADMIN
Steps to reproduce:

1. Run a performance test (performance counters should be gathering).
2. Open the details view
3. Enable some performance counters representation.
4. Select some specific step from the upper bar
5. Click 'Select all' link
6. Repeat step 

Expected:  The particular step is selected.
Actual: Unable to select a single step.
Unplanned
Last Updated: 18 Jan 2016 14:56 by ADMIN
On customer specific web page, after recording a click on a checkbox, playback yields:
'11/5/2015 10:35:47 AM' - 'Fail' : 11. Check 'IsCallActionHidden' to be 'True'
------------------------------------------------------------
Failure Information: 
~~~~~~~~~~~~~~~
Invalid input element type 'Hidden'!
InnerException:
System.ArgumentException: Invalid input element type 'Hidden'!
   at ArtOfTest.WebAii.Design.IntrinsicTranslators.Descriptors.CheckActionDescriptor.Execute(Browser browser)
   at ArtOfTest.WebAii.Design.Extensibility.HtmlActionDescriptor.Execute(IAutomationHost autoHost)
   at ArtOfTest.WebAii.Design.Execution.ExecutionEngine.ExecuteStep(Int32 order)

Detailed repro steps will be added to the internal bug report.
Unplanned
Last Updated: 21 Jul 2016 08:37 by ADMIN
In a customer supplied project and performance result set, 5 of the results are silently failing to load. When you look in the log you see:

Outer Exception Type: System.ArgumentNullException
     Message: Value cannot be null.
          Parameter name: key

From the users perspective he was expecting to see all 15 results, but can only see 5 of them. Test Studio did not report any errors to the user while loading the results. This is what I mean by "silently failing". It's not until you think to enable logging then look at the log do you see the error.

So this problem report is about two very closely related issues:
1) No error/warning is shown to the user when Test Studio failed to load specific .tsperf files
2) Why did Test Studio fail to load these specific result files?

The test project and result files will be added to the internal bug report.
Unplanned
Last Updated: 20 Jul 2016 10:07 by madnut
Steps to reproduce:


Execute the project attached internally.


Expected behavior: To add the value in the third numeric textbox

Actual behavior: The value is always set to the first numeric textbox
Unplanned
Last Updated: 19 Oct 2015 12:53 by ADMIN
A test that tries to click on the absolute center of a tab in a RadRibbonView ignores the click. Clicking just one pixel above or below or left or right of absolute center works as expected. Attached is a sample test project and WPF project to reproduce the problem.
Unplanned
Last Updated: 31 Aug 2015 15:48 by ADMIN
The highlighted the ID below is not getting recognized by Test Studio as dynamic target.

GET /expqaclone/PRServlet/5r4yig9LKACE6owwcMWTLQ%5B%5B*/!STANDARD?action=openAssignment&contentID=d40146a8-564d-4020-af02-a3cb9a263b8f&dynamicContainerID=null&isWAStaticHarness=undefined&key=ASSIGN-WORKLIST%20PEGAFIN-EXPENSE-WORK-REPORT%20EX-1934!ENTEREXPENSEITEMS&label=undefined&portalName=ExpenseManager&portalThreadName=STANDARD&pyActivity=%40baseclass.doUIAction&pzHarnessID=HID071763F6B0E70BF06EE1756A80DD7F23&reload=undefined&skipConflictCheck=undefined HTTP/1.1


Details for investigation such as load test, screenshot and fiddler trace are attached in the internal description.
Unplanned
Last Updated: 26 Aug 2015 07:52 by ADMIN
Please follow the instructions provided in the internal description.
Unplanned
Last Updated: 19 Aug 2015 11:33 by ADMIN
Debugger does not show when the monitor is portrait oriented.


Steps to reproduce:

1. Use the setup as attached.

2. Set the debugger and run a test.

Expected behavior: the debugger to show on the screen

Actual behavior: debugger does not show
Unplanned
Last Updated: 11 Sep 2017 15:05 by Matthias
With the tracelog ON the application can find windows and will run ok (except for the memory leak).If you turn the tracelog off, it will fail after a couple of iterations.(This is the registry key in HKEY_CURRENT_USER\Software\Wow6432Node\Telerik\Test Studio\TraceLogEnabled )

Application and test code to replicate the problem is shared internally.
Unplanned
Last Updated: 19 May 2015 08:12 by ADMIN
If a test script, when run in Chrome, causes the browser to get a Page Not Found returned the test is permanently stuck and cannot recover from this error. The rest of the iterations of a Data Drive test will not run even though it includes a NavigateTo step. NOTE: running the same test in IE works as expected. The other browsers are untested in this same scenario at this time.

A test to repro the problem can be found on the internal bug report.
Unplanned
Last Updated: 07 Apr 2015 13:36 by ADMIN
If the port for the storage service is blocked by a firewall on the external machine (but not for the scheduling service), and you then pick a local result and Publish to Server, after a long time (minutes) Test Studio will display "Results successfully published" but they actually were not published at all.