Won't Fix
Last Updated: 24 Mar 2016 15:52 by ADMIN
Access to the application and a test project are in the internal description.
Won't Fix
Last Updated: 01 Jul 2016 07:32 by ADMIN
ADMIN
Created by: Ivaylo
Comments: 3
Type: Feature Request
4
Steps for repro:

Execute the attached test (Web Test). Step 12 hangs infinitely without prompting an error message.

Expected behavior: To fail after certain period of time.

If you enable step 11, which is wait for exist for element in the failing step, the test passes. Also if you change the find logic to tagname == span and TextContent == Style, it starts working.

Won't Fix
Last Updated: 21 Apr 2015 14:14 by Kristine
Highlighting appears badly broken in Silverlight for v2014.4.1411.

Go to http://demos.telerik.com/silverlight and try the Grid or TreeView. Turn on highlighting mode, then hover over a grid cell or a tree node. 

0) Note the scoping buttons (sorry, don't know the "official title"; see snapshots) are offset and inaccessible--if you try to move over and click them, the scope of the highlight changes and the buttons vanish.

1) I'm unable to get the popup menu to appear at all--so I can't even move down into the DOM/XAML explorer to do things manually.

See attachment screenshot. Also check out video of the issue: http://www.screencast.com/t/dUsdmIXyqrhb
Won't Fix
Last Updated: 10 Nov 2015 07:21 by ADMIN
When a popup dialog (a div overlay) opens in a specific customers application, any clicks in the recording window are ignored. A video demonstration and repro steps will be added to the internal problem report.
Won't Fix
Last Updated: 20 Mar 2015 14:50 by ADMIN
Created by: Erik
Comments: 1
Type: Bug Report
0
Hi

I just installera test studio and capture a web test is no problem but when I want to capture a load test, no HTTP requests are captured? What can be the problem?
Won't Fix
Last Updated: 03 Nov 2015 09:00 by ADMIN
Created by: Imported User
Comments: 2
Type: Bug Report
1
V2014.4.1411

URL: http://www.ajaxcontroltoolkit.com/CascadingDropDown/CascadingDropDown.aspx

Record a test in IE 11 using options Audi, S4, Metallic. When selecting the final option, Metallic, I get an error as show in screenshot attached. "Microsoft Visual C++ Runtime Library. 

Works fine in FF 32 and Chrome 40.

Log attached. Message from error dialog below.

---------------------------
Microsoft Visual C++ Runtime Library
---------------------------



This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

---------------------------
OK   
---------------------------

Won't Fix
Last Updated: 03 Nov 2015 09:03 by ADMIN
In the DOM explorer's Verification for Content, the InnerText of the selected element is truncated. I can click in the field and move to the end of the text, but it's still the truncated content. If I move into the text field and press Ctrl-A, Ctrl-C, the *proper, untruncated* content is copied to the clipboard.

Hoverover text shows full content.
Won't Fix
Last Updated: 10 Nov 2015 15:29 by ADMIN
Sometimes the annotation red boxes are left behind when moving from one page to another page in an application.
Won't Fix
Last Updated: 20 Mar 2015 14:05 by ADMIN
In addition to the original server, I have two execution servers created and "connected" to the scheduling server. However, the only execution server that is listed is the local machine of the box the tests are running from. 

One of the execution servers is a physical box with Win 2008 R2 box and is connected over a VPN. The other is a VM with Win7 running on the original computer (also running the scheduling server and acting as one of the execution servers).

What am I missing?
Won't Fix
Last Updated: 15 Jan 2016 08:34 by ADMIN
1) Load the attached Fiddler playback trace file in Fiddler
2) Start the auto-responder
3) Launch Test Studio recorder on a machine with IE 8
4) Navigate to http://qcom.test/default_login.asp

Expected: A NavigateTo step to be recorded along with a Connect to Modal Popup step
Actual: The Connect to Modal Popup step is not recorded.

NOTE: This works as expected using IE 10.
Won't Fix
Last Updated: 04 Sep 2015 12:06 by ADMIN
After configuring a Test Studio test to automate a Silverlight Out Of Browser application, the browser thinks it's running in-browser. Silverlight API calls that only work when running in Out Of Browser mode now fail. For example:

This line of code returns false when it should return true:
Application.Current.IsRunningOutOfßrowser

This line of code throws an exception in the SL OOB application and will not run:
Application.Current.MainWindow.WindowState WindowState.Maximized;

Applications that rely heavily on such API calls cannot be automated by Test Studio's current SL OOB automation approach.
Won't Fix
Last Updated: 30 Apr 2015 05:50 by ADMIN
The value for UseQuery in a FrameInfo is always set. You clear it, save changes only to find it's turned back on. Test Studio is not persisting the change to disk.

Attached to the internal problem report will be a link to the project as well as a link to a 5 minute video demonstrating the problem.
Won't Fix
Last Updated: 01 Apr 2015 10:48 by ADMIN
Visual Studio 2012 introduced a new command line runner, VSTest.Console.exe
http://msdn.microsoft.com/en-us/library/jj155796.aspx

Test Studio works with it when given the right command line parameters, for example:
vstest.console "Scratch Html Test.tstest" /inIsolation /settings:TestSettings2.testsettings /logger:trx
Won't Fix
Last Updated: 03 Nov 2015 09:10 by ADMIN
After navigating to a specific page of a customers application while using the Chrome recorder, the highlighting is way off. Highlighting works as expected when recording in IE. Specific repro stpes will be given in the internal bug report.
Won't Fix
Last Updated: 03 Nov 2015 09:23 by ADMIN
From ticket 867813

Running the attached customers test "AdminAppointmentRulesMaintenance" in either Chrome 37 or 38, step 24 fails with:
'10/10/2014 5:15:50 PM' - 'Fail' : 24. Click 'Save Button (Html Input Submit Control)'
------------------------------------------------------------
Failure Information: 
~~~~~~~~~~~~~~~
ExecuteCommand failed!
InError set by the client. Client Error:
Cannot read property 'URL' of null
BrowserCommand (Type:'Information',Info:'DocumentMarkup',Action:'NotSet',Target:'null',Data:'',ClientId:'c3f8c7ec-d4e7-4856-947a-03f13b197b31',HasFrames:'False',FramesInfo:'',TargetFrameIndex:'0',InError:'True',Response:'Cannot read property 'URL' of null')
InnerException: none.

InnerException:
ArtOfTest.WebAii.Exceptions.ExecuteCommandException: ExecuteCommand failed!
InError set by the client. Client Error:
Cannot read property 'URL' of null
BrowserCommand (Type:'Information',Info:'DocumentMarkup',Action:'NotSet',Target:'null',Data:'',ClientId:'c3f8c7ec-d4e7-4856-947a-03f13b197b31',HasFrames:'False',FramesInfo:'',TargetFrameIndex:'0',InError:'True',Response:'Cannot read property 'URL' of null')
InnerException: none.

   at ArtOfTest.WebAii.Core.Browser.ExecuteCommandInternal(BrowserCommand request)
   at ArtOfTest.WebAii.Core.Browser.ExecuteCommand(BrowserCommand request, Boolean performDomRefresh, Boolean waitUntilReady)
   at ArtOfTest.WebAii.Core.Browser.RefreshDomTree()
   at ArtOfTest.WebAii.Core.Browser.ExecuteCommand(BrowserCommand request, Boolean performDomRefresh, Boolean waitUntilReady)
   at ArtOfTest.WebAii.Core.Browser.ExecuteCommand(BrowserCommand request)
   at ArtOfTest.WebAii.Core.Actions.Click(Element targetElement)
   at ArtOfTest.WebAii.Controls.HtmlControls.HtmlControl.Click()
   at ArtOfTest.WebAii.Controls.HtmlControls.HtmlControl.Click(Boolean isClosing)
   at ArtOfTest.WebAii.Design.IntrinsicTranslators.Descriptors.ClickActionDescriptor.Execute(Browser browser)
   at ArtOfTest.WebAii.Design.Extensibility.HtmlActionDescriptor.Execute(IAutomationHost autoHost)
   at ArtOfTest.WebAii.Design.Execution.ExecutionEngine.ExecuteStep(Int32 order)
Won't Fix
Last Updated: 03 Nov 2015 12:08 by ADMIN
Some customers (myself included) who use NVidia chipsets and setup for dual monitor find that image capture does not work properly. All you capture is white images in:
- Story board
- Image verification
Won't Fix
Last Updated: 20 Jul 2016 08:14 by ADMIN
ADMIN
Created by: Boyan Boev
Comments: 1
Type: Feature Request
0
StartTime method returns the start time always in Greenwich Mean Time time zone and not in the user's time zone.
Won't Fix
Last Updated: 30 Mar 2016 06:37 by ADMIN
After using the Visual Debugger to modify the find expression of an element, after the test is complete Test Studio prompts you to save changes into the test project. After you click Apply, Test Studio may take excessively long to store the changes.

Here's a video demonstration from a customer having the problem:
http://screencast.com/t/OHxRLid9MeW

Repro steps will be given in the internal bug report.
Won't Fix
Last Updated: 03 Nov 2015 11:37 by ADMIN
A specific customer test, when run in Chrome, is frequently (but randomly) failing while running.
The customer is using https://chrome.google.com/webstore/detail/user-agent-switcher-for-c/djflhoibgkdhkhhcedjiklpkjnoahfmg   to simulate that the browsers are on a mobile device. 
So, this causes the website to behave differently (it thinks it's talking to an iPhone). 

 The test log shows:

'8/20/2014 2:01:52 PM' - 'Fail' : 37. Verify 'InnerText' 'Contains' 'Lingerie' on 'CategoryHeading'
------------------------------------------------------------
Failure Information: 
~~~~~~~~~~~~~~~
ExecuteCommand failed!
BrowserCommand (Type:'Information',Info:'DocumentMarkup',Action:'NotSet',Target:'null',Data:'',ClientId:'8233b98f-2478-4409-8d22-c5b011da8938',HasFrames:'False',FramesInfo:'',TargetFrameIndex:'-1',InError:'False',Response:'')
InnerException: System.TimeoutException: Timed out waiting for command to be handled
   at ArtOfTest.WebAii.Messaging.Process.BrowserHostsProxyRemoted.ProcessBrowserRequest(BrowserCommand command, String requestId, Int32 timeout)
   at ArtOfTest.WebAii.Messaging.Process.BrowserHostsProxyRemoted.ProcessBrowserRequest(BrowserCommand command, String requestId)
   at ArtOfTest.WebAii.Core.Browser.ExecuteCommandInternal(BrowserCommand request)

InnerException:
ArtOfTest.WebAii.Exceptions.ExecuteCommandException: ExecuteCommand failed!
BrowserCommand (Type:'Information',Info:'DocumentMarkup',Action:'NotSet',Target:'null',Data:'',ClientId:'8233b98f-2478-4409-8d22-c5b011da8938',HasFrames:'False',FramesInfo:'',TargetFrameIndex:'-1',InError:'False',Response:'')
InnerException: System.TimeoutException: Timed out waiting for command to be handled
   at ArtOfTest.WebAii.Messaging.Process.BrowserHostsProxyRemoted.ProcessBrowserRequest(BrowserCommand command, String requestId, Int32 timeout)
   at ArtOfTest.WebAii.Messaging.Process.BrowserHostsProxyRemoted.ProcessBrowserRequest(BrowserCommand command, String requestId)
   at ArtOfTest.WebAii.Core.Browser.ExecuteCommandInternal(BrowserCommand request)
 ---> System.TimeoutException: Timed out waiting for command to be handled
   at ArtOfTest.WebAii.Messaging.Process.BrowserHostsProxyRemoted.ProcessBrowserRequest(BrowserCommand command, String requestId, Int32 timeout)
   at ArtOfTest.WebAii.Messaging.Process.BrowserHostsProxyRemoted.ProcessBrowserRequest(BrowserCommand command, String requestId)
   at ArtOfTest.WebAii.Core.Browser.ExecuteCommandInternal(BrowserCommand request)
   --- End of inner exception stack trace ---
   at ArtOfTest.WebAii.Core.Browser.ExecuteCommandInternal(BrowserCommand request)
   at ArtOfTest.WebAii.Core.Browser.ExecuteCommand(BrowserCommand request, Boolean performDomRefresh, Boolean waitUntilReady)
   at ArtOfTest.WebAii.Core.Browser.RefreshDomTree()
   at ArtOfTest.WebAii.Core.Browser.ArtOfTest.Common.IAutomationHost.EnsureStateIsCurrent()
   at ArtOfTest.WebAii.Design.Execution.ExecutionUtils.WaitForAllElements(IAutomationHost host, AutomationDescriptor descriptor, Int32 timeout)
   at ArtOfTest.WebAii.Design.Execution.ExecutionEngine.ExecuteStep(Int32 order)

Most of the time it fails on one of the many Verify steps, but you cannot predict which one. I tried increasing the WebKitExecutionDelay to solve the problem. It did not help.

The test that demonstrates the problem will be attached to the internal bug report.

Won't Fix
Last Updated: 14 Mar 2017 15:40 by Sebastien AUROUX
Access to the application and steps to reproduce are in the internal description.