Won't Fix
Last Updated: 02 Nov 2015 08:51 by ADMIN
Steps to reproduce:

Using this wpf application attached internally

Configure wpf test and record the following steps:


1. Close the main WPF window (Alt+F4) and make sure the close step is recorded.

2. A confirmation window appear, select Yes.


Replay the recorded steps:


Expected behavior: To be able to successfully close the application and the confirmation window.

Actual behavior: Step 2 fails with Unable to find the window error.


Won't Fix
Last Updated: 07 Oct 2015 12:27 by ADMIN
Steps to reproduce and the test project are in the internal description.
Won't Fix
Last Updated: 24 Aug 2015 15:51 by ADMIN
ADMIN
Created by: Cody
Comments: 0
Type: Feature Request
0
To more accurately simulate asynchronous ajax calls it would be useful to be able to set a step of a load test as "fire and forget". This means send the request but immediately move on to the next step. Don't hold up sending more requests waiting for the response to come back for the step marked "fire and forget".
Won't Fix
Last Updated: 11 May 2016 13:34 by Vivek
ADMIN
Created by: Andy Wieland
Comments: 2
Type: Bug Report
1
In Test Studio iOS native testing, once project is opened I immediately receive the attached "Recorder Host Error - Cannot connect to message server."
this worked correctly with the same settings and configuration just an hour before the error began.  The previous time this happened only a machine reboot seemed to fix the issue, but it has returned again. 
Won't Fix
Last Updated: 15 Jul 2016 15:04 by ADMIN
Steps to reproduce:

Using Windows 8 machine:


1. Navigate to : http://qa.app.mytaskit.com/

2. Login.


3. Click highlight element  and try to select an action from the context menu

Expected Behavior: You should be able to perform the action quite smoothly

Actual behavior: IE crashes


Poor performance is observed with Chrome as well, at least it is not crashing
Won't Fix
Last Updated: 14 Aug 2015 10:44 by ADMIN
Please follow the instruction in the internal description.
Won't Fix
Last Updated: 03 Sep 2015 06:58 by ADMIN
The SL project and steps to reproduce are in the internal description.
Won't Fix
Last Updated: 30 Mar 2016 11:10 by ADMIN
A customer specific WPF application has a sort of splash screen and long initialization time. If there's no execution delay at the beginning of the Test Studio test, i.e. the test starts with a Click X, the WPF test will hang indefinitely. No error is given, no timeout happens, it simply acts like it's caught in some sort of infinite loop.

Repro steps will be given in the internal problem report.
Won't Fix
Last Updated: 03 Sep 2015 10:34 by ADMIN
1) Use the attached WPF sample application as the application under test
2) Create a new WPF test and configure it for the attached sample application
3) Start recording
4) Click the big "Display Second Window" button - this opens a new popup window
5) Click the text "Name0" in the popup window
6) Play back the freshly recorded test

Expected: The test to pass
Actual: The test fails on step 2 saying it cannot find element
Won't Fix
Last Updated: 14 Jun 2017 11:43 by Tom
ADMIN
Created by: ipanchev
Comments: 4
Type: Feature Request
10
I want to be able to re-order the tests inside a dynamic test list.
Won't Fix
Last Updated: 03 Sep 2015 12:41 by ADMIN
Install the internally attached SL OOB application.

Start the installed application and try to configure it for testing. Test Studio prompts the following in the log:


[07/17 16:40:41,Telerik.TestStudio.Desktop.exe(18996:9),Recording] IERecorderManager.LaunchNewRecorder() : EXCEPTION! (see below)
     Outer Exception Type: System.ApplicationException
     Message: Exception thrown attempting to launch Silverlight application. Please make sure Silverlight is properly installed and you are able to launch it.
     HRESULT: 0x80131600 (Official ID (if app.) = COR_E_APPLICATION, Error Bit = FAILED, Facility = FACILITY_URT, Code = 5632)
     Call Stack:
          at ArtOfTest.WebAii.BrowserSpecialized.SilverlightOutOfBrowser.SilverlightOutOfBrowserActions.LaunchNewBrowserInstance(Int32 timeout, ProcessWindowStyle windowStyle, String arguments, String pipename)
          at ArtOfTest.WebAii.Core.Manager.LaunchNewBrowser(BrowserType browserToLaunch, Boolean waitForBrowserToConnect, ProcessWindowStyle windowStyle, String arguments)
          at Telerik.TestStudio.Web.IERecorder.IERecorderManager.LaunchNewRecorder(Action`2 asyncCallback, FloatingUIMode mode, BrowserType browserType, String arguments)

     Inner Exception Type: System.ArgumentException
     Message: Invalid path to Out-Of-Browser application: C:\Program Files (x86)\SEL\SEL SynchroWAVe Event 2015\SynchroWAVeEvent.exe
     HRESULT: 0x80070057 (Official ID (if app.) = E_INVALIDARG, Error Bit = FAILED, Facility = FACILITY_WIN32, Code = ERROR_INVALID_PARAMETER)
     Call Stack:
          at ArtOfTest.WebAii.BrowserSpecialized.SilverlightOutOfBrowser.SilverlightOutOfBrowserActions.LaunchNewBrowserInstance(Int32 timeout, ProcessWindowStyle windowStyle, String arguments, String pipename)
Won't Fix
Last Updated: 31 Aug 2015 14:06 by ADMIN
ADMIN
Created by: Boyan Boev
Comments: 1
Type: Feature Request
0
I want to be able to add multiple quick steps at once during the recording.

It would be very handy of I could do the following.

1) Activate highlighting
2) Select an element
3) Go to quick steps
>> Here comes the wish
4) Being able to select all the needed quick steps.
5) I click on a button to create all the desired quick steps.
Won't Fix
Last Updated: 23 Sep 2015 07:41 by ADMIN
While implementing AfterCommandExecuted browser event handler there is a difference between sender and EventsArgs :

private void ActiveBrowser_AfterCommandExecuted(object sender, ArtOfTest.WebAii.EventsArgs.BrowserCommandEventArgs e)
        {
            var browser = (Browser)sender;

            //This returns true when there are frames in the browser
            if (e.Command.HasFrames)
            {

                //This returns the frameInfo in String form for all frames in current browser. 
                Manager.Log.WriteLine("FrameInfo :" + e.Command.FramesInfo);

                //At the same time the 'normal' browser returns a frameCount of zero
                Manager.Log.WriteLine("FrameCount from browser:" + browser.Frames.Count);
               
                           
               
            }
        }

e.Command.HasFrames returns true while browser.FramesCount returns 0

Steps to reproduce:

Download the attached project and run it. The implementation of the event handler is in the very first step.
Won't Fix
Last Updated: 21 Aug 2015 11:10 by ADMIN
Please add the ability to edit particular day in a recurring scheduled test list.

For example you have scheduled test list for entire week to execute daily @ 5AM, for some reason on Friday only you want to execute @ 7AM.

Thanks.
Won't Fix
Last Updated: 30 Mar 2016 11:19 by ADMIN
A customer has a WPF app that will display a warning message at startup if Internet is not available. The user can click past this warning message and still use the app. However Test Studio will not record any actions in the app in this state.

It will record just fine if the app finds Internet connectivity and starts normal.

Details for obtaining, installing and running the customers WPF app can be found on the internal bug report.
Won't Fix
Last Updated: 01 Oct 2015 11:17 by ADMIN
Steps to reproduce:


1. Navigate to https://classflowqa2.prometheanjira.com

2. Login. (Credentials provided in the internal description)

3. After you are logged try to highlight an element


Expected behavior: to be able to highlight any element on the page

Actual behavior: the highlighting does not work at all
Won't Fix
Last Updated: 18 Nov 2015 08:42 by ADMIN
Using the help tab in Test Studio hit Submit ticket. All dropdowns and input fields are active except the message area, which is disabled. Refer to the screenshot attached.
Won't Fix
Last Updated: 13 May 2015 07:26 by ADMIN
Intermittently a specific customer is getting the error below after click Run to run a test in Test Studio on FireFox version 37.0.2. The customer just clicks Run a second time and it may or may not happen. I am unable to reproduce the problem and we cannot get direct access to his application.

Overall Result: Fail
------------------------------------------------------------
'30.04.2015 16:20:04' - Executing test: 'IBN_Test_20150423_11h40', path: 'IBN_Test_20150423_11h40.tstest.'
'30.04.2015 16:20:04' - Using .Net Runtime version: '4.0.30319.18444' for test execution. Build version is '2015.1.319.0'.
'30.04.2015 16:20:04' - Starting execution....
------------------------------------------------------------
------------------------------------------------------------
'30.04.2015 16:20:40' - Using 'FireFox' version '37.0.2' as default browser. 
'30.04.2015 16:20:49' - 'Pass' : 1. Navigate to : 'http://XXXXXXXXX'
'30.04.2015 16:20:50' - 'Pass' : 2. Click 'ENSpan'
'30.04.2015 16:20:50' - 'Pass' : 3. Click 'LoginLinkTopLink'
'30.04.2015 16:20:50' - 'Pass' : 4. Enter text 'i.nimaga@xpert-technologies.ch' in 'BugzillaLoginTopText'
'30.04.2015 16:20:50' - 'Pass' : 5. Click 'BugzillaPasswordTopPassword'
'30.04.2015 16:20:50' - 'Pass' : 6. Enter text 'qsxt2010' in 'BugzillaPasswordTopPassword'
'30.04.2015 16:20:51' - 'Pass' : 7. Click 'LogInTopSubmit'
'30.04.2015 16:20:51' - 'Pass' : 8. Enter text '3500' in 'QuicksearchMainText'
'30.04.2015 16:20:53' - 'Pass' : 9. Click 'FindSubmit'
'30.04.2015 16:20:58' - 'Pass' : 10. Click 'BzShowBugColumn2TableCell'
'30.04.2015 16:20:59' - 'Pass' : 11. Click 'NewLink'
'30.04.2015 16:21:03' - 'Pass' : 12. Click 'Metis Smart SuiLink'
'30.04.2015 16:21:04' - 'Pass' : 13. Select 'ByValue' option 'Monitoring' on 'ComponentSelect'
'30.04.2015 16:21:04' - 'Pass' : 14. Enter text 'Ticked made with Telerik Test Studio' in 'ShortDescText'
'30.04.2015 16:21:04' - 'Pass' : 15. Enter text 'Please see the attached document.' in 'CommentTextArea'
'30.04.2015 16:21:04' - 'Pass' : 16. Click 'TableCell'
'30.04.2015 16:21:04' - 'Pass' : 17. Click 'Button'
'30.04.2015 16:21:05' - 'Pass' : 18. Wait for '1000' msec.
'30.04.2015 16:21:06' - 'Fail' : 19. Click 'DataFile'
------------------------------------------------------------
Failure Information: 
~~~~~~~~~~~~~~~
hwnd cannot be IntPtr.Zero or null.
InnerException:
System.ArgumentException: hwnd cannot be IntPtr.Zero or null.
   at System.Windows.Automation.AutomationElement.FromHandle(IntPtr hwnd)
   at ArtOfTest.WebAii.BrowserSpecialized.Firefox.FireFoxActions.GetContentRectangle()
   at ArtOfTest.WebAii.Core.Browser.get_ContentRectangle()
   at ArtOfTest.WebAii.ObjectModel.Element.GetRectangle()
   at ArtOfTest.WebAii.Controls.HtmlControls.HtmlControl.MouseClick()
   at ArtOfTest.WebAii.Design.IntrinsicTranslators.Descriptors.ClickActionDescriptor.Execute(Browser browser)
   at ArtOfTest.WebAii.Design.Extensibility.HtmlActionDescriptor.Execute(IAutomationHost autoHost)
   at ArtOfTest.WebAii.Design.Execution.ExecutionEngine.ExecuteStep(Int32 order)
------------------------------------------------------------
'30.04.2015 16:21:06' - Detected a failure. Step is marked 'ContinueOnFailure=False' aborting test execution.
------------------------------------------------------------
'30.04.2015 16:21:06' - Overall Result: Fail
'30.04.2015 16:21:06' - Duration: [0 min: 25 sec: 854 msec]
------------------------------------------------------------
'30.04.2015 16:21:07' - Test completed!
Won't Fix
Last Updated: 13 May 2015 07:26 by ADMIN
Intermittently a specific customer is getting the error below after click Run to run a test in Test Studio on FireFox version 37.0.2. The customer just clicks Run a second time and it may or may not happen. I am unable to reproduce the problem and we cannot get direct access to his application.
     
------------------------------------------------------------
'30.04.2015 16:16:32' - Executing test: 'IBN_Test_20150423_11h40', path: 'IBN_Test_20150423_11h40.tstest.'
'30.04.2015 16:16:32' - Using .Net Runtime version: '4.0.30319.18444' for test execution. Build version is '2015.1.319.0'.
'30.04.2015 16:16:32' - Starting execution....
'30.04.2015 16:16:39' - Failure detected during execution. Details:
------------------------------------------------------------
'30.04.2015 16:16:39' - System.ServiceModel.EndpointNotFoundException: There was no endpoint listening at net.pipe://localhost/Telerik/TestingFramework.Hosts.Manager that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details. ---> System.IO.PipeException: The pipe endpoint 'net.pipe://localhost/Telerik/TestingFramework.Hosts.Manager' could not be found on your local machine. 
   --- End of inner exception stack trace ---

Server stack trace: 
   at System.ServiceModel.Channels.PipeConnectionInitiator.GetPipeName(Uri uri, IPipeTransportFactorySettings transportFactorySettings)
   at System.ServiceModel.Channels.NamedPipeConnectionPoolRegistry.NamedPipeConnectionPool.GetPoolKey(EndpointAddress address, Uri via)
   at System.ServiceModel.Channels.CommunicationPool`2.TakeConnection(EndpointAddress address, Uri via, TimeSpan timeout, TKey& key)
   at System.ServiceModel.Channels.ConnectionPoolHelper.EstablishConnection(TimeSpan timeout)
   at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.OnOpen(TimeSpan timeout)
   at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannel.OnOpen(TimeSpan timeout)
   at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannel.CallOpenOnce.System.ServiceModel.Channels.ServiceChannel.ICallOnce.Call(ServiceChannel channel, TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannel.CallOnceManager.CallOnce(TimeSpan timeout, CallOnceManager cascade)
   at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
   at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]: 
   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
   at Telerik.TestingFramework.Hosts.Common.IWebSocketHost.RegisterListener(Int32 pid)
   at ArtOfTest.WebAii.Messaging.Process.HostsProxy.Start()
   at ArtOfTest.WebAii.Messaging.Process.HostsProxy.RegisterListener(MessageListener listener)
   at ArtOfTest.WebAii.Messaging.Process.ExecutionMediator.RegisterManager(Manager manager)
   at ArtOfTest.WebAii.BrowserSpecialized.Firefox.FireFoxActions.LaunchNewBrowserInstance(ProcessWindowStyle windowStyle, Manager manager)
   at ArtOfTest.WebAii.Core.Manager.LaunchNewBrowser(BrowserType browserToLaunch, Boolean waitForBrowserToConnect, ProcessWindowStyle windowStyle, String arguments)
   at ArtOfTest.WebAii.Design.Execution.ExecutionEngine.InitializeWeb(ExecutionEngineCreateParams initParams)
   at ArtOfTest.WebAii.Design.Execution.TestExecuteProxy.CreateAndInitializeEngine(Test test, ExecutionEngineCreateParams cp)
   at ArtOfTest.WebAii.Design.Execution.TestExecuteProxy.ExecuteTest(ExecuteTestCommand command)
------------------------------------------------------------
'30.04.2015 16:16:39' - Test completed!
Won't Fix
Last Updated: 28 Apr 2015 07:47 by ADMIN
Steps to reproduce:
On the test list tab, filter the test lists by name.
Select a test list that is not hidden, then click copy.
The copied test list does not appear.
Clear the filters on the list of test lists
The Copied test list is there, but was hidden.

Expected results: If I have a filtered list of test cases and I copy a test case that is not filtered, the copied test case should inherit the same filtering criteria and should be visible in the list.