Won't Fix
Last Updated: 04 Oct 2016 06:30 by ADMIN
Created by: Valentijn
Comments: 1
Type: Bug Report
0
create a directory
select 3 tests
run
first test fails

but what about the rest now? There is no result of the other tests
a) at a fail it stops, and also stops the rest
b) the other tests should run.

anyhow, you'd like the results of ALL tests, not the first one.
Won't Fix
Last Updated: 20 Dec 2016 09:37 by ADMIN
Environment:

use the TestFramework with MS Excel Wpf XLL Addin

the Excel process is successfully attached like:

Manager.Current.ConnectToApplication(excelProc);

an open WpfWindow can be easily accessed like:

wpfWindows.First().Window.Close()

But the command "wpfWindow.Find.AllByType<Button>()" causes the test hanging with the following exception:

Die UnitTestProject1.TelerikXUnit2.TestSparks-Testmethode hat eine Ausnahme ausgelöst: System.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
Won't Fix
Last Updated: 19 Oct 2016 10:33 by ADMIN
Created by: Steve
Comments: 1
Type: Feature Request
1
Please by default sort the elements in the explorer, I'm not sure what the sort logic is here, but it's near impossible to find what you want at a glance
Won't Fix
Last Updated: 14 Oct 2016 17:15 by chris
Steps to Reproduce:
Step 1: Create a test list and click on Schedule Test List  for execution.

Step 2: Configure the SMTP settings.

Step 3: On step 3(Select Notification Settings), upon selecting the option- Send test results by email, the email customization area to enter email addresses gets enabled.

Step 4: Enter the distribution list here.

Expected Result: All the email recipients in the distribution list must receive the email notification, upon the execution of the test list.

Actual Result: Sometimes, only the first recipient from the distribution list receives the email notification, else there is no email being sent at all. 
When multiple distribution lists are entered, same results are observed.
Won't Fix
Last Updated: 22 Aug 2016 06:30 by ADMIN
Test A is bound to a single row and Test B is bound to multiple rows. Test B is set NOT to inherit parent data source. 

Test A calls Test B.
Test B executes only for 1 iteration if run with any of the 'Run From Here' and 'Run Selected Step' options available in the test explorer context menu. 

Please find attached sample tests that reproduces that behavior. 

Expected behavior: To perform all iterations as if the whole test was executed. 
Actual behavior: Only one iteration is performed. 
Won't Fix
Last Updated: 28 Jul 2016 07:14 by ADMIN
The project is in TFS source control.

When scheduled a test list on remote machine using option "Get latest version of tests automatically from TFS" and for some reason there is a problem with TFS connection - no information is logged about this problem.

The scheduling and execution service have to be restarted.
Won't Fix
Last Updated: 04 Oct 2016 10:45 by Leo
Recorder could be connected to the popup window but no further actions could be recorded. Test Studio freezes and after a while appears a message that the framework has stopped working. Same behavior is observed by execution. Test Studio process could be terminated only from Task manager.

Steps to reproduce: 

1. Open the attached test and run it to here selecting the last step in Chrome. 

2. Wait until the framework crashes and the message appear. 

3. The application continues running after the TS process is terminated. 



Expected behavior: to be able to interact with the elements in the popup window. 

Actual behavior: The testing framework crashes. 



Please note that the attached log file contains the exceptions generated when reproduced on our side. 
Won't Fix
Last Updated: 07 Jul 2016 12:29 by ADMIN
VS 2013, Browser type: Chrome and IE 

1. Open Telerik Test Studio project VSPlugin

2. Try to debug a script in Chrome that contains "Handle Dialog' step

Expected behavior: to be able to debug without errors since the script is executable

Actual behavior: it fails saying unexpected dialog encountered. 

If the browser is Firefox it works as expected. 
Won't Fix
Last Updated: 19 Oct 2016 13:17 by Zach
ADMIN
Created by: Ryan
Comments: 2
Type: Feature Request
3
I would like the ability to combine both web tests and mobile tests in a single test list. This would allow me to perform an action in browser, and then verify in a subsequent mobile test. 

Thanks
Won't Fix
Last Updated: 13 Oct 2016 06:45 by ADMIN
1. Schedule a  failing test list (i.e. element not found) with SMTP settings configured.

2. On step 3 where the notification settings are, select Only on unexpected errors (not related to the app) radio button.

Expected behavior: The test list is executed and it is failed, no email notification should be received

Actual behavior: The test list is executed, marked as failed and the email notification is received 
Won't Fix
Last Updated: 12 Jul 2016 05:55 by Tim
ADMIN
Created by: Andy Wieland
Comments: 1
Type: Bug Report
2
When I open a load test and change it's settings to a different total concurrent load, and update my concurrent goal as well prior to executing the load test, these new settings are not honored and the load test executes with the previous settings.
Here is a video I recorded of this issue : http://screencast.com/t/n4Q9mD3gz
Won't Fix
Last Updated: 23 May 2016 13:17 by ADMIN
Steps to reproduce: browser Chrome. OS: Win 10

1. Open and run the attached test. 

Expected behavior: The OnBeofreUnload dialog to be handled. 

Actual behavior: The test hangs with the dialog window opened. 

Note: It works for FF and IE on Win 10 and for all browser on Win 8.1
Won't Fix
Last Updated: 04 May 2016 07:31 by ADMIN
The following markup:

<div class="crumbs">
            <a href="/Property/List/F__20446"><span>My Campus</span></a>
            &nbsp;/&nbsp;
            <a href="/Property/List/F__52872"><span>ME Test</span></a>
            &nbsp;/&nbsp;
            <a href="/Property/List/F__52888"><span>My Multi Edits</span></a>
            &nbsp;/&nbsp;
            Americas (A-N)
    </div>

produces wrong verification step for the contained text: "///
            Americas (A-N)"


The correct verification should be against the following text: "/ / / 
            Americas (A-N)"
Won't Fix
Last Updated: 03 May 2016 08:28 by ADMIN
Telerik Testing Framework Mouse clicks do nothing when a test is executed with nUnit console runner (in a WPF app). The same test passes when executed with VS.
Won't Fix
Last Updated: 20 Mar 2019 14:16 by ADMIN
Created by: Martijn
Comments: 1
Type: Feature Request
1
What I want to achieve is to run a combination of tests for different browsers. 

The request is based on the situation that one particular test isn't able to run in e.g. Internet Explorer and I want that test to run in Chrome.

The example I have is:
001 (IE)
002 (Chrome)
003 (IE)
004 (IE)

It would be nice if you could specify at each test in the test list at what browser it should run.
Won't Fix
Last Updated: 06 Jul 2016 11:45 by ADMIN
ADMIN
Created by: Elena
Comments: 1
Type: Feature Request
0
Image verification steps always fails with difference more than 100% no matter if 'Verify Entire Image' is checked or unchecked. 

Steps to reproduce:

1. Record a simple image verification test 
2. Add a step with 'Verify Entire Image' unchecked and select part of the image to be verified) 
3. Add a step with 'Verify Entire Image' checked and verify the whole image. 
4. Execute the test.  

Expected behavior: to successfully verify the image

Actual behavior: 

executed with 'Verify Entire Image' unchecked - Percentage difference is more than 100% although expected and actual images are the same. But selected part of the image is not correctly highlighted in the expected image. Step is failing.


executed with 'Verify Entire Image' checked - Percentage difference is more than 100% although expected and actual images are the same. Step is failing
Won't Fix
Last Updated: 27 Apr 2016 08:38 by ADMIN
During the initial recording Test Studio records the selection option correctly with SelectBy steps. During the execution the proper options are selected, however some jQuery event is not triggered hence after saving the changes no selection is saved.

As a workaround I have tried adding manually the option element into the element explorer and perform a click step against it. Test Studio is clicking in upper left corner of the browser (step 9 in the attached project) . When click edit in live TS is not able to highlight that element at all.

To reproduce the issue see the attached test project.
Won't Fix
Last Updated: 20 Mar 2019 14:28 by ADMIN
When I restart the WPF application with the following code:

ActiveApplication.Quit();
var runningApp = System.Diagnostics.Process.GetProcesses().Where(p => p.ProcessName == "WPFCalculator2");
Manager.LaunchNewApplication(@"D:\calculator\csharp\bin\Debug\AvalonCalculator2_WPF40Copy.exe");
Manager.ConnectToApplication(runningApp.FirstOrDefault());

the recorded is not able to attach again with RunToHere option and TS throws the following exception:

 Outer Exception Type: System.ArgumentException
     Message: Process with an Id of 13348 is not running.
     HRESULT: 0x80070057 (Official ID (if app.) = E_INVALIDARG, Error Bit = FAILED, Facility = FACILITY_WIN32, Code = ERROR_INVALID_PARAMETER)
     Call Stack:
          at System.Diagnostics.Process.GetProcessById(Int32 processId, String machineName)
          at System.Diagnostics.Process.GetProcessById(Int32 processId)
          at Telerik.TestStudio.Wpf.WpfRecorderWindowManager.AttachRecorderToApplication(Int32 pid, Action`2 callback)
          at ArtOfTest.WebAii.Design.DesignTimeExecution._runner_TestCompleted(Object sender, TestCompletedEventArgs e)
          at ArtOfTest.WebAii.Design.Execution.RunnerController.OnTestCompleted(ExecutionReturnValues result)
          at ArtOfTest.WebAii.Design.Execution.RunnerController.CallBackListener()

If we just execute the test it works smoothly and executes all the steps after the restarting. 
Won't Fix
Last Updated: 16 Aug 2016 08:16 by ADMIN
Error when trying to deserialize large JS RAD object using Invoke JS Browser function.



In order to reproduce execute the test in the attached project.



The exception thrown is:



Error Message:
ArtOfTest.WebAii.Exceptions.ExecuteCommandException : ExecuteCommand failed!
InError set by the client. Client Error:
System.InvalidOperationException: Javascript call [JSON.stringify(eval(\"$(\\\'#ctl00_MainHeaderControl_TelerikLogoImage\\\')\"));] failed! Please make sure the function exists and the call is using the correct prototype signature. Javascript error: TypeError: Object expected 
   at ArtOfTest.InternetExplorer.IECommandProcessor.InvokeFunction(String functionCall, Boolean useEval, Boolean returnJSON, IHTMLDocument2 doc)
   at ArtOfTest.InternetExplorer.IECommandProcessor.ProcessActionCommands(BrowserCommand request)
   at ArtOfTest.InternetExplorer.IECommandProcessor.ProcessCommandInternal(WebBrowserClass ieInstance, BrowserCommand request, IHTMLDocument2 document)
BrowserCommand (Type:'Action',Info:'NotSet',Action:'InvokeJsFunctionReturnJSON',Target:'ElementId (tagName: '',occurrenceIndex: '-1')',Data:'$(\\\'#ctl00_MainHeaderControl_TelerikLogoImage\\\')',ClientId:'Client_d5694d3f-84a9-4f4c-94be-3201f1e1be48',HasFrames:'False',FramesInfo:'',TargetFrameIndex:'-1',InError:'True',Response:'System.InvalidOperationException: Javascript call [JSON.stringify(eval(\"$(\\\'#ctl00_MainHeaderControl_TelerikLogoImage\\\')\"));] failed! Please make sure the function exists and the call is using the correct prototype signature. Javascript error: TypeError: Object expected 
   at ArtOfTest.InternetExplorer.IECommandProcessor.InvokeFunction(String functionCall, Boolean useEval, Boolean returnJSON, IHTMLDocument2 doc)
   at ArtOfTest.InternetExplorer.IECommandProcessor.ProcessActionCommands(BrowserCommand request)
   at ArtOfTest.InternetExplorer.IECommandProcessor.ProcessCommandInternal(WebBrowserClass ieInstance, BrowserCommand request, IHTMLDocument2 document)')
InnerException: none.
Exception Message:
ArtOfTest.WebAii.Exceptions.ExecuteCommandException : ExecuteCommand failed!
InError set by the client. Client Error:
System.InvalidOperationException: Javascript call [JSON.stringify(eval(\"$(\\\'#ctl00_MainHeaderControl_TelerikLogoImage\\\')\"));] failed! Please make sure the function exists and the call is using the correct prototype signature. Javascript error: TypeError: Object expected 
   at ArtOfTest.InternetExplorer.IECommandProcessor.InvokeFunction(String functionCall, Boolean useEval, Boolean returnJSON, IHTMLDocument2 doc)
   at ArtOfTest.InternetExplorer.IECommandProcessor.ProcessActionCommands(BrowserCommand request)
   at ArtOfTest.InternetExplorer.IECommandProcessor.ProcessCommandInternal(WebBrowserClass ieInstance, BrowserCommand request, IHTMLDocument2 document)
BrowserCommand (Type:'Action',Info:'NotSet',Action:'InvokeJsFunctionReturnJSON',Target:'ElementId (tagName: '',occurrenceIndex: '-1')',Data:'$(\\\'#ctl00_MainHeaderControl_TelerikLogoImage\\\')',ClientId:'Client_d5694d3f-84a9-4f4c-94be-3201f1e1be48',HasFrames:'False',FramesInfo:'',TargetFrameIndex:'-1',InError:'True',Response:'System.InvalidOperationException: Javascript call [JSON.stringify(eval(\"$(\\\'#ctl00_MainHeaderControl_TelerikLogoImage\\\')\"));] failed! Please make sure the function exists and the call is using the correct prototype signature. Javascript error: TypeError: Object expected 
   at ArtOfTest.InternetExplorer.IECommandProcessor.InvokeFunction(String functionCall, Boolean useEval, Boolean returnJSON, IHTMLDocument2 doc)
   at ArtOfTest.InternetExplorer.IECommandProcessor.ProcessActionCommands(BrowserCommand request)
   at ArtOfTest.InternetExplorer.IECommandProcessor.ProcessCommandInternal(WebBrowserClass ieInstance, BrowserCommand request, IHTMLDocument2 document)')
InnerException: none.
Stacktrace:
 at ArtOfTest.WebAii.Core.Browser.ExecuteCommandInternal(BrowserCommand request)
 at ArtOfTest.WebAii.Core.Browser.ExecuteCommand(BrowserCommand request, Boolean performDomRefresh, Boolean waitUntilReady)
 at ArtOfTest.WebAii.Core.Actions.InvokeScript[T](String script)
 at TelerikSample.Test.RunTest() in C:\Users\ittodorov\Desktop\work files\18.03.2016\TelerikSample-2\TelerikSample\TelerikSample\Class1.cs:line 37
Output:
DialogPlayback: Manager.SetupDialogMonitoring() : Beginning monitoring for dialogs from the set {}.
Won't Fix
Last Updated: 18 Apr 2016 06:46 by ADMIN
In Chrome load url: https://qa-apps.availity.com/availity/web/public.elegant.login
Credentials for login: telerik001/ Password2@
From left menu click "Eligibility and Benefits", and select the "Eligibility and Benefits Inquiry" option from the expanded menu.
On the loaded page there are 2 comboboxes and highlighting does not work