Pending Review
Last Updated: 18 Jun 2019 09:15 by ADMIN
Created by: Bernhard
Comments: 1
Type: Feature Request
0

We are currently upgrading the vue-gid-wrapper to the better native-vue-grid. Unfortunately some features, like the minScreenWidth, don't seem to be included yet.

I assume the features from the wrapper will all be included in the new native grid, but to be sure I'm requesting the feature (minScreenWidth).

 

columns: [
        {
          field: 'variableName',
          title: 'fieldTitle',
          width: '125px',
          minScreenWidth: 1000
        },
        ...
      ]

Pending Review
Last Updated: 23 May 2019 11:38 by ADMIN

Steps to reproduce:

(latest version of vue, vue CLI, node etc. installed globally)

  • vue create test-project
  • cd test-project
  • npm install --save @progress/kendo-ui
  • npm install --save @progress/kendo-theme-default
  • npm install --save @progress/kendo-dateinputs-vue-wrapper
  • added Calendar component to App.vue (see https://www.telerik.com/kendo-vue-ui/getting-started/)
  • changed the name "kendo-calendar" in HTML template to "Calendar", otherwise I get build errors
  • npm run serve --> browse to localhost:8080 --> error in console:

Uncaught ReferenceError: $ is not defined
    at eval (webpack-internal:///./node_modules/@progress/kendo-ui/js/pdf-viewer/pager.js:85)
    at Object.eval (webpack-internal:///./node_modules/@progress/kendo-ui/js/pdf-viewer/pager.js:292)
    at eval (webpack-internal:///./node_modules/@progress/kendo-ui/js/pdf-viewer/pager.js:74)
    at Object.1472 (webpack-internal:///./node_modules/@progress/kendo-ui/js/pdf-viewer/pager.js:75)
    at __webpack_require__ (webpack-internal:///./node_modules/@progress/kendo-ui/js/pdf-viewer/pager.js:21)
    at Object.0 (webpack-internal:///./node_modules/@progress/kendo-ui/js/pdf-viewer/pager.js:49)
    at __webpack_require__ (webpack-internal:///./node_modules/@progress/kendo-ui/js/pdf-viewer/pager.js:21)
    at eval (webpack-internal:///./node_modules/@progress/kendo-ui/js/pdf-viewer/pager.js:41)
    at eval (webpack-internal:///./node_modules/@progress/kendo-ui/js/pdf-viewer/pager.js:44)
    at Object../node_modules/@progress/kendo-ui/js/pdf-viewer/pager.js (app.js:3624)

I could reproduce the error using different Kendo UI for vue components like Buttons etc. (following the getting-started page for the button component). The default vue project template uses Babel and Webpack. Is there a configuration missing for Kendo UI?

I already checked: