Declined
Last Updated: 21 Nov 2019 06:08 by ADMIN
Created by: Ruslan
Comments: 2
Type: Feature Request
0

 

Q:

From the last conversation through the webinar

jQuery Filter looks cool! What about Kendo React Filter?

A:

Right now we do not have a KendoReact Filter component, but feel free to drop us a line in our feedback portal and we will consider implementing it.


Pending Review
Last Updated: 07 Nov 2019 09:46 by ADMIN
Created by: Adam
Comments: 1
Type: Bug Report
0

Hello Kendo React Team,

 

Here are a few bugs to address on the Kendo React Scheduler (3.6.0)...

 

Issue 1: November 3, 2019 Repeated on Week/Month Views

Visit https://www.telerik.com/kendo-react-ui/components/scheduler/views/month/ or https://www.telerik.com/kendo-react-ui/components/scheduler/views/week/, navigate to the first full week in November 2019. You will notice that 11/3 is repeated for Sunday/Monday. I'm wondering if this issue is related to daylight savings time. The calendar does not have a timezone configured (just uses the default UTC and my local timezone is PST).

 

Issue 2: Clicking an empty all day slot does nothing.

The onSlotClick callback should be fired when clicking on an all day event. I currently have to add an event listener using document.querySelectorAll("[data-slot-allday='true']"); to get the right behavior (definitely not ideal).

 

Issue 3: onItemDoubleClick and onSlotDoubleClick do not work on mobile devices.

My current solution to get everything to work on desktop and mobile is to use the onItemClick and onSlotClick and to not integrate useCallback with double clicking.

 

Suggested Improvements:

  • The documentation is silent about onItemClick, onSlotClick, onItemDrop, etc. These are essential to extend the behavior of the scheduler. I had to dig through the node modules directory and look through the .ts files to figure out how to use these work.
  • The mobile experience is awful. I miss the isMobile prop on the kendo-scheduler-react-wrapper. Whether you reintroduce that prop or add better css for smaller viewports, it would be greatly appreciated.

 

 

Pending Review
Last Updated: 11 Nov 2019 10:44 by ADMIN
<Grid
                    style={{ height: '400px', width: '500px' }}
                    data={products}
                    reorderable
                >
                    <Column field="ProductID" title="ID" width="45px" locked />
                    <Column field="ProductName" title="Name" width="250px" />
                    <Column field="Category.CategoryName" title="CategoryName" />
                    <Column field="UnitPrice" title="Price" width="90px" />
                    <Column field="UnitsInStock" title="In stock" width="90px" />
                    <Column field="UnitsOnOrder" title="On order" width="90px" />
                    <Column field="Discontinued" width="120px" locked={true} />
                    <Column field="QuantityPerUnit" title="Additional details" width="250px" />
                </Grid>
Under Review
Last Updated: 11 Nov 2019 10:38 by ADMIN
How to select  cells in the KendoReact Grid, Not row selection
In Development
Last Updated: 11 Nov 2019 10:41 by ADMIN
Pending Review
Last Updated: 15 Nov 2019 13:45 by ADMIN

Hi, 

Is it possible to define where the dropdown container (i.e. k-list-container) is appended in the DOM?

By default it is appended at the bottom of the body but I'd like to define where it is appended.

The reason why I need to do this is because I'm using the KendoReact components in a WebComponent (custom element) which is hosted in a shadow-dom for isolation.
The styles are also only loaded within the shadow-dom and are therfore not applied to content on the outside. 

The issue is that the kendo dropdown container is appended outside of the shadow-dom and the scope of the kendo styles.
The dropdownlist component is styled correctly but the dropdown part that is appended to body is not styled.

I've solved this with other components (i.e. modal window) by defining where I want the the container appended with the createPortal method in React.

ReactDOM.createPortal(
        <React.Fragment>
          <ModalOverlay />
          <ModalWrapper
            aria-modal
            aria-hidden
            tabIndex={-1}
            role="dialog"
            data-testid="modal-wrapper"
          >
            <ModalMain>
              <ModalContent>
                <ModalHeader>
                  <ModalHeaderTitle>{title}</ModalHeaderTitle>
                </ModalHeader>
                <ModalBody>{content}</ModalBody>
              </ModalContent>
            </ModalMain>
          </ModalWrapper>
        </React.Fragment>,
        document.getElementsByTagName('custom-element').length > 0
          ? document.getElementsByTagName('custom-element')[0].shadowRoot

          : document.body

)

 

Approved
Last Updated: 16 Oct 2019 10:57 by ADMIN
Created by: Susanta
Comments: 3
Type: Feature Request
0

Hi,

 

We have requirement of date picker display quarters view . please see the below example

 

http://jsfiddle.net/4mwk0d5L/1/

 

Regards,

Susanta

Approved
Last Updated: 17 Oct 2019 09:25 by ADMIN
Created by: Christian
Comments: 2
Type: Bug Report
0

Hi,

I created a solution using KendoReact Editor.

The editor is set to enable the creation of tables (EditorTools.InsertTable).

When the property 'defaultEditMode' is set to 'iframe',  the editor inserts a correct table with a width of 100% and visible cell borders.

If I set the 'defaultEditMode' to 'div' and insert a table the table has a width of some pixels and no borders are shown. In other words, the inserted table is not usable.

I need to set the editMode to 'div' because otherwise the editor doesn't adjust its look to the other parts of the page. The font is wrong etc.

How can I get the tables to work in 'div' mode?

 

Kind regards

  Christian 

Approved
Last Updated: 17 Oct 2019 09:29 by ADMIN
Created by: Lauren
Comments: 1
Type: Feature Request
0

When using the Editor tools from https://www.telerik.com/kendo-react-ui/components/editor/tools/, the hyperlink option is disabled until I type AND select the typed text in the editor. Because the hyperlink allows for a title and a link, I believe it should not be disabled.

Also, when adding the hyperlink and title, the title does not appear in the editor

For example:
I have an empty editor with no text.

I cannot click the hyperlink option - it is disabled. (Bug 1)

I type 'hey' into the editor and highlight it (select it).

I can now click on the hyperlink option.
I type in 'http://imstilloscar.com' for the Web Address.

I type in 'Oscar' for the title. (It does not matter if I click open in new window or not).

Click Insert.

The title 'Oscar' does not appear in the editor. (Bug 2)

The editor still contains the word 'hey' and links you to 'http://imstilloscar.com' 

Pending Review
Last Updated: 28 Oct 2019 10:33 by ADMIN
Pending Review
Last Updated: 12 Nov 2019 08:58 by ADMIN

Problem:

The DateTimePicker does not work in IE11 due to it's failure to fully support the shorthand syntax for flex (https://github.com/philipwalton/flexbugs#flexbug-4). In order for it to work in IE11 flex-basis needs a unit defined and therefore does not support calc() in this scenario.

Potential Fix:

If you break out flex-grow, flex-shrink and flex-basis then calc() can be used for flex-basis.

Declined
Last Updated: 06 Dec 2019 08:05 by ADMIN
Created by: FIIG Securities
Comments: 1
Type: Bug Report
0

There seems to be bug in the React Grid around date formatting inconsistencies:


Current behavior
When entering a date format of {0:dd/MM/yyyy} for a ColumnData prop, when in edit mode a calendar picker shows the date format as US date of MM/dd/yyyy.Expected behavior
The date should show as dd/MM/yyyy per the requested date format.Minimal reproduction of the problem with instructions
Create a Kendo grid with one column with following ColumnData:
const settlementDate: ColumnData = {
field: 'settlementDate',
title: 'Setlement Date',
format: '{0:dd/MM/yyyy}',
filterable: true,
filter: 'date',
editor: 'date'
};
Note that the date is displayed as MM/dd/yyyy
Change the format to "dd/MM/yyyy"
Note that when in view mode the date is displayed as "dd/MM/yyyy".
What is the motivation or use case for changing the behavior?
Currently I have to create a custom date cell for every instance of using a date field in my grid which is less than ideal.Environment
Package versions:
@progress/kendo-data-query@1.5.2
@progress/kendo-dateinputs-react-wrapper@2019.4.1014
@progress/kendo-base-component-react-wrapper@2019.2.606
@progress/kendo-drawing@1.6.0
@progress/kendo-dropdowns-react-wrapper@2019.4.1014
@progress/kendo-base-component-react-wrapper@2019.2.606 deduped
@progress/kendo-react-data-tools@3.9.0
@progress/kendo-react-common@3.9.0
@progress/kendo-react-dateinputs@3.9.0
@progress/kendo-date-math@1.2.0
@progress/kendo-react-buttons@3.9.0
@progress/kendo-react-common@3.9.0
@progress/kendo-react-popup@3.9.0
@progress/kendo-react-dropdowns@3.9.0
@progress/kendo-react-common@3.9.0
@progress/kendo-react-popup@3.9.0
@progress/kendo-react-grid@3.9.0
@progress/kendo-react-common@3.9.0
@progress/kendo-react-inputs@3.9.0
@progress/kendo-react-common@3.9.0
@progress/kendo-react-popup@3.9.0
@progress/kendo-react-intl@3.9.0
@telerik/kendo-intl@1.5.2
@progress/kendo-react-pdf@3.9.0
@progress/kendo-file-saver@1.0.7
@progress/kendo-theme-default@4.7.0
@progress/kendo-theme-material@3.5.0
@progress/kendo-ui@2019.3.1113Browser:Chrome (desktop) version 78.0.3904.108
System:
Platform: Windows

Other information:
It appears that there is an incompatibility as to what a text display field requires as opposed to what a date picker requires. For text display it requires a format of '{0:dd/MM/yyyy}' whereas the datepicker requires a format of "dd/MM/yyyy".

Approved
Last Updated: 19 Nov 2019 08:31 by ADMIN
Created by: Chaz
Comments: 1
Type: Feature Request
0

I've noticed in your other products, the dropdownlists have a property that allows for grouping sets of data. 

What would it take to get that included in Kendo UI React?

We have a use case that this would be very helpful.

Thanks.

Pending Review
Last Updated: 19 Nov 2019 08:50 by ADMIN

Hello

There was an error calling “ chart.surface.redraw() ” 

 

  onRender = (args,mapValues,stackedOrderBy) => {              
        const chart = args.target.chartInstance;      

        const valueAxis = chart.findAxisByName("valueAxis");
        const categoryAxis = chart.findAxisByName("categoryAxis");

        if (!chart) return;        

           let x= 1;
            if( stackedOrderBy!="Ascending")
                x=-1;

            let axis = categoryAxis.options;

            axis.categories = axis.categories.sort(function (a, b) {
                if (mapValues[a] < mapValues[b]) {
                return -1*x;
                }
                if (mapValues[a] > mapValues[b]) {
                return 1*x;
                }

                return 0;
            });


            chart.surface.redraw();

                           
3 4 5 6 7 8