Approved
Last Updated: 05 Apr 2019 05:22 by ADMIN

Add on Add and onRemove events for the MultiSelect.

Also, the onChange event may receive additional parameters instead:

1) Action - Add or Remove

2) DataItem - It will contain the selected or the  deselected item

Approved
Last Updated: 05 Apr 2019 06:30 by ADMIN
Created by: Manjit
Comments: 0
Type: Feature Request
1
Add arrow for the MultiSelect.
Approved
Last Updated: 09 Apr 2019 12:32 by ADMIN
Created by: Antonios
Comments: 1
Type: Feature Request
1
I would find a Readonly bool prop for the Editor, really useful in certain scenarios
Declined
Last Updated: 01 Apr 2019 08:21 by ADMIN
Created by: yao
Comments: 1
Type: Feature Request
1

I don't know how to implement rowspan

Declined
Last Updated: 01 Apr 2019 08:25 by ADMIN
How does grid support footer row and fix it at the bottom of the table
Completed
Last Updated: 26 Jun 2019 14:19 by ADMIN
Created by: Daniel
Comments: 0
Type: Bug Report
0

The Switch layout is misaligned on IE 11.

54738802-5a28bf00-4bbe-11e9-91aa-7eb104343935.png (195×151)

This is reproducible in our demos as well.

GitHub issue: https://github.com/telerik/kendo-react/issues/220

Completed
Last Updated: 17 May 2019 11:49 by ADMIN
Release 2.11.0
Completed
Last Updated: 25 Mar 2019 09:45 by ADMIN
Created by: Lucia
Comments: 1
Type: Feature Request
0
Add a prop to add your own class name to the Dialog
Completed
Last Updated: 17 May 2019 11:55 by ADMIN
Release 2.10.0
TimePicker is missing the localization properties.
Approved
Last Updated: 17 May 2019 11:52 by ADMIN

DropDownList and MulstiSelect do not open on click(IE 11). 

They do open sometimes, but it seems random.

They do open when using the keyboard.


Declined
Last Updated: 26 Jun 2019 14:04 by ADMIN
Created by: Nathaniel
Comments: 6
Type: Bug Report
0

When rendering an AutoComplete, I get the following warning:

Warning: Failed prop type: Invalid prop `children` supplied to `Popup`.
    in Popup (created by ListContainer)
    in ListContainer (created by AutoComplete)
    in span (created by AutoComplete)
    in AutoComplete

I have tried this in the simple case below:

ReactDOM.render(
    <AutoComplete
        className="form-control"
        required={true}
        validationMessage="Location Required." />,
    document.getElementById('root'));
Completed
Last Updated: 30 May 2019 11:46 by ADMIN
Release 3.0.0

Typing 111 in DatePicker results in skipping the day part. The third 1 is set to the year portion.

It is reproduced in our demo as well: 

https://www.telerik.com/kendo-react-ui/components/dateinputs/datepicker/

Approved
Last Updated: 13 Mar 2019 09:38 by ADMIN
Created by: Rogelio
Comments: 1
Type: Feature Request
0

Currently, ComboBox generates a UUID and uses it as the input tag's id property (e.g. <input id="2e048165-6468-46c0-ba39-c47b12c7fcf2" />).

 

As a developer, I want to be able to set my own custom id so that I can set my own label tag as a sibling to the ComboBox component.

 

For example, I would like this to be possible:

<label for="hello">Hello World</label>
<ComboBox id="hello" />

 

There is a label prop offered on ComboBox which works fine but it does not let me specify the label tag with custom class names, styling, etc.

 

This new id prop should be optional and ComboBox can keep using the same technique it does when no id prop is passed to it.

 

Approved
Last Updated: 05 Mar 2019 06:32 by ADMIN
Created by: Ram
Comments: 0
Type: Bug Report
0
Calendar picker Template displays wrong year range when you click on a certain year.

Steps to Reproduce:

1) Open https://www.telerik.com/kendo-react-ui/components/dateinputs/datepicker/ in the Chrome browser

2) Click on the calendar icon, click on 'month/Year' in the calendar header e.g. March 2019

 
3) Click on the 'Year' in the calendar header i.e. 2019

4) further Click on the Year Range i.e 2010-2019

5) Year range will display from 2000 - 2090, Select year 2010

Wrong Year range (2090 - 2099) will display when clicked on 2010.

This is working properly in the Firefox browser and I observed the issue in Chrome.
Declined
Last Updated: 19 Feb 2019 12:19 by ADMIN

If you create a react grid without any GridColumn components and then add those components later, the added columns do not show and the grid is empty.  It appears, after a quick look that the columns have a width of 0 pixels.  They exist in the html, just not displayed.

 

See https://codesandbox.io/s/mmr894nllp as an example of the problem.  This example starts with a populated grid.  You can add columns and data using the buttons above the grid.  This works fine.  If you then "Reset" the grid with the button, which removes all data, any attempt to add columns and data will show a blank grid.

 

Thanks,

Joe

Declined
Last Updated: 14 Jan 2019 06:31 by ADMIN

We are evaluating the React Grid component for our application and need to be able to have rows that span all columns.  To do this, I have created a rowRender function that, for some rows, will render a single <td> element with the colspan set to 100%.  The row renders fine, but the other rows, that have multiple <td> elements do not all render correctly.  For my test application, they will render with a width of 8 pxs.  On resize of a column, they will almost render correctly.

Here are some pictures of the issue in our test code.

https://drive.google.com/open?id=1bMwlUi7-7QiVHc6lubPiz45svHG1FSnS

I have created a sandbox that sort of reproduces the bug. https://codesandbox.io/s/w73v0x0mz8

If you select the "Show Full Row", the row with Id 999 will convert to a single <td> element with colspan='100%'.  You will notice how after doing so, the last three columns collapse to a small number of pixels.

 

Thanks

Joe

Approved
Last Updated: 16 Oct 2019 10:57 by ADMIN
Created by: Susanta
Comments: 3
Type: Feature Request
0

Hi,

 

We have requirement of date picker display quarters view . please see the below example

 

http://jsfiddle.net/4mwk0d5L/1/

 

Regards,

Susanta

Approved
Last Updated: 17 Oct 2019 09:25 by ADMIN
Created by: Christian
Comments: 2
Type: Bug Report
0

Hi,

I created a solution using KendoReact Editor.

The editor is set to enable the creation of tables (EditorTools.InsertTable).

When the property 'defaultEditMode' is set to 'iframe',  the editor inserts a correct table with a width of 100% and visible cell borders.

If I set the 'defaultEditMode' to 'div' and insert a table the table has a width of some pixels and no borders are shown. In other words, the inserted table is not usable.

I need to set the editMode to 'div' because otherwise the editor doesn't adjust its look to the other parts of the page. The font is wrong etc.

How can I get the tables to work in 'div' mode?

 

Kind regards

  Christian 

Approved
Last Updated: 17 Oct 2019 09:29 by ADMIN
Created by: Lauren
Comments: 1
Type: Feature Request
0

When using the Editor tools from https://www.telerik.com/kendo-react-ui/components/editor/tools/, the hyperlink option is disabled until I type AND select the typed text in the editor. Because the hyperlink allows for a title and a link, I believe it should not be disabled.

Also, when adding the hyperlink and title, the title does not appear in the editor

For example:
I have an empty editor with no text.

I cannot click the hyperlink option - it is disabled. (Bug 1)

I type 'hey' into the editor and highlight it (select it).

I can now click on the hyperlink option.
I type in 'http://imstilloscar.com' for the Web Address.

I type in 'Oscar' for the title. (It does not matter if I click open in new window or not).

Click Insert.

The title 'Oscar' does not appear in the editor. (Bug 2)

The editor still contains the word 'hey' and links you to 'http://imstilloscar.com' 

Pending Review
Last Updated: 28 Oct 2019 10:33 by ADMIN