Approved
Last Updated: 26 Aug 2019 08:25 by Nitin

Bug report

When setting a special font of a given paragraph in the Editor component, if the "x" of the Font dropdown is pressed it will reset the font of this text to the default one. If we then want to change the format of a given paragraph(make it bold for example), we select the paragraph and click on the "Bold" button. The text which is being bolded is the one which font was previously reset, not the selected text which we expect to become bold.

Reproduction of the problem

  1. Open this Dojo and select a random text in the Editor
  2. Change the font of the selected text by choosing one from the "Fonts" dropdown
  3. After changing the font keep the text selection and click on the "x" in the "Fonts" dropdown. The font of the selected paragraph will be reset to the default one.
  4. Select a random text chunk in the Editor and click on the "Bold" button.
  5. See that the bolded text is not the one we expect to be, but the text which font we've reset.

The reported behavior is applicable to all styles - bold, italic, underline, text alignment, ul, ol.

Current behavior

When changing the style of a given selected text, after there was a font reset in the Editor, the new formatting we set is being applied on the text which font was reset, not on the selected one.

Expected/desired behavior

No matter the operations performed in the Editor when formatting a selected text, the format changes should be applied to the selected text only.

Environment

  • Kendo UI version: 2019.2.619
  • jQuery version: x.y
  • Browser: [all]
Approved
Last Updated: 07 Aug 2019 08:21 by ADMIN
Created by: Dmitry
Comments: 1
Category: Editor
Type: Bug Report
1

Bug report

The fontName tool shows an incorrect font name and gets focus after text selection.

Steps to reproduce 

* Open and run https://dojo.telerik.com/OHOHikin demo.

* Set the cursor to Line1, note an incorrect value in the fontName dropdown.

* Select/highlight Line4, choose Arial in the fontName dropdown and note an incorrect value in the dropdown.

* Put the cursor at the end of Line6, select Line4 and Line5 and Line6 using the mouse. Note that the keyboard focus has shifted to the fontName dropdown.

 

Approved
Last Updated: 27 Jun 2019 11:07 by ADMIN

Bug report

Reproduction of the problem

Reproducible in the demos.

  1. Shrink the browser window so that some of the Editor tools go under the overflow button.
  2. Click the overflow button and then click a tool in the dropdown that opens a dialog ("Insert Image" or "Insert hyperlink").

Current behavior

A new dialog opens, but the overflow dropdown does not close and remains visible below the newly opened dialog.

In the inline Editor the overflow dropdown is shown above the newly opened dialog.

Expected/desired behavior

The overflow dropdown closes.

Environment

  • Kendo UI version: 2019.2.619
  • jQuery version: x.y
  • Browser: [all ]
Approved
Last Updated: 25 Jun 2019 10:44 by ADMIN
Created by: Archy
Comments: 0
Category: Editor
Type: Bug Report
1

Hi, steps to reproduce problem:

1. Crete editor with content:

<p>hello&nbsp;
<strong contenteditable="false">OMG</strong>
&nbsp;world</p><p>&#65279;</p>

2. Put cursor at the end

3. Hit backspace

Strong tag disappears but it shouldn't.

 

Attached html file with the case.

Approved
Last Updated: 21 May 2019 06:16 by ADMIN
Created by: Jitender
Comments: 1
Category: Editor
Type: Bug Report
1

1. use safari browser

2. Go to https://demos.telerik.com/kendo-ui/editor/index

3.  copy a long text over 25 characters

4. paste the copied text in the editor

5. notice that the scroll takes you to the bottom of the page, The same is not noticed in any other browser.

6. This is very inconvenient. 

 
Approved
Last Updated: 25 Mar 2019 11:36 by ADMIN
Created by: Gopi
Comments: 2
Category: Editor
Type: Bug Report
0

Please check dojo https://dojo.telerik.com/UMiREWiL

 

There is one kendo editor on the main page which is editable and when you click on the link below "Edit the content in pop-up", pop-up opens but doesn't show the content and also text editor is not editable.

 

Thank you,

Gopi

Approved
Last Updated: 29 Jan 2019 14:57 by ADMIN
Created by: Shane
Comments: 1
Category: Editor
Type: Bug Report
0

after downloading 

@progress/kendo-ui version 2019.1.115 the default create table feature is not working. It is not working on multiple browsers even here: https://demos.telerik.com/kendo-ui/editor/all-tools

the table wizard works but not the cell selection way. Is there a fix for this soon?