Completed
Last Updated: 05 Aug 2019 11:11 by ADMIN
Release 2019.R3
Created by: Eduard Töws
Comments: 2
Category: Kendo UI for jQuery
Type: Bug Report
3

Bug report

An error occurs on components' initialization when using a custom Kendo UI build which includes PDFviewer

Reproduction of the problem

  1. Go to Kendo UI Custom Download page
  2. In the "WEB" section select random components including the Grid and PDFviewer
  3. Download the custom build(kendo.custom.min.js file) and put it in the same folder with an HTML file with the following structure.
<!DOCTYPE html>
<html>

<head>
    <style>
        html {
            font-size: 14px;
            font-family: Arial, Helvetica, sans-serif;
        }
    </style>
    <title></title>
    <link rel="stylesheet" href="https://kendo.cdn.telerik.com/2019.2.514/styles/kendo.default-v2.min.css" />

    <script src="https://kendo.cdn.telerik.com/2019.2.514/js/jquery.min.js"></script>
    <script src="./kendo.custom.min.js"></script>
</head>

<body>
    <div id="example">
        <div id="grid"></div>
        <script>
            $(document).ready(function () {
                $("#grid").kendoGrid({
                    dataSource: {
                        type: "odata",
                        transport: {
                            read: "https://demos.telerik.com/kendo-ui/service/Northwind.svc/Customers"
                        },
                        pageSize: 20
                    },
                    height: 550,
                    groupable: true,
                    sortable: true,
                    pageable: {
                        refresh: true,
                        pageSizes: true,
                        buttonCount: 5
                    },
                    columns: [{
                        template: "<div class='customer-name'>#: ContactName #</div>",
                        field: "ContactName",
                        title: "Contact Name",
                        width: 240
                    }, {
                        field: "ContactTitle",
                        title: "Contact Title"
                    }, {
                        field: "CompanyName",
                        title: "Company Name"
                    }, {
                        field: "Country",
                        width: 150
                    }]
                });
            });
        </script>
    </div>
</body>
</html>
  1. The following error appears:
    Uncaught TypeError: Cannot read property 'Toolbar' of undefined

Current behavior

grid_pdf

Expected/desired behavior

A Grid should be initialized properly and without errors if a custom build is including the PDFviewer

Environment

  • Kendo UI version: 2019.2.514
  • jQuery version: x.y
  • Browser: [all]
Completed
Last Updated: 16 May 2019 07:20 by ADMIN

Dear Telerik,

Please check this example. The single difference than the original one from the demos section, is that I deleted the tasksDataSource.schema.model.fields.parentId.defaultValue". Now the default value of the parentId will be 0 instead of null. If you try to add a new task, the logic will break because of inifinity loop caused by the new task with id=0 and parent=the same task(parentId=0).

I checked the documentation at https://docs.telerik.com/kendo-ui/api/javascript/data/ganttdatasource/configuration/schema and this obligation is missing. It is something small that can save an hour to someone else. 

Best Regards, Boyan.

Completed
Last Updated: 16 Apr 2019 09:55 by ADMIN
Created by: Reqs
Comments: 0
Category: Kendo UI for jQuery
Type: Bug Report
1

Video: https://www.youtube.com/watch?v=8pnFjgzdaJ8&feature=youtu.be

1. Navigate to: https://dojo.telerik.com/@milena/uZaGuZol (open the dojo sample in edit mode, but not in FullScreen)

2. Scroll Grid to the last item.

3. Open for editing ProductName cell.

4. Open for editing Discontinued cell.

Result: 'Discontinued' cell of the second item will be opened for editing.

Expected: 'Discontinued' cell of the last item should be opened for editing.

Completed
Last Updated: 02 Apr 2019 13:20 by ADMIN

When showOn assumes its default value(to work with hold event on touch devices), the ContextMenu cannot be displayed by tapping and holding over the target elements.

The iсsue can be reproduced with the ContextMenu Demo.

Completed
Last Updated: 08 Mar 2019 15:21 by ADMIN
Created by: DDL
Comments: 0
Category: Kendo UI for jQuery
Type: Bug Report
2

When a ContextMenu is opened for the first time, the animation is not executed. Every consequent open trigger the animation successfully.

The issue can be observed in the following Dojo.

Steps to reproduce:

  • Open the ContextMenu and notice there is no animation.
  • Open the ContextMenu again and notice the default animation is triggered.