Approved
Last Updated: 06 Sep 2019 07:33 by ADMIN

When using IE 11 and using Ctrl+X to cut, this only works the first time. All subsequent attempts to use cut produce the following dialog:

Approved
Last Updated: 30 Aug 2019 04:59 by ADMIN

Bug report

Reproduction of the problem

Reproducible in the demos.

  1. Use the HYPERLINK function in a cell:

=HYPERLINK("https://google.com")

Current behavior

The link does not work. It does if you specify a "friendly name":
=HYPERLINK("https://google.com", "google")

Expected/desired behavior

The link works with and without a "friendly name" specified, as in Excel.

Environment

  • Kendo UI version: 2019.2.619
  • jQuery version: x.y
  • Browser: [all]
Approved
Last Updated: 25 Jul 2019 13:04 by ADMIN

Bug report

The current client-side export functionality does not preserve the number of columns.

Reproduction of the problem

  • Load the following file in the Spreadsheet which contains columns up to "BA".

  • Export the file

  • Load the file again in the Spreadsheet and notice that the columns are displayed up to "AX" instead of "BA".

Current behavior

Client-side export does not preserve the number of columns greater than "AX".

Expected/desired behavior

Client-side export does not preserve the exact number of columns.

Environment

  • Kendo UI version: 2019.2.619
  • Browser: [all]
Approved
Last Updated: 18 Jun 2019 09:30 by Steven

Bug report

When a string, used as old_text for SUBSTITUTE(text, old_text, new_text, [instance_num]) function, is repeated more than once and the new_text is an empty string, one occurrence of the old_text remains not substituted.

Reproduction of the problem

  1. Go to Spreadsheet Basic usage demo
  2. Add a new sheet
  3. Type ab113abababab11ab in A1
  4. Enter the following formula in B1 =SUBSTITUTE(A1, "ab", "")

NOTE: substituting ab with another string, e.g. cd, replaces all instances of ab as expected.

Current behavior

113ab11 - when ab is repeated more than once in a row, one of its instances remains unchanged to an empty string

Expected/desired behavior

11311

Environment

  • Kendo UI version: 2019.2.514
  • Browser: all
Approved
Last Updated: 31 May 2019 12:35 by Paul

Bug report

When destroying a SpreadSheet and removing its corresponding DOM element, there are some DOM nodes added on SpreadSheet's initialization which are not removed after the execution of .destroy() and .remove().

Reproduction of the problem

  1. Open this Dojo and run it.
  2. Open browser's console and see the output in it. The initial number of the children nodes in the body is 2 and the children nodes after adding and removing a SpreadSheet are 5.
    Nodes_count
  3. Right-click the blank page in right and inspect it. Navigate to the body in the iframe and see the additional nodes in it
    Nodes_count_body

Current behavior

Not all DOM elements added on SpreadSheet initialization are being removed when destroying it and removing its corresponding DOM element.

Expected/desired behavior

After destroying a SpreadSheet and removing its corresponding DOM element, no DOM nodes added on component's initialization should be presented in the DOM tree.

Environment

  • Kendo UI version: 2019.2.514
  • jQuery version: x.y
  • Browser: [all]
Approved
Last Updated: 16 May 2019 08:04 by n/a
Created by: n/a
Comments: 0
Category: Spreadsheet
Type: Bug Report
0

Bug report

File:
3f0465a2-412c-4876-ba47-4b12ae46f92e_adam.zip

https://demos.telerik.com/kendo-ui/spreadsheet/index

Reproduction of the problem

  1. Import the file

Current behavior

Errors are encountered. Even if resolving the errors bold styles are not applied as they are part of the font definition and not of the inlineStyles.

Expected/desired behavior

The excel is imported as expected.

Environment

  • Kendo UI version: 2019.2.514
  • Browser: all
Approved
Last Updated: 24 Apr 2019 12:02 by ADMIN
Created by: Naveen
Comments: 1
Category: Spreadsheet
Type: Bug Report
1

Dear Concerned,

1. Launch https://demos.telerik.com/kendo-ui/spreadsheet/index

2. Open Workbook(1).xlsx (attached)

3. Edit B2, D2, F2 with some new values

4. See the results in B4, D4, F4

Calculations are different in Excel.

 

Approved
Last Updated: 01 Apr 2019 11:52 by ADMIN
Created by: Naveen
Comments: 1
Category: Spreadsheet
Type: Bug Report
2

Dear Concerned,

 

1. Launch https://demos.telerik.com/kendo-ui/spreadsheet/index

2. Try to select columns B to D using mouse

3. Click on column B, keeping mouse clicked, move your mouse towards C then D

4. It does not allow to select B,C,D where as it is possible in Excel.

It is serious issue for me as I could not proceed with Hide/Unhide columns and some other features depend on multiple columns selection

Note: if we add a blank row at first position then it works well, seems like first with merged columns is creating problem.

Approved
Last Updated: 14 Feb 2019 09:00 by ADMIN
Created by: Marin
Comments: 1
Category: Spreadsheet
Type: Bug Report
0

Dear Kendo,

 

I made research about Kendo Spreadsheet control and I found some of unlogical things in example:

1. When I made changes (kendoSpreadsheetCancelChanges.png) in spreadsheet and click on CANCEL CHANGES button, all of these changes aren't removed.

2. Manually reading spreadsheet datasource, all of these changes aren't removed. For example, when I type in console

$("#spreadsheet").data("kendoSpreadsheet").options.sheets[0].dataSource.read();, datasource is reading, but almost all changes are shown. Why?

 

 

Kind Regards,

Marin

Approved
Last Updated: 13 Feb 2019 15:07 by ADMIN

Hello there,

I am developing a Web application using  Kendo UI Spreadsheet control, but I noticed that when I copy some numbers from a Excel sheet to the spreadsheet and then copy back to Excel, the decimal values are quite different, I mean, the decimal precision has been affected.

For example:

I have the following numbers on a Excel sheet:

10.50.3333333330.250.20.1666670.1428570.1250.1111110.10.0909090.0833330.0769230.0714290.0666670.06250.0588240.0555560.052632

Then, I copy them to the Kendo spreadsheet and I got the following:

100.00%50.00%33.33%25.00%20.00%16.67%14.29%12.50%11.11%10.00%9.09%8.33%7.69%7.14%6.67%6.25%5.88%5.56%5.26%

But when I copy them back to Excel I got this:

10.50.33330.250.20.16670.14290.1250.11110.10.09090.08330.07690.07140.06670.06250.05880.05560.0526

Losing many decimals affecting the results of my computation and calculation.

Can you tell me why is this happening?

Thank you some much.