Unplanned
Last Updated: 29 May 2020 13:16 by ADMIN
Scheduled for 2020.R2
Created by: Lorenzo
Comments: 1
Category: Badge
Type: Bug Report
0

I've got a problem setting the value to integer 0, as in this sample

It works fine with:

    badge.value('0') instead of  badge.value(0);

 

Please help ... thanks

Unplanned
Last Updated: 29 May 2020 11:17 by Sid

Bug report

MultiSelect with virtualization and tagMode: single deselects items when too many items are selected.

Reproduction of the problem

  1. Download and unzip the attached project.
  2. Run the project.
  3. Start selecting items from the first item on.

For convenience, attached is a small video demonstrating the behavior.

Note: So far I was unable to reproduce the issue in a Dojo example when trying to replicate the configuration from the project.

Current behavior

At some point, the dropdown popup will scroll up, and some items that have been selected, will be deselected. Also, the single tag for the selected items will disappear.

Expected/desired behavior

The component should not be deselecting items, should not scroll up and the tag should not disappear.

Attachments:
Project - MultiSelectIssue.zip
Video - Kendosln_Issue.zip

Environment

  • Kendo UI version: 2020.1.406
  • Browser: [all]
Completed
Last Updated: 29 May 2020 07:55 by ADMIN

Bug report

Grid's layout breaks when having columns with defined widths which sum exceeds 960px and the scrollable property is set to false.

Regression introduced in 2020.1.114

Reproduction of the problem

Open this Dojo in fullscreen and see Grid's layout.

If you change the Kendo UI version to 2019.3.1023, Grid's toolbar is correct

Current behavior

Grid's layout is breaking
image

Expected/desired behavior

Grid's layout shouldn't break.
image

Environment

  • Kendo UI version: 2020.1.114
  • jQuery version: x.y
  • Browser: [all]
Completed
Last Updated: 29 May 2020 07:45 by ADMIN
Release 2020.R1.SP2

Bug report

When the horizontal scroll of the grid is shown and is configured for RTL, the resize handle is mispositioned. 

Reproduction of the problem

1. Make the grid scrollable and set explicit widths to all columns.

2. Make the grid RTL.

3. Introduce multi-column headers.

4. Notice that the columns cannot be resized due to the disposition of the handler.

5. Dojo for replication:

https://dojo.telerik.com/IZInOVUd

6. Notice that whenever the horizontal scroll is not present, the resize handle is positioned correctly.

Environment

* **Kendo UI version:** 2019.3.1023
* **jQuery version:** 1.12.4
* **Browser:** [all] 

Completed
Last Updated: 29 May 2020 07:38 by ADMIN
Release 2020.R1.SP2
Created by: Softwarehouse
Comments: 1
Category: DateRangePicker
Type: Bug Report
1

Dear Kendo Support Team,

we are using Kendo UI in our ASP.NET MVC application. We want to remove the values from DateRangePicker. The dates are removed from inputs but the calendar keeps the previous value highlighted when we move back and forth between the months.

Example code: https://dojo.telerik.com/ATuyAWuF/3

Best regards,
Peter

Pending Review
Last Updated: 28 May 2020 12:56 by Anna

Reproduction:

  1. Run dojo at https://dojo.telerik.com/@GaloisGirl/UYefIDES
  2. Check developer console

Expected result: a message should be logged.

Actual result: no message is logged.

 

Unplanned
Last Updated: 28 May 2020 12:34 by ADMIN

Hello,

I prepared a demo https://dojo.telerik.com/EYeYUSUw/6

Also applies to the latest default sass theme but probably to many more.

As you can see, the master grid its 'content row' hover effect is being applied to even the header of the detail grid and there is no way to resolve that unwanted effect apart from adding more styling tedious rules. 

The resolution is so simple:

.k-grid tbody tr:hover, .k-grid tbody tr.k-state-hover {
    background-color: #e6e6ea;
}


Should be

.k-grid tbody > tr:hover, .k-grid tbody > tr.k-state-hover {
    background-color: #e6e6ea;
}

 

I did not search for the source files/lines what might need to change - easy to find in your current version.

There could be many more of these simple improvements which would save many hours on ours side!

Regards,
Jan

 

Pending Review
Last Updated: 27 May 2020 17:12 by Guenter
Created by: Guenter
Comments: 0
Category: Kendo UI for jQuery
Type: Bug Report
0

Hello

 

on https://demos.telerik.com/kendo-ui/upload/async

 

In the area also available for

Also available for:

 

 

the .net core link is broken

https://demos.telerik.com/aspnet-core/upload/async

 

If you go there directly the link is

https://demos.telerik.com/aspnet-core/upload/asyncupload

 

Pending Review
Last Updated: 27 May 2020 13:03 by Anna
Created by: Anna
Comments: 0
Category: ComboBox
Type: Bug Report
0

I'm using the default theme:  "@progress/kendo-theme-default": "4.18.2" with some custom overrides.

The generated CSS has the following incorrect rule (because of the unitless zero, see https://www.w3.org/TR/css3-values/#calc-type-checking ):


.k-combobox .k-dropdown-wrap .k-clear-value {
	calc( calc( 1.2em + 8px) + 0 + 6px)
}

This rules comes from the following scss:

$picker-icon-offset: calc( #{$picker-select-calc-size} + #{$picker-select-border-width}  + #{$input-icon-offset}) !default; 

The unitless zero comes from this value:

$picker-select-border-width: 0 !default;

As a result, the "X" in a combobox overlaps the value.

 

 

Unplanned
Last Updated: 27 May 2020 12:19 by Janusz

Bug report

The Scheduler configured with remote dataSource, vertical grouping and with autoBind: false, throws an error "Cannot read property 'firstChild' of undefined" and the Scheduler layout is not rendered. The behavior is a regression introduced with Kendo UI v 2020.1.114

Reproduction of the problem

  1. Run this dojo

Expected/desired behavior

No error should be thrown with the above configuration.

Environment

  • Kendo UI version: 2020.2.513
  • Browser: [all]
In Development
Last Updated: 27 May 2020 10:37 by ADMIN
Created by: Martin
Comments: 4
Category: NumericTextBox
Type: Bug Report
5

Bug Report

Pressing the dot key on the NumPad does not apply the default decimal separator when the keyboard is set to EN-US/ UK. It always applies the dot. 

Steps for Reproduction

1. Set the culture to a culture that uses the comma as a decimal separator - Italian.
2. Switch the keyboard to EN-US/UK. 
3. Press the dot on the NumPad.
4. Validation prevents the input. 

Dojo sample for reproduction:

https://dojo.telerik.com/OXIsEVAk

Environment

jQuery version: 1.12.4

Kendo UI version: 2020.1.219

Browsers: [all]

 

In Development
Last Updated: 27 May 2020 08:54 by ADMIN
Created by: Shawn
Comments: 3
Category: Grid
Type: Bug Report
1

We have few of dynamically created grid controls. I like to change the grid header style for all of them. I found this solution on the forum however there is an issue with this. If I override ".k-grid-header th.k-header" the change effects column filter popup content as well. See this example on dojo: https://dojo.telerik.com/@ssharifi/AvayONaQ all text and drop down texts are also effected.

I just need to override the title text. What style can I set so the title text is bold but not the filter options?

Thanks,

Shawn

Completed
Last Updated: 22 May 2020 15:07 by ADMIN
Created by: cortex
Comments: 9
Category: Kendo UI for jQuery
Type: Bug Report
0

Hi,

I'm using the Grid version 2019.3.1023 but changelog for newer version doesn't seem to show this has been fixed.

 

Using Html.Kendo().Grid().Columns(columns => colums.ForeignKey(x => x.ForeignCol, data, "value", "label"));

 

If data contains html, it will not be escaped when the javascript for the kendoGrid component is rendered, and thus is exposed to XSS.

This should be either fixed or documentation and samples must tell explicitly we need to html encoded the data, as this is not the case for the model itself.

 

 

 

 

In Development
Last Updated: 22 May 2020 13:14 by ADMIN
Created by: Anna
Comments: 1
Category: TileLayout
Type: Bug Report
0

Reproduction:

  1. run dojo at https://dojo.telerik.com/@GaloisGirl/IxEGipeT
  2. resize the first item
  3. check the console to e.container

Expected result:

As per https://docs.telerik.com/kendo-ui/api/javascript/ui/tilelayout/events/resize , e.container should be a jQuery object

Actual result:

e.container is undefined

 

Completed
Last Updated: 22 May 2020 12:19 by ADMIN
Release 2020.R2.SP.next
Created by: AGB
Comments: 1
Category: Grid
Type: Bug Report
3
Hi Guys,

I have just tripped over a problem in the 2020 R1 release whereby the sort indicator is not being shown when autoBind is set to false.

To illustrate the problem run the following dojo

    https://dojo.telerik.com/eMELiMut

which will show a sort indicator on the 'Ship Country' column.

Now if you uncomment 'autoBind:true' and 'dataSource.read();' and re-run you will see that although the data is being sorted correctly the 'Ship Country' column is missing the indicator.

Regards
Alan
Unplanned
Last Updated: 22 May 2020 11:37 by ADMIN
Bug report

Incorrect number when decreasing the value via the keyboard in MS Edge.


Reproduction of the problem:

1. Open a NumericTextBox demo in the Edge browser. 
2. Focus on input. 
3. Increase the value to 3 using keyboard arrows. 
4. Press the Tab button so NumericTextBox loses focus. 
5. Press Shift+Tab buttons to bring the focus back to the NumericTextBox. 
6. Decrease the value using the keyboard arrow.
7. Value is decreased by two, while it should be decreased by one.
 

Current behavior:

When decreasing by the keyboard arrow, the value of the NumericTextBox goes directly from 3 to 1.

 

Expected/desired behavior:

When decreasing by the keyboard arrow, the value of the NumericTextBox should be decreased by one without skipping values.

 

Environment:

* **Kendo UI version:** 2020.2.513
* **jQuery version:** 1.12.4
* **Browser:** Microsoft Edge 44.18362.1.0
Completed
Last Updated: 22 May 2020 11:29 by ADMIN
Release 2020.R2.SP.next

Bug report

This is a regression introduced in R1 2020. To reproduce it, set a menu button within a splitButton as initially hidden. Then show it with the ToolBar's show API method.

Reproduction of the problem

Dojo example.

  1. Open the browser's dev tools console and run the example.

Current behavior

"btn2" is shown as expected, but a js exception is thrown:

kendo.all.js:91805 Uncaught TypeError: Cannot read property 'refresh' of undefined

Expected/desired behavior

No js exceptions

Environment

  • Kendo UI version: 2020.2.513
  • jQuery version: x.y
  • Browser: [all]
Unplanned
Last Updated: 22 May 2020 11:20 by ADMIN
Scheduled for 2020.R2.SP.next
Created by: Anna
Comments: 1
Category: Form
Type: Bug Report
0

Reproduction

  1. Run sample at https://dojo.telerik.com/@GaloisGirl/eConozaR
  2. Click "validate"

Expected result:

  1. Validation result should be displayed  as a boolean

Actual result:

  1. Undefined is displayed

Fix:

Just add return before "validator.validate();" in method "validate".

 

In Development
Last Updated: 22 May 2020 11:20 by ADMIN
Scheduled for 2020.R2.SP.next

Bug report

When adding a Rating with precision:"half" in a Gantt tooltip template the half item is not rendered. Using Rating with precision:"item" works as expected.

Reproduction of the problem

  1. Run this dojo
  2. Hover over the Task

Current behavior

Rating is set to 2.5, but the half item is not rendered.

Expected/desired behavior

Rating configured with precision:"half" should render the half item.

Environment

  • Kendo UI version: 2020.1.406
  • Browser: [all]
In Development
Last Updated: 22 May 2020 11:20 by ADMIN
Scheduled for 2020.R2.SP.next

Bug report

The rating component layout/functionality breaks when its precision configuration is set to "half" and the defined Kendo culture is "de-DE".

  • The issue is related to the defined in the de-DE culture decimal separator
    If the below definition

numberFormat: {
pattern: ["-n"],
decimals: 2,
",": ".",
".": ",",

is changed to this:

numberFormat: {
pattern: ["-n"],
decimals: 2,
",": "'",
".": ",",

The issue is no more reproducing

Reproduction of the problem

  1. Open this Dojo and run it
  2. See the second rating component

Current behavior

The layout of the rating component with "half" precision doesn't visualize the "half" precision and the value of the current rating is displayed without a decimal point
image

Expected/desired behavior

The expected behavior can be observed in this Dojo example
image

Environment

  • Kendo UI version: 2020.1.406
  • jQuery version: x.y
  • Browser: [all]
1 2 3 4 5 6