Completed
Last Updated: 23 May 2019 05:50 by ADMIN
Release 2019.R2.SP.Next

The issue is reproducible when the grid consists only from Multi-header columns, the setDataSource() method has been used and one of the columns is initially hidden.

After setting the new data source, the last header gets hidden. The "display: none;" style has been applied to the "th" HTML element.

Steps to reproduce:

1. Create a grid with multi-header columns only.

2. Hide one column initially.

3. Set a new data source via the setDataSource() method.

4. The last column gets hidden.

Sample Dojo:

https://dojo.telerik.com/AcipENOt

Kendo UI version: 2019.1.220


Approved
Last Updated: 10 Jun 2019 09:58 by ADMIN

### Reproduction of the problem
1. Run the Checkbox selection demo in IE 11.706.17134 - https://demos.telerik.com/kendo-ui/grid/checkbox-selection
2. Try clicking a checkbox

### Current behavior
Two clicks are required to change the state of the checkbox.

### Expected/desired behavior
Checkbox should be checked/unchecked with a single click

### Environment

* **Kendo UI version:** 2019.2.514
* **Browser:** [ IE 11.706.17134 ] 
Approved
Last Updated: 31 May 2019 15:01 by ADMIN

Cannot read property 'groupHeaderColumnTemplate' of undefined.

I have my grid, with 4 columns:

 

var dataSource = new kendo.data.DataSource({
                    transport: {
                        read: {
                            url: Utils.getUrlServices() + "getGrid",
                            dataType: "json",
                        }
                    },
                    requestEnd: function (e) {
                    },
                    schema: {
                        model: {
                            fields: {
                                id: {type: "number"},
                                name: { type: "string" },
                                    namecompany: { type: "string" },
                                hours: {type: "number"},
                                date: {type: "date"}
                            }
                        }
                    },
                    pageSize: 500,
                    group: [
                         {
                             field: 'name',
                             aggregates: [
                                          {field: "hours", aggregate: "sum" }
                                      ]
                         }, {
                             field: 'nomeImpresa',
                             aggregates: [
                                          {field: "hours", aggregate: "sum" }
                                      ]
                         },
                         { field: "hours",
                             aggregates: [
                                  {field: "hours", aggregate: "sum" },
                                  {field: "name", aggregate: "sum"},
                                  {field: "nameCompany", aggregate: "sum"},
                                  {field: 'date', aggregate: 'sum'}
                              ]
                         },
                         {field: 'date',
                             aggregates: [
                                          {field: "hours", aggregate: "sum" }
                             ]
                         }
                     ],
                     aggregate: [
                         {field: 'hours',aggregate: 'sum'}
                     ]
                });
                self.Grid.set("source", dataSource);

 

 

When i grouping for Date field, the browser run this error: 

 

kendo.all.js:65435 Uncaught TypeError: Cannot read property 'groupHeaderColumnTemplate' of undefined
    at HTMLTableRowElement.<anonymous> (kendo.all.js:65435)
    at Function.each (jquery.min.js:2)
    at I.fn.init.each (jquery.min.js:2)
    at init._renderGroupRows (kendo.all.js:65417)
    at init.hideColumn (kendo.all.js:64983)
    at Function.KendoUtils.hideGridColumns (kendo.utils.js:330)
    at init.dataBound (eval at <anonymous> (jquery.min.js:2), <anonymous>:77:32)
    at d (jquery.min.js:2)
    at init.handlers.<computed> (kendo.all.js:9520)
    at init.trigger (kendo.all.js:124)

 

 

 

 

 

 

 

 

 

Approved
Last Updated: 03 Oct 2019 09:15 by ADMIN
Created by: Szabolcs
Comments: 2
Category: Grid
Type: Bug Report
1

Dear Sir / Madam,

At grid PDF export, in case of allPages: false --> Actual rows are rendered to multiple pages properly, but all pages are written on the first page.

It works well, if I set "options.pdf.multiPage" to "true", but it is not in API reference.

A solution might be if this variable is fixed to true in grid prototype "saveAsPDF" function:
          "options.multiPage = true;" instead of "options.multiPage = options.multiPage || options.allPages;"

Please see this example: https://dojo.telerik.com/usUnUziL/2

Step 1: press "Export to PDF" --> Result: wrong pdf

Step 2: press "Set multiPage: true"

Step 3: press "Export to PDF" --> Result: good pdf

 

Best Regards,

Szabolcs Tóth

Approved
Last Updated: 27 Sep 2019 12:39 by ADMIN
Scheduled for 2019.R3.SP1

the Kendo grid does't accept cell value changes when using android mobile phone with the Chrome browser. You can test it on the telerik demo https:demos.telerik.com/aspnet-mvc/grid/editing.

for example change the value of the Unit Price and go to the other cell. you will see that the value will become the original value.

just by touching some where outside the border of the grid the value will change.

Approved
Last Updated: 27 Sep 2019 09:01 by ADMIN
Created by: AGB
Comments: 1
Category: Grid
Type: Bug Report
1

Hiding the first column in Grid will show a 2 pixels left border instead one.

Dojo Sample to replicate the issue: https://dojo.telerik.com/ubaLiYEN

Steps:

1. Hide the first column (OrderID) from the Column Menu.

2. Notice the doubled left-border on the left hand side of the Grid.

Approved
Last Updated: 26 Sep 2019 10:19 by ADMIN
Created by: Resty
Comments: 0
Category: Grid
Type: Bug Report
1
We have a project where we need the infinite scroll, column sorting/filtering, and remote data enabled.  We are having some issues with sort and filter.  For quick reference, I used the grid demo and changed it to reflect our configuration.  The problem is the grid fires the read command twice when we have loaded more than one page of data. No issues when we have only loaded the first page.

https://dojo.telerik.com/UDoREFID

To reproduce:

1.  Open Chrome

2.  Load the page

3. Hit run

4. Open Developer Tool

5. Switch to the Network tab and filter by XHR only  

7. Click ProductName to sort. There is only one AJAX call.

8. Scroll to the bottom so it loads the next page. It made two AJAX calls
Approved
Last Updated: 09 Sep 2019 05:53 by ADMIN

When the grid is configured for InCell editing and frozen columns, it is expected the first editable cell to be opened for editing when a new record is added. 

However, when there is not an editable cell in the locked columns, it would not search in the main content. Here is an example:

https://dojo.telerik.com/ucEraQOW

A temporary workaround would be to override the editModel function and check in the second table as well:

https://dojo.telerik.com/aJEsAnud

Approved
Last Updated: 02 Aug 2019 15:09 by ADMIN

Hi, 

Here is the dojo to reproduce. In this dojo I've created imitation of data, that coming from server in our case. The main idea is to have a grid with lazy loading - it has 10 groups (page 1) and after scrolling down it loads 10 more groups (page 2) and etc.

 

Issue 1. 

After scrolling down, data from the last group is updated with some data, that is not belongs to it. Please see 'Issue1.png' attached.

Issue 2.

Groups from the first page are duplicated after scrolling down. For example, there is a group named 'C3'. After scrolling down, it is duplicated once again. Please see 'Issue2.png' attached. New groups are placed after these duplications. By the way, as groups from the 1st page are duplicated, there is more than 20 groups is shown, but the counted at the bottom of the grid says that '20 of 137' elements are show.

 

So it would be great, if you could fix that. Or even provide temporary fix for us.

Thank you!

Pending Review
Last Updated: 06 Feb 2019 14:15 by ADMIN
Created by: Jyotika
Comments: 1
Category: Grid
Type: Bug Report
1

Hi Team,

Kendo grid does not allow all columns to be hidden from column menu as it disables the check box for last column in column menu.

But if we set hidden = true and menu = false properties for column, grid hides that column from grid and column menu, but enables the checkbox to hide all columns from grid leaving it empty. After which we can't get back the columns in grid which isn't valid.

Grid should always allow at least one column to be included in grid/menu.

Please find attached screenshot and below sample link.

https://dojo.telerik.com/EHOgaJUK/2

Thanks,

Jyotika

Pending Review
Last Updated: 03 Jul 2019 09:28 by JEAN CHARLES
Created by: JEAN CHARLES
Comments: 3
Category: Grid
Type: Bug Report
1

When clicking on CheckBox to select a line, the widget check other checkbox (on other column of the same line) inserted from column template.

I suppose that the selector that the system use is too large.

 

For information, i created a template for boolean column based on how kendo generate checkbox structure (just de be coherent)

 

See the code extracted from https://dojo.telerik.com/EqiPIkiV

 

 var checkBoxtemplate = function(boolValue){
   	var checkedStr = '';
    if (boolValue) {
    	checkedStr = 'checked="checked"';
    }

        
    return '<input class="k-checkbox" data-role="checkbox" ' + checkedStr + ' type="checkbox"><label class="k-checkbox-label k-no-text smi-checkbox-fordisplay"></label>';
 };
  
$("#grid").kendoGrid({
  columns: [
    {
      selectable: true, 
      width: '30px'
    },
    { field: "name" },
    { field: "age" },
    { field: "administator", 
      template: function (dataItem) { 
        return checkBoxtemplate(dataItem.administator); 
      }  
    }
  ],
  dataSource: [
    { name: "Jane Doe", age: 30, administator: false },
    { name: "John Doe", age: 33, administator: false },
    { name: "BigBoss Doe", age: 70, administator: true }
  ],
  selectable: true
});

Approved
Last Updated: 17 Jun 2019 09:42 by ADMIN
### Bug report

Ticket ID 1410772

### Reproduction of the problem

Calling dataSource.query with an empty object before the grid is initialized throws an error.

[https://dojo.telerik.com/OzasiZug/5](https://dojo.telerik.com/OzasiZug/5)

``` 
         ...
          var dataSource = new kendo.data.DataSource({
            type: "odata",
            transport: {
              read: "https://demos.telerik.com/kendo-ui/service/Northwind.svc/Customers"
            },
            pageSize: 5
          });

          dataSource.query({});


          var grid = $("#grid").kendoGrid({
            dataSource: dataSource,
          ...
```

### Current behavior

An error is thrown.

### Expected/desired behavior

No error should be thrown


### Environment

* **Kendo UI version:** 2019.2.514
* **jQuery version:** 1.12

Pending Review
Last Updated: 31 Dec 2018 07:47 by ADMIN
Created by: Behnam
Comments: 1
Category: Grid
Type: Bug Report
0

Hi,

Bring up an RTL kendo Grid which has resizable true and filter mode is "row".

then try to resize the grid from filter-row of grid. we will see an internal js error.

 

you can copy and paste this code in a dojo sample and resize grid from the point is shown in the attached picture.

    <div class="k-rtl"><div id="grid"></div></div>
    <script>
        $("#grid").kendoGrid({
          columns: [
              { field: "name" },
              { field: "age" }
          ],
          filterable: {
              mode: "menu, row"
          },
          resizable: true,
          dataSource: {
           data: [
            { id: 1, name: "Jane Doe", age: 30 },
            { id: 2, name: "John Doe", age: 33 }
           ],
           schema:{
            model: {
             id: "id",
             fields: {
               age: { type: "number"}
             }
            }
           }
          }
      });
    </script>
Pending Review
Last Updated: 14 Dec 2018 10:38 by ADMIN

Hello Support Team,

with jQuery 3.3.1 the resizable option set to true is not working with the configuration in the example below. When removing other options like "toolbar" or "scrollable" it works. :D 

See the following example: https://dojo.telerik.com/IkigawaX

With jQuery 1.x everything works fine.

Regards

Alexander

Pending Review
Last Updated: 13 Dec 2018 11:01 by ADMIN
Created by: Christian
Comments: 1
Category: Grid
Type: Bug Report
0

The autofix column feature does not work properly if you enable sorting on the grid. You can see the issue if you open the Dojo for the following demo: https://docs.telerik.com/kendo-ui/knowledge-base/grid-autofit-all-columns-width

If you sort e.g. by column "Ship Country" and sort ascending you will see the name of the column ending with "..." but not the icon for the sort direction. If you press the column again and sort descending than everything works as expected - the column width increases and the icon is show.

I tested the problem in multiple browsers, but the main browser I have to support will be the IE.

BR,
Christian 

Pending Review
Last Updated: 11 Dec 2018 11:18 by ADMIN

The following event-handler does not work when run in a mobile environment (iPad). Otherwise it works as expected:

Result: all columns a set to their minimum width.

 

    var grid = $("#grid").kendoGrid({
        dataSource: dataSource,
        columns: [

// ...       
],

        columnShow: function (event) {

            console.time('autoFitColumn');
            for (var i = 0; i < this.columns.length; i++) {

                var col = this.columns[i];
                             this.autoFitColumn(i);
            }
            console.timeEnd('autoFitColumn');
        },
      // ...
        filterable: true,
        sortable: {
            mode: "multiple",
            allowUnsort: true
        },
        pageable: true,
        reorderable: true,
        scrollable: true,
        columnMenu: true,
        mobile: true,
    }); 
Declined
Last Updated: 02 Aug 2019 09:53 by ADMIN

Hi

I am binding columns dynamcially in jquery without template column header spacing working file becuase i have added "[ ]" this symbol.

but when try to add anchor tag link with onclick method then i am getting issue.

i have attached file java script error please provide some solutions.

 

Pending Review
Last Updated: 30 Jul 2019 15:53 by ADMIN

Following example @ https://docs.telerik.com/kendo-ui/knowledge-base/grid-sort-displayed-columns-menu-items sorts a column menu. When hide column is then clicked, the wrong column is hidden.

This can be seen in your own dojo example linked in the above doc and @ https://dojo.telerik.com/UWuxOseV . Hiding column Ship Name hides Ship Address instead.

This seems to have been introduced in 2019 R2 SP1 version.

 

Pending Review
Last Updated: 04 Sep 2019 12:03 by ADMIN

When using the Nova theme locked command columns are not styled correctly.   
In the following dojo one command column is locked and not styled while another command column is not locked but styled correctly.
https://dojo.telerik.com/eWECAZEw

Here's the code in case the dojo doesn't work:

<!DOCTYPE html>
<html>
<head>
    <meta charset="utf-8"/>
    <title>Kendo UI Snippet</title>

    <link rel="stylesheet" href="https://kendo.cdn.telerik.com/2019.2.619/styles/kendo.common.min.css">
    <link rel="stylesheet" href="https://kendo.cdn.telerik.com/2019.2.619/styles/kendo.rtl.min.css">
    <link rel="stylesheet" href="https://kendo.cdn.telerik.com/2019.2.619/styles/kendo.nova.min.css"/>
    <link rel="stylesheet" href="https://kendo.cdn.telerik.com/2019.2.619/styles/kendo.mobile.all.min.css">

    <script src="https://code.jquery.com/jquery-1.12.3.min.js"></script>
    <script src="https://kendo.cdn.telerik.com/2019.2.619/js/kendo.all.min.js"></script>
</head>
<body>
  
<div id="grid"></div>
<script>
  var dataSource = new kendo.data.DataSource({
    data: [
      { category: "category 1", subCategory: "sub. category 1", name: "product 1", val: 1 },
      { category: "category 1", subCategory: "sub. category 1", name: "product 2", val: 1 },
      { category: "category 1", subCategory: "sub. category 1", name: "product 3", val: 1 },
      { category: "category 1", subCategory: "sub. category 1", name: "product 4", val: 1 },
      { category: "category 1", subCategory: "sub. category 2", name: "product 5", val: 1 },
      { category: "category 1", subCategory: "sub. category 2", name: "product 6", val: 1 },
      { category: "category 1", subCategory: "sub. category 2", name: "product 7", val: 1 },
      { category: "category 1", subCategory: "sub. category 2", name: "product 8", val: 1 },
      { category: "category 1", subCategory: "sub. category 3", name: "product 9", val: 1 },
      { category: "category 1", subCategory: "sub. category 3", name: "product 10", val: 1 },
      { category: "category 1", subCategory: "sub. category 3", name: "product 11", val: 1 },
      { category: "category 1", subCategory: "sub. category 3", name: "product 12", val: 1 },
    ]
  });
  
$("#grid").kendoGrid({
  columns: [
    { command: "edit", locked: true, width: 150 }, // <<-- columns is locked
    { field: "category", locked: true, width: 150 }, // <<-- columns is locked
    { command: "edit", width: 150 },
    { field: "subCategory", width: 200 },
    { field: "name", width: 500 }
  ],
  dataSource: dataSource,
  scrollable: true,
  selectable: "row"
});
</script>
</body>
</html>
Approved
Last Updated: 09 Aug 2019 11:12 by ADMIN
When using server paging and grouping when the new subset of data is requested the content which is rendered does not correctly match data. More information in ticket 1422210
1 2