Approved
Last Updated: 30 Jul 2019 09:16 by ADMIN

I'm submitting a...

  • Bug report

Current behavior

When the MultiSelect is wrapped in a container with class .k-edit-field or .k-edit-buttons (e.g in a Grid popup editor) and the selected tags are hovered, their background-color becomes transparent.

The issue is partly related to #701.

Expected behavior

The MultiSelect tags should not have transparent background when hovered.

Minimal reproduction of the problem with instructions

The issue can be reproduced with the following Dojo example:

  • Hover over one of the selected tags to see the background-color issue.

Environment

Product:

  • Kendo Ui for jQuery
Approved
Last Updated: 29 Mar 2019 07:39 by ADMIN
Created by: Eduard Töws
Comments: 1
Category: MultiSelect
Type: Bug Report
1

Hello ladies and gentlemen.

In Bootstrap 4 (and Material) SASS theme the opacity setting for placeholder is missed.

Example: https://demos.telerik.com/kendo-ui/multiselect/index

My fix for Bootstrap 4 (I not known the opacity setting for Material placeholders):

.k-multiselect-wrap {
  > .k-readonly {
    opacity: 0.7;
  }
}
Best regards,
Eduard Töws
Approved
Last Updated: 14 Mar 2019 14:11 by ADMIN
Created by: Farukh
Comments: 1
Category: MultiSelect
Type: Bug Report
0

The bug I was talking was when setting tagMode of kendoMultiSelect to single, clicking the clear button (x at right of textbox) doesn’t trigger “deselect” event. Not sure if it’s by design. They fixed a similar bug regarding “change” event - https://github.com/telerik/kendo-ui-core/issues/4649.

 

Repro snippet could be found at

https://dojo.telerik.com/AHAwETUx

Approved
Last Updated: 11 Mar 2019 14:15 by ADMIN
  • Open the MultiSelect and add some items
  • Use backspace to remove items

Result: The items that were selected, then un-selected still show as selected in the list

This can be reproduced on the latest demo page. https://demos.telerik.com/kendo-ui/multiselect/index 

 

 

Approved
Last Updated: 25 Jun 2019 08:58 by ADMIN

Bug report

The "aria-setsize" attribute is missing when initializing a MultiSelect with default selected values in AngularJS

Reproduction of the problem

  1. Open this Dojo and run it
  2. Right-click on one of the initially selected items in the MultiSelect.
  3. The selected DOM element will be a "li" tag
  4. Select a new item in the MultiSelect and watch how the definition of the "li" tag will change
  5. When selecting a third element in the MultiSelect. All the three "li" tags will receive an aria-setsize="3" tag, which wasn't presented for the default selected values

Current behavior

When initializing a MultiSelect with default values, the aria-setsize attribute is missing for these values.
aria-size

Expected/desired behavior

The default MultiSelect values should have an aria-setsize attribute added to their selected values
aria-size1

Environment

  • Kendo UI version: 2019.2.619
  • jQuery version: x.y
  • Browser: [all]
Approved
Last Updated: 26 Sep 2019 10:39 by ADMIN

Hello!

 

Firstly, in the keyboard navigation demo for the MultiSelect widget (https://demos.telerik.com/kendo-ui/multiselect/keyboard-navigation) the follwing two keyboard shortcuts are documented:

  • SHIFT + UP-ARROW: select previous item
  • SHIFT + DOWN-ARROW: select next item

 

In the following scenario, these shortcuts cause some strange behaviour:

  • select two consecutive items with SHIFT+DOWN-ARROW (e.g. "Small" and "Medium")
  • use the arrow keys to move the focus further down (e.g. to "X-Large")
  • press SHIFT+DOWN-ARROW again

I would expect "X-Large" and "2X-Large" to be selected in addition to the already selected items "Small" and "Medium". Instead, "Large" is selected as well. Is this behaviour intended?

 

Secondly, every time the user clicks and selects an entry of the MultiSelect popup, the popup is closed. Is there a way to prevent that closing. Or is there a way of selecting without triggering a close event (like pressing CTRL etc.)?

 

Thank You!