Completed
Last Updated: 16 Sep 2019 14:23 by ADMIN
Release 2019.R3

Bug report

Defining a custom namespace with Kendo.ns stops the displaying of all submenus in the Menu component.

This is a regression represented in R2 2019

Reproduction of the problem

  1. Open this Dojo and run it.
  2. The Menu component is being rendered
  3. Move the mouse cursor over the Menu.
  4. A thin grey line appears under each section of the Menu. No submenus are being displayed

Expected/desired behavior

The Menu component should work properly even when a custom Kendo namespace is being defined. To see the expected behavior put a comment on the following line:
kendo.ns = "kendo-";

Environment

  • Kendo UI version: 2019.2.619
  • jQuery version: x.y
  • Browser: [all]
Approved
Last Updated: 15 Oct 2019 16:40 by Rich

Bug report

Reproducible with version 2017.2.504 (R2 2017) and newer.

Reproduction of the problem

Dojo example.

  1. Open a submenu in the top Menu (it has scrollable: true set).

Current behavior

Separators are not displayed.

Expected/desired behavior

Separators are displayed.

Workaround:

.k-menu-scroll-wrapper .k-menu-group .k-separator {
  border-bottom: 1px solid #c5c5c5;
  width: 100%;
}

Environment

  • Kendo UI version: 2019.3.917
  • jQuery version: x.y
  • Browser: [all ]
Completed
Last Updated: 05 Feb 2019 14:34 by ADMIN
Created by: Shawn
Comments: 1
Category: Menu
Type: Feature Request
0
Please fix your demo page.
https://demos.telerik.com/kendo-ui/menu/context-menu

I'm showing a js error and am not able to see the demo work.  Thanks!
1 2