Planned
Last Updated: 28 Nov 2019 16:05 by JangHyen

Bug report

Dropping an image into the Editor's content results in the image being opened in the browser instead of being added to the widget's content. Reproducible in Chrome, IE and Edge. If there is existing content and the image is dropped in it, the image is added to the content as expected.

Regression introduced in 2019.2.619.
Related to #4994

Reproduction of the problem

Screencast.
Dojo example.

  1. Drag an image into the Editor's content.

Current behavior

The image is opened in the browser.

Expected/desired behavior

The image is added to the Editor's content.

Environment

  • Kendo UI version: 2019.3.1023
  • jQuery version: x.y
  • Browser: [Chrome 78, IE, Edge ]
Approved
Last Updated: 11 Nov 2019 08:33 by ADMIN
  • Create a WYSIWG Editor
  • Add a Table with 2 rows and 2 columns
  • Select multiple cells by clicking on the first cell and then dragging to the right[Firefox_TableWizard_CellStyling_selection.png]
  • Click on the table wizard icon to open the table wizard
  • Select the Cell tab
  • Change the Background Color to something like red
  • Press the Ok Button
  • Now the first cell has a red background color and 2 columns are added after the first cell[Firefox_TableWizard_CellStyling_afterCellStyling.png]

 

Issue is only present in Firefox, Chrome does not allow selecting multiple cells.

The editor used for this was from the Demo Page:

https://demos.telerik.com/kendo-ui/editor/index

Completed
Last Updated: 18 Oct 2019 09:26 by ADMIN
Release 2019.R3.SP.next

Bug report

Reproduction of the problem

Dojo example.

  1. Copy a word
  2. Click in the Editor after "Location" or "Date"
  3. Press Enter
  4. Press Ctrl + V to pasted the copied text.

Current behavior

The Editor adds an extra

element after the nested table:

<p>&nbsp;</p>

Expected/desired behavior

No empty paragraph is added on pasting content.

Environment

  • Kendo UI version: 2019.3.917
  • jQuery version: x.y
  • Browser: [all]
Approved
Last Updated: 26 Aug 2019 08:25 by Nitin

Bug report

When setting a special font of a given paragraph in the Editor component, if the "x" of the Font dropdown is pressed it will reset the font of this text to the default one. If we then want to change the format of a given paragraph(make it bold for example), we select the paragraph and click on the "Bold" button. The text which is being bolded is the one which font was previously reset, not the selected text which we expect to become bold.

Reproduction of the problem

  1. Open this Dojo and select a random text in the Editor
  2. Change the font of the selected text by choosing one from the "Fonts" dropdown
  3. After changing the font keep the text selection and click on the "x" in the "Fonts" dropdown. The font of the selected paragraph will be reset to the default one.
  4. Select a random text chunk in the Editor and click on the "Bold" button.
  5. See that the bolded text is not the one we expect to be, but the text which font we've reset.

The reported behavior is applicable to all styles - bold, italic, underline, text alignment, ul, ol.

Current behavior

When changing the style of a given selected text, after there was a font reset in the Editor, the new formatting we set is being applied on the text which font was reset, not on the selected one.

Expected/desired behavior

No matter the operations performed in the Editor when formatting a selected text, the format changes should be applied to the selected text only.

Environment

  • Kendo UI version: 2019.2.619
  • jQuery version: x.y
  • Browser: [all]
Declined
Last Updated: 07 Aug 2019 08:25 by ADMIN
Created by: Dmitry
Comments: 1
Category: Editor
Type: Bug Report
0

Bug report

The fontSize tool gets focus after text selection. 

Steps to reproduce

* Open and run https://dojo.telerik.com/oRuLayir demo.

* Select /highlight Line4, choose 16 in the fontSize dropdown.

* Put the cursor at the end of Line6, select  Line4, Line5 and Line6 using the mouse. Note that the keyboard focus has shifted to the fontSize dropdown.

 

Approved
Last Updated: 07 Aug 2019 08:21 by ADMIN
Created by: Dmitry
Comments: 1
Category: Editor
Type: Bug Report
1

Bug report

The fontName tool shows an incorrect font name and gets focus after text selection.

Steps to reproduce 

* Open and run https://dojo.telerik.com/OHOHikin demo.

* Set the cursor to Line1, note an incorrect value in the fontName dropdown.

* Select/highlight Line4, choose Arial in the fontName dropdown and note an incorrect value in the dropdown.

* Put the cursor at the end of Line6, select Line4 and Line5 and Line6 using the mouse. Note that the keyboard focus has shifted to the fontName dropdown.

 

Completed
Last Updated: 16 Sep 2019 14:18 by ADMIN
Release 2019.R3

Bug report

Once the content area is blurred it can be focused only by clicking its upper part.

Regression introduced in R2 2019 SP1. Reproducible only in Chrome.

Reproduction of the problem

Demos. Screencast.

  1. Clear the Editor's content.
  2. Blur the widget and try to focus the content area by clicking in its bottom or mid section.

Current behavior

Content is not focused.

Expected/desired behavior

Content is focused.

Environment

  • Kendo UI version: 2019.2.619
  • jQuery version: x.y
  • Browser: [Chrome XX ]
Pending Review
Last Updated: 05 Aug 2019 07:33 by ADMIN
Created by: Dmitry
Comments: 1
Category: Editor
Type: Bug Report
1

Bug report

Copied text is pasted with some (editor's ?) styles.

Steps to reproduce

1. Open the Demo page in the Edge browser:

https://demos.telerik.com/kendo-ui/editor/index

2. Copy some words (e.g. "Kendo UI Editor") from the editor's default text.

3. Paste them at the end of the text.

4. Open developer tools (F12).

5. On the Elements tab, select the pasted paragraph and check its style, you will see <span style="display: inline !important; etc.

 

 

Completed
Last Updated: 16 Sep 2019 14:24 by ADMIN
Release 2019.R3
Created by: Pål
Comments: 0
Category: Editor
Type: Bug Report
1

Bug report

Unable to resize a column inside a table inserted in Editor

This is a regression represented after Kendo UI 2019.2.619

Reproduction of the problem

  1. Open this Dojo and run it
  2. Add a table(no matter of its size)
  3. Try to resize a column, not the whole table. No matter of the direction you resize the column its board is moving to the left
  4. When you release the mouse button the column is resized in a totally different way than the resize indicator showed

Current behavior

Please check this video for more details

Expected/desired behavior

The columns inside a table should be resizable.

Environment

  • Kendo UI version: 2019.2.619
  • jQuery version: x.y
  • Browser: [all]
Approved
Last Updated: 27 Jun 2019 11:07 by ADMIN

Bug report

Reproduction of the problem

Reproducible in the demos.

  1. Shrink the browser window so that some of the Editor tools go under the overflow button.
  2. Click the overflow button and then click a tool in the dropdown that opens a dialog ("Insert Image" or "Insert hyperlink").

Current behavior

A new dialog opens, but the overflow dropdown does not close and remains visible below the newly opened dialog.

In the inline Editor the overflow dropdown is shown above the newly opened dialog.

Expected/desired behavior

The overflow dropdown closes.

Environment

  • Kendo UI version: 2019.2.619
  • jQuery version: x.y
  • Browser: [all ]
Completed
Last Updated: 16 Sep 2019 14:25 by ADMIN
Release 2019.R3

When a bullet list with a nested table is created in Word, and then copied into the Editor, a "Cannot read property 'cells' of undefined" error is being thrown. The issue can be reproduced only when the msConvertLists option is set.

Reproduction of the problem

  1. Open https://demos.telerik.com/kendo-ui/editor/paste-cleanup

  2. Paste content from editor-test.docx.


Approved
Last Updated: 25 Jun 2019 10:44 by ADMIN
Created by: Archy
Comments: 0
Category: Editor
Type: Bug Report
1

Hi, steps to reproduce problem:

1. Crete editor with content:

<p>hello&nbsp;
<strong contenteditable="false">OMG</strong>
&nbsp;world</p><p>&#65279;</p>

2. Put cursor at the end

3. Hit backspace

Strong tag disappears but it shouldn't.

 

Attached html file with the case.

Approved
Last Updated: 21 May 2019 06:16 by ADMIN
Created by: Jitender
Comments: 1
Category: Editor
Type: Bug Report
1

1. use safari browser

2. Go to https://demos.telerik.com/kendo-ui/editor/index

3.  copy a long text over 25 characters

4. paste the copied text in the editor

5. notice that the scroll takes you to the bottom of the page, The same is not noticed in any other browser.

6. This is very inconvenient. 

 
Completed
Last Updated: 28 Nov 2019 15:31 by ADMIN
Release 2019.R2.SP1
Created by: Daniel
Comments: 1
Category: Editor
Type: Bug Report
1

Dear Telerik team,

 

when I apply a HTML-text with a paragraph to kendo editor it does show a vertical scroll bar in IE. Which is wrong. Chrome does not. See this dojo: https://dojo.telerik.com/AsuNiPuh/4

 

How can I fix this?

 

Kind regards

Daniel

Approved
Last Updated: 25 Mar 2019 11:36 by ADMIN
Created by: Gopi
Comments: 2
Category: Editor
Type: Bug Report
0

Please check dojo https://dojo.telerik.com/UMiREWiL

 

There is one kendo editor on the main page which is editable and when you click on the link below "Edit the content in pop-up", pop-up opens but doesn't show the content and also text editor is not editable.

 

Thank you,

Gopi

Completed
Last Updated: 22 Nov 2019 08:50 by ADMIN
Created by: Shane
Comments: 2
Category: Editor
Type: Bug Report
0

after downloading 

@progress/kendo-ui version 2019.1.115 the default create table feature is not working. It is not working on multiple browsers even here: https://demos.telerik.com/kendo-ui/editor/all-tools

the table wizard works but not the cell selection way. Is there a fix for this soon?

 

Completed
Last Updated: 13 May 2019 16:22 by ADMIN
Release 2019.R2

Steps to reproduce:

1. Go to https://demos.telerik.com/kendo-ui/editor/index using IE11

2. Delete a sentence in the editor by repeatedly pressing the backspace key.

Result:

The characters are deleted slowly with noticeable lag and jank.

Investigation

The following profile shows the FPS drop when you repeatedly press backspace.

 

I believe the call to refreshTools is expensive (for IE) and it is invoked on every keyup for backspace.