Approved
Last Updated: 18 Apr 2019 06:50 by ADMIN
Created by: Cedric
Comments: 0
Category: UI for ASP.NET MVC
Type: Bug Report
0

Passing a dynamic object to a template column builder throws an exception:

c.Template(m => { })
.ClientTemplate("<input type='checkbox' value='#= Id #' />")
.Visible(ViewBag.Can.Edit);

Using an explicit cast doesn't throw the error:

c.Template(m => { })
.ClientTemplate("<input type='checkbox' value='#= Id #' />")
.Visible((bool)ViewBag.Can.Edit);

Pending Review
Last Updated: 10 Apr 2019 14:05 by ADMIN
Created by: Stacy
Comments: 2
Category: UI for ASP.NET MVC
Type: Bug Report
3

Using Visual Studio Enterprise 16.0.0.

Created MVC Project 4.6.1

Run Telerik utility to "Convert to Telerik Web Application" from Project context menu. On a clean project just created from the VS Template.

Since previous step errors out and doesn't complete an attempt was made to use the Telerik Upgrade Wizard.

This produced the following error: 


An error occurred while running the wizard.

Error executing custom action Telerik.VSX.Actions.ShowConversionLogAction: Could not instantiate a TextTransformation object from the compiled assembly. The following Exception was thrown:
System.InvalidCastException: Unable to cast object of type 'Microsoft.VisualStudio.TextTemplating3e7341780e3e4a17bdabe17b447cd796.GeneratedTextTransformation' to type 'Microsoft.VisualStudio.TextTemplating.TextTransformation'.
   at Microsoft.VisualStudio.TextTemplating.TransformationRunner.CreateTextTransformation(String fullClassName, ITextTemplatingEngineHost host, Assembly assembly, ITextTemplatingSession userSession)

 

 

 

Pending Review
Last Updated: 10 Apr 2019 13:23 by ADMIN
Created by: Stacy
Comments: 2
Category: UI for ASP.NET MVC
Type: Bug Report
1

Using Visual Studio Enterprise 16.0.0.

Created MVC Project 4.6.1

Run Telerik utility to "Convert to Telerik Web Application" from Project context menu. On a clean project just created from the VS Template.

 

Error output from from Telerik VSX:


An error occurred while running the wizard.

 

Error executing custom action Telerik.KendoUI.Mvc.VSX.Actions.UpdateWebConfigAction: Could not instantiate a TextTransformation object from the compiled assembly. The following Exception was thrown:

System.InvalidCastException: Unable to cast object of type 'Microsoft.VisualStudio.TextTemplating1fd31dc42b754a598ac1cf6e6d72e8f7.GeneratedTextTransformation' to type 'Microsoft.VisualStudio.TextTemplating.TextTransformation'.

   at Microsoft.VisualStudio.TextTemplating.TransformationRunner.CreateTextTransformation(String fullClassName, ITextTemplatingEngineHost host, Assembly assembly, ITextTemplatingSession userSession)
Web.config as generated by VS 2019 MVC project Template


<?xml version="1.0" encoding="utf-8"?>
<!--
  For more information on how to configure your ASP.NET application, please visit
  https://go.microsoft.com/fwlink/?LinkId=301879
  -->
<configuration>
  <appSettings>
    <add key="webpages:Version" value="3.0.0.0"/>
    <add key="webpages:Enabled" value="false"/>
    <add key="ClientValidationEnabled" value="true"/>
    <add key="UnobtrusiveJavaScriptEnabled" value="true"/>
  </appSettings>
  <system.web>
    <compilation debug="true" targetFramework="4.6.1"/>
    <httpRuntime targetFramework="4.6.1"/>
    <authentication mode="Windows"/>
    <authorization>
      <deny users="?"/>
    </authorization>
  </system.web>
  <runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
      <dependentAssembly>
        <assemblyIdentity name="Antlr3.Runtime" publicKeyToken="eb42632606e9261f"/>
        <bindingRedirect oldVersion="0.0.0.0-3.5.0.2" newVersion="3.5.0.2"/>
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="System.Web.Optimization" publicKeyToken="31bf3856ad364e35"/>
        <bindingRedirect oldVersion="0.0.0.0-1.1.0.0" newVersion="1.1.0.0"/>
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="WebGrease" publicKeyToken="31bf3856ad364e35"/>
        <bindingRedirect oldVersion="0.0.0.0-1.6.5135.21930" newVersion="1.6.5135.21930"/>
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Newtonsoft.Json" publicKeyToken="30ad4fe6b2a6aeed"/>
        <bindingRedirect oldVersion="0.0.0.0-11.0.0.0" newVersion="11.0.0.0"/>
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="System.Web.Helpers" publicKeyToken="31bf3856ad364e35"/>
        <bindingRedirect oldVersion="0.0.0.0-3.0.0.0" newVersion="3.0.0.0"/>
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="System.Web.Mvc" publicKeyToken="31bf3856ad364e35"/>
        <bindingRedirect oldVersion="0.0.0.0-5.2.7.0" newVersion="5.2.7.0"/>
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="System.Web.WebPages" publicKeyToken="31bf3856ad364e35"/>
        <bindingRedirect oldVersion="0.0.0.0-3.0.0.0" newVersion="3.0.0.0"/>
      </dependentAssembly>
    </assemblyBinding>
  </runtime>
  <system.codedom>
    <compilers>
      <compiler language="c#;cs;csharp" extension=".cs"
        type="Microsoft.CodeDom.Providers.DotNetCompilerPlatform.CSharpCodeProvider, Microsoft.CodeDom.Providers.DotNetCompilerPlatform, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"
        warningLevel="4" compilerOptions="/langversion:default /nowarn:1659;1699;1701"/>
      <compiler language="vb;vbs;visualbasic;vbscript" extension=".vb"
        type="Microsoft.CodeDom.Providers.DotNetCompilerPlatform.VBCodeProvider, Microsoft.CodeDom.Providers.DotNetCompilerPlatform, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"
        warningLevel="4" compilerOptions="/langversion:default /nowarn:41008 /define:_MYTYPE=\&quot;Web\&quot; /optionInfer+"/>
    </compilers>
  </system.codedom>
</configuration>

Pending Review
Last Updated: 21 Mar 2019 07:45 by ADMIN
Created by: Bob
Comments: 1
Category: Installer and VS Extensions
Type: Bug Report
0

I just upgraded to the latest Telerik version.  First of all, congratulations on a job well done on the MVC Project Upgrade Wizard!  With version 2017.3.1026 it was unreliable, took hours to run, and generally locked up Visual Studio; the new version runs cleanly and quickly.

One comment:  The popup dialogs for the Upgrade Wizard do not adapt to different screen resolutions.  I see this where my primary display is high resolution (3840 x 2160) and the secondary is lower res (1920 x 1080).  The effect is that the popup dialogs are cropped if Visual Studio is running on the secondary display:  the message ("file xxx exists; do you want to overwrite?") appears, but the Yes/No buttons and "apply to all files" checkbox do not.  The only actionable option is to kill the dialog, at which point the next one pops up.  The only way I found to stop the Wizard is to kill Visual Studio through the Task Manager. 

The Wizard works perfectly on the primary high-res display.

Bob

Pending Review
Last Updated: 18 Mar 2019 15:26 by ADMIN

When using the Telerik upgrade wizard I get a error while upgrading my web app:

 

An error occurred while running the wizard.

Error executing custom action Telerik.KendoUI.Mvc.VSX.Actions.MultiProjectUpdateReferencesAction: System.NullReferenceException: Object reference not set to an instance of an object.
   at Telerik.VSX.Internal.ProjectManagement.ProjectAssemblyReferenceBase.Equals(AssemblyWrap assemblyReference)
   at Telerik.VSX.ProjectConfiguration.ProjectReferenceManager.EnsureDifferentExistingReferenceRemoved(AssemblyWrap assemblyReference)
   at Telerik.VSX.ProjectConfiguration.ProjectReferenceManager.AddAssemblyReference(AssemblyWrap assemblyReference)
   at Telerik.VSX.ProjectConfigurators.ApplicationReferenceManager.AddReferences()
   at Telerik.VSX.ProjectConfigurators.ApplicationReferenceManager.UpdateReferences()
   at Telerik.VSX.Actions.UpdateReferencesAction.UpdateReferences(IProjectWrapUIComponents projectWrap)
   at Telerik.VSX.Actions.UpdateReferencesAction.Execute(WizardContext wizardContext, IPropertyDataDictionary arguments, IProjectWrap project)
   at Telerik.VSX.Actions.ProjectActionBase.Telerik.VSX.Actions.IProjectAction.Execute(IWizardContext wizardContext, IPropertyDataDictionary arguments, IProjectWrap projectWrap)
   at Telerik.VSX.Actions.MultiProjectActionBase`1.Execute(WizardContext wizardContext, IPropertyDataDictionary arguments)
   at Telerik.VSX.Actions.MultiProjectUpdateReferencesActionBase`1.Execute(WizardContext wizardContext, IPropertyDataDictionary arguments)
   at Telerik.VSX.WizardEngine.Actions.ActionBase.Telerik.WizardFramework.IAction.Execute(IWizardContext wizardContext, IPropertyDataDictionary arguments)
   at Telerik.VSX.WizardEngine.ActionManager.ExecActions()
Approved
Last Updated: 26 Feb 2019 10:21 by ADMIN

Bug report
The issue is reproducible when the DatePicker with DateInput is used as an editor in Kendo Grid for ASP.NET MVC with "InCell" edit mode.

When a value which is less than the Min value or more than the Max value is typed in, the DatePicker is left blank rather than applying the Min/Max value.

Reproduction of the problem
1. Create a grid and set the "InCell" edit mode.
2. Create a DatePickerFor() editor and enable the DateInput(true) property.
3. Input value which is before 1/1/1900 or after 12/31/2099. E.g 1/1/1111
4. Value is left blank instead of the Min value being applied. (Same goes for Max value)

Current behavior
When value before 1/1/1900 or after 12/31/2099 is typed in, the cell is left blank instead of the Min/Max value being applied.

Expected/desired behavior
Apply Min/Max value to the model, instead of null.

Environment
Kendo UI version: 2019.1.220

jQuery version 1.12.4

Browser: [all]

Completed
Last Updated: 14 Feb 2019 14:49 by ADMIN
Created by: Kevin
Comments: 1
Category: UI for ASP.NET MVC
Type: Bug Report
0

Hi,

I notice that some of the styling has changed for the Blue Opal theme in the latest release (2019 R1), notably the background colour of the selected page on the grid and the already selected items on a Drop Down List have gone from dark blue to a bright blue (see attached screenshots from demos.telerik.com).

Is this by design or by mistake?

Particularly on the drop down list, this change makes it more difficult to identify the already selected items.

Can this go back to what it used to be - or is there a way of manually changing this setting via the site.css?

Thanks

Kevin

 

 

 

Declined
Last Updated: 18 Jan 2019 13:57 by ADMIN

I'm using drawing.drawDOM to create a PDF. I have to make a table of contents in the beginning of the PDF. I've got two issues:

- How do I link to another section of the PDF? <a href="#conclusion">Conclusion</a> and then later <a name="conclusion"></a> doesn't seem to work :-/

- How do I figure out on which page a specific part of the document is being rendered? In my TOC I would like to say "Conclusion....page 22".

Pending Review
Last Updated: 11 Jan 2019 09:19 by ADMIN

I'm trying to create a kendo grid inside of a kendo splitter in ASP.Net MVC. My problem is the pager info (i.e. "1 of 20 items") is not displayed on load. If the splitter is moved or a button inside of the splitter is pressed the grid resizes and the pager is displayed correctly. When there are more than 10 pages and the pager numbers and pager info size change to accommodate more digits the pager wrapper is not drawn correctly every time when changing pages.  This issue seems to only be present when the grid has a toolbar

I have tried using the dataBound event to resize the grid elements, but the pager div is not computed yet. I also tried applying a flex box to the pager wrapper and that did not change anything. I added a size to the splitter and it fixed the issue when set to 400px. But when set to something like 33% the issue persists. I need the splitter pane to be bigger than 400px on load so that fix does not work. 

I replicated the issue in this dojo: https://dojo.telerik.com/URIbinEY/12. The issue appears when in fullscreen mode on a 1920x1080 monitor. I have attached screen shots from my application showing the issue while navigating with the pager. paging 1.png shows the initial load fixed using a flex-box. paging 2.png shows navigating to the second page. The pager info is resized and moved off screen. paging 1.2 shows navigating back to page 1. There is a white space left at the bottom. Paging 3 shows the end of the pages. Paging 4 shows clicking the "..." to the previous paging page and the pager info being hidden. Paging inspected shows that the pager info is in the DOM, but resized off the screen when the toolbar is drawn. 

The expected result should show the pager info on load and the grid should fill 100% of the splitter pane. The pager info should be adjusted when navigating to another page in the pager to always be displayed. 

Any help with this issue will be much appreciated. Thanks!

Pending Review
Last Updated: 11 Dec 2018 08:59 by ADMIN

Hello,

 

I noticed that the date format from my current kendo culture (fr-FR) is not applied properly for Weeks and Days units on xAxis labels of a chart with date axis.

 

I had to set the property DateFormats for Weeks and Days of my XAxis Labels to force the format (other units work fine) :

@(Html.Kendo.Chart(Of Models.DataViewModel).
        Name("chart").
        Title(typeMesure.GetDescription()).
        DataSource(Sub(dataSource)
                       dataSource.Read(Sub(read)
                                           read.Type(HttpVerbs.Get).Action("GetData","Data"))
                                       End Sub).
                                       Sort(Sub(sort) sort.Add(Function(m) m.Dt).Ascending())
                   End Sub).
                            Series(Sub(series) series.
                                        ScatterLine(Function(m) m.Dt, Function(m) m.Value).
                                        Markers(False).
                                        MissingValues(ChartScatterLineMissingValues.Gap).
                                        Color("#cb1d39").
                                        Tooltip(Sub(tooltip)
                                                    tooltip.Visible(True).
                                                    Template("Date : #= kendo.toString(value.x, 'dd/MM/yyyy HH:mm') # <br/>Valeur : #= kendo.toString(value.y, 'n3') #")
                                                End Sub)).
                            XAxis(Sub(xAxis) xAxis.Date().
                                        Min(Model.DateDebut).
                                        Max(Model.DateFin).
                                        Labels(Sub(labels) labels.DateFormats(Sub(dateFormats) dateFormats.Weeks("dd/MM").Days("dd/MM")))).
                            Panes(Sub(panes) panes.Add().Clip(False)).
                            Pannable(True).
                            Zoomable(Sub(zoomable)
                                         zoomable.Mousewheel(Sub(mousewheel) mousewheel.Lock(ChartAxisLock.Y)).
                                         Selection(Sub(selection) selection.Lock(ChartAxisLock.Y))
                                     End Sub))

 

Could you please fix this issue in a future version ?

Thanks and regards.

1 2