Pending Review
Last Updated: 19 Sep 2019 19:36 by Dave
Created by: Dave
Comments: 0
Category: Grid
Type: Bug Report
0

Hello, 

 

I think there is a bug with the DataTimeOffset field when used in a Grid. It cannot display correctly and is showing something like /Date(1364927400000)/. I have to retrieve my data from database as DateTimeOffset format and then use a new ViewModel to convert the DateTimeOffset values to DateTime values. This is really annoying.

 

Could you let me know if there is a way a DateTimeOffset field can be supported in the grid? Sometimes you do have to display the time zone info.

 

I hope this can be fixed in a future release.

 

Thanks,

Sam

Pending Review
Last Updated: 17 Sep 2019 10:56 by Jasmine
Created by: Jasmine
Comments: 0
Category: UI for ASP.NET MVC
Type: Bug Report
0

Hi,

 

I have developed an application where I am displaying records in kendo Gantt chart, Initially I want to display only title and give user the option to select start & end date.  This means that I need to pass null value for start & end date, but I could not find the option. Could you please help me with it.

Also I want to add validations for start date & end date i.e. if user does not enter start & end date an alert should be displayed specifying user to add dates.

Please let m know whether its possible or not & if possible how should I go ahead with it.

  

Approved
Last Updated: 16 Sep 2019 15:30 by ADMIN

Bug report

When we want to add a formula in a given cell in the Spreadsheet, we double-click it and enter the "=" in it as an identifier that a formula definition will follow. If we want to include in the formula a cell that is not inside the visible range of the Spreadsheet, we scroll to that cell and select it. In Internet Explorer, if we scroll to a given cell using the arrows of the Spreadsheet's scrollbar the "double-clicked" cell becomes just a selected one and the "=" sign is converted to a string value.

Reproduction of the problem

  1. Open this Dojo example in Internet Explorer 11
  2. Select the A1 cell and enter "=" in it.
  3. Press the "down" direction arrow of the Spreadsheet trying to reach cell A50.
  4. With the first click on the arrow, the A1 cell is no more "double-clicked" and the "=" inside it is converted to a string

Current behavior

When building a formula in a given cell and trying to navigate to a cell using the scrollbar, this usage stops the formula building and converts the "=" into a string.

Expected/desired behavior

When a user creates a formula for a given cell, they should be able to navigate through the Spreadsheet using its scrollbars.

Environment

  • Kendo UI version: 2019.2.619
  • jQuery version: x.y
  • Browser: IE 11.950.17134.0
Approved
Last Updated: 09 Sep 2019 15:14 by ADMIN
Created by: Jon
Comments: 1
Category: Dialog
Type: Bug Report
0

I have a dialog defined but the "mydialog-control" CSS class never gets added to the dialog when it's rendered.  Why is that happening?

@(Html.Kendo().Dialog()
    .Name("SalesTypeWarning")
    .Title("Warning")
    .Content(warningTextContent)
    .Modal(true)
    .Closable(false)
    .Visible(false)
    .Width(600)
    .HtmlAttributes(new { @class = "mydialog-control"})
    .Actions(act =>
    {
      act.Add().Text("Continue").Primary(true).Action("allowSalesTypeChange");
      act.Add().Text("Cancel Change").Action("cancelClicked");
    })
    .Deferred(true)
)
Pending Review
Last Updated: 27 Aug 2019 10:51 by ADMIN
When using data attributes on a viewmodel for a grid popup editor:
1. Provide input that causes a validation error message to appear
2. Correct the error with new input, do not blur the final field
3. Click save.
4. Instead of validating the data and submitting, only validation occurs
Declined
Last Updated: 06 Sep 2019 13:57 by ADMIN
Created by: Patrick
Comments: 3
Category: DropDownList
Type: Bug Report
0

Kendo Version - Kendo MVC 2019.2.619

 

My values appear in the previous option item.

Drop Down List name and values:

  • Name = "Select From" 
  • ID = ""
  • Name = "ABCHERG"
  • ID = "ABCHERG"

I have one item and a "Select from" option (see data above) in my list

I select "ABCHERG" from my drop down list and the value that's returned is blank.

If I select the "Select From" option the value returned is "ABCHERG"

Approved
Last Updated: 07 Aug 2019 08:48 by ADMIN
Created by: Kornelius
Comments: 1
Category: MultiSelect
Type: Bug Report
1
  • Regression report
    Introduced in 2019.2.514.

Current behavior

margin-left causes selected items on second + rows in the MultiSelect to appear unaligned to the items in the first row.

Expected behavior

Reproduction

Dojo example.

What is the motivation or use case for changing the behavior?

Regression

Environment

  • Kendo Ui for jQuery

Browser:

  • Chrome (desktop) version XX
  • Firefox version XX
  • Edge version XX
Pending Review
Last Updated: 06 Aug 2019 15:00 by ADMIN
Created by: Tommy
Comments: 1
Category: UI for ASP.NET MVC
Type: Bug Report
0
It seems that the Kendo Grid control no longer treats null text to show as empty when using client templates for columns. Previously, if the model property reference in the client template was null (on initial add, for example), it would display empty text. Now all of our columns are showing 'null' text... Was this intended?
Approved
Last Updated: 25 Jul 2019 13:11 by Sam

Bug report

Class k-state-focused is not removed from DropDownlist on blur, if its filter input was clicked.

Reproduction of the problem

  1. Use Events demo
  2. Click on DropDownList to expand its dropdown.
  3. Click on DropDownList's filter input.
  4. Click on demo's title to blur the DropDownList

Current behavior

DropDownList appears focused as k-state-focus class is not removed from its span
<span unselectable="on" class="k-dropdown-wrap k-state-default k-state-focused">
image

Expected/desired behavior

DropDownList does not appear focused.

Environment

  • Kendo UI version: 2019.2.619
  • Browser: all
Completed
Last Updated: 16 Sep 2019 14:23 by ADMIN
Release 2019.R3

Bug report

The toolbar.click is not serialized correctly when a custom button is added to the ToolBar of the widget. Thus, the click event is not being executed.

Reproduction of the problem

@(Html.Kendo().PDFViewer()
    .Name("test")
    .PdfjsProcessing(pdf => pdf.File(""))
        .Toolbar(t => t.Items(i =>
            {
            i.Add().Name("Open").Id("Open").Command("OpenCommand").Type("button").Icon("folder-open");
            i.Add().Name("Print").Id("Print").Type("button").Icon("print").Click("onPrintClick");
        }))
        .Height(500)
)

<script>
   function onPrintClick(e) {
        alert(e);
    }
</script>

Current behavior

toolbar is not serialized correctly.

Expected/desired behavior

toolbar.click should be serialized correctly.

Environment

  • Kendo UI version: 2019.2.516
  • Browser: [all]
Approved
Last Updated: 02 Jul 2019 09:01 by ADMIN
Created by: Julius
Comments: 1
Category: Window
Type: Bug Report
0

I have discovered a bug in Kendo UI that seems to only affect IE11. 

When you create a Window with a position and width that renders partially off screen, IE11 will scroll the body to show as much of the window as possible.

Worse still, it seems to scroll to the last Kendo Window that was created.

This is undesirable. Is there a known workaround, or fix for this?

You can see it in this dojo if you shrink IE11 to be smaller than the window is wide:

https://dojo.telerik.com/iBiFatAT

See attached.

 

Thanks,

Julius

Pending Review
Last Updated: 04 Jul 2019 10:44 by ADMIN

Hi, 

For example:

  1. Go to: https://demos.telerik.com/aspnet-mvc/numerictextbox
  2. Click on "Events" in left menu.
  3. Click on back button in browser.
  4. The fields are now empty.

Tried with Firefox 67 for Mac.

 

Approved
Last Updated: 13 Jun 2019 12:02 by ADMIN

Bug report

Reproducible in Chrome and IE11. In Firefox highlighting a row and applying formatting (bold) applies it only to the first cell on the row.

Reproduction of the problem

Screenshot.

  1. Copy/paste a table from Excel into the Editor.
  2. Highlight the first row and use the Bold tool.
  3. Inspect the table Html.

Current behavior

strong tags are added under the tr element

Expected/desired behavior

strong tags are added only under the td elements.

Environment

  • Kendo UI version: 2019.2.514
  • jQuery version: x.y
  • Browser: [Chrome, IE]
Completed
Last Updated: 13 Jun 2019 08:08 by ADMIN
Release 2019.R2.SP.Next
Created by: Sergey
Comments: 0
Category: ComboBox
Type: Bug Report
0

Bug report

ComboBox with filtering option set to "contains".

Search for the last element in ComboBox dropdown and select it. Delete the selected item with mouse selection and "Delete" button. The dropdown will open again. Select the first element in the dropdown. It will close and no data will be selected. If we repeat the scenario and instead of selecting the first element, we select another one, everything is working properly.

This is regression introduced in 2018 R1 SP1

Reproduction of the problem

  1. Open this Dojo and run it
  2. Select the ComboBox and enter "rib", then select "Rib Knit"
  3. Unfocus the ComboBox and then focus it again
  4. Using the mouse select the "Rib Knit" text and delete it. The dropdown of the ComboBox will open.
  5. Select the first element "Cotton".
  6. The dropdown closes and no item is selected

Current behavior

Please check this demo video.

Expected/desired behavior

Please check this demo video

Environment

  • Kendo UI version: 2019.2.514
  • jQuery version: x.y
  • Browser: [all]
Pending Review
Last Updated: 29 May 2019 16:14 by ADMIN
Created by: Manu
Comments: 1
Category: Grid
Type: Bug Report
1

Hello,

since I updated Telerik UI for ASP.net MVC from version 2019.1.220 to 2019.2.514, the paging part of the grid doesn't display as expected in IE11 with compatibility with IE9  (<meta http-equiv="x-ua-compatible" content="IE=9">)

If I remove the compatibility with IE9, it's ok, but I need it to support older computer.  

version 2019.1.220: 

version 2019.2.514:

 

 Is there a solution to display it correctly?

Thank you very much and best regards.

 

Emmanuel Tharin

Approved
Last Updated: 04 Jun 2019 08:17 by ADMIN
Scheduled for 2019.R2.SP.Next
Created by: Taki Xaftellis
Comments: 1
Category: ListView
Type: Bug Report
0

Since upgrading to 2019.2.514, all Kendo ListViews have the following styling added:

overflow-y: scroll; position: relative;

Please explain the purpose and the best way to turn off.

 

Pending Review
Last Updated: 28 May 2019 10:04 by ADMIN

When the page first loads, everything looks okay...

 

But if I show a hidden column...

 

Here's what happens...

The newly shown column is circled in blue. The problem, as you can see, is that the position of the column circled in red should actually be swapped with the column to the left of it. And column #2 (ordering from left to right in the picture, starting from #1) now has an incorrect parent header ("Average") - it should be "Total". And column #4 (the one circled in red), "Constrained", should have a parent header of "Average" (that gray one in column #2).

 

And just FYI, if I show another column (which should also be under "Session Time [minutes]")...

 

...then here's what we get...

(Newly shown column circled in blue.)

 

But, you can see that the data columns are placed correctly. Just not the headers.

Pending Review
Last Updated: 17 May 2019 08:51 by Prashanth
Created by: Prashanth
Comments: 0
Category: Grid
Type: Bug Report
1

The issue is present only when a field in the model has been updated. When an invalid value is attempted to be saved, the validation is triggered. Upon pressing the Esc key, the dirty indicator should not be shown.

The expected behavior would be to not show the dirty indicator at all as the value has been returned to the initial one. Furthermore, the indicator is not positioned in the left top corner but immediately above the value.

Steps to replicate:

1. Change the value of any field.

2. Navigate to a field which has validation.

3. Set an invalid value in order to trigger the validation, respectively show a validation message.

4. Press Esc to undo the change.

5. The dirty indicator is shown and mispositioned.

Dojo sample:

https://dojo.telerik.com/iHoRaWIg

Short video demonstration:

https://screencast-o-matic.com/watch/cqhbjKTeK2

Approved
Last Updated: 21 May 2019 09:08 by ADMIN
Created by: Tim
Comments: 1
Category: ComboBox
Type: Bug Report
0

Bug report

Reproduction of the problem

Setup:
Grid PageSize is set to 100 or more (e.g. 200)
Column with virtualized ComboBox editor

Clicking on the cells consecutively causes some of the cells to lose their value. Screencast.

A sample project, in which the issue can be observed can be found in ticket: 1408425.

Current behavior

Cells lose value

Expected/desired behavior

Cells do not lose value

Environment

  • Kendo UI version: 2019.1.220
  • jQuery version: x.y
  • Browser: [all]
Pending Review
Last Updated: 02 May 2019 06:50 by ADMIN

Issue
If a single tag MultiSelect is blurred on filtering and then refocused, then the clear button is pressed with the dropdown open, the single tag remains even though there are no selected items.

Reproduction
1.  Run this dojo.
2.  Click on MultiSelect input and type L
3.  Click outside the MultiSelect to blur it - filter is removed.
4.  Click on MultiSelect input (dropdown opens) and press the clear button.

Current behavior
MultiSelect value is cleared. But the single tag remains visible and states that there are selected items even though there are none.

Expected/desired behavior
The single tag should be removed as shown in this Kendo UI Dojo using R3 2018.

Workaround
Handle MultiSelect's change event as follows:

            function onChange(e) {
              if(!e.sender.value().length){
                e.sender.element.closest(".k-multiselect").find(".k-button").remove();
              }
            }

1 2