Planned
Last Updated: 08 Nov 2019 13:19 by ADMIN

Bug report

The ComboBox doesn't reset its default state when removing the selected items with Ctrl+A && pressing the Delete/Backspace button.

This bug is a regression from the 2018 R3 version.

Reproduction of the problem

  1. Open this Dojo project
  2. Select the ComboBox and enter "Hanari Carnes", then select the first element
  3. Clear the value of a field in one step (press Ctrl+A then Delete/Backspace button). The dropdown of the ComboBox will open.
  4. Select the first element in the list - "Vins et alcools Chevalier".
  5. The dropdown closes and no item is selected

Current behavior

When selecting the first element in the list, the Combobox closes without adding a value to the ComboBox input.

Expected/desired behavior

When the "Vins et alcools Chevalier" value is selected , the value should be added in the ComboBox input and the dropdown should close.
Here is a Dojo demonstrating the correct behavior.

Environment

  • Kendo UI version: 2019.3.1023
  • jQuery version: x.y
  • Browser: [all]
Approved
Last Updated: 14 Nov 2019 10:33 by ADMIN

Bug report

Using server binding does not render the NoRecords message for the Grid

Reproduction of the problem

	@(Html.Kendo().Grid(new List<Product>())    
		.Name("Grid")
		.Columns(columns => {
			columns.Bound(p => p.ProductID).Groupable(false);
			columns.Bound(p => p.ProductName);
			columns.Bound(p => p.UnitPrice);
			columns.Bound(p => p.UnitsInStock);
		})
		.NoRecords("No records found.")
		
		.Pageable()
		.Sortable()
		.Scrollable() 
		.DataSource(d=>d.Server())
		.Filterable()
		.Groupable()
	)

Workarond

A possible workaround is to use local binding by setting the AJAX binding in the DataSource, but keep the initial server binding:

	@(Html.Kendo().Grid(new List<Product>())    
		.Name("Grid")
		.Columns(columns => {
			columns.Bound(p => p.ProductID).Groupable(false);
			columns.Bound(p => p.ProductName);
			columns.Bound(p => p.UnitPrice);
			columns.Bound(p => p.UnitsInStock);
		})
		.NoRecords("No records found.")
		
		.Pageable()
		.Sortable()
		.Scrollable() 
		.DataSource(d=>d.Ajax().ServerOperation(false))
		.Filterable()
		.Groupable()
	)

Environment

  • Kendo UI version: 2017.3.1026
Pending Review
Last Updated: 11 Nov 2019 10:32 by ADMIN
Created by: Peter
Comments: 1
Category: Window
Type: Bug Report
0

Hello,

I'd like to report a problem with the window component. It's only related to Google Chrome and occurred after the last Chrome update. Windows and Mac alike.

When dragging a non-modal window it does not move smoothly, but in a jerking manner. There is no problem with modal windows.

I've enclosed a screen video. The first windows is moving perfectly, the second erratically. Of course, this is not a major issue, but the client still complains.

This is the configuration. .Draggable(true) does not change the behavior.
@(Html.Kendo().Window()
      .Deferred()
      .Name("insert-products-window")
      .Title("Placering produktdokument")
      .LoadContentFrom("LoadInsertProductsDialog", "Catalog")
      .Events(e => e.Error("utilities.handleWindowError"))
      .Events(e => e.Close("insertProducts.onClose"))
      .Events(e => e.Activate("insertProducts.wireToolbarEvents"))
      .HtmlAttributes(new {style = "padding: 0;"})
      .Scrollable(false)
      .Draggable(d => d.Containment(Model.IsPhone ? "" : ".body-content"))
      .Modal(false)
      .Width(Model.IsPhone ? 0 : 700)
      .Height(Model.IsPhone ? 0 : 450)
      .Resizable(r => r.MinWidth(300))
      .Resizable(r => r.MinHeight(260))
      .Visible(false)
      .Actions(a => a.Custom("help").Minimize().Close())
      )

Approved
Last Updated: 04 Nov 2019 15:06 by ADMIN

Bug report
Open a pdf file with links in PDF Viewer. Links are not clickable.

Reproduction of the problem
Open the demo for the PDF Viewer
Open a file, containing links
Click on a link

Current behavior
Clicking on a link does not redirect to the page

Expected/desired behavior
Clicking on a link should redirect to the link.

Environment
Kendo UI version: 2019.3.1023

Browser: [all]

Completed
Last Updated: 11 Nov 2019 07:54 by ADMIN
Release 2019.R3.SP.next
Created by: Ikbum Kim
Comments: 1
Category: Grid
Type: Bug Report
0

When I use lock column, margin is created in the right scroll of the grid. Did you know this problem?
How can I fix this problem? 

 

 

Approved
Last Updated: 28 Oct 2019 13:42 by ADMIN
Created by: Abdullateef
Comments: 0
Category: TreeView
Type: Bug Report
0

When the Kendo UI TreeView (DropDownTree as well) is nested inside a template and the Checkboxes(true) property is set, Invalid Template error is thrown. 

For instance:

<script type="text/x-kendo-template" id="template">
        @(Html.Kendo().TreeView()
        .Name("treeview")
        .Checkboxes(true)
        .Items(treeview =>
        {
            treeview.Add().Text("My Web Site")
                .SpriteCssClasses("folder")
                .Expanded(true)
                .Checked(true)
                .Items(root =>
                {
                    root.Add().Text("images")
                        .Expanded(true)
                        .SpriteCssClasses("folder")
                        .Items(images =>
                        {
                            images.Add().Text("logo.png")
                                .SpriteCssClasses("image");

                            images.Add().Text("body-back.png")
                                .SpriteCssClasses("image");

                            images.Add().Text("my-photo.jpg")
                                .SpriteCssClasses("image");
                        });

                    root.Add().Text("resources")
                        .Expanded(true)
                        .SpriteCssClasses("folder")
                        .Items(resources =>
                        {
                            resources.Add().Text("pdf")
                                .Expanded(true)
                                .SpriteCssClasses("folder")
                                .Items(pdf =>
                                {
                                    pdf.Add().Text("brochure.pdf")
                                        .SpriteCssClasses("pdf");

                                    pdf.Add().Text("prices.pdf")
                                        .SpriteCssClasses("pdf");
                                });
                        });
                });
        }).ToClientTemplate()
    )
</script>

 

    function showDetails(e) {
        e.preventDefault();
        var detailsTemplate = kendo.template($("#template").html());
        var dataItem = this.dataItem($(e.currentTarget).closest("tr"));
        var wnd = $("#Details").data("kendoWindow");
        wnd.content(detailsTemplate(dataItem));
        $("#SendArtifactId").val(dataItem.ArtifactId);
        wnd.center().open();
    }

Approved
Last Updated: 23 Oct 2019 14:29 by ADMIN
Bug report
Telerik UI for ASP.NET MVC version for the Editor's ImageBrowser CRUD methods does not support the method Data(string handler) in order to send additional parameters. This is supported for Kendo UI for JQuery:
https://docs.telerik.com/kendo-ui/api/javascript/ui/editor/configuration/imagebrowser

Reproduction of the problem
Currently, it is not possible to pass additional data when using the Telerik UI for ASP.NET MVC HTML helpers.

Current behavior
It is not possible to pass additional data when using the Telerik UI for ASP.NET MVC HTML helpers.

Expected/desired behavior
It should be possible to pass additional data when using the Telerik UI for ASP.NET MVC HTML helpers.

Environment
Kendo UI version: 2019.3.917
Browser: [all]
Completed
Last Updated: 13 Nov 2019 15:09 by ADMIN
Release 2019.R3.SP.next

Bug report

If the CurrentTimeMarker is enabled (it is by default), the resources are grouped, and events with different resource values (about 70) are loaded for the current day, a significant performance deterioration is observed.
With the CurrentTimeMaker disabled or the events loaded for a date different than today (past or future) the performance issue is not exhibited.

Reproduction of the problem

MVCSchedulerCurrentTimeMarker.zip

  1. Run the attached sample project.

Current behavior

No exceptions are thrown, but the Scheduler becomes unresponsive.

Expected/desired behavior

There should be no performance hit, regardless of CurrentTimeMarker being enabled/disabled.

Environment

  • Kendo UI version: 2019.3.917
  • jQuery version: x.y
  • Browser: [all]
Completed
Last Updated: 23 Oct 2019 08:34 by ADMIN

Hi,

I'm experiencing a bug with the kendo grid. In my project I have a rather complicated website where a kendo grid is loaded depending an multiple criteria which can be chosen by the user through dropdowns and multiselects. Luckily, I could break it down to a simple test website and the bug still is bugging around ;)

Description: Depending on the criteria chosen, the grid loads different data which reach from zero to thousands of data rows. In my example here, it's either zero or 100 data rows (depending on the dropdown, if there is either "Empty" or "Not empty" selected). The grid loads its data if you press the button ok (by calling the Load action on the server). The result is meant to be limited to paging of 25 rows (no user choice wanted)!

Heres the code for the cshtml site:

<!DOCTYPE html>

<html>
<head>
    <meta name="viewport" content="width=device-width" />
    <title>Index</title>
</head>
<body>
    <div id="content">
        <div>
            @(Html.Kendo().DropDownList()
                            .Name("test_selector")
                            .DataTextField("Display")
                            .DataValueField("Value")
                            .BindTo(new List<DropDownVM>() {
                                            new DropDownVM()                                                                    {
                                                Display = "Empty",
                                                Value = "empty"
                                            },
                                            new DropDownVM()                                                                    {
                                                Display = "Not empty",
                                                Value = "notEmpty"
                                            }
                            })
            )
        </div>
        <div>
            @(Html.Kendo().Grid<MyProject.ViewModels.Test.TestItem>()
                                            .Name("grid_Test")
                                            .Columns(columns =>
                                            {
                                                columns.Bound(x => x.TestId).Title("TestId").Width(75);
                                                columns.Bound(x => x.TestName).Title("TestName").Width(75);
                                            })
                                            .Sortable()
                                            .Pageable()
                                            .DataSource(dataSource => dataSource
                                                .Ajax()
                                                .PageSize(25)
                                                .Read(read => read.Action("Load", "Test").Data("GetSelectorData"))
                                            )
                                            .AutoBind(false) //Do not load Grid data initially
            )
        </div>
        <div>
            @Html.Kendo().Button().Name("Load").Content("Load")
        </div>
    </div>
    <script type="text/javascript">
        $("#Load").on("click", function (e) {
            var grid = $("#grid_Test");
            grid.data("kendoGrid").dataSource.read();
        });

        function GetSelectorData() {
            var selectorData = {
                type: $('#test_selector').data("kendoDropDownList").value()
            }
            return selectorData;
        }
    </script>
</body>
</html>

And the corresponding controller:


public class TestController : BaseController
    {
        public ActionResult Index()
        {
            return View();
        }

        public ActionResult Load([DataSourceRequest] DataSourceRequest request, string type)
        {
            List<TestItem> result = new List<TestItem>();
            if (type == "notEmpty")
            {
                for (int id = 1; id <= 100; id++)
                    result.Add(CreateTestItem(id));
            }

            request.PageSize = 25;
            return Json(result.ToDataSourceResult(request));
        }

        private TestItem CreateTestItem(int id)
        {
            TestItem result = new TestItem()
            {
                TestId = id,
                TestName = "Name" + id
            };
            return result;
        }
    }

Problem: The scenario described above works actually fine as long as the grid gets at least one data row delivered as DataSourceResult (i.e., result.Count > 0 in the Load method of the controller). The request object in the controller's Load method also shows request.PageSize to be configured to 25. Also, if I choose "Empty" from the dropdown and press the Load-button, the request in the controller will show PageSize = 25. But if I switch the selector to "Not empty" afterwards and press Load, the request will show PageSize = 0! This results in the grid not being paged at all and showing all results on a single page (which leads to serious connectivity problems in my productive project as soon as there are several thousands of data rows).

I tried a quick workaround in the Load method of the controller by setting the PageSize manually back to 25 (which is not wanted of course, but would actually work for me at the moment):


public ActionResult Load([DataSourceRequest] DataSourceRequest request, string type)
        {
            List<TestItem> result = new List<TestItem>();
            if (type == "notEmpty")
            {
                for (int id = 1; id <= 100; id++)
                    result.Add(CreateTestItem(id));
            }

            request.PageSize = 25;
            return Json(result.ToDataSourceResult(request));
        }

Unfortunately, this doesn't work either. The paging will be back on again and there will be only 25 data rows loaded in the grid but there is only one single page no matter how many data rows are loaded (see attached screenshot).

Do you know about this? Unfortunately I couldn't find any help for this problem so far.

Greetings!

Approved
Last Updated: 16 Oct 2019 15:23 by ADMIN

Bug report

An occurrence can be deleted from the "x" button in the event's top right corner, but when it is edited a "Delete" button is not displayed in the editor.

Reproduction of the problem

Reproducible in the demos and also with editRecurringMode: "occurrence" (dojo example).

Current behavior

Delete button is not displayed.

Expected/desired behavior

Delete button is displayed.

Environment

  • Kendo UI version: 2019.3.917
  • jQuery version: x.y
  • Browser: [all]
Approved
Last Updated: 07 Oct 2019 13:58 by ADMIN
Created by: Bill
Comments: 0
Category: MultiSelect
Type: Bug Report
0

When data for the MultiSelect widget is virtualized and mapValueTo: "dataItem" option is set, the widget returns incorrect dataItem on subsequent selection.

1. Select Order 3 and submit selection. Alert displays the selected Id 3
2. Clear selection and submit. Alert displays no data.
3. Select Order 131313 and submit selection. Alert displays the selected Id 131313 
4. Clear selection and submit. Alert displays no data.
5. Select Order 24242 and submit selection. Alert displays the selected Id 131313

Approved
Last Updated: 08 Oct 2019 09:23 by ADMIN

Hello,

On MAC, command+c cut instead of copy when selected texts are in a table. To duplicate, please follow these steps.

1. Go here: https://demos.telerik.com/aspnet-mvc/editor

2. Insert a new table.

3. Add some text into the table.

4. Select texts in the table.

5. Press command+c on MAC.

 

Please advise.

Thank you.

Approved
Last Updated: 02 Oct 2019 08:56 by René Spruit

Bug report

The input field of the Combobox is being shifted when a "position: absolute" style is set on its initial element.

Reproduction of the problem

  1. Open this Dojo example
  2. Run it and see the floating "Rib Knit" text which is the input field of the Combobox

Current behavior

The input field of the Combobox is shifted when "position: absolute" style is set on its initial element.

Expected/desired behavior

When setting "position: absolute" style on ComboBox initial element the whole component should be shifted according to the set "top, bottom, left, right" parameters.

A possible workaround that could be applied in the above linked Dojo is the following one:
$("#comboboxA").getKendoComboBox().input.css("position", "static");

Here is the modified Dojo with correctly working Combobox with "position: absolute" style is set on its initial element.

Environment

  • Kendo UI version: 2019.3.917
  • jQuery version: x.y
  • Browser: [all]
Approved
Last Updated: 04 Oct 2019 12:31 by ADMIN
Scheduled for 2019.R3.SP.next
Created by: Chris
Comments: 0
Category: Spreadsheet
Type: Bug Report
0

Bug report

Regression introduced in R3 2019.

Reproduction of the problem

Open this Spreadsheet demo. Even though the Toolbar configuration is set to false, it is not hidden. This applies only for ASP.Net Core and ASP.Net MVC.

Current behavior

The Toolbar is visible when set to false.

Expected/desired behavior

The Toolbar should be hidden.

Environment

  • Kendo UI version: 2019.3.917
  • Browser: [all]
Completed
Last Updated: 10 Oct 2019 14:34 by ADMIN
Release 2019.R3.SP.next

Bug report

Regression introduced in R2 2018.

Reproduction of the problem

The mobile mode of the Scheduler must be turned off.
Reproducible in the demos.

  1. Tap, hold and try to move an event

Current behavior

The moveStart event does not fire and the event cannot be moved.

Expected/desired behavior

The moveStart event fires and the event can be moved.

Environment

  • Kendo UI version: 2019.3.917
  • jQuery version: x.y
  • Browser: [Android]
Pending Review
Last Updated: 24 Sep 2019 07:14 by ADMIN
Created by: Jasmine
Comments: 1
Category: Gantt
Type: Bug Report
0

Hi,

 

I have developed an application where I am displaying records in kendo Gantt chart, Initially I want to display only title and give user the option to select start & end date.  This means that I need to pass null value for start & end date, but I could not find the option. Could you please help me with it.

Also I want to add validations for start date & end date i.e. if user does not enter start & end date an alert should be displayed specifying user to add dates.

Please let m know whether its possible or not & if possible how should I go ahead with it.

  

Approved
Last Updated: 16 Sep 2019 15:30 by ADMIN

Bug report

When we want to add a formula in a given cell in the Spreadsheet, we double-click it and enter the "=" in it as an identifier that a formula definition will follow. If we want to include in the formula a cell that is not inside the visible range of the Spreadsheet, we scroll to that cell and select it. In Internet Explorer, if we scroll to a given cell using the arrows of the Spreadsheet's scrollbar the "double-clicked" cell becomes just a selected one and the "=" sign is converted to a string value.

Reproduction of the problem

  1. Open this Dojo example in Internet Explorer 11
  2. Select the A1 cell and enter "=" in it.
  3. Press the "down" direction arrow of the Spreadsheet trying to reach cell A50.
  4. With the first click on the arrow, the A1 cell is no more "double-clicked" and the "=" inside it is converted to a string

Current behavior

When building a formula in a given cell and trying to navigate to a cell using the scrollbar, this usage stops the formula building and converts the "=" into a string.

Expected/desired behavior

When a user creates a formula for a given cell, they should be able to navigate through the Spreadsheet using its scrollbars.

Environment

  • Kendo UI version: 2019.2.619
  • jQuery version: x.y
  • Browser: IE 11.950.17134.0
Approved
Last Updated: 09 Sep 2019 15:14 by ADMIN
Created by: Jon
Comments: 1
Category: Dialog
Type: Bug Report
0

I have a dialog defined but the "mydialog-control" CSS class never gets added to the dialog when it's rendered.  Why is that happening?

@(Html.Kendo().Dialog()
    .Name("SalesTypeWarning")
    .Title("Warning")
    .Content(warningTextContent)
    .Modal(true)
    .Closable(false)
    .Visible(false)
    .Width(600)
    .HtmlAttributes(new { @class = "mydialog-control"})
    .Actions(act =>
    {
      act.Add().Text("Continue").Primary(true).Action("allowSalesTypeChange");
      act.Add().Text("Cancel Change").Action("cancelClicked");
    })
    .Deferred(true)
)
Pending Review
Last Updated: 27 Aug 2019 10:51 by ADMIN
When using data attributes on a viewmodel for a grid popup editor:
1. Provide input that causes a validation error message to appear
2. Correct the error with new input, do not blur the final field
3. Click save.
4. Instead of validating the data and submitting, only validation occurs
Declined
Last Updated: 06 Sep 2019 13:57 by ADMIN
Created by: Patrick
Comments: 3
Category: DropDownList
Type: Bug Report
0

Kendo Version - Kendo MVC 2019.2.619

 

My values appear in the previous option item.

Drop Down List name and values:

  • Name = "Select From" 
  • ID = ""
  • Name = "ABCHERG"
  • ID = "ABCHERG"

I have one item and a "Select from" option (see data above) in my list

I select "ABCHERG" from my drop down list and the value that's returned is blank.

If I select the "Select From" option the value returned is "ABCHERG"

1 2 3