Declined
Last Updated: 22 Mar 2019 10:56 by ADMIN
The content of RadEditor does not get styled in div mode in IE11. The styling tag is added before the selected content, instead of around it (e.g. strong tag).

https://www.screencast.com/t/HoqeLyeZX

Steps to reproduce:
1. Open in IE11:  https://demos.telerik.com/aspnet-ajax/editor/examples/contentareamodediv/defaultcs.aspx
2. Clear whole content and write some new symbols
3. Try to style the new content (e.g. make it bold)
Declined
Last Updated: 21 Mar 2019 11:53 by ADMIN
Created by: Ravi
Comments: 1
Category: Editor
Type: Bug Report
0
Hi Telerik Team,

There is one recent problem we faced when copy paste from word document to Rad Editor. The spacing between the paragraphs is more than what exists in the word document.

The property we are using while copy paste from document to RadEditor

    radTextEditor.StripFormattingOptions = Telerik.Web.UI.EditorStripFormattingOptions.MSWordNoMargins | Telerik.Web.UI.EditorStripFormattingOptions.ConvertWordLists;

The functionality working fine in IE 11.

We are using version telerik version ASP.NET AJAX Q2 2016.

Also there is a default font of Times New Roman in Edge browser which not in IE 11

Attached is the screenshot of html. 

Please look into this.
Declined
Last Updated: 21 Mar 2019 10:25 by ADMIN
Created by: Ravi
Comments: 1
Category: Editor
Type: Bug Report
0
Hi Telerik Team,

There is one recent problem we faced when using RadEditor. The bottom line is distorted.

We are using version telerik version ASP.NET AJAX Q2 2016.

Attached is the screenshot of html. 

Declined
Last Updated: 21 Mar 2019 05:51 by ADMIN
Hi,

MissingValue set to Gap or Zero doesn't work in RadHtmlChart with ScatterLineSeries.

Interpolation is done instead.

              <telerik:RadHtmlChart runat="server">
                    <PlotArea>
                        <Series>
                            <telerik:ScatterLineSeries Name="Test" DataFieldX="XValue"
                                DataFieldY="YValue" MissingValues="Gap">
                                <SeriesItems>
                                    <telerik:ScatterSeriesItem X="1" Y="8" />
                                    <telerik:ScatterSeriesItem X="2" Y="9" />
                                    <telerik:ScatterSeriesItem X="3" Y="4" />
                                    <telerik:ScatterSeriesItem X="4" Y="6" />
                                    <telerik:ScatterSeriesItem X="5" Y="7" />
                                    <telerik:ScatterSeriesItem X="8" Y="1" />
                                    <telerik:ScatterSeriesItem X="9" Y="5" />
                                    <telerik:ScatterSeriesItem X="10" Y="4" />
                                </SeriesItems>
                            </telerik:ScatterLineSeries>
                        </Series>
                    </PlotArea>
                </telerik:RadHtmlChart>


The workaround described in the following link doesn't work either :
https://feedback.telerik.com/Project/108/Feedback/Details/44399-fix-the-functionality-of-the-missingvalue-property-when-set-to-gap-in-areaserie

Can you please fix this bug ?

Thanks and regards.
Declined
Last Updated: 17 Dec 2018 13:20 by ADMIN
RadGrid filter command is not triggered for strings containing "and" word.

Video: https://www.screencast.com/t/j649UvPQ3z6

Steps to reproduce:
Filter by "SUNBAY AND LEONA A" in the following demo:
https://demos.telerik.com/aspnet-ajax/grid/examples/functionality/filtering/excel-like-filtering/defaultcs.aspx
Declined
Last Updated: 17 Apr 2018 19:23 by ADMIN
Created by: Shivi
Comments: 2
Category: Grid
Type: Bug Report
1
Hello Sir

As I was workimg on Print functionality of RadGrid data.

While working on this functionality I found issue of "Print Preview" in chrome. Its working fine in IE and Firefox but in Chrome blank screen is coming with Print Preview Failed.

While searching on it I found "RadGrid Not Printing in Chrome" Post on telerik developer forum, I have created Telerik account and also reply to this post. 

Sir can you please help me regarding this issue. I look forward to hearing from you.

Regards
Declined
Last Updated: 06 Apr 2018 12:55 by ADMIN
The agregate sum value shown in the bottom of the TreeList columns displays bigger sum than the actual one (it seems that the child items values are also taken into consideration).

Steps to reproduce:
1. Open http://demos.telerik.com/aspnet-ajax/treelist/examples/columns/aggregates/defaultcs.aspx?show-source=true

2. Check the sum shown in the Population column

Actual: It shows 10,702,470,081.00

Expected: It should be 6,464,732,588.00
Declined
Last Updated: 02 Jun 2017 10:23 by ADMIN
Checkbox buttons are missing when ToggleType='CustomToggle' in Lightweight rendering. The issue is introduced in 2017 R1 release.

Code to reproduce:
        <telerik:RadButton runat="server" ID="btnEnableTrace" RenderMode="Lightweight"
            ButtonType="ToggleButton" ToggleType="CustomToggle">
            <ToggleStates>
                <telerik:RadButtonToggleState PrimaryIconCssClass="rbToggleCheckbox"></telerik:RadButtonToggleState>
                <telerik:RadButtonToggleState PrimaryIconCssClass="rbToggleCheckboxChecked"></telerik:RadButtonToggleState>
            </ToggleStates>
        </telerik:RadButton>
Declined
Last Updated: 19 Jan 2017 09:36 by ADMIN
ADMIN
Created by: Telerik Admin
Comments: 2
Category: Gauge
Type: Bug Report
5

			
Declined
Last Updated: 14 Oct 2016 10:48 by ADMIN
Created by: pranav
Comments: 2
Category: Editor
Type: Bug Report
0
Hi Telerik Team,

There is one recent problem we faced when copy paste of email address doesn't get open in outlook as HREF property is not set in Edge Browser. The functionality working fine in IE 11.

We are using version telerik version ASP.NET AJAX Q2 2016.

Attached is the screenshot of html. 
Declined
Last Updated: 20 Sep 2016 06:46 by ADMIN
Declined
Last Updated: 20 Sep 2016 06:42 by ADMIN
Declined
Last Updated: 20 Sep 2016 05:32 by ADMIN
Hi,

I am getting the below issue on button click.Its working fine in all browsers ,but not in Edge.Please help.

Microsoft Edge SCRIPT65535: Argument not optional

It is saying grid is not available.
Declined
Last Updated: 02 Sep 2016 11:57 by ADMIN
RadScheduler Server-side PDF Export does not support Lightweight render mode, as specified in the respective help article:
http://docs.telerik.com/devtools/aspnet-ajax/controls/scheduler/export/pdf/overview.html
Declined
Last Updated: 18 Aug 2016 18:16 by wildyaker
Created by: Matthew
Comments: 4
Category: Grid
Type: Bug Report
1
Reference: http://www.telerik.com/forums/radgrid-column-header-and-data-item-alignment-problem

This has apparently been an issue with RadGrid for a long time, according to the above thread. I have done a significant amount of testing to isolate this bug and have attached a self-contained solution in VB.NET 4.0 (VS 2010).

I removed all the surplus RadGrid properties I could in order to simplify the debugging process on your end and included my notes in the code and on the test page. There is indeed some peculiar behavior with the control.

Regards,
Matthew
Declined
Last Updated: 05 Aug 2016 12:18 by ADMIN
export of the chart to image (or pdf) will show an html code of non-breaking space in chart title and chart legend, but not in a label added to HtmlChartHolder
Declined
Last Updated: 03 Aug 2016 13:33 by ADMIN
Created by: Legis
Comments: 1
Category: BinaryImage
Type: Bug Report
1
System.Threading.ThreadAbortException    2    Thread was being aborted.    System.Threading.Thread.AbortInternal() 
   System.Threading.Thread.Abort(System.Object) 
   System.Web.HttpResponse.AbortCurrentThread() 
   Telerik.Web.UI.RadBinaryImageHandler.ProcessRequestInternal() 
   Telerik.Web.UI.HandlerRouter.ProcessHandler(System.String, System.Web.HttpContext) 
   Telerik.Web.UI.WebResource.ProcessRequest(System.Web.HttpContext) 
   System.Web.HttpApplication+CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() 
   System.Web.HttpApplication.ExecuteStep(IExecutionStep, Boolean ByRef) 
    
System.Exception    1    <none>    System.Threading.Thread.AbortInternal() 
   System.Threading.Thread.Abort(System.Object) 
   System.Web.HttpResponse.AbortCurrentThread() 
   Telerik.Web.UI.RadBinaryImageHandler.ProcessRequestInternal() 
   Telerik.Web.UI.HandlerRouter.ProcessHandler(System.String, System.Web.HttpContext) 
   Telerik.Web.UI.WebResource.ProcessRequest(System.Web.HttpContext) 
   System.Web.HttpApplication+CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() 
   System.Web.HttpApplication.ExecuteStep(IExecutionStep, Boolean ByRef) 
    
System.OutOfMemoryException    1    <none>    System.Threading.Thread.AbortInternal() 
   System.Threading.Thread.Abort(System.Object) 
   System.Web.HttpResponse.AbortCurrentThread() 
   Telerik.Web.UI.RadBinaryImageHandler.ProcessRequestInternal() 
   Telerik.Web.UI.HandlerRouter.ProcessHandler(System.String, System.Web.HttpContext) 
   Telerik.Web.UI.WebResource.ProcessRequest(System.Web.HttpContext) 
   System.Web.HttpApplication+CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() 
   System.Web.HttpApplication.ExecuteStep(IExecutionStep, Boolean ByRef) 
    
System.StackOverflowException    1    <none>    System.Threading.Thread.AbortInternal() 
   System.Threading.Thread.Abort(System.Object) 
   System.Web.HttpResponse.AbortCurrentThread() 
   Telerik.Web.UI.RadBinaryImageHandler.ProcessRequestInternal() 
   Telerik.Web.UI.HandlerRouter.ProcessHandler(System.String, System.Web.HttpContext) 
   Telerik.Web.UI.WebResource.ProcessRequest(System.Web.HttpContext) 
   System.Web.HttpApplication+CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() 
   System.Web.HttpApplication.ExecuteStep(IExecutionStep, Boolean ByRef) 
    
System.ExecutionEngineException    1    <none>    System.Threading.Thread.AbortInternal() 
   System.Threading.Thread.Abort(System.Object) 
   System.Web.HttpResponse.AbortCurrentThread() 
   Telerik.Web.UI.RadBinaryImageHandler.ProcessRequestInternal() 
   Telerik.Web.UI.HandlerRouter.ProcessHandler(System.String, System.Web.HttpContext) 
   Telerik.Web.UI.WebResource.ProcessRequest(System.Web.HttpContext) 
   System.Web.HttpApplication+CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() 
   System.Web.HttpApplication.ExecuteStep(IExecutionStep, Boolean ByRef) 
    
System.Threading.ThreadAbortException    2    <none>    System.Threading.Thread.AbortInternal() 
   System.Threading.Thread.Abort(System.Object) 
   System.Web.HttpResponse.AbortCurrentThread() 
   Telerik.Web.UI.RadBinaryImageHandler.ProcessRequestInternal() 
   Telerik.Web.UI.HandlerRouter.ProcessHandler(System.String, System.Web.HttpContext) 
   Telerik.Web.UI.WebResource.ProcessRequest(System.Web.HttpContext) 
   System.Web.HttpApplication+CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() 
   System.Web.HttpApplication.ExecuteStep(IExecutionStep, Boolean ByRef)  

Declined
Last Updated: 23 Jun 2016 21:49 by John
Declined
Last Updated: 14 Jun 2016 07:46 by ADMIN
Having a font/span tag with applied inline font-size style cannot be formatted by FontSize tool.  

This is a possible workaround that removes font-size inline style when size attribute is to be added:

<telerik:RadEditor runat="server" ID="RadEditor1" OnClientCommandExecuting="OnClientCommandExecuting">
    <Tools>
        <telerik:EditorToolGroup>
            <telerik:EditorTool Name="FontSize" />
        </telerik:EditorToolGroup>
    </Tools>
    <Content>
       <p><span style="font-size:15px;">text</span></p>
    </Content>
</telerik:RadEditor>

<script>
    function OnClientCommandExecuting(editor, args) {
        var command = args.get_commandName();
        if (command === "FontSize") {
            $telerik.$(editor.getSelectedElement()).css("font-size", "");
        }
    }
</script>
Declined
Last Updated: 09 Jun 2016 14:46 by ADMIN
The default action for the Bold and Italic buttons ([B] and [I]) on the toolbar, is to insert the <strong> and <em> tags. However, this is not the same, and may insert the wrong semantic information.

Bold and Italic are used in far more contexts than just emphasis. For example, many people use these functions to create headlines. (While not semantic, this is not incorrect because they choose to apply a styling.) Italic is also commonly used in quotes and references. None of these applications are correct with <strong> and <em> tags.

Also, remember that <strong> and <em> only render as bold and italic in the default settings for the most common browsers. There are many browsers that don't/can't render these as bold and italic, and a website's stylesheet can also easily override the rendering of <strong> and <em>. This is not what the writer expects, as they have simply used the Bold and Italic buttons in the editor.

Instead, the Bold and Italic buttons should insert style code, such as <span style="font-weight: bold"> and <span style="text-decoration: italic">. The Underline button is already doing this.

If the preference is to use tags instead of inline style, then the <b> and <i> tags should be used instead. Please note that, even though these were deprecated in HTML4, they are now again valid for HTML5.

If the goal is to produce semantic HTML, then the Bold and Italic buttons should be replaced with Emphasis and Strong buttons.

I *know* the editor can be configured to do this. It is the default setting (which is used by 99% of your users) that is wrong.

A similar situation was previous the case for the Indent button, which inserted the <blockquote> tag. Thankfully, this has been changed to insert the style="margin-left: 40px;" code instead.

References:
- https://www.nosegraze.com/difference-between-b-strong-html/
- https://web.archive.org/web/20091124170143/http://lists.evolt.org/archive/Week-of-Mon-20010521/032901.html
- http://engineeredweb.com/blog/2013/html5-semantic-diff-bold-strong/
- http://stackoverflow.com/questions/4939807/strong-vs-font-weightbold-em-vs-font-styleitalic
- https://developer.mozilla.org/en/docs/Web/HTML/Element/strong#Bold_vs._Strong
- http://stackoverflow.com/questions/271743/whats-the-difference-between-b-and-strong-i-and-em
- http://www.html5-tutorials.org/html-basics/i-b-em-strong-tags/

(This is not a new situation, many of the references are over 5 years old.)