Completed
Last Updated: 19 Jun 2015 05:51 by ADMIN
For the time being you can place the following JavaScript workaround at the end of the form:
		<script>
			$T = Telerik.Web.UI;
			$T.RadButton.prototype.initialize = function () {
				var that = this;
				$T.RadButton.callBaseMethod(that, "initialize");

				//if the button is in RTL parent apply rbRtl CSS class to the holding element
				that._setRightToLeft();

				that._createToggleStates();

				that._requestIconsAndImages();

				if (that.get_checked()) {
					that.clearCheckedRadios(that.get_uniqueGroupName());
				}
				$T.registerRadButton(that);

				that._initModules();

				that._initHTML();
				that._attachClickEvent(true);
				if (that.get_enabled() && !that.get_readOnly()) {
					that._attachEvents(true);
				}
				that.updateClientState();
				that.raiseEvent('load', Sys.EventArgs.Empty);
			};
		</script>
Completed
Last Updated: 10 Jun 2015 14:07 by eBuild
ADMIN
Created by: Danail Vasilev
Comments: 3
Category: Button
Type: Bug Report
2
SharePoint 2013 applies global styles to the inputs that affect the appearance of the RadButtons.For the time being the styles that SharePoints sets to the inputs can be overriden:

ASPX:
<telerik:RadButton ID="RadButton1" runat="server" Text="RadButton"><Icon PrimaryIconCssClass="rbAdd" /></telerik:RadButton>

CSS:
<style type="text/css">
    .RadButton.RadButton_Default.rbSkinnedButton input {
        padding: 0px 10px 0px 25px;
        border: none;
        margin-left: 0px;
    }
</style>
Completed
Last Updated: 25 May 2015 14:07 by ADMIN
RadButton with ButtonType="ToggleButton", ToggleType="CheckBox" or ToggleType="Radio" in lightweight mode, renders the icons and the text labels at incorrect position.

For the time being, you can use the following CSS as a workaround:

.RadButton.rbCheckBox span.rbText,
.RadButton.rbRadioButton span.rbText,
.RadButton.rbToggleButton span.rbText {
    vertical-align: initial; /* FF and Chrome */
    vertical-align: auto; /* IE */
}

button.RadButton {
    vertical-align: initial;
    vertical-align: auto;
}
Completed
Last Updated: 13 May 2015 07:46 by Elena
RadButton peforms a duplicate request (the second request aborts the first one) when the following conditions are met:

-The page is opened from Visual Studio 2008

- A RadButton exists on the page and the form is submitted when a text box is focused and enter key is hit.

-Default button is not set to the form.

-RadButton's UseSubmitBehavior is set to true

-.NET Framework 3.5 is used.

-The browser is Internet Explorer.

The workaround is to either set Default button for the form or set the UseSubmitBehavior property of the RadButton to false.
Completed
Last Updated: 12 May 2015 11:03 by Elena
For the time being the following JavaScript workaround can be used:
JavaScript:
		function pageLoad() {
			fixImageURL();
		}
		function fixImageURL() {
			var imageBtns = $telerik.$('.rbImageButton');
			for (var i = 0; i < imageBtns.length; i++) {
				var btnStyle = imageBtns[i].getAttribute('style').replace("background-image:url(", "background-image:url('").replace(");", "');");
				imageBtns[i].setAttribute('style', btnStyle);
			}
		}
ASPX:
		<telerik:RadButton ID="RadButton1" runat="server" Width="50px" Height="50px">
			<Image ImageUrl="50x50.png" />
		</telerik:RadButton>
		<telerik:RadButton ID="RadButton2" runat="server" Width="50px" Height="50px">
			<Image ImageUrl="50x50.png" />
		</telerik:RadButton>
Completed
Last Updated: 11 May 2015 14:51 by Elena
ADMIN
Created by: Danail Vasilev
Comments: 1
Category: Button
Type: Bug Report
0
Currently disabled RadButton doesn't have a border for Silk skin. For the time being the border can be set manually:

        <telerik:RadButton ID="RadButton1" runat="server" Skin="Silk" Text="Submit" BorderColor="#C9C9C9" BorderWidth="1px" Enabled="false">
        </telerik:RadButton>


Approved
Last Updated: 11 May 2015 14:12 by ADMIN
Completed
Last Updated: 11 May 2015 09:53 by Elena
Currently when the RadButton is used as an Image button:

- There is a flickering on mouse over and mouse out.

- During the postback the image of the current or other image buttons disappears on mouse over/mouse out.

The unexpected behavior is observed under Chrome and page is hosted on Cassini. It is caused due to the image requests that Chrome does for each state of the RadButton - normal and hovered.
Completed
Last Updated: 04 May 2015 13:12 by ADMIN
When RadButton (ButtonType="StandardButton") is set with a particular width, the text of the button is decentralized. Fix the center of this text. For the time being can be used either the new SkinnedButton or the following workaround:

    <style type="text/css">
        .rbDecorated
        {
            padding-left: 6px !important;
            padding-right: 10px !important;
        }
    </style>
Approved
Last Updated: 29 Apr 2015 14:38 by Jon
ADMIN
Created by: Danail Vasilev
Comments: 1
Category: Button
Type: Bug Report
0
For the time being the following workaround can be used:

CSS:

    <style>
     .RadButton.RadButton_Metro.rbSkinnedButton:focus input.rbDecorated {
            background-color: #25A0DA !important;
        }
    </style>

        <telerik:RadSkinManager ID="RadSkinManager1" runat="server" Skin="Metro"></telerik:RadSkinManager>
        <telerik:RadTextBox ID="RadTextBox1" runat="server"></telerik:RadTextBox>
        <telerik:RadButton ID="RadButton1" runat="server" Text="click" />
Completed
Last Updated: 28 Apr 2015 06:37 by ADMIN
Completed
Last Updated: 17 Apr 2015 13:48 by ADMIN
 Currently the value of RadButton's property 'Width' is not applied correctly and its width is not as specified.
Completed
Last Updated: 17 Apr 2015 13:46 by ADMIN
Declined
Last Updated: 16 Mar 2015 16:17 by Sylvain
Created by: Sylvain
Comments: 0
Category: Button
Type: Bug Report
0

			
Completed
Last Updated: 23 Feb 2015 15:30 by sharath
Completed
Last Updated: 11 Dec 2014 15:18 by ADMIN
Currently RadButton configured as a toggle radio/checkbox button doesn't accept custom icons to be used because it already has predefined icons. For the time being the ButtonType property can be set to "StandardButton" and its background image can be hidden. For example:
CSS:
<style>
    .RadButton_Default.rbSkinnedButton,
    .RadButton_Default .rbDecorated,
    .RadButton_Default.rbVerticalButton,
    .RadButton_Default.rbVerticalButton .rbDecorated,
    .RadButton_Default .rbSplitRight,
    .RadButton_Default .rbSplitLeft {
        background-image: none !important;
    }
</style>
ASPX:
<telerik:RadButton ID="RadButton3" runat="server" GroupName="OverSampling"
    Text="" ButtonType="StandardButton" ToggleType="Radio" Checked="false" AutoPostBack="false">
    <ToggleStates>
        <telerik:RadButtonToggleState Text="Yes" PrimaryIconUrl="radio6-on.png" Selected="true" />
        <telerik:RadButtonToggleState Text="Yes" PrimaryIconUrl="radio6-off.png" />
    </ToggleStates>
</telerik:RadButton>
 
<telerik:RadButton ID="RadButton4" runat="server" GroupName="OverSampling"
    Text="No" ButtonType="StandardButton" ToggleType="Radio" AutoPostBack="false" Checked="true">
    <ToggleStates>
        <telerik:RadButtonToggleState PrimaryIconUrl="radio6-on.png" Selected="true" />
        <telerik:RadButtonToggleState PrimaryIconUrl="radio6-off.png" />
    </ToggleStates>
</telerik:RadButton>
Completed
Last Updated: 15 Aug 2014 06:25 by ADMIN
Currently when cookiless session is enabled and RadButton with custom image is used the Image is not displayed, until the button is hovered.

ASPX:

        <telerik:RadButton ID="ButtunTest" runat="server" Icon-PrimaryIconUrl="~/Examples7/eClose.png" Text="Testbutton"
            Width="200px" UseSubmitBehavior="False" />

Web.Config:

  <system.web>
        <sessionState cookieless="true"></sessionState>
  </system.web>

The workaround is to override the background image of the button:

    <style>
        .RadButton.RadButton_Default.rbSkinnedButton .rbPrimaryIcon {
            background-image: url("/RadControlsWebSite2/Examples7/eClose.png");
        }
    </style>




Approved
Last Updated: 23 Jul 2014 08:28 by ADMIN
For the time being the following workaround can be used:
		<script>
			function OnClientClicked() {
				alert('OnClientClicked');
			}

			function OnClientClicking() {
				alert('OnClientClicking');
			}

			function fixBtnClicked(sender, args) {
				sender._useModules = false;
			}

		</script>
		<telerik:RadButton ID="RadButton1" runat="server" ButtonType="LinkButton" Text="Click" OnClientLoad="fixBtnClicked" Target="_parent" NavigateUrl="http://www.google.com" OnClientClicked="OnClientClicked" OnClientClicking="OnClientClicking" />
Completed
Last Updated: 21 Jul 2014 07:16 by ADMIN
 For the time being the following workaround can be used:

ASPX:

       <telerik:RadButton ID="RadButton1" runat="server" Text="Click" NavigateUrl="http://www.google.bg" Target="_blank" ButtonType="LinkButton">
        </telerik:RadButton>
        <script>
            Telerik.Web.UI.Button.NavigationFunctionality.prototype._handleNavigateUrl = function () {
                $ = $telerik.$;
                var that = this,
                    target = that.options.navigateTarget,
                    url = that.options.navigateUrl;

                if (target && target == "_blank")
                    window.open(url);
                if (target && target == "_parent")
                    window.parent.location.href = url;
                if (target && target == "_top")
                    window.parent.location.href = url;
                else if (!target || target == "_self")
                    window.location.href = url;
                else {
                    var targetFrame = $("iframe[name='" + target + "']").get(0)
                                        || $("frame[name='" + target + "']").get(0)
                                        || $("#" + target).get(0);

                    if (targetFrame && targetFrame.tagName.toLowerCase().indexOf("frame") > -1)
                        targetFrame.setAttribute("src", url);
                }
            }
        </script>
Approved
Last Updated: 03 Jul 2014 14:40 by Rick Atkinson
If the Target property of the RadButton (ButtonType="LinkButton") is set to a custom string (the name of the target window, where the content of the linked page will be rendered), the link is not opened. For the time being the following workaround can be used:

JavaScript:

    <script>
        function OnClientClicked(sender, args) {
            var target = sender.get_target();
            var navURL = sender.get_navigateUrl();
            window.open(navURL, target)
        }
    </script>

ASPX:

<telerik:RadButton ID="RadButton1" runat="server" ButtonType="LinkButton" Text="click" Target="MyWindow" NavigateUrl="http://www.google.com" OnClientClicked="OnClientClicked" />