Declined
Last Updated: 21 Mar 2019 10:25 by ADMIN
Created by: Ravi
Comments: 1
Category: Editor
Type: Bug Report
0
Hi Telerik Team,

There is one recent problem we faced when using RadEditor. The bottom line is distorted.

We are using version telerik version ASP.NET AJAX Q2 2016.

Attached is the screenshot of html. 

Approved
Last Updated: 20 Mar 2019 16:38 by ADMIN
I have an issue when I line break in RADEditor but it keeps going to the bottom of the line in Internet Explorer v11.

Please note that the issue is reproducible on Telerik Demo site.

Steps to reproduce the issue:

Copy and paste the following content in HTML mode 

Some content
<br />
<br />
Put the cursor in the beginning of this line, press Backspace and after that Enter
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
Switch to Design panel
Press Backspace twice in front of the text "Put the cursor in the beginning of this line, press Backspace and after that Enter"
Press Enter
Result

The content jump to the bottom of the line


See the attached video for more information.
Won't Fix
Last Updated: 20 Mar 2019 15:54 by ADMIN

When editing certain HTML layouts in a RadEditor on a Mac, when you right-click on the empty space to the right of the text content in a table cell inside a nested table, then click Row -> Insert Row Above, the editor inserts a row above the current row in one of the parent tables, instead of in the table containing the specific cell that was clicked on.

To reproduce, paste the following code into the HTML view of a RadEditor. Then switch to Design mode, and right click in the empty space to the right of the text "Type your message here!", but within the same table cell as that text. Select Row -> Insert Row Above, and see that the editor inserts a row into the wrong table.

This is only reproducible on a Mac, but it has been confirmed to happen in both Safari and Chrome.

The project this is for is currently using version 2016.3.1027, however I've pasted this code into the Telerik RadEditor demo at https://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx , which I presume is running the latest version, and the problem is reproducible there also.

 

<!DOCTYPE html>
<html>
    <head>
        <meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
        <meta content="width=device-width" name="viewport" />
        <title>Newsletter from your Pro</title>
        <style type="text/css">
            <!--
	
	-->
        </style>
    </head>
    <body>
        <table style="background-color: #C9CAC8 ;" cellspacing="0" cellpadding="0" border="0" width="100%">
            <tbody>
                <tr>
                    <td>
                    <table style="border-collapse: collapse; mso-table-lspace: 0pt; mso-table-rspace: 0pt; font-family: Gotham, 'Helvetica Neue', Helvetica, Arial, sans-serif;" class="body" cellspacing="0" cellpadding="0" align="center" border="0" width="640">
                        <tbody>
                            <tr>
                                <td style="background-color: #ffffff; height: 60px;" class="side-pad" colspan="6" align="center"><span style="text-align: center;" class="devicewidthinner"></span></td>
                                <td style="background-color: #ffffff; height: 60px;" class="side-pad" align="center"><span style="font-size: 14px; font-family: Helvetica, Arial, sans-serif; color: #63666a;">February 5, 2019</span></td>
                            </tr>
                            <tr>
                                <td style="background-color: #ffffff; height: 87px;" class="side-pad" colspan="6" align="center"><span class="devicewidth"></span></td>
                                <td style="background-color: #ffffff;" class="side-pad" align="center"></td>
                            </tr>
                            <tr>
                                <td style="background-color: #d55c19; width: 201px; height: 30px;" class="side-pad" align="center"><span style="text-align: center; font-weight: normal; line-height: 24px; font-family: Helvetica, Arial, sans-serif; font-size: 13px; color: #ffffff;"><a style="color: #fff; text-decoration: none;" href="http://www.test.com">Visit website</a></span></td>
                                <td style="background-color: #ffffff; width: 4px;" class="side-pad" align="center">&nbsp;</td>
                                <td style="background-color: #d55c19; width: 86px;" class="side-pad" align="center"><span style="font-family: Helvetica, Arial, sans-serif; font-size: 13px; color: #ffffff;"><a style="color: #fff; text-decoration: none;" href="mailto:test@test.com">Email me!</a></span></td>
                                <td style="background-color: #ffffff; width: 4px;" class="side-pad" align="center">&nbsp;</td>
                                <td style="background-color: #d55c19; width: 122px;" class="side-pad" align="center"><span style="text-align: center; line-height: 15px; font-family: Helvetica, Arial, sans-serif; font-size: 13px; color: #ffffff;">123-456-7890</span></td>
                                <td style="background-color: #ffffff; width: 4px;" class="side-pad" align="center">&nbsp;</td>
                                <td style="background-color: #63666a; width: 201px; height: 30px;" class="side-pad" align="center"><span style="text-align: center; font-weight: normal; font-size: 12pt; line-height: 24px; font-family: Helvetica, Arial, sans-serif; color: #ffffff;">Test Testerson</span></td>
                            </tr>
                            <tr>
                                <td style="background-color: #ffffff;" class="side-pad" colspan="7" align="center">
                                <table class="container" cellspacing="0" cellpadding="0" align="center" border="0" width="600">
                                    <tbody>
                                        <tr>
                                            <td style="height: 250px;" align="center">
                                            <table class="row" cellspacing="0" cellpadding="0" align="center" border="0" width="580">
                                                <tbody>
                                                    <tr>
                                                        <td style="height: 250px;">
                                                        <table cellspacing="0" cellpadding="0" border="0" width="100%">
                                                            <tbody>
                                                                <tr>
                                                                    <td style="width: 100%; height: 205px;" valign="top">
                                                                    <table style="mso-table-lspace:0;mso-table-rspace:0;" cellspacing="0" cellpadding="0" align="left" border="0" width="100%">
                                                                        <tbody>
                                                                            <tr>
                                                                                <td style="font-size: 14px; color: #63666a; font-weight: normal; line-height: 20px; width: 205px;" colspan="4" valign="top">&nbsp;</td>
                                                                            </tr>
                                                                            <tr>
                                                                                <td style="font-size:14px; color:#63666a; font-weight:normal; text-align:left; line-height:20px;" colspan="4" valign="top"><span style="font-size: 14px; font-family: Helvetica, Arial, sans-serif; color: #63666a;">Type your message here!</span></td>
                                                                            </tr>
                                                                            <tr>
                                                                                <td style="font-size:14px; color:#63666a; font-weight:normal; text-align:left; line-height:20px;" colspan="4" valign="top">&nbsp;</td>
                                                                            </tr>
                                                                            <tr>
                                                                                <td style="font-size:14px; color:#63666a; font-weight:normal; text-align:left; line-height:20px;" colspan="4" valign="top">&nbsp;</td>
                                                                            </tr>
                                                                            <tr>
                                                                                <td style="font-family: Helvetica, Arial, sans-serif; font-weight: normal; font-size:14px; color: #63666a; line-height:18px; text-align:left;" colspan="4">
                                                                                <p>&nbsp;</p>
                                                                                </td>
                                                                            </tr>
                                                                            <tr>
                                                                                <td colspan="4" valign="top">&nbsp;</td>
                                                                            </tr>
                                                                            <tr>
                                                                                <td colspan="4" valign="top">&nbsp;</td>
                                                                            </tr>
                                                                        </tbody>
                                                                    </table>
                                                                    </td>
                                                                </tr>
                                                            </tbody>
                                                        </table>
                                                        </td>
                                                    </tr>
                                                </tbody>
                                            </table>
                                            </td>
                                        </tr>
                                    </tbody>
                                </table>
                                </td>
                            </tr>
                            <tr>
                                <td style="background-color: #63666a;" class="side-pad" colspan="7" align="center">
                                <table class="container" cellspacing="0" cellpadding="0" align="center" border="0" width="600">
                                    <tbody>
                                        <tr>
                                            <td align="center">
                                            <table class="row" cellspacing="0" cellpadding="0" align="center" border="0" width="580">
                                                <tbody>
                                                    <tr>
                                                        <td>
                                                        <table cellspacing="0" cellpadding="0" border="0" width="100%">
                                                            <tbody>
                                                                <tr bgcolor="#63666A">
                                                                    <td style="height: 18px;" valign="top" align="center">&nbsp;</td>
                                                                </tr>
                                                                <tr>
                                                                    <td valign="top">
                                                                    <table style="mso-table-lspace:0;mso-table-rspace:0;" class="full-width collapse" cellspacing="0" cellpadding="0" align="left" border="0" width="100%">
                                                                        <tbody>
                                                                            <tr>
                                                                                <td style="font-size:12px; color:#63666a; font-weight:normal; text-align:left;" class="center">
                                                                                <p><span style="font-size: 12px; line-height: 14px; text-align: left; font-family: Helvetica, Arial, sans-serif; color: #ffffff;" class="footer">Here is some footer text.</span></p>
                                                                                </td>
                                                                            </tr>
                                                                        </tbody>
                                                                        <tbody>
                                                                            <tr>
                                                                                <td class="center" valign="top" align="center">&nbsp;</td>
                                                                            </tr>
                                                                            <tr>
                                                                                <td class="center" valign="top" align="center">
                                                                                <table cellspacing="0" cellpadding="0" align="center" border="0">
                                                                                    <tbody>
                                                                                        <tr>
                                                                                            <td align="center"></td>
                                                                                            <td style="width: 12px;" align="center">&nbsp;</td>
                                                                                            <td align="center"></td>
                                                                                            <td style="width: 12px;" align="center">&nbsp;</td>
                                                                                            <td align="center"></td>
                                                                                            <td style="width: 12px;" align="center">&nbsp;</td>
                                                                                            <td align="center"></td>
                                                                                        </tr>
                                                                                    </tbody>
                                                                                </table>
                                                                                </td>
                                                                            </tr>
                                                                        </tbody>
                                                                    </table>
                                                                    </td>
                                                                </tr>
                                                            </tbody>
                                                        </table>
                                                        </td>
                                                    </tr>
                                                </tbody>
                                            </table>
                                            </td>
                                        </tr>
                                    </tbody>
                                </table>
                                </td>
                            </tr>
                            <tr style="background-color: #636666a;">
                                <td style="background-color: #63666a;" class="side-pad" colspan="7" align="center">
                                <table class="container" cellspacing="0" cellpadding="0" align="center" border="0" width="600">
                                    <tbody>
                                        <tr>
                                            <td align="center">
                                            <table class="row" cellspacing="0" cellpadding="0" align="center" border="0" width="580">
                                                <tbody>
                                                    <tr>
                                                        <td style="height: 20px;">&nbsp;</td>
                                                    </tr>
                                                </tbody>
                                            </table>
                                            </td>
                                        </tr>
                                    </tbody>
                                </table>
                                </td>
                            </tr>
                        </tbody>
                    </table>
                    <p>&nbsp;</p>
                    </td>
                </tr>
            </tbody>
        </table>
    </body>
</html>

Completed
Last Updated: 19 Mar 2019 14:19 by ADMIN

Setup:  

  1. Create a page with a basic Rad Editor, with HTML mode enabled
  2. Go into HTML Mode, add at least the following:
    <input type="number" />
  3. Go back to Design Mode
  4. Click on the numeric input

To See the Problem:

  1. In the console of the Browser's Developer Tools, get a reference to the Rad Editor
  2. Call its getSelectedElement() function
  3. In Chrome, the returned element will be a <body> tag (NOT GOOD)
  4. In Firefox, it will be an apparently random (maybe the first?) user-selectable element within the HTML (NOT GOOD)
  5. In IE11, it will be the numeric input (DESIRED)
  6. In Edge, it will be a <body> tag (NOT GOOD)
Completed
Last Updated: 18 Mar 2019 12:47 by ADMIN
We've a RadEditor controls, we want disable editting in mobile render mode. How can we do it?

Here examle:

Case 1. RadEditor is LightWeight:

<telerik:RadEditor ID="redEdt" runat="server"    RenderMode="LightWeight"     Width="100%" Height="500px" ></telerik:RadEditor>

<script>
                $(document).ready(function () {
                    var editor = $telerik.findControl(document.documentElement, "redEdt");
                    editor.enableEditing(false);
                })

</script>   

--> It work great. All buttons in toolbar disabled.

Case 2. RadEditor is Mobile:

<telerik:RadEditor ID="redEdt" runat="server"    RenderMode="Mobile"     Width="100%" Height="500px" ></telerik:RadEditor>

<script>
                $(document).ready(function () {
                    var editor = $telerik.findControl(document.documentElement, "redEdt");
                    editor.enableEditing(false);
                })

</script> 

--> System error: 

M.enableContextMenus is not a function
    at c.RadEditor.enableEditing
Completed
Last Updated: 08 Mar 2019 10:04 by ADMIN

I am using Telerik.WEB.UI version: 2018.1.117.45 in my website. I am getting as issue in RADEditor control when I create a hyperlink within Editor. Right clicking on that hyperlink opens a context menu, when I click on properties from the context menu, it opens an 'Image Manager' instead of 'Hyperlink Manager'.

The issue is occurring only in IE 11, rest all the browsers are opening 'Hyperlink Manager'. Please advise.

Thank you

Completed
Last Updated: 08 Mar 2019 09:45 by ADMIN

There's a bug in the RadEditor WordListConverter convert method.  See the attached image for details.  Note that the variable z is initialized and treated as an array (a stack, actually, with its items being pushed in and popped out).  However, perhaps because of a naming scope failure in the js-minifier, the z variable is, under certain conditions, set equal to an HTMLCollection, so a subsequent z.push method call fails.

This sample Word document reproduces the error.  It is admittedly full of bad list formatting, because it began life as a PDF, but it does exercise the RadEditor code in a way that causes the problem.  Select and copy its content and paste it in the RadEditor demo page here:

https://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx

Click OK to "clean" the pasted content and note that nothing appears because of the error shown in the attached image.

Verified in the latest Chrome and FF builds on Windows 10.

Approved
Last Updated: 06 Mar 2019 15:22 by ADMIN

This behavior is occuring only if use firefox browser:

1. If you set the EditModes within backend only to EditMode.Preview then all html table elements within content appears like in EditMode.Design with dashed borders.

You can reproduce it on your own demo site https://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx simple disable EditMode.Html and EditMode.Design.

Now you see the dashed table element borders like in design mode....

2. Sometimes if you switch edit mode from Html to Preview the same affect is occuring with displaying dashed border with html table elements. If you switch directly from Design mode to preview mode all works fine.

3. If you resize the editor in preview mode with resize button on right lower corner the display switch immediatly to dashed borders for all html table elements...

At the moment we use a fix to reset preview mode: If only preview mode is activated for the editor we set the preview mode again with a timeout of 250 ms after loading of dialog is ready (if the timeout is to low no affect appear).
Sys.Application.add_load(function(){ window.setTimeout(function(){$find('AjaxEditorClientID').set_mode(4)},250); }); });

Regards
Thomas

Approved
Last Updated: 27 Feb 2019 14:05 by ADMIN

Reproduction steps: 

<telerik:RadEditor runat="server" ID="RadEditor1">
     <Content>
        <span style="color: #548dd4;">asdas</span>this is sample text
     </Content>
</telerik:RadEditor>

When the mode is changed to HTML, the content is as follows: 

Expected: 

<span style="color: #548dd4;">asdas</span>this is sample text

Actual: 

<span style="color: rgb(84, 141, 212);">asdas</span>this is sample text

 

Completed
Last Updated: 11 Feb 2019 10:07 by ADMIN

I've been trying to upgrade an existing solution to use the latest release version (2019) of the Telerik UI for ASP.NET AJAX and have encountered a major problem with the 'Tool Provider', a technique which is significantly used in my solution.  This same error displays in your own Telerik Demo.  Details are:

 

Description of the issue

Having multiple RadEditors on the same page, and trying the property "ToolProviderID" (to reuse the same floating tool amongst the different editors on the same page), causes a "javascript exception" on the client side.


   
URL of the Demo (Telerik Website)

https://demos.telerik.com/aspnet-ajax/editor/examples/toolprovider/defaultcs.aspx



Exception description

Uncaught TypeError: R.get_canAcceptTrackChange is not a function at c.RadEditor._initializeToolProvider (RadEditor.js:8239) at c.RadEditor.initialize (RadEditor.js:8297) at c.RadEditor.endUpdate (Telerik.Web.UI.WebRe597d4b%3ab25378d2:6) at Sys._Application.endCreateComponents (Telerik.Web.UI.WebRe597d4b%3ab25378d2:6) at Sys.WebForms.PageRequestManager._scriptsLoadComplete (Telerik.Web.UI.WebRe97d4b%3ab25378d2:15) at Sys.WebForms.PageRequestManager.<anonymous> (Telerik.Web.UI.WebRe597d4b%3ab25378d2:6) at Telerik.Web.UI.WebRe597d4b%3ab25378d2:6 at Sys._ScriptLoader._loadScriptsInternal (Telerik.Web.UI.WebRe97d4b%3ab25378d2:15) at Sys._ScriptLoader._loadScriptsInternal (Telerik.Web.UI.WebRe97d4b%3ab25378d2:15) at Sys._ScriptLoader._loadScriptsInternal (Telerik.Web.UI.WebRe97d4b%3ab25378d2:15)
    



How to reproduce the error (on Telerik demo website)

    - Mark the checkbox at the bottom of the page and click on "Update":

(the error can be seem on console, pressing F12)




Error message happening in our system

RadEditor.js:8239 Uncaught TypeError: R.get_canAcceptTrackChange is not a function at c.RadEditor._initializeToolProvider (RadEditor.js:8239) at c.RadEditor.initialize (RadEditor.js:8297) at c.RadEditor.endUpdate (Telerik.Web.UI.WebRe597d4b%3ab25378d2:6) at Sys._Application.endCreateComponents (Telerik.Web.UI.WebRe597d4b%3ab25378d2:6) at Sys._Application._raiseInit (Telerik.Web.UI.WebRe597d4b%3ab25378d2:6) at Sys._Application.initialize (Telerik.Web.UI.WebRe597d4b%3ab25378d2:6) at b (Telerik.Web.UI.WebRe597d4b%3ab25378d2:6) at HTMLDocument.a (Telerik.Web.UI.WebRe597d4b%3ab25378d2:6)
   



Sample code, causing the issue (our system)

Refer the attached image.

Completed
Last Updated: 29 Jan 2019 11:22 by ADMIN
Inconsistent Behavior of RadEditor with Ribbon Bar Toolbar for a different type of dropdown toolbar controls.

In RadEditor with Ribbon Bar Toolbar, there are two different types of drop-down control observed.

Type1 includes "Paste" and "Strip All Formatting" 
Type2 includes "Font Name", "Real font size", "Foreground Color", "Background Color", "Apply CSS Class", "Paragraph Style" and "Undo"


Issue1:
In RadEditor with Ribbon Bar Toolbar When "Type 1" Dropdown is opened or expanded and we click on any "Type 2" Dropdown then "Type 1" dropdown is still remain open or expand.

Issue2:
vice versa In RadEditor with Ribbon Bar Toolbar When "Type 2" Dropdown is opened or expanded and we click on any "Type 1" Dropdown then "Type 1" dropdown is still remain open or expand.
Completed
Last Updated: 28 Dec 2018 10:31 by ADMIN
When EnableComments is set to true, the content from the clipboard is pasted twice in an empty editor.

RadEditor Configuration:

<telerik:RadEditor runat="server"
    EnableComments="true">
    <Tools>
        <telerik:EditorToolGroup>
            <telerik:EditorTool Name="Bold" />
            <telerik:EditorTool Name="Italic" />
            <telerik:EditorTool Name="Underline" />
            <telerik:EditorSeparator />
            <telerik:EditorTool Name="Undo" />
            <telerik:EditorTool Name="Redo" />
            <telerik:EditorTool Name="Cut" />
            <telerik:EditorTool Name="Copy" />
            <telerik:EditorTool Name="Paste" />
            <telerik:EditorTool Name="PastePlainText" Text="Paste Plain Text" />
            <telerik:EditorTool Name="FindAndReplace" Text="Find and Replace" />
            <telerik:EditorSeparator />
            <telerik:EditorTool Name="Indent" />
            <telerik:EditorTool Name="Outdent" />
            <telerik:EditorTool Name="InsertOrderedList" Text="Numbered List" />
            <telerik:EditorTool Name="InsertUnorderedList" Text="Bulleted List" />
            <telerik:EditorTool Name="LinkManager" />
            <telerik:EditorTool Name="Unlink" />
            <telerik:EditorSeparator />
            <telerik:EditorTool Name="AjaxSpellCheck" Text="Spell Check" />
            <telerik:EditorTool Name="InsertSymbol" Text="Insert Symbol" />
        </telerik:EditorToolGroup>
        <telerik:EditorToolGroup>
            <telerik:EditorTool Name="AcceptTrackChange" Text="Accept Change" />
            <telerik:EditorTool Name="RejectTrackChange" Text="Reject Change" />
            <telerik:EditorTool Name="AcceptAllTrackChanges" Text="Accept All Changes" />
            <telerik:EditorTool Name="RejectAllTrackChanges" Text="Reject All Changes" />
            <telerik:EditorTool Name="EnableTrackChangesOverride" Text="Track Changes" />
            <telerik:EditorTool Name="AddComment" Text="Add Comment" />
            <telerik:EditorTool Name="RemoveComment" Text="Remove Comment" />
            <telerik:EditorTool Name="RemoveAllComments" Text="Remove All Comments" />
            <telerik:EditorTool Name="ImageManager" Text="Insert Image" />
        </telerik:EditorToolGroup>
    </Tools>
</telerik:RadEditor>
Potential workaround:
<script type="text/javascript">
    function OnClientPasteHtml(sender, args) {
        var commandName = args.get_commandName();
        var value = args.get_value();
 
        if (commandName == "Paste" && Telerik.Web.Browser.ie) {
            args.set_value(value);
            args.set_cancel(true);
        }
    }
</script>
<telerik:RadEditor runat="server" Height="300px" StripFormattingOptions="Span,Font,Css" EnableTrackChanges="true" OnClientPasteHtml="OnClientPasteHtml"
    ContentFilters="FixEnclosingP,RemoveScripts,FixUlBoldItalic,IECleanAnchors,MozEmStrong,ConvertFontToSpan,ConvertToXhtml,IndentHTMLContent,EncodeScripts,OptimizeSpans,ConvertTags,StripCssExpressions,RemoveExtraBreaks"
    EnableComments="true" NewLineMode="P" EditModes="Design,Html">
</telerik:RadEditor>
Completed
Last Updated: 26 Dec 2018 08:57 by ADMIN
ADMIN
Created by: Vessy
Comments: 1
Category: Editor
Type: Bug Report
0
Likely to happen when an element is empty, not just the editor, if you can get the cusros in an empty <p>, and press backspace you can get the same behavior, it can happen as you work on some content

Steps to reproduce:

1. Go to the Editor demo page http://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx in Chrome
2. CTRL+A on the editor and hit delete
3. Hit Delete or Backspace again

Result: Uncaught TypeError  Cannot read property 'nodeType' of undefined Appears in the console
Completed
Last Updated: 20 Dec 2018 17:18 by ADMIN
After performing some tests with images using the RadEditor I have found that when selecting the class to apply in the image properties dialog, it will not let you clear the class. When choosing the clear class option from the drop down it does not change the class of the image it will keep the same class that is already applied from the drop down.
Completed
Last Updated: 07 Nov 2018 17:06 by ADMIN
If RadEditor is initially hidden with display:none, its tools do not work when displayed in Firefox 62.0:

<div style="display: none" id="hiddenWrapper">
    <telerik:RadEditor ID="RadEditor1"  runat="server"></telerik:RadEditor>
</div>
<script>
    function f() {
        $get('hiddenWrapper').style.display = "block";
      }
    Sys.Application.add_load(f);
</script>


There is a warning error in the console: "Mutation Events is deprecated and to use MutationObserver".

The fix is to call the $find("RadEditor1").onParentNodeChanged(); method to recreate the content area:

<div style="display: none" id="hiddenWrapper">
    <telerik:RadEditor ID="RadEditor1"  runat="server"></telerik:RadEditor>
</div>
<script>
    function f() {
        $get('hiddenWrapper').style.display = "block";
        $find("RadEditor1").onParentNodeChanged();
    }
    Sys.Application.add_load(f);
</script>
Completed
Last Updated: 05 Nov 2018 14:44 by ADMIN
ADMIN
Created by: Rumen
Comments: 0
Category: Editor
Type: Bug Report
3
Steps to reproduce:
1. Go to the Editor demo page in Chrome
2. CTRL+A on the editor and hit delete
3. Hit Delete or Backspace again
Result: Uncaught TypeError Appears in the console
Approved
Last Updated: 29 Oct 2018 18:15 by ADMIN
We have an issue where the RadEditor context menu for <td> element doesn't get displayed. It throws a "Permission Denied" error. Within <td> the table toolbar is not functional either. 
To reproduce: In an aspx page, create an updatepanel with a LoadContent button, RadEditor and Save button.
1. Click on Load Contents button
2. RadEditor with text "Loaded" will get displayed
3. Insert a table
4. Go to a table cell and verify context menu for td shows fine
5. Click Save
6. Go to a table cell and right click - context menu doesn't show (If you have IE developers tool, you will see "Permission Denied" error.)

ASPx page:
<asp:Content ID="Content2" ContentPlaceHolderID="ContentPlaceHolder1" runat="server">
    <asp:UpdatePanel ID="upd" runat="server">
        <ContentTemplate>
              <asp:Button ID="btnLoad" runat="server" Text="Load Contents"  OnClick="btnLoad_Click"  />
              <telerik:RadEditor ID="HTMLEditor" runat="server"></telerik:RadEditor>          
                <asp:Button ID="btnSave" runat="server" Text="Save"  OnClick="btnSave_Click" UseSubmitBehavior="false" />
        </ContentTemplate>
    </asp:UpdatePanel>     
</asp:Content>
C# Code:
 protected void Page_Load(object sender, EventArgs e)
        {
        }
        protected void btnSave_Click(object sender, EventArgs e)
        { 
            HTMLEditor.Content = HTMLEditor.Content + " updated";            
        }
        protected void btnLoad_Click(object sender, EventArgs e)
        {
            HTMLEditor.Content = "Loaded";
        }
Won't Fix
Last Updated: 19 Oct 2018 13:43 by ADMIN
Created by: Jinita
Comments: 2
Category: Editor
Type: Bug Report
0
When the tracking feature is enabled some of the existing features don't work properly. For eg:
a. If existing text were bulleted they were not displayed properly.
b. If bulleted content was copied over from a web page and pasted into the RadEditor control formatting was not retained.
c. If text in the editor that was modified previously and not accepted by a user, a change made to the same text after some time does not capture the new username and date time stamp by the same /different user. 

Please fix the tracking feature for SharePoint
Completed
Last Updated: 22 Aug 2018 12:59 by ADMIN
ADMIN
Created by: Rumen
Comments: 1
Category: Editor
Type: Bug Report
0

			
Approved
Last Updated: 06 Jul 2018 12:33 by ADMIN
We have an issue with paragraph styles which have some custom classes.
It has different behavior depending on how you select your paragraph.
In some cases, when you fully select your paragraph the class remains the same the previous paragraph.
Please see the video of issue reproducing on the Telerik demo for more details:
https://www.screencast.com/t/xg9b1imVO

Workaround:
<script type="text/javascript">
    function OnClientCommandExecuting(editor, args) {
        //The command name   
        var commandName = args.get_commandName();
        //The tool that initiated the command   
        if (commandName == "FormatBlock") {
            //editor.get_document().execCommand("FormatBlock", false, "div");
            var selectedElement = editor.getSelectedElement();
            if (selectedElement.getAttribute("style")) {
                selectedElement.removeAttribute("style");
            }
            else if (selectedElement.getAttribute("class")) {
                selectedElement.removeAttribute("class");
            }
        }
    }
</script>
<telerik:RadEditor RenderMode="Lightweight" runat="server" ID="RadEditor1" ToolsFile="Tools.xml" Width="800px" OnClientCommandExecuting="OnClientCommandExecuting">
    <Content>
            some plain text
    </Content>
    <CssFiles>
        <telerik:EditorCssFile Value="Styles.css" />
    </CssFiles>
</telerik:RadEditor>