Approved
Last Updated: 23 Jan 2020 16:18 by ADMIN
A JavaScript error is thrown when the Print dialog is being disposed.
Error message:
Uncaught TypeError: Cannot read property 'dispose' of undefined

    at $IE.Print.dispose (<anonymous>:90:18)

 

Workaround:
Enable the external dialogs of the Editor/ImageEditor and modify dispose() function of the Print.ascx dialog:

 

Print.ascx

				dispose: function ()
				{
					this._attachHandlers(false);

					this._printBtn.dispose();
					this._cancelBtn.dispose();

					$IE.Print.callBaseMethod(this, "dispose");
				},

 

Approved
Last Updated: 02 Jan 2020 16:33 by ADMIN

Hi, I have trouble with RadScriptManager. I would like combine scripts on page to only one file. But when I enabled it, my site threw javascript error on loading.
Please help me fix it, it would also be better if you can help me understand what happened.

First image is what I set up for RadScriptManager

Secondary image is the error.



I have no idea what's Telerik.Web.UI.Point, I haven't used it anywhere.

Please help me get this error out & fix it.
Thank you.

Approved
Last Updated: 27 Dec 2019 00:06 by ADMIN
Created by: Vance
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
0

Steps to repro:

1. Go to https://demos.telerik.com/aspnet-ajax/chat/toolbar/defaultcs.aspx

2. Show the toolbar with the ellipses

3. Enter enough messages so that the scroll is shown and continue to enter

4. The toolbar drop down on each click of an icon

See the attached video for more information.

Approved
Last Updated: 02 Oct 2019 14:01 by ADMIN
  1. Open your demo for Batch Editing: https://demos.telerik.com/aspnet-ajax/grid/examples/data-editing/batch-editing/defaultcs.aspx
  2. Add a new row
  3. Enter values
  4. Click on x to delete

Expected: the row disappears.

Actual result: nothing happens.

 

 

Approved
Last Updated: 10 Jul 2019 15:56 by ADMIN
I have found that there is a bug when working with tables in the editor in inline editing mode in Safari on Mac - https://demos.telerik.com/aspnet-ajax/editor/examples/inline-editing/defaultcs.aspx.

In the normal editing mode, you can edit the table properties by right clicking inside the table to get the context menu, then choose table properties, add row etc.

In Inline editing mode, it shows the context menu but when you click on any item it says to select the table. None of the other context menu commands like inserting rows etc work.

I have tested on your demo site and you should be able to simulate it there.
Approved
Last Updated: 05 Jun 2019 11:26 by ADMIN

Hello,

I enabled the ShowButton property to the radtextbox, but while writing and the words reach the button I can't see the final of the text. 

<telerik:RadTextBox ID="RadTextBox1" runat="server" ShowButton="true"></telerik:RadTextBox>

If I disable the ShowButton and write something in the radtextbox, I can see the final words. 

How I can fix this? 

Thanks,
Edson

Approved
Last Updated: 07 May 2019 11:43 by ADMIN
In Classic RenderMode, Windows7 skin, TreeView nodes are higher when inside ContentTemplate of RadPanelBarItem:



<div>
    wrong:
    <telerik:RadPanelBar RenderMode="Classic" Skin="Windows7" runat="server" ID="RadPanelBar1" Width="100%" Height="100%">
        <Items>
            <telerik:RadPanelItem Text="Custom" Expanded="true">
                <ContentTemplate>
                    <telerik:RadTreeView RenderMode="Classic" Skin="Windows7" ID="radTreeView" runat="server">
                        <Nodes>
                            <telerik:RadTreeNode  Text="Custom">
                                <Nodes>
                                </Nodes>
                            </telerik:RadTreeNode>
                            <telerik:RadTreeNode  Text="Custom">
                                <Nodes>
                                </Nodes>
                            </telerik:RadTreeNode>
                            <telerik:RadTreeNode  Text="Custom">
                                <Nodes>
                                </Nodes>
                            </telerik:RadTreeNode>
                        </Nodes>
                    </telerik:RadTreeView>
                </ContentTemplate>
            </telerik:RadPanelItem>
        </Items>
    </telerik:RadPanelBar>
</div>
<div>
        OK:
    <telerik:RadTreeView ID="radTreeView2" RenderMode="Classic" Skin="Windows7" runat="server">
        <Nodes>
            <telerik:RadTreeNode Text="Custom">
                <Nodes>
                </Nodes>
            </telerik:RadTreeNode>
            <telerik:RadTreeNode  Text="Custom">
                <Nodes>
                </Nodes>
            </telerik:RadTreeNode>
            <telerik:RadTreeNode  Text="Custom">
                <Nodes>
                </Nodes>
            </telerik:RadTreeNode>
        </Nodes>
    </telerik:RadTreeView>
</div>


Approved
Last Updated: 19 Apr 2019 09:41 by ADMIN

Using CommandItemTemplate (Grid - Command Item) for Editing DetailTable records and selecting an item after filtering or from another page, one item from the first page is put for editing instead. Open the attached GIF animation (EditSelectedEditWrongItem.gif) to see it in action.

 

Currently the workaround we offer is to handle the EditSelected command manually for all the DetailTables Except for the Master.

 

Grid markup:

 

        <telerik:RadGrid ID="RadGrid1" runat="server" AllowPaging="True" Width="100%" PageSize="3"
            OnItemCommand="RadGrid1_ItemCommand"
            OnDetailTableDataBind="RadGrid1_DetailTableDataBind"
            OnNeedDataSource="RadGrid1_NeedDataSource">
            <MasterTableView Name="MasterTable" AutoGenerateColumns="true" DataKeyNames="OrderID">
                <DetailTables>
                    <telerik:GridTableView Name="ChildTable" DataKeyNames="OrderID" AutoGenerateColumns="true" CommandItemDisplay="Top">
                        <CommandItemTemplate>
                            <asp:LinkButton ID="btnEditSelected" runat="server" CommandName="EditSelected" CssClass="btn btn-default">Edit Selected</asp:LinkButton>
                        </CommandItemTemplate>
                    </telerik:GridTableView>
                </DetailTables>
            </MasterTableView>
            <ClientSettings>
                <Selecting AllowRowSelect="true" />
            </ClientSettings>
        </telerik:RadGrid>

 

C# - ItemCommand

 

    protected void RadGrid1_ItemCommand(object sender, GridCommandEventArgs e)
    {
        // Logic applies for all the tables (detail tables) which are not named "MasterTable"
        if(e.Item.OwnerTableView.Name != "MasterTable" && e.CommandName == RadGrid.EditSelectedCommandName)
        {
            e.Canceled = true;

            GridTableView detailTable = e.Item.OwnerTableView;

            if (detailTable.OwnerGrid.SelectedIndexes.Count == 0)
            {
                return;
            }

            foreach (GridDataItem selectedItem in detailTable.OwnerGrid.SelectedItems)
            {
                selectedItem.Edit = true;
            }

            detailTable.Rebind();
        }
    }

 

VB - ItemCommand


Protected Sub RadGrid1_ItemCommand(ByVal sender As Object, ByVal e As GridCommandEventArgs)
    If e.Item.OwnerTableView.Name <> "MasterTable" AndAlso e.CommandName = RadGrid.EditSelectedCommandName Then
        e.Canceled = True
        Dim detailTable As GridTableView = e.Item.OwnerTableView

        If detailTable.OwnerGrid.SelectedIndexes.Count = 0 Then
            Return
        End If

        For Each selectedItem As GridDataItem In detailTable.OwnerGrid.SelectedItems
            selectedItem.Edit = True
        Next

        detailTable.Rebind()
    End If
End Sub

Approved
Last Updated: 11 Apr 2019 08:09 by ADMIN
Created by: Don Leduc
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
0
I have a big problem here. I have the following code and this code is launched in RadWindow as well:

<telerik:RadTabStrip runat="server" ID="RadTabStrip2" MultiPageID="RadMultiPage2" SelectedIndex="0">
    <Tabs>
        <telerik:RadTab Text="Add Response"></telerik:RadTab>
    </Tabs>
</telerik:RadTabStrip>
<telerik:RadMultiPage runat="server" ID="RadMultiPage2" SelectedIndex="0">
    <telerik:RadPageView runat="server" ID="RadPageView11">
 
            <telerik:RadEditor Width="100%" EditModes="Design" ID="reReqCom" runat="server"  ContentAreaCssFile="~/AppRoot/Xml/RadEditor/EditorContentArea.css"
                ToolsFile="~/AppRoot/Xml/RadEditor/BasicTools.xml" Skin="Material" />
 
    </telerik:RadPageView>
</telerik:RadMultiPage>

 
The problem here is only using the iPhone (ioS), that the user is NOT able to select onto the RadEditor to begin typing. Seems to somehow block it out. I have stripped down to the basic code above and tested.

Can you tell us if this is a known issue?

Is there a workaround?

 

Don
Approved
Last Updated: 29 Mar 2019 12:38 by ADMIN
When the DatePicker is with enabled WAI-ARIA support, Jaws reads "link 11" instead of the selected date "Monday, March 11, 2019".
Approved
Last Updated: 26 Mar 2019 15:05 by ADMIN
Table layout is broken when a cell content is formatted in enabled track changes.
Video: https://www.screencast.com/t/BGiGk8q1Nf
Approved
Last Updated: 22 Mar 2019 11:10 by ADMIN
I am exporting all the appointments using the RadScheduler's Export Calendar functionality (RadScheduler.ExportToICalendar(apptCollection, true)). 

I have the scheduler working with both regular and recurring appointments in my project with RadScheduler along with different timezone for each of the appointments within the scheduler properly. 

However, when I export the same through the above API as an ICS file, I am seeing that the date time is always coming out as UTC on recurring events giving me the wrong results in Outlook. 
Approved
Last Updated: 20 Mar 2019 15:35 by ADMIN
Some of the arrows in the Mobile Menu are missing in Chrome



<telerik:RadMenu ID="RadMenu1" RenderMode="Mobile" runat="server" ></telerik:RadMenu>

protected void Page_Load(object sender, EventArgs e)
{
    RadMenu1.RenderMode = RenderMode.Mobile;
    RadMenu1.Width = 300;
    for (int i = 0; i < 10; i++)
    {
        var radmenuItem = new RadMenuItem();
        radmenuItem.Text = "demo radmenu item " + i.ToString();
        for (int j = 0; j < 10; j++)
        {
            var radmenuItemChild = new RadMenuItem();
            radmenuItemChild.Text = "demo radmenu item child " + j.ToString();
            radmenuItem.Items.Add(radmenuItemChild);
        }
 
        RadMenu1.Items.Add(radmenuItem);
    }
}
Approved
Last Updated: 20 Mar 2019 15:22 by ADMIN

<telerik:RadNumericTextBox ID="RadNumericTextBox2" runat="server" MaxValue="9223372036854775807" Value="545445456456465454">
    <NumberFormat AllowRounding="false" DecimalDigits="0" />
</telerik:RadNumericTextBox>

MaxValue property is set to use the maximum value of int64: 9223372036854775807

Original value introduced is: 545445456456465454

Value becomes:  545445456456465000

Approved
Last Updated: 18 Mar 2019 10:15 by ADMIN
Issue can be replicated using the following Grid settings:

  • Wire up the onCommand client-side event to the grid
  • Set the excel format to Biff
  • Set the RenderMode to Lightweight
  • Enable Sorting


<telerik:RadGrid ID="RadGrid2" runat="server" RenderMode="Lightweight" AllowSorting="true">
    <ExportSettings>
        <Excel Format="Biff" />
    </ExportSettings>
    <ClientSettings>
        <ClientEvents OnCommand="onCommand" />
    </ClientSettings>
    <MasterTableView AutoGenerateColumns="True" CommandItemDisplay="Top">
        <CommandItemSettings ShowExportToExcelButton="true" />
    </MasterTableView>
</telerik:RadGrid>
Approved
Last Updated: 12 Feb 2019 16:15 by ADMIN

When attempting to view the page in design view, here's what it looks like:

 

Here is the markup:

    <telerik:RadPanelBar ID="RadPanelBar1" runat="server">
        <Items>
            <telerik:RadPanelItem runat="server" Expanded="True" PreventCollapse="true">
                <HeaderTemplate>
                    <div ID="content-header">
                        Auditing Report | GPO Changes For User
                    </div>
                </HeaderTemplate>
                <ContentTemplate>
                    <div ID="content-body">
                        <telerik:ReportViewer ID="ReportViewer1" runat="server" ReportBookID="" Width="100%" Height="12in">
                        </telerik:ReportViewer>
                    </div>
                </ContentTemplate>
            </telerik:RadPanelItem>
        </Items>
    </telerik:RadPanelBar>

Approved
Last Updated: 20 Dec 2018 17:16 by ADMIN
Created by: Sunil Sutar
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
1
url to test with JAWS - https://demos.telerik.com/aspnet-ajax/combobox/examples/wai-aria-support/defaultcs.aspx

When I use JAWS to read the combobox present on this demo it reads as follows - ComboBox readonly - Alice Mutton. To change the selection press the arrow keys.

Over here, why JAWS is reading "readonly". It's not readonly. It's making our screenreader blind users confusing.

I drilled down more into the problem and found that, the input element below has the aria-readonly=true set though the combobox is not readonly.
Here is the html generated for above combobox from telerik demo site -

<input name="ctl00$ContentPlaceholder1$RadComboBox2" class="rcbInput radPreventDecorate" id="ctl00_ContentPlaceholder1_RadComboBox2_Input" role="combobox" aria-busy="false" aria-disabled="false" aria-expanded="false" aria-haspopup="true" aria-readonly="true" aria-owns="ctl00_ContentPlaceholder1_RadComboBox2_listbox" aria-autocomplete="none" type="text" readonly="readonly" value="Alice Mutton" autocomplete="off">

I understand that this input control should be readonly so that aria users should not type and go haywire. But looks like to maintain the readonly=readonly property, telerik is generating aria-readonly=true for this _Input control and resulting this issue.

When you change this attribute aria-readonly="true" to aria-readonly="false", JAWS read it correctly as follows - ComboBox - Alice Mutton. To change the selection press the arrow keys.
Approved
Last Updated: 19 Dec 2018 11:58 by ADMIN

Hi,

As per title and I also find out it able to reproduce in the demo site: https://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx

Step:

1. Change to 'HTML' mode.

2. Open 'Find And Replace' dialog.

3. Enter a word to find and hit the 'Find' button.

Notice that the word does not get highlighted. It only happens in 'HTML' mode, 'Design' mode working fine.

Please help as this feature is very useful in my project.

Thank you.

Approved
Last Updated: 01 Nov 2018 12:35 by ADMIN
ADMIN
Created by: Vessy
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
1
RadButton's focus state styling is missing in Bootstrap.

Steps to reproduce:
1. Open https://demos.telerik.com/aspnet-ajax/button/examples/keyboardsupport/defaultcs.aspx?skin=Bootstrap
2. Focus any of the first buttons using the Tab key
    Result: No focus styles are applied
    Expected: Follow the steps above in Sunset skin

-----------------------------------------
Workaround:

        button.RadButton.rbButton:focus {
            box-shadow: 0 3px 5px rgba(0, 0, 0, 0.125) inset;
        }

Approved
Last Updated: 22 Oct 2018 14:21 by ADMIN
1 2 3 4 5 6