Approved
Last Updated: 17 Jul 2017 12:09 by ADMIN
ADMIN
Created by: Peter Milchev
Comments: 0
Category: UI for ASP.NET AJAX
Type: Bug Report
0

			
Approved
Last Updated: 12 Jul 2017 13:21 by ADMIN
Completed
Last Updated: 06 Jul 2017 18:24 by FRANK
ADMIN
Created by: Kostadin
Comments: 2
Category: UI for ASP.NET AJAX
Type: Bug Report
0

			
Approved
Last Updated: 06 Jul 2017 14:38 by ADMIN
ADMIN
Created by: Peter Milchev
Comments: 0
Category: UI for ASP.NET AJAX
Type: Bug Report
0
Workaround: 

.RadListBox .rlbEmptyMessage {
    font-style: italic;
    text-align: center;
    filter: alpha(opacity=80);
    opacity: .8;
    position: absolute;
}
Pending Review
Last Updated: 28 Jun 2017 15:33 by ADMIN
When track changes disabled the backspace is OK:
- User typed two lines (1) & (2)
- At the beginning of the line (2) user presses the backspace key, it successfully appended the line (2) with line (1) (where there was a space available). 
When track changes enabled the backspace does not work as expected:
- User typed two lines (1) & (2)
- At the beginning of the line (2) user presses the backspace key, it removes the end of the character in line (1).
Completed
Last Updated: 20 Jun 2017 14:51 by ADMIN
Completed
Last Updated: 20 Jun 2017 14:49 by ADMIN
In Chrome and Safari, adding a space with disabled Track Changes right after a tracked text, the space appears inside the <ins> tag instead of outside. 
Completed
Last Updated: 20 Jun 2017 14:48 by ADMIN
ADMIN
Created by: Dobromir
Comments: 0
Category: UI for ASP.NET AJAX
Type: Bug Report
4

			
Completed
Last Updated: 08 Jun 2017 18:06 by Kaka
The issue is reproducible when an &nbsp; is added in from of the white space, when adding a subsequent white space after a word. The caret is repositioned at the start of the next tag, if such does not exists, it goes to the end of the line.
Won't Fix
Last Updated: 02 Jun 2017 17:03 by ADMIN
A workaround is to add the settings in the markup, for example:

<telerik:RadPersistenceManager runat="server" ID="RadPersistenceManager1">
	<PersistenceSettings>
		<telerik:PersistenceSetting ControlID="RadTileList1" />
	</PersistenceSettings>
</telerik:RadPersistenceManager>
<telerik:RadTileList runat="server" ID="RadTileList1">
</telerik:RadTileList>
Completed
Last Updated: 01 Jun 2017 12:30 by ADMIN
When zoom is applied in IE browser and button coordinates are not an integer RadImageButton tries to convert them to an integer on the server on postback and fails.

Workaround:

			<telerik:RadImageButton runat="server" ID="rib1" Width="50" Height="50" OnClick="rib1_Click" Image-Url="~/images/myImage.png"></telerik:RadImageButton>
			<script>
				Telerik.Web.UI.Button.ImageCoordsFunctionality.prototype._calculateCoords = function (e) {
					var container = this._ui.element;
					var pos = $telerik.getLocation(container);
					var scroll = $telerik.getScrollOffset(container, true);

					return new Telerik.Web.UI.Point(parseInt(e.clientX + scroll.x - pos.x), parseInt(e.clientY - pos.y + scroll.y));
				}
			</script>
Approved
Last Updated: 31 May 2017 07:31 by ADMIN
ADMIN
Created by: Vessy
Comments: 0
Category: UI for ASP.NET AJAX
Type: Bug Report
0
Several JS errors are trown when writing in re-focussed empty Editor in Chrome.

Video:  https://www.screencast.com/t/Wx6Ucs8m6S5w

First error's message:
RadEditor.js:10521 Uncaught TypeError: Cannot read property 'startContainer' of null


Steps to reproduce:
1. Open in Chrome: http://demos.telerik.com/aspnet-ajax/editor/examples/trackchanges/defaultcs.aspx
2. Switch to HTML mode and clear the whole content
3. Switch back to Design mode
4. Click any of the Bold/Italic/Underline commands
5. Click out of the Editor's element
6. Click back in the Editor's content area and start typing

Result: JS errors are thrown
Completed
Last Updated: 25 May 2017 10:24 by Suneetha
ADMIN
Created by: Nikolay
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
0
Steps to reproduce:
1. Open the demo page http://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx
2. Switch to the 'HTML' mode of the RTE and replace all existing HTML content with the following HTML snippet:
<div>text</div>

3. Switch to the 'Design' mode of the RTE and click once on the 'text' word;
4. Switch keyboard language to Japanese and select 'Hiragana' input type. Place focus on the 'text';
5. Type the 'a' and 'e' characters;

Expected result:
The 'あえ' characters are typed.

Actual result:
Just 'え' character is typed. The 'あ' character is replaced by the 'え'. 

Note:
The first character disappears.
You may need to try several times to reproduce the issue.
The issue is reproducible in Chrome (Version 54.0.2840.99 m).
The issue is not reproducible in Firefox and IE11.

Screencast reproduction: http://screencast.com/t/Lj6plU0di99



Workaround:

<telerik:RadEditor ID="RadEditor1" runat="server">
<Content><p>test</p></Content>
</telerik:RadEditor>

<script>
var editorPrototype = Telerik.Web.UI.RadEditor.prototype;
var onKeyDown = editorPrototype._onKeyDown;
editorPrototype._onKeyDown = function (e) {
if (e.composed) {
   this._pendingTextTypeCmd = {};
}
onKeyDown.call(this, e);
if (e.composed) {
   delete this._pendingTextTypeCmd;
}
};
</script>
Completed
Last Updated: 18 May 2017 15:48 by Vicky Johnson
ADMIN
Created by: Vessy
Comments: 2
Category: UI for ASP.NET AJAX
Type: Bug Report
3
RadCombobox with allowed custom text is transperant in Silk in Classic Render mode.

Video: https://www.screencast.com/t/tgubeklglq


Code to reproduce:
        <div style="width: 300px; background-color: red">
            <h2>Allow custom text</h2>
            <telerik:RadComboBox RenderMode="Classic" ID="RadComboBox1" runat="server" Width="100%" AllowCustomText="true" Skin="Silk">
                <Items>
                    <telerik:RadComboBoxItem Text="RadComboBoxItem1" />
                    <telerik:RadComboBoxItem Text="RadComboBoxItem2" />
                    <telerik:RadComboBoxItem Text="RadComboBoxItem3" />
                </Items>
            </telerik:RadComboBox>
        </div>
Completed
Last Updated: 16 May 2017 13:34 by ADMIN
Additional white border added to the RadRibbonbar buttons in Windows7 skin. The problem is reproducible in Classic rendering.

Steps to reproduce:
1. Open http://demos.telerik.com/aspnet-ajax/ribbonbar/examples/rendermodes/defaultcs.aspx?skin=Windows7

2. Switch to Classic rendering.

Result: All buttons have white border.
Approved
Last Updated: 28 Apr 2017 08:47 by ADMIN
The manually entered value of RadDateTimePicker is replaced with the original one in Batch Edid mode in iPad.

To reproduce this incorrect behavior add a new 

<telerik:GridDateTimeColumn HeaderText="Start Date" UniqueName="StartDate" DataField="StartDate" DataFormatString="{0:MM/dd/yyyy}">
            </telerik:GridDateTimeColumn>

column in the Batch Edit demos of RadGrid and test under iPad. 

Tap over RadTextBox, enter some new date and press Go/tap out and you'll see the problem.
Completed
Last Updated: 25 Apr 2017 15:30 by rleast
Won't Fix
Last Updated: 25 Apr 2017 13:28 by ADMIN
ADMIN
Created by: Anton
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
1
The issue can be workarounded by calling preventDefault of the mousedown event when ComboBox item is clicked:
<telerik:RadScriptManager runat="server" />
<script>
	var onDocumentClick = Telerik.Web.UI.RadComboBox.prototype._onDocumentClick;
	Telerik.Web.UI.RadComboBox.prototype._onDocumentClick = function (e) {
		if (!e) e = event;

		var target = e.target || e.srcElement;

		while (target.nodeType !== 9) {
			if (!target.parentNode || target == this.get_element() || target == this.get_dropDownElement()) {
				e.preventDefault();
				return;
			}

			target = target.parentNode;
		}
		onDocumentClick.call(this, e);
	};
</script>

<telerik:RadComboBox ID="RadComboBox1" runat="server" RenderMode="Lightweight" OnClientBlur="OnClientBlur"
	CheckBoxes="true">
	<Items>
		<telerik:RadComboBoxItem Text="Item1" Value="1" />
		<telerik:RadComboBoxItem Text="Item2" Value="2" />
		<telerik:RadComboBoxItem Text="Item3" Value="3" />
		<telerik:RadComboBoxItem Text="Item4" Value="4" />
	</Items>
</telerik:RadComboBox>

<script>
	function OnClientBlur(sender, args) {
		console.log("Blur event");
	}
</script>
Completed
Last Updated: 21 Apr 2017 14:10 by ADMIN
ADMIN
Created by: Marin Bratanov
Comments: 0
Category: UI for ASP.NET AJAX
Type: Bug Report
0

			
Approved
Last Updated: 20 Apr 2017 13:04 by ADMIN
S error is thrown when the Rotator items do not fill its viewport and EnableRandomOrder="true". The problem occurs in all render modes, when the width of the Rotator is set to 100%.

Error message:
Uncaught Error: Sys.ArgumentNullException: Value cannot be null.
Parameter name: element

WORKAROUNDS:
- set EnableRandomOrder="false" or
- set fixed width to the control, e.g. Width="1000px"



Reproduction code:
        <telerik:RadRotator ID="ProductRotator" runat="server" RotatorType="AutomaticAdvance" Height="100"
            ItemHeight="90" Skin="Default" Width="100%" EnableRandomOrder="true" ScrollDuration="1000">
            <ItemTemplate>
                <div style="width:100px; height: 75px; border: 1px solid red">
                    <%# Eval("title")%>
                </div>
            </ItemTemplate>
        </telerik:RadRotator>


    protected void Page_Load(object sender, EventArgs e)
    {
        if (!IsPostBack)
        {
            ProductRotator.DataSource = GetData();//Producten;
            ProductRotator.DataBind();
        }
    }
    private object GetData()
    {
        DataTable dt = new DataTable();
        dt.Columns.Add("title", typeof(string));
        dt.Columns.Add("desc", typeof(string));
        dt.Rows.Add("T1", "AAA");
        dt.Rows.Add("T2", "BBB");
        dt.Rows.Add("T3", "CCC");
        return dt;
    }