Approved
Last Updated: 19 Dec 2018 11:58 by ADMIN

Hi,

As per title and I also find out it able to reproduce in the demo site: https://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx

Step:

1. Change to 'HTML' mode.

2. Open 'Find And Replace' dialog.

3. Enter a word to find and hit the 'Find' button.

Notice that the word does not get highlighted. It only happens in 'HTML' mode, 'Design' mode working fine.

Please help as this feature is very useful in my project.

Thank you.

Completed
Last Updated: 05 Dec 2018 17:36 by MA
ADMIN
Created by: Vessy
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
1
When the scripts are loaded through a script manager with enabled CDN and RadScriptManager.CombinedResource="Enabled", JS error will be thrown then the filtering button of the Grid is clicked.

Code to reproduce the problem:
        <telerik:RadScriptManager ID="RadScriptManager1" runat="server">
            <CdnSettings TelerikCdn="Enabled" CombinedResource="Enabled" />
        </telerik:RadScriptManager>

        <telerik:RadGrid ID="UserDetailsGrid" runat="server" AllowFilteringByColumn="true" OnNeedDataSource="UserDetailsGrid_NeedDataSource"
            EnableHeaderContextMenu="true" EnableHeaderContextFilterMenu="true">
        </telerik:RadGrid>

C#:
        protected void UserDetailsGrid_NeedDataSource(object sender, Telerik.Web.UI.GridNeedDataSourceEventArgs e)
        {
            var list = new[] {
                    new { FirstName = "F1", LastName ="L1"},
                    new { FirstName = "F2", LastName ="L2"},
                    new { FirstName = "F3", LastName ="L3"},
                    new { FirstName = "F4", LastName ="L4"}
                    }.ToList();
            UserDetailsGrid.DataSource = list;
        }
Completed
Last Updated: 28 Nov 2018 15:29 by ADMIN
Can be reproduced with the following page setup:

<%@ Page Language="C#" AutoEventWireup="true" CodeFile="Default.aspx.cs" Inherits="Default" %>
<%@ Register Assembly="Telerik.Web.UI" Namespace="Telerik.Web.UI" TagPrefix="telerik" %>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">


<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>


</head>
<body>
    <form id="form1" runat="server">
    <telerik:RadScriptManager ID="RadScriptManager1" runat="server">
    </telerik:RadScriptManager>


    <div style="height:930px">
        Scroll down to bottom of the page and right mouse click to see context menu miss placement....
    </div>
   
        <telerik:RadEditor RenderMode="Classic" ID="redHtmlEditor" runat="server" 
            ContentAreaMode="Div">
           <Content>           
                    Right-click on image to see custom menu
                    <img style="marign-left: 6px" src="http://demos.telerik.com/aspnet-ajax/Editor/Img/productLogoLight.gif" />
                    <br/><br/>           
                    <p>Right-click here to see the custom Paragraph menu.<br/></p><br/>           
                    Right-click on the link to see the default link menu disabled: <a href="/">www.telerik.com</a>   
            </Content>
       </telerik:RadEditor>
    
    </form>
</body>
</html>

Completed
Last Updated: 08 Nov 2018 15:00 by ADMIN
The ContextMenu popup is not position properly relative to its target element when the page is horizontally scrolled in Edge. The problem is reproducible with R2 2018.

Steps tp reproduce:
1. Run the code below and scroll the page to the right
2. Right click over a number


<!DOCTYPE html>

<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>
</head>
<body>
    <form id="form1" runat="server">
        <telerik:RadScriptManager ID="RadScriptManager1" runat="server">
        </telerik:RadScriptManager>
        <telerik:RadContextMenu ID="rcmMenu" runat="server">
            <Targets>
                <telerik:ContextMenuTagNameTarget TagName="a" />
            </Targets>
            <Items>
                <telerik:RadMenuItem Text="Menu Item 1" Value="a" />
                <telerik:RadMenuItem Text="Menu Item 2" Value="b" />
            </Items>
        </telerik:RadContextMenu>
        <div style="width: 3500px; height: 100px; position: relative; background-color: yellow;">
            <a style="position: absolute; left: 1000px; top: 40px;" onclick="return showMenu(event);">1000</a>
            <a style="position: absolute; left: 2000px; top: 40px;" onclick="return showMenu(event);">2000</a>
            <a style="position: absolute; left: 3000px; top: 40px;" onclick="return showMenu(event);">3000</a>
        </div>
    </form>
</body>
</html>


Pending Review
Last Updated: 08 Nov 2018 14:27 by Attila Antal
ADMIN
Created by: Attila Antal
Comments: 0
Category: UI for ASP.NET AJAX
Type: Bug Report
1
Images that reside in the grid will get resized (scaled down with about 3-5 %) which might cause issues, specially if exporting bar-codes, thus the bar-code scanners won't be able to read them.

Current workaround is to use the Telerik Documents Processing Library  and build the table manually where the images are inserted without changing the size.

Here is an example:

        protected void RadGrid1_InfrastructureExporting(object sender, GridInfrastructureExportingEventArgs e)
        {
            Telerik.Web.UI.ExportInfrastructure.Table table = e.ExportStructure.Tables[0];

            Workbook workbook = new Workbook();
            workbook.Worksheets.Add();

            Worksheet worksheet = workbook.ActiveWorksheet;


            foreach (var row in table.Rows)
            {
                if (row.Index > 1)
                {
                    worksheet.Rows[row.Index - 1].SetHeight(new RowHeight(55, true));
                }

                foreach (var cell in row.Cells)
                {
                    if (row.Index == 1 || cell.ColIndex != 2)
                    {
                        worksheet.Cells[cell.Index.Y - 1, cell.Index.X - 1].SetValue(cell.Value.ToString());
                    }
                    else
                    {
                        FloatingImage image = new FloatingImage(worksheet, new CellIndex(cell.Index.Y - 1, cell.Index.X - 1), 0, 0);
                        Stream stream = File.Open(Server.MapPath(cell.Value.ToString()), FileMode.Open);
                        using (stream)
                        {
                            image.ImageSource = new Telerik.Windows.Documents.Media.ImageSource(stream, "jpg");
                        }
                        worksheet.Shapes.Add(image);
                    }
                }
            }

            byte[] data;

            using (MemoryStream ms = new MemoryStream())
            {
                XlsxFormatProvider xlsProvider = new XlsxFormatProvider();
                xlsProvider.Export(workbook, ms);
                data = ms.ToArray();
            }

            Response.ContentType = "application/vnd.openxmlformats-officedocument.spreadsheetml.sheet";
            Response.Headers.Remove("Content-Disposition");
            Response.AppendHeader("Content-Disposition", "attachment; filename=" + RadGridLista.ExportSettings.FileName + ".xlsx");
            Response.BinaryWrite(data);
            Response.End();
        }
Completed
Last Updated: 07 Nov 2018 15:31 by ADMIN
ADMIN
Created by: Ivan Danchev
Comments: 0
Category: UI for ASP.NET AJAX
Type: Bug Report
0
Affects RadCloudUpload and RadAsyncUpload combined with RadProgressArea. Manifests most often on slow networks or very large files.
Scroll down for workarounds for both cases.

NOTE: RadCloudUpload issue is logged separately - https://feedback.telerik.com/Project/108/Feedback/Details/258958-cloudupload-progress-shows-more-than-100-when-uploading-a-file

WORKAROUND FOR PROGRESS AREA is to round down the data, as it seems the server reports more bytes uploaded than they actually are, and that tends to happen under slow network conditions

<telerik:RadAsyncUpload RenderMode="Lightweight" runat="server" ID="RadAsyncUpload1" MultipleFileSelection="Automatic" EnableInlineProgress="false" />
<telerik:RadProgressManager runat="server" ID="RadProgressManager1" />
<telerik:RadProgressArea RenderMode="Lightweight" runat="server" ID="RadProgressArea1" OnClientProgressUpdating="OnClientProgressUpdating" />
<script>
function OnClientProgressUpdating(sender, args) {
    //debugger
    if (args._progressData.PrimaryPercent > 100) {
        args._progressData.PrimaryPercent = 100;
    }
    if (args._progressData.PrimaryValue > args._progressData.PrimaryTotal) {
        args._progressData.PrimaryValue = args._progressData.PrimaryTotal;
    }
    console.log(args.get_progressData());
}
</script>

WORKAROUND FOR CLOUD UPLOAD is to add the following script at the end of the form that will override the built-in XHR handilng to change the way the totals are calculated:

        <script>
            Telerik.Web.UI.RadCloudUpload.HandlerUploader.prototype._initializeXmlHttpRequest = function () {
                this._xhr = new XMLHttpRequest();

                var that = this,
                    module = this._module,
                    xhr = this._xhr;

                xhr.onreadystatechange = function readyStateChanged() {
                    if (xhr.readyState == 4) {
                        if (xhr.status == 200) {
                            that._successfulResponseStatus(xhr);
                        }
                        else if (xhr.status != 0) {
                            that._failedResponseStatus(xhr);
                        }
                    }
                };

                xhr.upload.onprogress = function (event) {
                    that._uploadedSize += event.loaded;

                    var percents = Math.round((event.loaded / event.total) * 100) + "%";

                    module._renderingManager.updateRowProgress(that._uploadingEntity.row, percents, true);
                };
            }
        </script>
Completed
Last Updated: 05 Nov 2018 08:54 by Smit
After having a filter applied, filter value is not cleared when FilterOption was set to "NoFilter".


The following client-side logic would clear the textbox values before the filtering is applied if filter options are set to "NoFilter"

            function onCommand(sender, args) {
                if (args.get_commandName() == "HeaderContextMenuFilter") {
                    var firstTextBox = $("[id$='HCFMRTBFirstCond']")[0].control;
                    var firstFilterOption = args.get_commandArgument().split("|")[1];

                    var secondTextBox = $("[id$='HCFMRTBSecondCond']")[0].control;
                    var secondFilterOption = args.get_commandArgument().split("|")[3];

                    if (firstFilterOption.includes("NoFilter") && firstTextBox.get_value() != "") {
                        args.set_cancel(true);
                        var value = firstTextBox.get_value();
                        firstTextBox.clear();
                        var newArg = args.get_commandArgument().replace("|" + value + "|?", "||?");
                        args.get_tableView().fireCommand(args.get_commandName(), newArg);
                    }

                    if (secondFilterOption.includes("NoFilter") && secondTextBox.get_value() != "") {
                        args.set_cancel(true);
                        var value = firstTextBox.get_value();
                        secondTextBox.clear();
                        var newArg = args.get_commandArgument().replace("|" + value + "|?", "||?");
                        args.get_tableView().fireCommand(args.get_commandName(), newArg);
                    }
                }
            }
Approved
Last Updated: 01 Nov 2018 12:35 by ADMIN
ADMIN
Created by: Vessy
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
0
RadButton's focus state styling is missing in Bootstrap.

Steps to reproduce:
1. Open https://demos.telerik.com/aspnet-ajax/button/examples/keyboardsupport/defaultcs.aspx?skin=Bootstrap
2. Focus any of the first buttons using the Tab key
    Result: No focus styles are applied
    Expected: Follow the steps above in Sunset skin

-----------------------------------------
Workaround:

        button.RadButton.rbButton:focus {
            box-shadow: 0 3px 5px rgba(0, 0, 0, 0.125) inset;
        }

Completed
Last Updated: 30 Oct 2018 15:42 by ADMIN
Some colors (for example #ccffff, #ccccff, #e5f2ff, #eef9fc, #003366, #006400) are not properly  applied in the Colorize tab of the Visual Style Builder and choosing one of them results in setting a different color.
Approved
Last Updated: 22 Oct 2018 14:21 by ADMIN
Approved
Last Updated: 19 Oct 2018 14:35 by ADMIN
The issue is as we are deleting the entire line which contains bullets, it doesn't delete the bullets. We are using server side AcceptTrackChanges() method and it keeps the background color of the deleted lines. 

ASPX

<telerik:RadEditor RenderMode="Lightweight" ID="RadEditor1" EnableTrackChanges="true" runat="server" Width="750px"
    Height="400px" ToolsFile="~/ToolsFile.xml">
    <TrackChangesSettings Author="RadEditorUser" CanAcceptTrackChanges="true" UserCssId="reU0"></TrackChangesSettings>
    <Content>
        <ol>
            <li>test
            <ol>
                <li>test2</li>
            </ol>
            </li>
            <li>test3</li>
        </ol>
    </Content>
</telerik:RadEditor>
<asp:Button Text="Get Content" OnClick="GetContent" runat="server" />
<br />
EditorWithoutTracking:<br />
<asp:TextBox runat="server" id="EditorWithoutTracking" TextMode="MultiLine" Width="1000px" Height="500px"/><br />
EditorWithTracking:<br />
<asp:TextBox runat="server" id="EditorWithTracking" TextMode="MultiLine" Width="1000px" Height="500px"/>

Codebehind

    protected void GetContent(object sender, EventArgs e)
    {
        EditorWithoutTracking.Text = RadEditor1.Content;
        RadEditor1.AcceptTrackChanges();
        EditorWithTracking.Text = RadEditor1.Content;
    }



In Development
Last Updated: 18 Oct 2018 14:19 by ADMIN
 https://www.screencast.com/t/UgqUZbqenpj5
Pending Review
Last Updated: 03 Oct 2018 17:00 by ADMIN
Simple reproducible is attached to illustrate the problem.

A workaround may be replacing RadButtons that invokes such postbacks with regular buttons and using a form decorator

Alternatively, you can simply disable the handler URL encryption

You can also put the following in the global.asax file to prevent the version from rendering on the page markup
        protected void Application_BeginRequest(object sender, EventArgs e)
        {
			System.Web.HttpContext.Current.Items["_!TelerikVersionStampRendered"] = true;
        }
or you can add the same line in a global Page_Load handler (e.g., in a base page class or in the master page your project uses)
Completed
Last Updated: 27 Sep 2018 15:14 by ADMIN
ADMIN
Created by: Rumen
Comments: 0
Category: UI for ASP.NET AJAX
Type: Bug Report
1
I am seeing a strange problem when opening LinkManager dialog from RadEditor. The width of the dialog keeps decreasing on successive opening of the dialog. Sample page code to reproduce this is given below.
You can see a video of this issue at think URL : https://goo.gl/UuPwtA    
Sample page code (code-behind is empty)

<%@ Page Language="C#" AutoEventWireup="true"%>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>
    <telerik:RadStyleSheetManager ID="RadStyleSheetManager1" runat="server" />
</head>
<body>
    <form id="form1" runat="server">
        <telerik:RadScriptManager ID="RadScriptManager1" runat="server">
        </telerik:RadScriptManager>
        <div>
            <telerik:RadEditor ID="RadEditor1" runat="server" ToolbarMode="Default" RenderMode="Lightweight"  Skin="Metro"></telerik:RadEditor>
        </div>
    </form>
</body>
</html>

Reproducible in every browser.
Approved
Last Updated: 26 Sep 2018 15:52 by Kavitha
When Scrolling is enabled with Frozen columns in RadGrid, horizontal scrollbar not visible in Microsoft Edge.

Issue appears in Microsoft Edge Version:
- Microsoft Edge 42.17134.1.0
- Microsoft EdgeHTML 17.17134



WORKAROUND:

Apparently, setting the horizontal scrollbar's height to 17 pixels will make Microsoft Edge display it. (Note: in case it still not displaying, you may try with 18px)

To set the height, you can choose one of the options below:

1. Using CSS style to increase the size of the horizontal scrollbar by one pixel.

<style type="text/css">
    .RadGrid div[id$="_Frozen"] {
        height: 18px;

        /* or  */
        /*padding-bottom: 1px;*/
    }
</style>


2. Using JavaScript

Subscribe the grid to its GridCreated client-side event, and in the event handler increase the element's height with the scrollbar then revert it back to its original size with a delay:

<script type="text/javascript">
    function GridCreated(sender, args) {
        $('div[id$="_Frozen"]').height(17);
    }
</script>
Won't Fix
Last Updated: 05 Sep 2018 23:05 by silvio
ADMIN
Created by: Marin
Comments: 8
Category: UI for ASP.NET AJAX
Type: Bug Report
3
Native browser behavior is vendor specific and the above issue cannot be replicated with the latest version. Default browser in latest Android versions is Chrome and we recommend using it instead of the older native browser
Won't Fix
Last Updated: 20 Aug 2018 09:15 by Des
When a RadEditor or SPRadEditor in a custom WebPart for SharePoint 2013 is placed in an UpdatePanel or RadAjaxPanel it is not ajaxified and loses its content after a post back.
Approved
Last Updated: 03 Aug 2018 11:42 by ADMIN
ADMIN
Created by: Peter Milchev
Comments: 0
Category: UI for ASP.NET AJAX
Type: Bug Report
0
Workaround: 

.rtsDropClueLeft {
    margin: -0.5em 0 0 -0.75em;
}

    .rtsDropClueLeft:before {
        content: "\e005";
    }

.rtsDropClueRight {
    margin: -0.5em 0 0 -0.25em;
}

    .rtsDropClueRight:before {
        content: "\e007";
    }
Approved
Last Updated: 27 Jul 2018 10:59 by ADMIN
The click event of the toolbar is triggered only when the user clicks outside of the set button icon (the text or the button element). Clicking directly over the icon does not perform any action in IE11.

video: https://www.screencast.com/t/K50K4X8Ck

Code to reproduce:
            <telerik:RadToolBar runat="server" ID="ToolBar1">
                <Items>
                    <telerik:RadToolBarButton
                        ImageUrl="//d585tldpucybw.cloudfront.net/sfimages/default-source/labs/kendo/kendoka-states.png"
                        NavigateUrl="Default.aspx"
                        Text="Link"/>
                    <telerik:RadToolBarButton
                        ImageUrl="//d585tldpucybw.cloudfront.net/sfimages/default-source/labs/kendo/kendoka-states.png"
                        NavigateUrl="Default.aspx"/>
                </Items>
            </telerik:RadToolBar>
Completed
Last Updated: 16 Jul 2018 11:16 by ADMIN
The RadFormDecorator decorated checkboxes in the Grid are hard to read when checked in the following skins:
BlackMetroTouch, Bootstrap, Glow, Metro, MetroTouch, Office2010Black, Telerik, WebBlue

Screenshot with Telerik Skin:
https://www.screencast.com/t/1P2hyvWNX

Steps to reproduce:
1. Open http://demos.telerik.com/aspnet-ajax/formdecorator/examples/formdecoratorandtelerikcontrols/defaultcs.aspx?skin=Telerik
2. Scroll to the Grid
3. Select one or all checkboxes
Result: The selected color of the checkbox almost matches the background color