Completed
Last Updated: 02 Oct 2019 18:56 by ADMIN
When loading custom skin trough  RadSkinManager -> Skins -> SkinReference.Path, the logic inside RadSkinManager.FillNonEmbeddedSkinsInfo does not work correctly: in order to load ComboBox.MySkin.css, per say, it requires ComboBox folder to be present inside the custom skin folder.
Completed
Last Updated: 02 Oct 2019 14:34 by ADMIN
ADMIN
Created by: Vessy
Comments: 0
Category: UI for ASP.NET AJAX
Type: Bug Report
0
Missing background color of the Grid's headers in IE9 due to the unsupported by the browser linear-gradient. The issue can be reproduced with Skin="Web20".

Workaround:

        div.RadGrid_Web20 .rgHeader, .RadGrid_Web20 th.rgResizeCol, .RadGrid_Web20 .rgHeaderWrapper {
            background-image: linear-gradient(#9db7db,#7b95c6 50%,#698ac0 50%,#92b3de);
            background-color: #92b3de;
        }

Code to reproduce:
                <telerik:RadGrid ID="RadGrid1" runat="server" OnNeedDataSource="RadGrid1_NeedDataSource" AutoGenerateColumns="false" Skin="Web20" EnableEmbeddedSkins="true">
                    <MasterTableView>
                        <Columns>
                            <telerik:GridBoundColumn DataField="description" HeaderText="Description"></telerik:GridBoundColumn>
                            <telerik:GridBoundColumn DataField="value" HeaderText="Value"></telerik:GridBoundColumn>
                        </Columns>
                    </MasterTableView>
                </telerik:RadGrid>

    protected void RadGrid1_NeedDataSource(object sender, Telerik.Web.UI.GridNeedDataSourceEventArgs e)
    {
        (sender as RadGrid).DataSource = GetData();
    }

    private DataTable GetData()
    {
        DataTable dt = new DataTable();
        dt.Columns.Add("description");
        dt.Columns.Add("value");
        for (int i = 0; i < 100; i++)
        {
            dt.Rows.Add(
                "description_" + i.ToString(),
                i * 100);
        }

        return dt;
    }
Completed
Last Updated: 02 Oct 2019 14:34 by ADMIN
ADMIN
Created by: Peter Milchev
Comments: 0
Category: UI for ASP.NET AJAX
Type: Bug Report
0
Screencast demonstrating the issue and the fixes: https://www.screencast.com/t/hvCSwumhW

Caused by 

https://groups.google.com/a/chromium.org/forum/#!topic/blink-dev/GbVcuwg_QjM/discussion%5B1-25%5D
https://stackoverflow.com/a/45495974
https://stackoverflow.com/a/45746963

Workaround attached
Completed
Last Updated: 02 Oct 2019 14:33 by ADMIN
 https://www.screencast.com/t/UgqUZbqenpj5
Approved
Last Updated: 02 Oct 2019 14:01 by ADMIN
  1. Open your demo for Batch Editing: https://demos.telerik.com/aspnet-ajax/grid/examples/data-editing/batch-editing/defaultcs.aspx
  2. Add a new row
  3. Enter values
  4. Click on x to delete

Expected: the row disappears.

Actual result: nothing happens.

 

 

Pending Review
Last Updated: 17 Sep 2019 19:30 by ADMIN

We suspect a bug of Telerik controls:

 

Bug of Telerik: PageView.set_contentUrl(MyUrl) method - call MyUrl twice if RadTabStrip and RadMultiPage is inside RadAjaxPanel control. Firefox only.

Code: http://bit.ly/2NVbm8Z

It enter here two times: http://bit.ly/2NZ0cQH

 

If try it in chrome - request goes only one time.

If remove RadAjaxPanel - also request goes only one time.

 

Is it bug of your Controls?

Declined
Last Updated: 04 Sep 2019 09:02 by ADMIN
ADMIN
Created by: Chavdar Dimitrov
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
6

			
Completed
Last Updated: 02 Sep 2019 14:52 by ADMIN
Created by: Patrick
Comments: 2
Category: UI for ASP.NET AJAX
Type: Bug Report
0
When we create a link to an external web site such as www.cnn.com using the RadEditor (6.3.0.0) on our SP2010 farm we are getting an error that says this:
"cannot find this location in the current site location"
"the URL may refer to an external web site for to a location in the site collection that does not exist or you do not have the right to access"

When I bring up a browser on the SharePoint server themselves I can access those sites.

Completed
Last Updated: 27 Aug 2019 10:43 by ADMIN
ADMIN
Created by: Dimitar
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
1

			
Completed
Last Updated: 19 Aug 2019 12:26 by ADMIN
Completed
Last Updated: 14 Aug 2019 12:34 by ADMIN
Created by: Chris Dalessandri
Comments: 3
Category: UI for ASP.NET AJAX
Type: Bug Report
0

Reproduction steps:

Go to the Telerik demo at https://demos.telerik.com/aspnet-ajax/textbox/overview/defaultcs.aspx
In the Comment box, type "one two".  Do not let the textbox lose focus.
Highlight "two" and start to drag it to move it before "one". The other text ("one") will disappear, and is gone forever, as far as I can tell.

It can be also reproduced with this configuration:

<telerik:RadTextBox RenderMode="Lightweight" runat="server" ID="RadTextBox3" Width="200px" EmptyMessage="Enter comment" TextMode="MultiLine" Height="100px" Resize="None"></telerik:RadTextBox>

Pending Review
Last Updated: 07 Aug 2019 15:21 by ADMIN

Hi, I have trouble with RadScriptManager. I would like combine scripts on page to only one file. But when I enabled it, my site threw javascript error on loading.
Please help me fix it, it would also be better if you can help me understand what happened.

First image is what I set up for RadScriptManager

Secondary image is the error.



I have no idea what's Telerik.Web.UI.Point, I haven't used it anywhere.

Please help me get this error out & fix it.
Thank you.

Completed
Last Updated: 29 Jul 2019 07:48 by ADMIN

We are evaluating whether to use Telerik to redesign a legacy web app written using an old version of Telerik.

After downloading Trial version on fresh install of windows, I can't add ajax control to form. `I am using visual studio 2019, this is the first version of Telerik installed on this computer.  I just get the "Error Creating Control RadScriptManager1. They do show up in the toolbox so this surprises me.

Very latest version.

7/28/2019

Could it be a license issue?

Approved
Last Updated: 10 Jul 2019 15:56 by ADMIN
I have found that there is a bug when working with tables in the editor in inline editing mode in Safari on Mac - https://demos.telerik.com/aspnet-ajax/editor/examples/inline-editing/defaultcs.aspx.

In the normal editing mode, you can edit the table properties by right clicking inside the table to get the context menu, then choose table properties, add row etc.

In Inline editing mode, it shows the context menu but when you click on any item it says to select the table. None of the other context menu commands like inserting rows etc work.

I have tested on your demo site and you should be able to simulate it there.
Completed
Last Updated: 04 Jul 2019 07:47 by ADMIN
ADMIN
Created by: Ivan Zhekov
Comments: 2
Category: UI for ASP.NET AJAX
Type: Bug Report
0
When trying to load a light-weight skin from external assembly (other than Telerik.Web.UI.Skins), the path to the files is not resolved correctly, hence no resource is loaded.
Completed
Last Updated: 28 Jun 2019 11:02 by ADMIN
Completed
Last Updated: 28 Jun 2019 10:58 by ADMIN
ADMIN
Created by: Pavlina
Comments: 2
Category: UI for ASP.NET AJAX
Type: Bug Report
1

			
Approved
Last Updated: 05 Jun 2019 11:26 by ADMIN

Hello,

I enabled the ShowButton property to the radtextbox, but while writing and the words reach the button I can't see the final of the text. 

<telerik:RadTextBox ID="RadTextBox1" runat="server" ShowButton="true"></telerik:RadTextBox>

If I disable the ShowButton and write something in the radtextbox, I can see the final words. 

How I can fix this? 

Thanks,
Edson

1 2 3 4 5 6