Won't Fix
Last Updated: 20 Jul 2015 14:14 by ADMIN
The RadTextBox are placed inside a asp gridview. When an item from the combo box in the page is selected. The server side logic hide one of the columns of the gridview using such approach:

grdExamples.Columns[2].Visible = false;

This, however, keeps the controls inside the vary same GridView. So during Ajax their ScriptDescriptrs got registered in the ScriptManager. When the result $create execute client side, the JS error is thrown.

It can not be fixed in general, because we can not cover scenarios where the control is:

1. Visible

2. In the control collection. (have .Page!=null)

3. All it's parents are visible.

4. Does not render, because it's parent control ( the gridview) decides not to render some of it's childs.

When all of 1,2,3,4 are true, the control will describe, but not visible in the output HTML resulting in error.

It will happen in all controls (not only RadTextBox), when you are using the RadAjaxManager. Since the manager registers the ScriptDescriptors manually per control, before the Render of the page, therefore it can't know if the control is "Really Visible". This is limitation of the manager, that can not be changed without breaking fundamentals of how it works.
Won't Fix
Last Updated: 16 Jul 2015 11:54 by Andy
ADMIN
Created by: Kostadin
Comments: 2
Category: InputManager
Type: Feature Request
1
Due to a bug in the WebKit-based browsers this issue could not be fixed since it will introduce another bugs in those browsers. 
Won't Fix
Last Updated: 16 Jul 2015 08:50 by ADMIN
Won't Fix
Last Updated: 16 Jul 2015 08:44 by ADMIN
Can not open database created with the latest sql using 2008, same issue here.
Won't Fix
Last Updated: 26 Jun 2015 10:53 by ADMIN
ADMIN
Created by: Maria Ilieva
Comments: 0
Category: UI for ASP.NET AJAX
Type: Feature Request
0
The grid adds the correct Aria-Selected attribute, but JAWS does not work
Won't Fix
Last Updated: 15 Jun 2015 14:31 by ADMIN
Won't Fix
Last Updated: 15 Jun 2015 11:31 by ADMIN
A sample project for reproducing the issue is attached:

Each of the pages in the ContentUrl properties has an alert("PageName") displayed at pageLoad.

1, Brows the Default.aspx - an alert - page1 occurs

2. Select Level 2 tab, which would load the subTab - Page4 and the "page4" alert should be shown.

Problem : In addition to the "page4" alert - the "page5" alert is raised and the page5.aspx had been loaded along with page4.aspx.

----------------------------------

Workaround:
To workaround this issue, set the PageViewID property of the parent tab to be with the same value as the PageViewID property on the selected child tab.

<telerik:RadTabStrip runat="server" ID="RadTabStrip1" MultiPageID="rmpPages" Width="100%">
    <Tabs>
        <telerik:RadTab Text="Level 1" Selected="true" PageViewID="page1">
            <Tabs>
                <telerik:RadTab Text="Page 1" PageViewID="page1" Selected="true" />
                <telerik:RadTab Text="Page 2" PageViewID="page2" />
                <telerik:RadTab Text="Page 3" PageViewID="page3" />
            </Tabs>
        </telerik:RadTab>
        <telerik:RadTab Text="Level 2" PageViewID="page4">
            <Tabs>
                <telerik:RadTab Text="Page 4" PageViewID="page4" Selected="true" />
                <telerik:RadTab Text="Page 5" PageViewID="page5" />
                <telerik:RadTab Text="Page 6" PageViewID="page6" />
            </Tabs>
        </telerik:RadTab>
    </Tabs>
</telerik:RadTabStrip>

<telerik:RadMultiPage runat="server" ID="rmpPages">

    <telerik:RadPageView runat="server" ID="page1" ContentUrl="page1.aspx" Selected="true" />
    <telerik:RadPageView runat="server" ID="page2" ContentUrl="page2.aspx" />
    <telerik:RadPageView runat="server" ID="page3" ContentUrl="page3.aspx" />
    <telerik:RadPageView runat="server" ID="page4" ContentUrl="page4.aspx" />
    <telerik:RadPageView runat="server" ID="page5" ContentUrl="page5.aspx" />
    <telerik:RadPageView runat="server" ID="page6" ContentUrl="page6.aspx" />

</telerik:RadMultiPage>
Won't Fix
Last Updated: 18 May 2015 14:41 by ADMIN
Silverlight Module doesn't work correctly with RadProgressArea, when uploading is canceled.
Won't Fix
Last Updated: 15 May 2015 08:25 by ADMIN
The error that is thrown on page load is that two components with the same ID cannot be added to the page.

Possible workarounds:
1) set EnableAriaSupport to false
2) use client-side code to show tooltips, as shown in this demo: http://demos.telerik.com/aspnet-ajax/tooltip/examples/radtooltipmanagerclientapi/defaultcs.aspx .
Won't Fix
Last Updated: 22 Apr 2015 15:02 by ADMIN
Workaround:
Set ClickToOpen = true in the control markup or if you want to set it only for the problematic browsers, use the following server-side code:

    protected void Page_Load(object sender, EventArgs e)
    {
        string userAgent = Request.UserAgent;
        string searchPattern = "ARM(?i)|Touch(?i)";

        if (System.Text.RegularExpressions.Regex.IsMatch(userAgent, searchPattern))
        {
           RadContextMenu1.ClickToOpen = true;
        }
    }
Won't Fix
Last Updated: 16 Apr 2015 08:17 by Elena
Won't Fix
Last Updated: 16 Apr 2015 08:15 by Elena
Won't Fix
Last Updated: 14 Apr 2015 14:53 by ADMIN
1 2