Completed
Last Updated: 04 Sep 2019 14:24 by ADMIN
Release Q1 2014
The error is Sys.InvalidOperationException: Sys.InvalidOperationException: Component 'RadEditor1_dialogOpener' was not found.

When not enabled RadEditor should merely show its content, when Enabled is toggled to true it should render toolbars and add its functionality.

A possible workaround is using the Visible property instead and a div with runat=server as a placeholder for the editor while it is not rendered (its Content property will still return the HTML in it). Thus, the innerHTML server property of the div can be used to set the HTML from RadEditor in it.
Completed
Last Updated: 04 Sep 2019 14:22 by ADMIN
When I call OnParentNodeChanged on an Editor, while viewing the page using HTTPS, I get the following message in IE:
SEC7111: HTTPS security is compromised by (null) 
Completed
Last Updated: 04 Sep 2019 12:51 by ADMIN
Created by: murugesan
Comments: 1
Category: Scheduler
Type: Bug Report
0
Hi,


I used "Telerik Ajax Rad Scheduler" using DLL  "Telerik.Web.UI.dll" version "2014.1.225.40", but i got an error "Failed to load resource: the server responded with a status of 404 (Not Found)" and UI styles are only loaded partially.



I also tried the below mentioned steps  provided on the URL , but it did not work. Please  let me know your thoughts and help me to overcome this scenario

1) https://www.telerik.com/forums/telerik-web-ui-webresource-axd-404-error-not-found

2) https://docs.telerik.com/devtools/aspnet-ajax/general-information/troubleshooting/web-resources-troubleshooting
Completed
Last Updated: 04 Sep 2019 08:27 by ADMIN
See: https://demos.telerik.com/aspnet-ajax/combobox/examples/accessibility/defaultcs.aspx

1. Click somewhere in the page to establish focus.

2. Use the tab key to focus the combo box.  (This works in Chrome, but in IE the control is skipped.)

3. Note that the combo box does not drop-down the list of options like it does when you click the mouse. Clicking the enter key does not drop down the list. Alt-Down-Arrow does not drop down the list.

4. Press Tab and note that focus skips the arrow icon on the combo box and moves down to the "validate with Wave" link.

5. Press Shift-Tab and note that the Arrow icon is now focuses and the enter key will drop down the options list.

6. While JAWS 2019 is running, press the "C" key and note that JAWS reports that there are no combo boxes on the page.

 

Expectations:

* Jaws is able to properly identify the combo box based on ARIA tags

* Tabbing into the combo box presents the same behaviors as using the mouse button
Completed
Last Updated: 04 Sep 2019 07:58 by ADMIN
Release R3 2019

The current colors, #0082CC and #FFFFFF that are used for forecolor and backcolor, have 4.14:1 color contrast ratio: https://webaim.org/resources/contrastchecker/?fcolor=FFFFFF&bcolor=0082CC

The minimum required color contrast ratio is 4.5:1 for AA Compliance, and 7:1 for AAA Compliance.

A possible alternative color for the #0082CC blue can be #007CC.

Completed
Last Updated: 03 Sep 2019 16:13 by ADMIN
Release R3 2019
Created by: Sunil Sutar
Comments: 2
Category: TabStrip
Type: Bug Report
1

Hi Telerik team,

 

Few of our clients reported the following issue with respect to WCAG 2.0 SC 4.1.2 standard. (508 Standard and compliance) -

PracticeFunction (example)
Ensure ARIA roles, states, and properties are validLI has an aria-level attribute of 0, which is not an integer value greater than, or equal to, 1

 

Example: visit https://demos.telerik.com/aspnet-ajax/tabstrip/examples/wai-aria-support/defaultcs.aspx 

 

Observe the ul-li elements created for tabstrip. On each li element, there is aria-level attribute whose value is set to 0.

As per WCAG this value should start from 1. The value 0 is invalid. Refer: https://www.w3.org/TR/WCAG20-TECHS/ARIA12.html

 

Please let me know when are you going to fix this for compliance. 

--

Sunil

Completed
Last Updated: 03 Sep 2019 16:12 by ADMIN
Release R3 2019

Few of our clients reported the following issue with respect to WCAG 2.0 SC 4.1.2 standard. (508 Standard and compliance) -

 
Practice Function (example)
Ensure sub-lists are marked up properly This UL should only contain li elements (without an ARIA-assigned role), script elements (without an ARIA-assigned role) or template elements (without an ARIA-assigned role); or
 
elements with a role=listitem attribute; as direct child elements

 

Example: When Telerik Tabstrip has EnableAriaSupport=true, internally tabstrip is combination of ul-li with css to display the Tabs properly -

The html looks like as follows -  

<ul class="rtsUL">
    <li class="rtsLI rtsFirst" role="tab" aria-disabled="false" aria-level="0" aria-controls="LayoutPageView">
        <a accesskey="L" title="Layout" class="rtsLink rtsBefore" id="LayoutTab" href="#"><span class="rtsOut">
            <span class="rtsIn">
                <span class="rtsTxt">
                    <h2 class="RadTabStrip RadTabStrip_Default"><u>L</u>ayout</h2>
                </span>
            </span>
        </span>
        </a>
    </li>
    <li class="rtsLI" role="tab" aria-disabled="false" aria-level="0" aria-controls="SearchPageView" aria-selected="true" id="SearchTabStrip_active_tab">
        <a accesskey="S" title="Search" class="rtsLink rtsSelected" id="SearchTab" href="#">
            <span class="rtsOut">
                <span class="rtsIn">
                    <span class="rtsTxt">
                        <h2 class="RadTabStrip RadTabStrip_Default"><u>S</u>earch</h2>
                    </span>
                </span>
            </span>
        </a>
    </li>
    <li class="rtsLI rtsLast" role="tab" aria-disabled="false" aria-level="0" aria-controls="ResultsPageView">
        <a accesskey="R" title="Statewide Search Results 0 records" class="rtsLink rtsAfter" id="ResultsTab" href="#">
            <span class="rtsOut">
                <span class="rtsIn">
                    <span class="rtsTxt">
                        <h2 class="RadTabStrip RadTabStrip_Default">Statewide Search<u>R</u>esults (0)</h2>
                    </span>
                </span>
            </span>
        </a>
    </li>
</ul>


Observe the aria attributes which are on li elements. Is that really necessary considering the compliance? (as mentioned in practice and example).

 

Please let me know when are you going to fix this for compliance. 

--

Sunil 

Completed
Last Updated: 03 Sep 2019 16:11 by ADMIN
Release R3 2019
Completed
Last Updated: 03 Sep 2019 16:11 by ADMIN
Release R3 2019

Reproduction: https://demos.telerik.com/aspnet-ajax/combobox/examples/wai-aria-support/defaultcs.aspx

1) focus the ComboBox

2) press C 

Expected: 

- Camembert Pierrot is selected

- JAWS pronounces "c" and "Camembert Pierrot"

Actual: 

- Camembert Pierrot is selected

- JAWS pronounces "c"

Reference for expected behavior: https://www.w3.org/TR/wai-aria-practices/examples/listbox/listbox-collapsible.html

Completed
Last Updated: 03 Sep 2019 16:10 by ADMIN
Release R3 2019
Problem:  Latest Telerik version of Combobox or RadCombobox reads "readonly" though it's not, when EnableAriaSupport is enabled.

Details: 

url to test with JAWS - https://demos.telerik.com/aspnet-ajax/combobox/examples/wai-aria-support/defaultcs.aspx

When I use JAWS to read the combobox present on this demo it reads as follows - 
              ComboBox readonly - Alice Mutton. To change the selection press the arrow keys.

Over here, why JAWS is reading "readonly". It's not readonly. It's making our screenreader blind users confusing.

I drilled down more into the problem and found that, the input element below has the aria-readonly=true set though the combobox is not readonly.
Here is the html generated for above combobox from telerik demo site -

<input name="ctl00$ContentPlaceholder1$RadComboBox2" class="rcbInput radPreventDecorate" id="ctl00_ContentPlaceholder1_RadComboBox2_Input" role="combobox" aria-busy="false" aria-disabled="false" aria-expanded="false" aria-haspopup="true" aria-readonly="true" aria-owns="ctl00_ContentPlaceholder1_RadComboBox2_listbox" aria-autocomplete="none" type="text" readonly="readonly" value="Alice Mutton" autocomplete="off">

I understand that this input control should be readonly so that aria users should not type and go haywire. But looks like to maintain the readonly=readonly property, telerik is generating aria-readonly=true for this _Input control and resulting this issue.

When you change this attribute aria-readonly="true" to aria-readonly="false", JAWS read it correctly as follows - 
              ComboBox - Alice Mutton. To change the selection press the arrow keys.

Let me know how to achieve that so that users will not be confused.
Completed
Last Updated: 03 Sep 2019 16:06 by ADMIN
Release R3 2019
ADMIN
Created by: Marin Bratanov
Comments: 1
Category: Spreadsheet
Type: Feature Request
1
The current context menu lets you hide a row or column, but then you cannot show it again, so the user can lose data. At present there is no context menu option to unhide it and there is no element indicating the column/row was there in the first place. This should behave like in Excel.

Such a feature must be implemented first in the underlying Kendo Spreadsheet widget, and to this end I encourage you to cast your votes for its implementation here: http://kendoui-feedback.telerik.com/forums/127393-kendo-ui-feedback/suggestions/19240072-context-menu-option-to-unhide-row-column
Completed
Last Updated: 03 Sep 2019 16:05 by ADMIN
ADMIN
Created by: Angel Petrov
Comments: 0
Category: Filter
Type: Bug Report
0

			
Completed
Last Updated: 03 Sep 2019 15:56 by ADMIN
Release R3 2019
For keyboard users who don't have a specific Context Menu key (see  https://en.wikipedia.org/wiki/Menu_key), they typically need to use the Windows standard SHIFT+F10 hotkey to trigger a contextmenu event.

For example:

1.	In IE, load http://demos.telerik.com/aspnet-ajax/grid/examples/columns-rows/columns/context-menu/defaultcs.aspx
2.	Tab to a column header link
3.	Press SHIFT+F10 (standard Windows/IE hotkey to open context menu)
4.	Notice the context menu displays, however, the focus is really on the IE menubar. IE supports F10 to open the menubar, but is also seeing SHIFT+F10 too.

Or
1.	In FireFox, load http://demos.telerik.com/aspnet-ajax/grid/examples/columns-rows/columns/context-menu/defaultcs.aspx
2.	Tab to a column header link
3.	Press SHIFT+F10 (standard Windows/IE hotkey to open context menu) then press down arrow
4.	Notice the context menu displays, however, the focus is really on FireFox's application system menu in the upper left.

Chrome does not have this issue - it opens the grid context menu only.
We need IE and FireFox to also only open the grid's context menu, and not trigger default browser behavior.

According to https://yuilibrary.com/yui/docs/event/contextmenu.html, it is possible to correct this behavior by calling event.preventDefault() when SHIFT+F10 is pressed, but then trigger a synthetic contextmenu event anyway.

As a workaround, we know users can press Escape to close the browser's default menu and bring focus back into the HTML document (and thus the grid's context menu), but this throws off the user experience and becomes a training issue.
Completed
Last Updated: 03 Sep 2019 12:00 by ADMIN
Hi, we are having a problem with the column picker, we are trying to move columns and they are getting "stuck". 

The same issue happens in the Telerik online demo page https://demos.telerik.com/aspnet-ajax/grid/mobile-examples/overview/default.aspx?name=overview

1. Open the above page using the latest google chrome

2. Open dev tools and pick mobile browser iPhone 5/SE (note: problem also happens on Android)

3. Click the ||| icon on the top right

4. Drag a column up or down using the hamburger icon (3 horizontal lines)

5. It gets stuck
Completed
Last Updated: 02 Sep 2019 15:28 by ADMIN
Created by: Joao
Comments: 1
Category: DropDownTree
Type: Feature Request
0
Cannot add a label to a RadDropDownTree
Completed
Last Updated: 02 Sep 2019 15:26 by ADMIN
When using the Microsoft Edge browser with the Editor, you cannot add field values for some form elements. This seems to affect Radio buttons and checkboxes. It is possible that it affects other form elements as well. I also see this same problem when using your demo page https://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx.

Edge does not offer the hasLayout capability of Internet Explorer, which selects the form element on click. In Edge you can select a form element as you could do it with a text: https://www.screencast.com/t/mo25Rm1kTSdB. The click selection is not currently supported.
Completed
Last Updated: 02 Sep 2019 15:19 by ADMIN
I have a Telerik RadEditor (2017.3) control with custom/unembedded skin (created using the themebuilder on telerik), and when I enter a value for the DialogsCssFile attribute, the markup of the page changes, meaning that my custom skin is not applied to the editor anymore.

Why is this a problem? Well the css inside the dialog for Find/replace for example didn't display correct, and having done some research, I needed to do some @imports into a customDialog.css file and drop that into the DialogsCssFile attribute.

As soon as I do this, the generated markup in the page for RadEditor changes from

Radeditor RadEditor_MyCustomSkin reWrapper

to

Radeditor MyCustomSkin reWrapper

meaning that my radeditor Skin is not applied to the editor, If I remove the DialogCssFile then the editor skin loads correctly, but the dialogs look wrong. In the Page source, the Window is a div within the page, and not an iFrame

Code :

Page CSS files (in order)

<link type="text/css" rel="stylesheet" href="/assets/css/MyCustomSkin/formdecorator.MyCustomSkin.css" />
<link type="text/css" rel="stylesheet" href="/assets/css/MyCustomSkin/toolbar.MyCustomSkin.css" />
<link type="text/css" rel="stylesheet" href="/assets/css/MyCustomSkin/window.MyCustomSkin.css" />
<link type="text/css" rel="stylesheet" href="/assets/css/MyCustomSkin/combobox.MyCustomSkin.css" />
<link type="text/css" rel="stylesheet" href="/assets/css/MyCustomSkin/dropdownlist.MyCustomSkin.css" />
<link type="text/css" rel="stylesheet" href="/assets/css/MyCustomSkin/tabstrip.MyCustomSkin.css" />
<link type="text/css" rel="stylesheet" href="/assets/css/MyCustomSkin/editor.MyCustomSkin.css" />
Main Radeditor Class (to give idea of class names)

.RadEditor_MyCustomSkin { /* css styles - all generated automatically */ }
Control :

<telerik:RadEditor runat="server" ID="pageRadEdit" ToolbarMode="Default" EditModes="Design,Html"
DialogsCssFile="~/assets/css/MyCustomSkin/DialogHandler.MyCustomSkin.css"
ToolsFile="~/App_Data/Editor.xml" Width="980px" Height="800px"
EnableResize="false" OnClientLoad="resizeMe" NewLineMode="P"
OnClientSelectionChange="$page.setdirty"
ContentFilters="DefaultFilters,ConvertFontToSpan,IECleanAnchors,OptimizeSpans,MozEmStrong,FixEnclosingP"
EnableEmbeddedSkins="false">
        <SpellCheckSettings DictionaryLanguage="en-GB" AllowAddCustom="false" />
        <Languages>
            <telerik:SpellCheckerLanguage Code="en-GB" Title="English (UK)" />
        </Languages>
</telerik:RadEditor>
DialogHandler.MyCustomSkin.css

@import url('FormDecorator.MyCustomSkin.css');
/*@import url('Grid.MyCustomSkin.css');*/
@import url('Input.MyCustomSkin.css');
@import url('Splitter.MyCustomSkin.css');
@import url('TabStrip.MyCustomSkin.css');
@import url('ToolBar.MyCustomSkin.css');
/*@import url('Upload.MyCustomSkin.css');*/
@import url('Window.MyCustomSkin.css');
@import url('ComboBox.MyCustomSkin.css');
@import url('Button.MyCustomSkin.css');
/*@import url('Editor.MyCustomSkin.css');*/
Note : Editor css is still using wrong class even if the bottom import is uncommented

Web.Config settings

<add key="Telerik.Skin" value="MyCustomSkin" />
<add key="Telerik.ScriptManager.TelerikCdn" value="Disabled" />
<add key="Telerik.StyleSheetManager.TelerikCdn" value="Disabled" />
<add key="Telerik.Web.UI.RenderMode" value="lightweight" />
<add key="Telerik.Web.UI.EnableEmbeddedSkins" value="false" />
<add key="Telerik.EnableEmbeddedSkins" value="false" />
Completed
Last Updated: 02 Sep 2019 14:52 by ADMIN
Created by: Patrick
Comments: 2
Category: UI for ASP.NET AJAX
Type: Bug Report
0
When we create a link to an external web site such as www.cnn.com using the RadEditor (6.3.0.0) on our SP2010 farm we are getting an error that says this:
"cannot find this location in the current site location"
"the URL may refer to an external web site for to a location in the site collection that does not exist or you do not have the right to access"

When I bring up a browser on the SharePoint server themselves I can access those sites.

Completed
Last Updated: 02 Sep 2019 14:33 by ADMIN
Please add an ability to move text in different styles, something like HTML MARQUEE.


For example:

http://www.htmlcodetutorial.com/_MARQUEE_BEHAVIOR.html

http://www.plus2net.com/html_tutorial/html_marquee_behvr.php
Completed
Last Updated: 02 Sep 2019 14:25 by ADMIN
ADMIN
Created by: Ivan Zhekov
Comments: 2
Category: Editor
Type: Bug Report
0
Based on customer feedback:

1) Toggle full screen
2) Finish AJAX spell checker
3) Then full screen icon is not selected even the editor is in full screen mode